Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
1
vote
0answers
11 views

“edited” key always return false. even though it shows edited on site

CommentID: 1193255 On site Meta Stack Exchange The Api returns edited as false However if you see the comment itself, you can see it has been edited. Is there something that I am missing here?
4
votes
1answer
94 views

Cannot authenticate with OAuth2

I was testing an app and suddenly I can't login any more. Neither my app or the Stack App configuration hasn't changed, so I'm thinking this might be a bug on the API side. The OAuth error seems a ...
0
votes
0answers
18 views

Can I have more than one OAuth Domain?

I tried to set more than one OAuth Domain, but seems to it's not working. I tried to set them separated by comma or space, but got redirect_uri - must be under an apps registered domain error message. ...
3
votes
1answer
45 views

StackApps Captcha doesn't work: “Invalid domain for site key”

The Captcha page on this site doesn't seem to be set up correctly, it shows an error message: ERROR for site owner:Invalid domain for site key
1
vote
1answer
23 views

Wrong sorting parameter in documentation for question/{ids}/answers

It looks like that in the question/{ids}/answers documentation, there is a mistake: votes – score Shouldn't this be votes – votes
3
votes
1answer
29 views

Wrong results for fetch timeline from offset

To get the timeline for a question I am sending this request: https://api.stackexchange.com/2.2/questions/63299112/timeline?site=stackoverflow&fromdate=1597649222 I am getting empty results: {&...
2
votes
0answers
16 views

Please migrate the question templates to CommonMark

We have three templates for new questions (for apps, libraries and scripts): They'll insert a body like this: <!-- thumbnail: https://example.com/some-image.png --> <!-- version: 1.0 --> ...
1
vote
0answers
16 views

API returns flags options for election comments while flagging them isn't possible

When trying to retrieve the flag options on a comment, e.g. on the currently active one on Skeptics.SE (but it works for any election): https://api.stackexchange.com/docs/comment-flag-options#id=...
12
votes
1answer
361 views

Why is my API quota not resetting after UTC reset?

According to How API Keys Work, the default daily API limit -- which is per site, per day -- is 300. I started with 300, as expected, but over a period of days, I've noticed that the remaining quota ...
2
votes
0answers
23 views

Pluralisation bugs in /apps/oauth

In Your Apps, if 1 user has been authorized and been given an access token, here's what the site shows: It must be "user". Also, if you have one application:
2
votes
0answers
25 views

/me/associated doesn't return meta sites anymore

The documentation of /me/associated says: You can filter the network_users returned by this method with the types parameter. Specify, semicolon delimited, main_site or meta_site to filter by site. ...
4
votes
1answer
246 views

API stopped allowing CORS requests

I'm currently using the API via JavaScript AJAX calls and it all of a sudden stopped allowing CORS requests. I'm on localhost and I tried uploading my code to live and am still getting: Access to ...
3
votes
0answers
33 views

Permission request form is broken, approve button is hidden, css variables are missing

You can check that form doesn't work with this link https://stackoverflow.com/oauth?client_id=17581&scope=no_expiry&redirect_uri=http://functional.localdomain:3449/login/github
2
votes
1answer
79 views

“Javascript” typo on documentation pages

On page Usage of /sites, it should be JavaScript, not Javascript, in the right sidebar: This obviously also applies to (most/all) API documentation pages, since they share the sidebar.
5
votes
1answer
134 views

Few typos in the documentation pages

https://api.stackexchange.com/docs/vectors When passing a vector, sepeate each id with a semicolon. For example, /users/1;2;3;4;5?site=somesite would fetch users with ids 1 through 5 on somesite. ...
8
votes
1answer
97 views

Typos in API documentation

From the /posts documentation: Most applications should use the question or answer specific methods, but /posts is available for those rare cases where any activity is of intereset. intereset => ...
5
votes
1answer
108 views

API docs titled “v2.0”; should be “v2.1”

The documentation is titled "StackExchange API v2.0"... this should be updated to "v2.1" as it's not readily obvious that version 2.1 has been published otherwise. https://api.stackexchange.com/docs
2
votes
0answers
33 views

Spelling mistake in API Documentation's “Authentication” page

Can you find the spelling mistake in "Unregistered Users" (last section) of the Authentication page? In case you're not in the mood for games, here is it: This is actually a correct spelling - of ...
2
votes
0answers
32 views

Wrong error message when attempting to edit a locked answer

When attempting to edit a locked answer like this one via the /answers/{id}/edit API method, I get an error message: Account is not allowed to suggest edits I have the privilege to edit the post, ...
2
votes
0answers
123 views

window.opener is null in Stack Exchange login_success page

I am using the JavaScript SDK to authenticate Stack Exchange users in our application. But the dialog stays in "Authorizing Application" page, as I found there is a error thrown in this page: ...
0
votes
0answers
31 views

Error invalid_request “OAuth request must be over HTTPS” when starting oauth flow

I'm building an application on top of StackExchange's API for a month now. While I was building the OAuth flow to allow users to authenticate using their StackExchange account, everything was working ...
1
vote
0answers
29 views

Passing `networkUsers: true` to the `authenticate` method returns `bad_barameter` error

Following the steps provided in the docs to authenticate to stackexchange via the js sdk api, I'm unable to authenticate if I pass the networkUsers: true to the auth call. I'm getting the following ...
2
votes
0answers
33 views

Stack Exchange search API not returning results with min, max vote count

Query to search for all question with perl6 tag created between Oct 1 - Oct 5 2019. I'm sorting the results by votes. /2.2/search?fromdate=1569888000&todate=1570233600&order=desc&sort=...
3
votes
0answers
51 views

API 404's when I try to fetch related tags for the `bin` tag

If you query the API for tags related to [bin]: https://api.stackexchange.com/2.2/tags/bin/related?site=stackoverflow this simply returns: Invalid JSON returned and a 404. (live demo) But it ...
2
votes
1answer
46 views

503 errors on batch get questions endpoint

I receive a lot of "socket hung up" and 503 Service Unavailable on the /questions/{ids} endpoint. I make requests in batches: 10 parallel requests with 15 question ids, interval between each 10-size ...
2
votes
1answer
46 views

What happened to the links to a Stack App mentioned in the documentation about write access?

The documentation about write access states: The application responsible for creating content via the API may be indicated with a link to an app's Stack Apps post. The exact manner of display is ...
1
vote
0answers
41 views

Misaligned label “Stack Apps Post (optional)” on app information page

When editing the application information (from https://stackapps.com/apps/oauth/), the label for the optional Stack Apps Post is misaligned: It should be left-aligned like the other labels; the only ...
2
votes
1answer
33 views

Timeline activities appear to be missing (because creation_date has wrong and useless values)

When I'm looking at my Stack Overflow timeline according to the API, It's missing a lot of events. According to the API, the last thing I did was posting this answer, five days ago, and you can see ...
2
votes
0answers
26 views

List /network-activity methods under Network Methods in the documentation

The API methods /users/{id}/network-activity and /me/network-activity, both return a summary of a user's activity across the Stack Exchange network and do not take a site parameter. They are ...
4
votes
2answers
100 views

Possible bug in the help page?

There are some weird dot things in this help page: api.stackoverflow.com/0.8/help/method?method=users/{id}/badges {Dead link to missing image: http://files.quickmediasolutions.com/stackbug.png} ...
6
votes
1answer
209 views

After successfully retrieving 180 pages, the API gracelessly, semi-silently, fails

I'm trying to synchronize tags using the Stack Exchange API and this works for about 180 pages, but around 180 pages it always ends with an exception that seems to indicate that there is no HTTP ...
4
votes
0answers
34 views

/revisions/{ids} returns wrong body

Since a couple of days, the /revisions/{ids} method returns a wrong value for the body field. An example is this Ask Different post. When viewing the (only) revision on the website, you see that the ...
2
votes
0answers
30 views

Linked questions API call fails for frequently asked questions on Stack Overflow

The Linked Questions API fails for some of the Frequently Asked Questions on Stack Overflow, maybe because of the sheer amount of linked questions they have. As an example, take What is a ...
3
votes
0answers
38 views

Tags are not returned when querying /users/{ids}/answers

I'm querying the API for answers-by-user, and I want the tags belonging to the parent questions. I seem to be seeing intermittent results: sometimes the tags attribute of the response includes the ...
3
votes
0answers
64 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
1
vote
2answers
90 views

Incorrect Wordpress and Electronics icons

Currently Meta Icon Currently Main Icon With all the other sites (except electronics, which has the same icon for both), Meta has the B&W or sepia icon, while the main site's icon is coloured. ...
8
votes
2answers
122 views

Stack Apps homepage truncates user names

A picture says more than a thousand words: These users aren't called "Bhargav Rac" and "Tunak", but Bhargav Rao and Tunaki. This happens on both the 'apps' and 'scripts' tabs of the Stack Apps ...
2
votes
1answer
63 views

Default listing images aren't served from CDN, fail to load because of certificate error

The default images used on the app/script/library pages aren't pointing to the CDN, so their use of HTTPS causes a certificate error that prevents the image from loading: Could the image sources be ...
1
vote
0answers
52 views

The authentication doc gives a wrong domain for authentication

The authentication doc page now lists URL's like: https://stackoverflow.com/oauth https://stackoverflow.com/oauth/access_token etc. While these seem to work, the correct domain is stackexchange.com, ...
3
votes
0answers
146 views

OAuth Dialog rendering problems in iPad

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: (...
3
votes
0answers
79 views

Only Stack Overflow has documentation, but the API erroneously lists documentation privileges for all sites

Privileges related to Stack Overflow Documentation are displaying in every other site's API data. Using Meta Stack Exchange, for example, /2.2/privileges?site=meta returns the following documentation ...
1
vote
3answers
273 views

Icons of beta sites

Icons of beta sites are different form the icons given in the http://stackauth.com/1.0/sites . As example: Original icon of the English Language and Usage is     where http://stackauth....
1
vote
1answer
75 views

Why am I getting an “Access token sent over non-HTTPS request, it has been invalidated” message?

I've been using the Stack Overflow for Teams API for a while now, but since yesterday it stopped working for one of the Teams; that Team also wasn't listed in the Applications (https://stackoverflow....
2
votes
1answer
87 views

The new implicit authentication dialog doesn't handle comma-delimited scopes

The authentication docs state that the scopes parameter of the URL to which a user should be directed to, for implicit authentication, should be a list of scopes that are delimited by either commas or ...
5
votes
0answers
40 views

OBSOLETE - revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
1
vote
1answer
51 views

Why doesn't the API return a 'locked date' for this locked answer?

This answer has been locked, yet when I ask the API about this post it fails to return a locked_date: It's a rather old lock, but I can't see anything suspicious in the timeline or the Post History.
3
votes
1answer
84 views

top-answerers / top-askers documentation bug: number of results returned incorrect

The top-answerers-on-tags and top-askers-on-tags documentation claim: Returns the top 30 answerers active in a single tag, of either all-time or the last 30 days. and Returns the top 30 askers ...
3
votes
0answers
69 views

OBSOLETE - Unanswered questions with tags returns wrong total

When requesting a list of unanswered questions with a specific tags the total count show the total number of questions for that tag, not the count for the unanswered questions. Using http://api....
0
votes
0answers
24 views

Strange pagination behaviour of /search/excerpts [duplicate]

In an attempt to (automatically) restore broken images* which have originally been included as HTTP links, I've tried to use /search/excerpts to look for candidate posts; specifically, I'm setting the ...
3
votes
1answer
69 views

Paging fails at 10K items for /search on any site but Stack Overflow

There's a problem with requesting more than 10,000 items. With Stack Overflow it works just fine. But with Super User, Server Fault, etc. no items are returned for requests for items after the 10,...

1
2 3 4 5
9