2

I have recently published an app for browsing Stack Exchange websites and a major feedback I received from users was about the inability to use oauth login form while loging into the app. The screenshots were suggesting that the users were directed to full web site instead of the mobile one (the screenshots are from two different windows phone apps but the problem is the same).

After some research I found out that Microsoft made a change to user agent of IE11 with Window Phone 8.1 Update 1 in order to emulate Android and iOS. Users that upgrade to new version no longer has that issue. So it seems that Stack Exchange login form forwards WP users (without OS upgrade) to full site because of the user-agent.

Is the Stack Exchange team aware of the issue? Might there be a way to fix it?

Thanks.

  • We weren't aware, no. The full site may be inconvenient, but it should still work (with the caveat that I'm not even a little bit familiar with Windows Phone devices - but it's a smartphone, so... should work?). What exactly is the problem? – Adam Lear Jun 12 '15 at 2:49
  • As I don't have a device with the specified OS version, I cannot reproduce the problem. But what I guess from the screenshots is that there is some kind of an error that causes some javascript code to fail because there is no buttons to click on the full site. There should be icons for different login types. – Birkan Cilingir Jun 13 '15 at 11:45

You must log in to answer this question.

Browse other questions tagged .