5

No changes in stack apps or my code, it was working fine for a while, suddenly it stopped working now.

I get "InternalOAuthError: Failed to obtain access token"

After more details inspection, I came to conclusion that CloudFlare is blocking my requests due to security measures. Why is CloudFlare perceiving my requests as harmful/not trusted?

I have my application deployed in Azure Virtual Machine. So it's Azure External IP and it is under a .com domain name.

Additional information I get this:

<!DOCTYPE html>
<html lang=\"en-US\">

<head>
  <title>Just a moment...</title>
  <meta http-equiv=\"Content-Type\" content=\"text/html; charset=UTF-8\">
  <meta http-equiv=\"X-UA-Compatible\" content=\"IE=Edge\">
  <meta name=\"robots\" content=\"noindex,nofollow\">
  <meta name=\"viewport\" content=\"width=device-width,initial-scale=1\">
window._cf_chl_opt.cOgUHash = location.hash === '' && location.href.indexOf('#') !== -1 ? '#' : location.hash;
window._cf_chl_opt.cOgUQuery = location.search === '' && location.href.slice(0, location.href.length - window._cf_chl_opt.cOgUHash.length).indexOf('?') !== -1 ? '?' : location.search;
if (window.history && window.history.replaceState) {
  var ogU = location.pathname + window._cf_chl_opt.cOgUQuery + window._cf_chl_opt.cOgUHash;
  history.replaceState(null, null, \"\\/oauth\\/access_token?__cf_chl_rt_tk=-1708042411-0.0-4071\" + window._cf_chl_opt.cOgUHash)

[Edit]: After more tests, I found out that I can't even do a HTTP GET request to Stack Overflow Website from my Azure Virtual Machine due to the same message.

So even "curl https://stackoverflow.com" fails with the "Just a moment..."

2

0

You must log in to answer this question.

Browse other questions tagged .