unread messages in your inbox

More screenshots: https://github.com/Rob--W/stackexchange-notifications/tree/master/screenshots


Get real-time desktop notifications for your inbox at the Stack Exchange.

After installing and setting your Stack Exchange account ID, you will get desktop notifications whenever the inbox notification count changes. Click on the notification to visit your inbox.

NEW in 2.2: The unread message count is also displayed on the extension button, and clicking on the extension button will directly show the contents of your inbox in a panel. There is a "mark as read" button to mark all messages as read.

Don't want to receive notifications any more? Visit options and click on Stop.



It is supported by Chrome and Firefox, because they are the only browsers that support Desktop notifications out-of-the-box.


Drop an issue at Github, or post an answer/comment here.


Used technologies: JavaScript, Chrome Extension API, WebExtensions API, Web Sockets, Stack Exchange API.

  • 1
    Can this extension notify me about new questions with a given tag? Commented Nov 28, 2012 at 4:05
  • @reprogrammer Technically, yes. Can you post a feature request with desired details as an answer, or create an issue on Github? In particular, how do you imagine this feature, what determines whether a post is "new" or "read"?
    – Rob W
    Commented Dec 2, 2012 at 10:51
  • Hi Rob, this can be done in Firefox too. The HTML5 Notifications for Firefox extension let's Firefox use window.webkitNotifications in the same way as you consume the API in Chrome. Your extension would of course depend on another Firefox extension, but you'd have at least one avid user. See this meta post for more details. Hope this helps!
    – jmort253
    Commented Dec 8, 2012 at 19:06
  • wud be cool for it to use more native notifications on OSX. I.e, currently the app pops up with it's own notification system instead of using Chrome's native notifications. But great otherwise. Commented Apr 19, 2016 at 14:05
  • 1
    @LeoUfimtsev The Chrome extension is using Chrome's native notifications.
    – Rob W
    Commented Apr 19, 2016 at 14:06
  • @RobW Thank you for quick response. Hmm, I'm using Chrome Canary with experimental OS X notification feature: "chrome://flags/#enable-native-notifications". All notifications (Facebook/Google calendar etc..) looks like so: i.imgur.com/btW1yxf.png But Stackoverflow notifications look different, they have a square something like: i.imgur.com/uytXp.png I kinda wonder why.. The reason I care is native notifcations stick around for later review in OSX's notification bar along with all other notifications. Any ideas? I wouldn't mind trying to fix it if given tips/advice? Commented Apr 19, 2016 at 14:16
  • @LeoUfimtsev Ah, native in that sense. I don't have a mac, but can you try out the following: 1. Open chrome://extensions, enable developer mode. Click on Inspect background page at my extension. Click on the sources tab, select "using-websocket.js" and set a breakpoint at the first line. Then run delete chrome.notifications; in the console. Then copy-paste gist.github.com/Rob--W/5926727 in the console and run it. Then continue the breakpoint, and generate a notification (e.g. by calling setUnreadCount(1); ). Does that give the desired result?
    – Rob W
    Commented Apr 19, 2016 at 14:26
  • @RobW Cool. This works :-D!. Before/After pictures: imgur.com/a/bW5eQ Now notifications do look native to OS X. Pretty :-3. They also stick around in notification bar. Is there a way to enable it permanently? Is this in the latest source? (Mind you, OS X notifications are only half-backed at present, in current stable chrome they're pretty meh. But on Canary they're pretty decent). Commented Apr 19, 2016 at 15:02
  • @LeoUfimtsev Cool. I've opened a new to-do (github.com/Rob--W/stackexchange-notifications/issues/21). I put the steps for the implementation, if you want to you can create a pull request.
    – Rob W
    Commented Apr 19, 2016 at 15:11
  • @RobW kewl. I posted in the request. Commented Apr 19, 2016 at 15:15
  • 1
    Desktop notification not working ? Commented Jul 28, 2019 at 11:44

4 Answers 4


Can somebody please port this to Firefox? I would definitely appreciate it.

FF Desktop Notification support: https://code.google.com/p/ff-html5notifications/

  • 4
    It took some efforts, but I've managed to port the extension to a Firefox add-on. I'll update the first post once it has passed review at AMO. Till then, you can get it from the Github repository at github.com/Rob--W/stackexchange-notifications/tree/master/….
    – Rob W
    Commented Dec 9, 2012 at 22:43
  • @RobW Awesome! I'll be a beta tester and help you out with bugs! Thank you so much! I will tell you if I ever manage to get it built... (I hate building code from source. It's hard, buggy, and almost never succeeds.) I will give it a shot, though. Commented Dec 10, 2012 at 4:18
  • @RobW Ummmmm.... what file am I supposed to download? I have never done this before, and there are no good instructions anywhere. Am I supposed to download all the files to the same folder, then change to that folder, and run the command? Am I supposed to find a "Download as .zip" link, and then run the command on that? What do I do? Commented Dec 10, 2012 at 4:20
  • @RobW Oh, wait. I poked around for a bit, then managed to find an XPI file. (THAT, I knew what to do with.) The configuration windows appeared for a minute, but I can't seem to make it come back. Commented Dec 10, 2012 at 4:24
  • Hey, I don't know whether it's turned on or not. Can somebody reply to this comment, so I can see if it's working? Commented Dec 10, 2012 at 4:26
  • 1
    You can install the extension with a few clicks at the Add-on gallery: addons.mozilla.org/en-US/firefox/addon/…. I have added usage notes to Github (and this question's first post), I hope that it's more clear how to use it.
    – Rob W
    Commented Dec 10, 2012 at 14:53
  • @JamesTheAwesomeDude - In your SO profile, click "network user", then grab the uid out of the url. Then in Firefox, just disable and re-enable the extension and the configuration window will pop up and you can paste in your accountId (or "uid" as Rob W calls it)
    – jmort253
    Commented Dec 11, 2012 at 7:17
  • @jmort253 Okay, so in the first box, I need to put 9121977, and the second one needs to have https://stackexchange.com/users/1921977/jamestheawesomedude?tab=inbox, right? Or do I need to put http://stackexchange.com/users/1921977/?tab=inbox? Commented Dec 11, 2012 at 17:39
  • 1
    I faced the following issues: 1) every time I start FF I see add-on config screen. That's a bit annoying( 2) It would be nice to have option to show notification only once for new message(s) - currently it still shows notes once every few minutes until they're still in "Unread" state.
    – Peter L.
    Commented Jan 31, 2013 at 15:35
  • @JamesTheAwesomeDude I was redirected from this META thread: meta.stackoverflow.com/a/165086/208917 QA at your service, good luck with fixes)
    – Peter L.
    Commented Jan 31, 2013 at 21:45
  • 1
    @JamesTheAwesomeDude Unfortunately FF plugin does not work anymore: perhaps SE changed something, but Socket can't start listening... Could you fix please?
    – Peter L.
    Commented Feb 21, 2013 at 19:20
  • @PeterL. Are you still experiencing problems? I'm using the add-on myself, and get notifications as expected. The notifications are triggered whenever a new message is emitted on the Web socket, or when a new message is found after restoring the network connection. If you're seeing multiple notifications, then either the socket connection keeps dropping, or someone has deleted a message, then posted a new one. (PS. I'm the OP, the author of this add-on)
    – Rob W
    Commented May 30, 2013 at 9:52
  • @RobW now it's working fine - about a month ago it was updated automatically (at least it appears so)
    – Peter L.
    Commented May 30, 2013 at 11:13
  • @RobW I am running FF 16.0.1, and the Socket Status flickers between "listening" and "stopped" about once every half-second. Is this to be expected, or no?
    – apnorton
    Commented Aug 1, 2013 at 1:14
  • @anorton That's not the expected behaviour (and does not happen here, FF 22). Consider upgrading your browser, see also this meta question.
    – Rob W
    Commented Aug 1, 2013 at 8:20

I'm probably talking to myself here since it appears nobody except me has been on this page in years, but I figured I should mention that (contrary to my previous comment) the add-in still works just fine, and I've been using the Firefox version daily (minutely?!) for months without issue.

If the developer(s) were around, I'd have a couple minor feature requests, but in the meantime, the add-in does exactly what it says, and is actually more attractive than the original post might lead you to believe...

       img: notification                                 arrow

             image: S.E. Inbox               (As rendered with Firefox 56/Windows 7)

  • 1
    I'm still around. The exact appearance of the desktop notification depends on the browser and operating system. I saw your Github issue and will get back to that later.
    – Rob W
    Commented Apr 13, 2018 at 11:22
  • 1
    The GitHub issue wasn't a big deal - great that's you're still around. Does the app have many active users?
    – ashleedawg
    Commented Apr 13, 2018 at 18:48
  • I don't know, I don't keep track. You could take a look at the extension galleries and sum the shown number of active users to get an estimate.
    – Rob W
    Commented Apr 13, 2018 at 23:05

The Follow Questions and Answers feature is now live across the Network. This allows users to get notifications about any activity on a question when they follow it.

follow question popup

However, this extension does not work properly with the new feature. The extension successfully notifies the user when they have a notification from a followed question, but fails to actually display the notification. As a result, the user has to navigate to the actual Stack Exchange site in order to view the notification.


I seem to have a stuck "1" notification, even though I've read everything in my inbox. Didn't this used to have a "mark as read" button or am I crazy? Either way, how do I make this 1 go away?

enter image description here

  • 1
    Clicking on the "Mark as read" button should work, provided that you're logged in. Do you see a "1" on your inbox when you visit a StackExchange website? Do you see any unread notifications on the website?
    – Rob W
    Commented Jun 19, 2020 at 13:08
  • When I posted this I did not have a "mark as read" button (as mentioned in the post). But it is there now and it did work as expected. Very strange. Commented Jun 19, 2020 at 19:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .