1

I am about to integrate a Stack Overflow app to a third party website / integration service (Zoho).

The third party website's documentation mentioned that the redirect URL is https://deluge.zoho.com/delugeauth/callback.
I gave this URL as the OAuth Domain during stack app registration.

And I did not not enable Client Side OAuth Flow and I enabled Desktop OAuth Redirect Uri.

After I had given all the credentials (Client id,Secret,Authorize url,access token url), I'm getting this message:

redirect_uri is not under the registered domain for this application

Please do help me connect the Stack Exchange API to the third party site. Thanks.

  • (1) Provide a link to that do that documentation. (2) How did you give " all the credentials (Client id,Secret,Authorize url,access token url)"? – Brock Adams Aug 6 at 15:33
0

Note that a URI is not a domain, but this seems to be a common mistake when setting up OAuth2.

Also reference:

So, apparently, on your Stack Apps configuration page you would set OAuth Domain to zoho.com (not deluge.zoho.com, and not to a URL).

Also: Disable Desktop OAuth Redirect Uri in this case.

  • I changed oauth domain to zoho.com and disabled ''Desktop OAuth Redirect Uri". Now after i connect, i'm getting "Processing" message still for infinite time :( – Tamil Student Aug 7 at 18:21
  • That sounds like a new problem and possibly a Zoho issue. You can open a new question for that, but only if you include a Minimal, Reproducible Example. – Brock Adams Aug 7 at 18:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .