3

This is a userscript that converts the selected text to Markdown and allows you to quickly copy it.

It is mainly useful for when copying from comments on posts, where you want to quote the user, or even quoting from a post.

Press Ctrl + Alt + m (m for markdown) to show the prompt for you to copy

Example:

This is a test of the markdown converter

(the source: This <b>is</b> a <i>test</i> of the <a href='http://stackapps.com'>markdown converter</a>)

gets converted to for you to copy:

This **is** a _test_ of the [markdown converter](http://stackapps.com)

It uses the to-markdown converter.

Install it from GitHub Gist

(or view source)

It's only been tested on Chrome, so please post bugs/feature requests here :)

  • 1
    This script is buggy; not clear where to report details. It conflicts with at least some SOX features, like fixing the top bar (that just disappeared), and I was unable to use this comment box with it enabled (clicking Add Comment just reloaded the page). Looks like a potentially useful script, though. – fixer1234 Oct 3 '16 at 0:18
  • 1
    @fixer1234 I can't reproduce the top bar thing, but I can reproduce the comment bug -- I'll try and fix this ASAP :) – ᔕᖺᘎᕊ Oct 16 '16 at 13:05
  • @ᔕᖺᘎᕊ: Thanks for the scripts! I am also unable to use the comment box with it enabled. The inbox and achievements button in the top bar also don't seem to work with this script. – Franck Dernoncourt Jan 1 '17 at 18:05
  • @fixer1234 1 year later... it's fixed! sorry for the delay – ᔕᖺᘎᕊ Jan 1 '17 at 18:23
  • @FranckDernoncourt fixed :) please can you reinstall? – ᔕᖺᘎᕊ Jan 1 '17 at 18:23
  • This was a little confusing, but it worked. It would be helpful to add an instruction that it's a two-step process: ctrl-alt-M, then ctrl-C on the pop-up. The ctrl-C instruction looked like either advice of revision to the interface, or going back to the original comment to do it as a second step. – fixer1234 Jan 1 '17 at 22:48
  • Bad news. Just discovered that it is still interfering with comments. Was just on a thread with a long comment history, with the last comments replaced with the "N more comments" placeholder. Nothing would display the additional comments until I disabled this script. – fixer1234 Jan 1 '17 at 23:49
  • @fixer1234 weird, can't repro on chrome, probably another FF thing ;( sighs and opens FF again :P – ᔕᖺᘎᕊ Jan 1 '17 at 23:57
  • Can't delete comments with this enabled either... – miken32 Sep 12 '17 at 23:43

You must log in to answer this question.

Browse other questions tagged .