1

I am working on a Stack Exchange App (Stack App for Windows 10 PC/Mobile and Windows 8.1 Mobile).

I have a user login set up and using the WebAuthenticationBroker in Universal Windows Platform, to get the access_token. This works fine on Windows 10 Desktop.

But when it comes to Windows 10 Mobile, The login page Hangs after tapping on Login with StackExchange.
By the time I am typing this question, it's almost 28 Mins and it is still running. I tried to enter the URL on my Mobile browser ( Microsoft Edge ) and still the same but it works on my Windows 10 Machine and Tablet.

Below is the screenshot. If you see it hangs @ this page not giving me option to enter my username and password.

enter image description here

During my last 10 Mins of search on this topic using query strings Application Hangs,Login hangs,Authentication Hangs, WebBrowser Hangs I was redirected to this question

Can anyone point me as to what could be the issue?

Part of my **AuthenticationBroker:

string str = string.Format("https://stackexchange.com/oauth/dialog?client_id={0}&scope={1}&redirect_uri={2}", client_id, "no_expiry", "https://stackexchange.com/oauth/login_success");
WebAuthenticationResult WebAuthenticationResult = await WebAuthenticationBroker.AuthenticateAsync(WebAuthenticationOptions.None, new Uri(str),new Uri("https://stackexchange.com/oauth/login_success"));
if (WebAuthenticationResult.ResponseStatus == WebAuthenticationStatus.Success)
{
    RetVal = OutputToken(WebAuthenticationResult.ResponseData);
    _class = await GetProfileData(RetVal);
}
  • @BrockAdams This is after OpenID login options. As I mentioned in my question, This happens after I Tap on Login with StackExchange. – AVK Sep 12 '16 at 22:34
1

I had to change the structure of Authentication on my App. For windows 10, I use AuthenticationBroker but for Windows 10 Phone I used the old WebView Model and completed login implementation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .