I want to create a simple desktop application which connects to my account and shows some information in the status bar. I've been trying to authenticate using OAuth2.0 but I'm getting stuck and I cannot see what I´m doing wrong.

The steps I've followed are:

  1. I've registered my application.
  2. Checked the option "Enable Client Side OAuth Flow".
  3. Call:

  4. I authenticate using my Google account and grant access.

From what I understood after reading the documentation is that I should get a redirect to this URL:


with my token in the query string.

Instead, I'm getting this:


This is the error message:

This application has been registered for implicit grants, and cannot requests codes

I've tried several scope options with the same result.

What am I doing wrong?

2 Answers 2


The implicit flow uses the url https://stackexchange.com/oauth/dialog, not https://stackexchange.com/oauth.

You should just need to change the url, otherwise that looks correct.


The fix for me was unchecking "Enable Client Side OAuth Flow"

  • 1
    Confirmed that this worked for me too. Not sure why it was downvoted. Jan 30, 2014 at 5:17
  • 1
    This worked for me too.
    – user27477
    Jun 10, 2014 at 13:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .