Questions tagged [documentation]

Question pertaining to the documentation provided with the API.

24 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
10 votes
0 answers
127 views

Tell us that POST is required to write

While troubleshooting /posts/{id}/comments/add in order to answer Why am I getting a 404 when trying to post a comment?, it was noticed that the API path in question only responded to POST requests. ...
user avatar
8 votes
0 answers
135 views

Incomplete information in API documentation

I am struggling a little bit with the Stack Exchange API since there seems to be no formal specification for the individual endpoints of the API. Example: Endpoint: https://api.stackexchange.com/2.2/...
user avatar
  • 513
6 votes
0 answers
54 views

Docs say the API returns a user's age, but it doesn't (anymore)

The doc page says that the user object returns an age property (for those users that specified an age). But the API  no  longer  does.   (Plus spot checks of users that had age in ...
user avatar
  • 12.6k
6 votes
0 answers
44 views

API docs for "stack overflow" still feature v1.0 docs

I guess I'd call this a doc bug. Currently the page http://api.stackoverflow.com redirects to http://api.stackoverflow.com/1.0/usage, which says at the top "Don't use 1.0, use 2.1". This URL ...
user avatar
  • 161
5 votes
0 answers
105 views

"What is meta" should be rephrased

Stackapps.com/help/whats-meta tells that there is "Meta Stack Apps". However there isn't. Stack Apps is its own meta and meta is used to ask meta questions here.
user avatar
  • 386
4 votes
0 answers
30 views

Link to applied_count leads to a 404

To Reproduce Run an API query on tag-synonyms, you will get a result that includes something like this: Issue(s) Click on the applied_count link and you get redirected to this page which is a 404. It ...
user avatar
  • 141
4 votes
0 answers
102 views

Parameter `tagged` in `search/advanced` seems to use `AND` instead of `OR`

It seems that search/advanced has the same problem as in "The tagged parameter does not work with multiple tags" question. When I select c#; .net I only get results tagged both c# and .net: http://...
user avatar
3 votes
0 answers
25 views

Browsing method documentation consumes 4 quota units per page

Is it my imagination (scratch that, it's definitely not), or does simply browsing method doc pages (without using the "Run" function) consume quota? From Bash using httpie and jq (on a ...
user avatar
3 votes
0 answers
32 views

"users" link lands on the answer page

On the /users/moderators documentation site, the following link is wrong: This method returns a list of users. The users link mistakenly points to the answers object instead of to the users object....
user avatar
3 votes
0 answers
48 views

Authorization dialog shows wrong API version

If you go on this doc page and click on Get Token, you'll see this: Minor bug, but still, I thought it would be nice to fix this inconsistency :)
user avatar
3 votes
0 answers
35 views

Types missing from the "Member Types" section

The following types are not listed on http://api.stackexchange.com/docs?tab=category#docs under the Member Types section: network_post closed_details original_question Note that it's a nonexhaustive ...
user avatar
  • 263
3 votes
0 answers
39 views

'answer' type has "unchanged in unsafe filters" listed for the wrong field

http://api.stackexchange.com/docs/types/answer says the can_flag field is unchanged in unsafe filters. It's probably meant for the field above it: body_markdown.
user avatar
  • 263
3 votes
0 answers
40 views

Incorrect link parameter on the "Complex Queries" documentation page

The "Complex Queries" documentation page has this link: Of these three posts on Server Fault, the one with the most recent activity where "the one with the most recent activity" links to https://...
user avatar
3 votes
0 answers
70 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
user avatar
  • 131
2 votes
0 answers
46 views

Update Teams API documentation to reflect dependency on tier

The documentation says (emphasis mine): Starting with the release of Stack Overflow For Teams, the Stack Exchange API exposes read-only access to data stored in private Teams. This is slightly ...
user avatar
  • 5,442
2 votes
0 answers
42 views

List /network-activity methods under Network Methods in the documentation

The API methods /users/{id}/network-activity and /me/network-activity, both return a summary of a user's activity across the Stack Exchange network and do not take a site parameter. They are ...
user avatar
  • 5,442
2 votes
0 answers
30 views

.wrapper not sorted correctly in filter edit popup

When editing the filter, e.g. on this API documentation page, all types are sorted alphabetically except for .wrapper which is always shown below answer, instead of above it (or at the end): ...
user avatar
  • 5,442
2 votes
0 answers
39 views

Spelling mistake in API Documentation's "Authentication" page

Can you find the spelling mistake in "Unregistered Users" (last section) of the Authentication page? In case you're not in the mood for games, here is it: This is actually a correct spelling - of ...
user avatar
2 votes
0 answers
22 views

'search_excerpt' type issues

On the search_excerpt page: community_owned_date should be marked as may be absent locked_date should be marked as may be absent search/excerpts should be listed in the Methods That Return This Type ...
user avatar
  • 263
2 votes
0 answers
30 views

New line missing between 'notice' and 'related_site' member types

At the bottom of http://api.stackexchange.com/docs?tab=type#docs under the Member Types section, notice and related_site are on the same line. A <br> is missing between the items.
user avatar
  • 263
2 votes
0 answers
63 views

Clarification on related tags for a tag returned by API

I was assuming that the related tags API call, returns all the tags that co-occur with the input tag. But a closer look at the API documentation indicate the following: Returns the tags that are ...
user avatar
  • 121
1 vote
0 answers
62 views

The authentication doc gives a wrong domain for authentication

The authentication doc page now lists URL's like: https://stackoverflow.com/oauth https://stackoverflow.com/oauth/access_token etc. While these seem to work, the correct domain is stackexchange.com, ...
user avatar
  • 12.6k
1 vote
0 answers
63 views

Get Token button in "Try it" doesn't give me a key in IE11

When I visit for example the timeline docs to try that api I need to get a token first by clicking 'Get Token'. In IE11 (win 7/x64) this is broken. A window does pop-up but there is never a key ...
user avatar
  • 1,810
0 votes
0 answers
12 views

Auto-links to collectives in documentation aren't working

The Collective objects returned by the API, e.g. this method, have a link property that seems to be clickable, just like post and comment IDs in other object types: However, they lead to links like ...
user avatar
  • 5,442