3

Note: This is not the same as The Unofficial Wheel of Blame.

The Stack Exchange chat sites have an Easter egg called "Wheel of Blame" that activates for the current user only. Right now, the only way to activate it is by entering commands into the JavaScript console.

I'm looking for a user script that can execute the requisite commands to activate this built-in Easter egg, without having to open up the JS console and enter the commands myself.

1

Okay, here's a script that adds a button to launch those Easter eggs:

New easter egg button

Once installed, merely select the desired Easter egg from the drop-down then press the EEgg button. (Then weep for the poor puppy you could have petted/walked with that time.)

To install, click here (Chat, Wheel of Blame and other Easter eggs install at GitHub).
(Requires a userscript engine like Tampermonkey or Violentmonkey.)


To preview the source, click here (Chat, Wheel of Blame and other Easter eggs preview at GitHub).


Tested on/with Tampermonkey. Should work with other decent userscript engines...

  • The dropdown shows up twice for me, with the SOUP user script enabled. Disabling SOUP fixes it. – gparyani Mar 28 '18 at 1:39
  • Weird, what URL, exactly, of your chatroom? – Brock Adams Mar 28 '18 at 1:41
  • Also, what engine (Tampermonkey, VM, GM, etc)? Is a/the script installed more than once? – Brock Adams Mar 28 '18 at 1:43
  • It's installed only once. Using Tampermonkey in Edge. Clicking "EEgg" the second dropdown always activates the choice selected in the first dropdown regardless of what's selected in the second, corresponding dropdown. Is this a bug in SOUP? chat.meta.stackexchange.com/rooms/89/tavern-on-the-meta – gparyani Mar 28 '18 at 1:46
  • Ugh, MS Edge. It's probably a bug in Edge or in TM on Edge. Try the following: Shut down Edge and make sure it's killed using Task manager. Restart and retry. ... If still a problem, uninstall the script, restart the browser, and install version 1.1 of the script. If that doesn't work, it's an Edge+TM bug; switch browsers. – Brock Adams Mar 28 '18 at 2:00
  • I don't see any obvious conflicts with SOUP, although that script is doing way too much. And, running version 1.0 (or 1.1) of this script, plus SOUP, on a Chromium based browser doesn't seem to be a problem. IE and Edge are notorious for being problematic... – Brock Adams Mar 28 '18 at 2:19
  • Version 1.1 of the patch fixes it for me in Edge with SOUP running. – gparyani Mar 28 '18 at 3:21
  • Good, but either your instance of Edge needs to be restarted or there is a bug in Tampermonkey on Edge (that SOUP helps trigger). If you are feeling frisky, boil it down to an MCVE and make a TM bug report. Version 1.1 is a just a workaround that should never have been needed (and isn't on other browsers). – Brock Adams Mar 28 '18 at 3:37
  • I filed an issue with the developer of SOUP: github.com/vyznev/soup/issues/35 – gparyani Mar 28 '18 at 17:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .