1

I moved my app to a different server as part of a rewrite, and forgot to update the URL of the app on Stack Apps. When I tried to send a query to https://stackexchange.com/oauth and pass my (old, incorrect) callback URL to the redirect_uri parameter, this is the error I got:

Application Login Failure

An error occurred while login into an application.

Error Details

error description: Cannot return to provided redirect_uri

I’m still debugging, so I don’t know for sure that that was the issue, but either way, this error message could be a lot more helpful. I don’t know if this is the right place to file a bug/question like this, so I’m happy to post this elsewhere.

Update: I pointed the app at my new domain, and it’s working now, so it was a domain mismatch. I’m leaving this open in case it counts as a support request, because this took several hours to debug. Even after I had fixed the domain, I had a typo that meant I was getting the same error message. Just printing out the received and expected URLs would have made the problem instantly clear.

  • 1
    That message at least points in the right direction without compromising security. Printing out the expected URL would be a security hole. Maybe a message to make sure the two URL/domains match -- without providing details? – Brock Adams Jul 4 '14 at 6:34
  • Good point. What about showing the part of the sent parameters that are wrong, and telling you what part of the configuration to look in to see if they match? – Zev Eisenberg Jul 4 '14 at 11:38
  • Might be good. Specify. – Brock Adams Jul 4 '14 at 12:16
  • try this stackexchange.com/oauth/… – Ramesh Kumar Jul 29 '14 at 10:16
  • Hi Ramesh how did you create this link ? I did register my app but my link dosen't work. – Ankita Jain Apr 19 '15 at 17:42