I registered an app and tried to make a couple of requests via Chrome (without actually creating any application yet). The thing that is really confusing is that with making a single request, quota_remaining decreased by a few thousand.


  1. Registered app
  2. Starting quota 10 000
  3. Sent request below (only once, via Chrome): https://api.stackexchange.com/2.2/questions?order=desc&sort=votes&tagged=microservices&site=stackoverflow&filter=!*fZOXQJitmsheGqKd_WMzQ.84jVWfBO.1Sqt*&key=XXXXXX
  4. In response received "quota_remaining":7524, so it already decreased by 2.5k with single request
  5. made request below (again only once, via chrome): https://api.stackexchange.com/2.2/questions?order=desc&sort=votes&tagged=docker&site=stackoverflow&filter=!*fZOXQJitmsheGqKd_WMzQ.84jVWfBO.1Sqt*&key=XXXXXX
  6. In response received "quota_remaining":7463. It is obviously much better than 2.5k decrease, but still decrease by 100 on single request doesn't make any sense to me

I understand, from the documentation, that each single request should decrease quota by 1 only.

Does anyone know if it is expected behavior? And if it is, how to I avoid depleting quota that fast?

  • 1
    Works okay for me (using my own app key). Are you behind a corporate/university/country firewall with a lot of other people? Sure you don't have other SE apps running? May 14, 2015 at 10:32
  • Thanks for checking this request, so it is not a filter issue. I don't have any other SE apps. Yes, I'm behind corporate firewall with about couple of thousands potentially sharing same IP (not sure about this part). Actually before registering an app, I tried this request once without auth, and then few minutes later when I tried similar request on different tag - it said either my quota got depleted or backoff flag and I need to wait ~16000 seconds till next request. After that I decided to try registered app so shared IP wouldn't matter.Do you think corporate network still have some effect May 14, 2015 at 11:16
  • 16000 seconds; that's over 4 hours! Your IP must've been seriously abusing the API. Maybe the quota weirdness is a precursor to a permanent ban? ... Anyway, see the Throttles page: Since you are not using an access_token, the 10K quota limit is shared by everything on your firewall's IP. May 14, 2015 at 11:50
  • it may be explaining everything... I thought &key=XXXXX IS usage of access_token? at least I'm passing access_token as key parameter. I was looking for specific example on how to pass access_token but didn't find any. In app usage with keys/tokens documentation - in key section it says "Pass this as key when making requests against the Stack Exchange API to receive a higher request quota.". So I thought it is all I need. Am I doing something wrong? May 14, 2015 at 12:39
  • 1
    No key and access_token are very different. key identifies an app. access_token identifies a logged-in user of that app. See here for a Q&D example of using an access_token (with the client-side OAuth flow enabled in the app's settings). May 14, 2015 at 12:49


You must log in to answer this question.

Browse other questions tagged .