According to this question, the "could not parse proxy url" bug was solved more than 2 years ago.

However, when using the client-side OAuth flow, the aforementioned error message appears when executing SE.authenticate. Moreover, neither of success and error functions within SE.authenticate are executed. Instead, the user will be redirected to a page that tells him:

Application Login Failure

An error occurred while login into an application.
Error Details

error description: could not parse proxy url

although the login is successful, as the username appears in the page top navbar.

I encountered this error while developing a Firefox add-on that uses Stack Exchange API. You can confirm the bug by visiting this SE documentation page and clicking on the demo "Run Example" button at the bottom of the page.

Important Notice

The bug takes place only when the user is not already logged in. Otherwise, he won't see this error.

  • I tried with both Firefox and Chrome, usual profile and new profile, and all cases have given the same error so far. And I just tried using a remote server (with different OS and internet connection), only to face the same error again. I am beginning to think it has something to do with my user, or rather my choice of OpenID authentication (I use Google OpenID).
    – Linostar
    Feb 15, 2015 at 21:07
  • Tried with SE auth, and it is the same. Made a new dummy account to test with it and got the same error again. I should mention that pressing the "Run Example" for a second time will authenitcate successfully and give the alert box, in all cases. Any ideas?
    – Linostar
    Feb 16, 2015 at 8:30
  • 2
    You might make it clear that this bug only occurs on a cold login. When I completely de-auth a machine and then try the test page, I see the failure as you describe (after being asked to sign in and successfully doing so). Once I am signed in to SE, then the second attempt at auth succeeds. I can see that this would be quite annoying. Feb 16, 2015 at 9:41
  • You're right. I have updated the question now.
    – Linostar
    Feb 16, 2015 at 12:28
  • I just ran into this issue myself. I was also running into a secondary issue. I think I figured out what was causing the second issue but I'm not sure if it's a bug in the SE.authenticate() flow (using the SDK), or working as intended. Basically, if I didn't re-run SE.init() every time I tried to use SE.authenticate() within a single session, the proxy URL would return "undefined" at the end. Now that I figured out how to get around that, I still run into the issue mentioned here.
    – Kizmar
    Feb 18, 2015 at 23:42
  • Also ran into this error. Mar 12, 2016 at 22:12
  • @Linostar I'm also facing this issue. Did you find a solution?
    – yusaku
    Oct 4, 2016 at 21:55
  • @yusaku Unfortunately, no.
    – Linostar
    Oct 5, 2016 at 10:20
  • Oh.. Thanks. I will implement it without the library.
    – yusaku
    Oct 5, 2016 at 16:02
  • is there any fix for this ? Jul 9, 2017 at 5:45


You must log in to answer this question.

Browse other questions tagged .