See symbolhound.com

SymbolHound is was a search engine that doesn't ignore special characters. I was always frustrated that I couldn't search for symbols like >> and && using Google or the custom Stack Overflow search, so I made a search engine for programmers. It currently searches mostly Stack Overflow pages, with plans to eventually index a much wider range of programming websites (including symbols, of course).

This is a problem that I know a lot of other Stack Exchange users have run into. It is frequently asked about:

MSE: Is it possible to search for punctuation/special characters?

SO: How can I use a search engine to search for special characters?

WebApps: How to search the internet for terms with special characters


[email protected]


It uses the open source Apache Nutch and Apache Solr for crawling, indexing, and searching, with a small PHP backend for processing user queries.


Nutch and Solr, which power the backend of SymbolHound, both use the open source Apache license.

  • 6
    +1 I tried it with some Perl variables (which are impossible to search for with Google, etc.) and I'm pleased to report it worked perfectly. Commented Nov 29, 2011 at 22:34
  • 2
    this is really great -- and answers at least a few requests on meta.stackoverflow.com Commented Dec 16, 2011 at 19:50
  • Oddly enough, this was not at the top of the list when I search stackapps for "symbol search" haha. I think it was like 10th down.
    – styfle
    Commented Jan 17, 2012 at 0:54
  • Too bad you can't flag a post "Awesome!"
    – l0b0
    Commented Apr 3, 2012 at 14:40
  • Fantastic work! Just tried several special character "strings" for different languages and all queries where answered topic-related, whereas Google just displayed junk.. o) Searching for "color-stop()" made Symbolhound stall, though!
    – Robert G.
    Commented Apr 18, 2012 at 23:10
  • It doesn't seem to work for me. The following search: ffmpeg -progress does not find the following SO question: stackoverflow.com/questions/40216927/…
    – JoeMjr2
    Commented Mar 7, 2019 at 19:41
  • 5
    I have been a regular but not very frequent user for the last few years. It worked for me up until a few days ago. My browser history shows successful visits on March 17 and 25 and April 4. (Before that, in January, in this browser instance.) Did you shut it down, or are you having technical issues?
    – tripleee
    Commented Apr 13, 2022 at 9:10
  • 4
    I haven't been able to get to symbolhound.com either for a few weeks. I hope it isn't down permanently. It was very useful!
    – raphael75
    Commented May 6, 2022 at 15:41
  • 3
    How frustrating to find something you need, only to discover it's been dead for years…
    – Calion
    Commented Oct 11, 2022 at 20:53
  • 3
    @Calion: it hasn't been down/dead for years. It only went down ~4/2022
    – smci
    Commented Oct 12, 2022 at 0:07
  • 2
    Holy crud! Well, that's irritating…
    – Calion
    Commented Oct 13, 2022 at 1:18

2 Answers 2


Unfortunately there is a bug:

enter image description here

It seems like some of the results for "©" are not from Stack Overflow at all.

  • 1
    Use advanced search.
    – kinokijuf
    Commented Jan 2, 2012 at 20:43
  • Note: this problem doesn't seem to happen with other symbols (like Perl variables, etc.). Commented Jan 2, 2012 at 23:17
  • 6
    Though the site does say it searches multiple sites - "SymbolHound searches a growing index of programming websites", maybe there aren't that many posts with the copyright symbol in them.
    – ChrisF
    Commented Jan 2, 2012 at 23:20
  • 9
    Like ChrisF said, this isn't a bug: SymbolHound is expanding to index sites other than Stack Overflow (currently most searches will still give you almost entirely SO pages, though). There is an advanced search feature that allows you to limit searches to specific sites, if you only want to see SO pages.
    – dncrane
    Commented Jan 6, 2012 at 1:49
  • Ah, thanks for the clarification. I must have missed reading that part :) Commented Jan 6, 2012 at 3:23

Although Google claims to support special characters, it still does not support escape characters.

I tried searching for \w with it and found only three results.

Would you please improve this?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .