Questions tagged [status-completed]

Indicates that a feature request has been implemented, a bug has been fixed, or another type of request has been processed.

Filter by
Sorted by
Tagged with
1 vote
1 answer
51 views

/stats is broken on OnStartups

The following URL is returning an object that is missing some data: http://api.onstartups.stackexchange.com/1.1/stats The entire site object is missing from the returned data. Other sites, such as ...
  • 22.9k
3 votes
1 answer
49 views

The /users/{id}/timeline route is reporting incorrect totals

It seems that the /users/{id}/timeline route is returning an incorrect total. For example, the following URL is reporting a total of 1607 items: http://api.stackapps.com/1.1/users/7789/timeline ......
  • 22.9k
2 votes
1 answer
28 views

Sort ranges on /questions/unanswered is broken

The following API request should return all unanswered questions with a score of at least 30: http://api.stackapps.com/1.1/questions/unanswered?sort=votes&min=30 However, the response consists ...
  • 22.9k
3 votes
1 answer
54 views

What happened to the unique users count?

When visiting https://stackapps.com/apps, I used to be able to see how many unique users were using my application - but now all I see is zeroes for all of the apps. Were the numbers reset or is this ...
  • 22.9k
1 vote
0 answers
55 views

Wrong API response?

Well, if you look here, you'll see i have "down_vote_count": 94, But if you look here on my Stackoverflow profile, you see that my down vote count is 64. For those who would ask if I'm sure ...
  • 113
15 votes
1 answer
384 views

Support Cross-Origin Resource Sharing

Currently, the only way to call the API from javascript is to use JSONP, but this can be cumbersome and has security issues. If the following header was included in all API responses, the API could be ...
  • 786
1 vote
2 answers
96 views

Incorrect Wordpress and Electronics icons

Currently Meta Icon Currently Main Icon With all the other sites (except electronics, which has the same icon for both), Meta has the B&W or sepia icon, while the main site's icon is coloured. ...
  • 3,058
4 votes
1 answer
94 views

When will the API allow posting of questions and answers? [duplicate]

I am planning on building a client for the Stack Exchange Sites, but it seems you cannot post any information via the API yet. Is this going to happen at any time soon? It seems a pain to force users ...
3 votes
1 answer
87 views

How do you retrieve list of users sorted by reputation?

I am failing in my attempt to retrieve results sorted by reputation. For example, the following query sorts the results by ID. Is there an error in the URI? http://api.stackoverflow.com/1.1/users/...
3 votes
1 answer
33 views

Get a list of required tags for site

How can I get the tags which are required, (fulfills_required = true) for each site? Like order/filter the tags route to show the fulfills_required tags first?
  • 3,058
1 vote
1 answer
45 views

/questions/{id}/linked is failing for this question on ServerFault.

This route is reporting an error: http://api.serverfault.com/1.1/questions/45734/linked Incidentally, I discovered this error thanks to my handy tool StackStatus, which runs a status check on the ...
  • 22.9k
4 votes
1 answer
47 views

API usage "Try It" form for linked questions queries meta.tex.stackexchange instead of Stackoverflow

I was wondering why the form at http://api.stackoverflow.com/1.1/usage/methods/linked-questions did not return the questions I was expecting. Then I noticed that it is calling http://api.meta.tex....
  • 606
2 votes
1 answer
43 views

nottagged only works when tagged is set (/search)

On the /search route, the nottagged parameter doesn't work properly (at least it isn't specially documented to only work at certain times) For example: http://api.stackoverflow.com/1.1/search?pagesize=...
  • 3,058
7 votes
2 answers
108 views

Expose the contents of the "accounts" tab of the SE network profile as machine-readable data

It would be really nice if there were a way to get all the data that is displayed on the accounts tab of the Stack Exchange network profile for a user (e.g. mine) as machine-readable data with a ...
  • 623
1 vote
2 answers
60 views

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API
  • 5,022
3 votes
1 answer
179 views

Reputation query doesn't match that on SO

This morning, at 2011-04-06 00:22:38Z, I received a question upvote for this question. That shows up as giving me 5 reputation when looking at the Stack Overflow reputation page. However, when I use ...
  • 283
2 votes
1 answer
57 views

Reputation losses aren't reflected in the API

This includes reputation recalculations (e.g., the latest) and (speculative) when people take upvote back. First case you can see on standard stackauth/users query: it displays meta reputation before ...
  • 1,261
12 votes
2 answers
1k views

Why does this Stack Overflow API query return binary data?

The Stack Overflow API query http://api.stackoverflow.com/1.1/search?tagged=javascript&intitle=%3Cdiv%3E returns what appears to be binary data: ���I�%&/m�{J�J��t��$ؐ@�������iG#)�*��eVe]...
  • 5,022
2 votes
1 answer
66 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
  • 355
1 vote
1 answer
57 views

StackAuth 1.1 API reports a site without a site_name

Calling the StackAuth 1.1 API associated method for a particular user returns one site with no site_name property (the one for which the user_id is 349). I cannot find a matching account in ...
  • 623
0 votes
1 answer
50 views

Why aren't badges paginated?

What is the current reasoning for the badge routes not being paged? Badges (/tags) is probably the current longest route, and it is annoying that this route isn't paginated, but stackauth/sites is. ...
  • 3,058
0 votes
1 answer
58 views

Mismatch between user_id as reported in StackAuth 1.1 (invalid) and 1.0 (valid)

For the association id 1de2e2b0-2fb6-4db6-b90d-d0244ed5d13a, the StackAuth 1.1 call returns an invalid user_id of 73203 for Server Fault whereas the StackAuth 1.0 call returns the correct user_id of ...
  • 623
2 votes
1 answer
114 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } ...
3 votes
1 answer
74 views

API search page size limit mismatch

The 1.1 API help text for search says that the pagesize parameter can go up to 100. Indeed, passing a value up to 100 returns some results, while passing pagesize=101 yields an HTTP 400 status (Bad ...
0 votes
1 answer
75 views

API console always queries Stack Overflow

On any Stack Exchange site (well, I tried Super User (trilogy), Unix (SE-2.0 launched) and SFF (SE-2.0 beta)), the console (“Show Console” button) in the 1.1 API queries http://api.stackoverflow.com/1....
2 votes
1 answer
45 views

The associated accounts are broken once again for this same user

As I reported before (and which was fixed) and again (which was also fixed), the associated accounts are broken once again for for Joel Coehoorn using this query. What's the deal?
4 votes
1 answer
198 views

API ignores jsonp callback after initial request - erroneous caching?

This bug is still prevalent, appears to be cache related. Two identical requests return different data: first request respects jsonp query parameter, all subsequent requests ignore it until (I presume)...
  • 143
1 vote
0 answers
101 views

Can we have the usage pages linked to the side bar?

The usage page for the API used in the blog is a very good reference of the current API methods, and slightly better then the current documentation link in the FAQ. Would it at all be possible to ...
1 vote
1 answer
59 views

The /questions/{id}/linked method is returning extra questions

Consider the following question on ServerFault: https://serverfault.com/questions/45734/the-coolest-server-names Linked questions: Note that there's only two listed. However, querying: http://api....
  • 22.9k
2 votes
1 answer
43 views

The 'total' field of /comments result is showing up as 0.

Running the following query: http://api.stackoverflow.com/1.1/comments Yields: { "total": 0, "page": 1, "pagesize": 30, "comments": [ ... Notice that the total entry indicates there are ...
  • 22.9k
1 vote
1 answer
69 views

The /top-answer-tags method is not working

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
  • 22.9k
3 votes
1 answer
64 views

What happened to the /stats method?

I can't find the /stats method in the new usage documentation. A quick run of http://api.stackoverflow.com/1.1/stats reveals that the method is still there. However, it is not documented.
  • 22.9k
1 vote
1 answer
93 views

fromdate is ignored for /posts/{id}/comments requests

The api docs: http://api.stackoverflow.com/1.0/help/method?method=posts/{id}/comments The test request. You can see comment itself here, it's four months old, while cutoff date in request is less than ...
  • 1,261
22 votes
3 answers
326 views

Changing the display of the apps tab

We're looking at changing the front page of Stack Apps to look more like a proper app "marketplace" and less like a run of the mill Stack Exchange site. Proposal (third draft) This would ...
5 votes
1 answer
55 views

User's display name field omitted?

If a user doesn't have a username "set" for an account, then the display_name field is omitted. This is similar to a few other questions, but the only official answer says that "display_name should ...
  • 225
7 votes
1 answer
72 views

User's Comments: returning 500 error?

It looks like when I try to get the comments of a user that has "a huge number" of comments, I get a 500 error. Jon Skeet's comments, 500 error: http://api.stackoverflow.com/1.0/users/22656/comments ...
  • 225
6 votes
1 answer
107 views

API 'search' method with 'tagged' parameter

From the docs for tagged paremeter: List of tags delimited by semi-colons of which at least one must be on a question Yet, when I execute this query (http://api.stackoverflow.com/1.0/search?tagged=...
  • 1,261
5 votes
1 answer
61 views

You can gain reputation from edits to tag wikis, although they are not accessible through the API.

Reputation gain from edits to tag wikis appear through the API; the API reports them as answers, but fetching them via the /answers route does not work. Case in point: My accepted edit (+2 rep) My ...
  • 935
3 votes
1 answer
111 views

Add Twitter accounts on the /sites route?

Would it be possible to add references to the site Twitter accounts in the /site listing? If your wondering what I'm talking about: blog.stackoverflow.com/2011/01/twitter-question-feeds-for-stack-...
  • 3,058
5 votes
1 answer
73 views

/user/{id}/timeline results leaking template used for badge information

From my elections statistics page: I inserted in the detail field as plain text because I wasn't sure if the results would be HTML, but the $ChatUrl left in the anchor's href is surely a bug.
  • 819
2 votes
1 answer
98 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
  • 4,285
4 votes
0 answers
125 views

Let's delete the off topic questions?

There's like 5 in the top few of the front page and it's a little annoying as they get in the way so can a mod just delete them they serve no useful purpose.
  • 3,058
1 vote
1 answer
73 views

Associated accounts is broken for this user

When I retrieve associated accounts for Joel Coehoorn using this query it only includes Programmers.SE and Webmasters.SE despite the fact that I retrieved the association key from a query to SU. The ...
3 votes
1 answer
82 views

tag colors incorrect

the tag color for english site seem incorrect, the dark grey color is the background while the yellow colour is the foreground. This is contradictory to other sites which have the darker colours as ...
  • 3,058
2 votes
1 answer
125 views

MSO is not being returned in StackAuth's /users/{id}/associated route

In looking into a StackFlair issue, I have discovered that MSO is not being returned as part of a user's associated accounts. Please see my associated accounts according to the api. Note that there ...
2 votes
1 answer
65 views

An associated query is returning a partial record for a particular user

This query returns (in addition to several complete records) this incomplete one: { "user_id": 2196, "user_type": "registered", "display_name": "Wil", "reputation": 151, "email_hash": "...
2 votes
1 answer
565 views

Problem accessing API endpoints from Google App Engine

I'm experiencing a weird problem on StackPrinter hosted on Google App Engine. It seems that the application can't reach several endpoints like Super User or Server Fault; Stack Overflow and other ...
1 vote
1 answer
104 views

Comments are returning markdown.

Look at the output of the following: http://api.askubuntu.com/1.0/questions/12218?comments=true Output: { "comment_id": 12713, "creation_date": 1289269467, "owner": { "user_id"...
  • 22.9k
5 votes
2 answers
157 views

API Help's CSS is missing

The API Help page's CSS file, located at http://sstatic.net/so/all.css, is current returning 404 for me: <div id="header"><h1>Server Error</h1></div> <div id="content"> ...
  • 819
2 votes
1 answer
79 views

/questions/{id}/answers missing title attribute

http://api.stackoverflow.com/1.0/help/method?method=questions/{id}/answers (it won't linkify properly!): "title": { "description": "title of this post, in plaintext", "values": "string", "...
  • 1,522

1 2 3
4
5
7