Questions tagged [status-completed]

Indicates that a feature request has been implemented, a bug has been fixed, or another type of request has been processed.

Filter by
Sorted by
Tagged with
5
votes
1answer
152 views

Few typos in the documentation pages

https://api.stackexchange.com/docs/vectors When passing a vector, sepeate each id with a semicolon. For example, /users/1;2;3;4;5?site=somesite would fetch users with ids 1 through 5 on somesite. ...
3
votes
1answer
110 views

Permission request form is broken, approve button is hidden, css variables are missing

You can check that form doesn't work with this link https://stackoverflow.com/oauth?client_id=17581&scope=no_expiry&redirect_uri=http://functional.localdomain:3449/login/github
3
votes
0answers
89 views

Moderation request: Please make `app-key` a synonym of `api-key`

Refer to Are "api-key" and "app-key" the same thing?. Although I've now retagged the questions that used app-key, there are still plenty of places where the redundant term is ...
3
votes
1answer
82 views

Paging fails at 10K items for /search on any site but Stack Overflow

There's a problem with requesting more than 10,000 items. With Stack Overflow it works just fine. But with Super User, Server Fault, etc. no items are returned for requests for items after the 10,...
3
votes
1answer
81 views

Why is "body" missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
2
votes
1answer
42 views

/answers/{id} summary incorrect

/answers/{id} Gets a set of questions enumerated in id should probably be Gets a set of answers enumerated in id
2
votes
1answer
106 views

API selectively ignores jsonp parameter - havok ensues

UPDATE: this is happening on all routes now and seems to be getting worse. Whatever it is just started this morning. compare url to json response GET /1.0/users/14/badges?key=qgAq_KfDu0KYzlNG-qaTuw&...
2
votes
3answers
148 views

display_name isn't always there (should have OpenID name if needed)

usually in the owner dictionary there is a display_name value to give the username. But in a few questions it simply doesn't exist and I can't see why only those questions: eg, this excerpt from the 0....
2
votes
1answer
66 views

Problem getting a users answers within a date range

This issue is similar to Problem getting a users questions within a date range. Only this time I'm calling a different api and getting unexpected results. I'm calling http://api.stackoverflow.com/0.8/...
2
votes
1answer
74 views

Suddenly, some entries on /questions route are missing display_name

An odd bug has developed this morning. At the moment, api.stackoverflow.com/1.0/questions is returning a question of the format... ... }, { "tags": [ "jsf-2.0" ], "...
2
votes
2answers
128 views

Can we have maximum length of string in API help pages?

For the type "string", I think there is some upper limit of character count. For example, post title : 200 characters post body : 30000 characters In the help page, currently like this "body": { ...
2
votes
1answer
31 views

Can I get more results/options from /users/{ids}/top-answer-tags?

/users/{ids}/top-answer-tags returns the top 30 tags for a given user. It's also the only endpoint that returns the user's tag scores along with the rest of the tag info. I'd like to use this data ...
2
votes
3answers
124 views

StackAuth returning 404?

http://stackauth.com/1.0/sites http://stackauth.com/1.0/help Both of these are currently returning 404 Not Found. What's up with that?
2
votes
1answer
91 views

the stack exchange javascript library is 404

the library listed on the doc page for Authentication https://api.stackexchange.com/js/2.0/all.js ultimately redirects to https://api-v2cdn.sstatic.net/js/all.js which results in varying degrees ...
2
votes
1answer
109 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } ...
2
votes
1answer
62 views

questions/{id} help page sort parameter description is inconsistence with others

The description of the Sort parameter in questions/{id} help page is inconsistent with those of other pages. On the questions/{id} help page: sort (optional): How a collection should be ...
1
vote
1answer
56 views

StackAuth 1.1 API reports a site without a site_name

Calling the StackAuth 1.1 API associated method for a particular user returns one site with no site_name property (the one for which the user_id is 349). I cannot find a matching account in ...
1
vote
1answer
45 views

fromdate is ignored for /posts/{id}/comments requests

The api docs: http://api.stackoverflow.com/1.0/help/method?method=posts/{id}/comments The test request. You can see comment itself here, it's four months old, while cutoff date in request is less ...
1
vote
1answer
73 views

Associated accounts is broken for this user

When I retrieve associated accounts for Joel Coehoorn using this query it only includes Programmers.SE and Webmasters.SE despite the fact that I retrieved the association key from a query to SU. The ...
1
vote
1answer
102 views

Comments are returning markdown.

Look at the output of the following: http://api.askubuntu.com/1.0/questions/12218?comments=true Output: { "comment_id": 12713, "creation_date": 1289269467, "owner": { "user_id"...
0
votes
1answer
56 views

Mismatch between user_id as reported in StackAuth 1.1 (invalid) and 1.0 (valid)

For the association id 1de2e2b0-2fb6-4db6-b90d-d0244ed5d13a, the StackAuth 1.1 call returns an invalid user_id of 73203 for Server Fault whereas the StackAuth 1.0 call returns the correct user_id of ...

1
2