Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [status-completed]

Indicates that a feature request has been implemented, a bug has been fixed, or another type of request has been processed.

1
vote
0answers
95 views

Can we have the usage pages linked to the side bar?

The usage page for the API used in the blog is a very good reference of the current API methods, and slightly better then the current documentation link in the FAQ. Would it at all be possible to ...
1
vote
1answer
50 views

The /questions/{id}/linked method is returning extra questions

Consider the following question on ServerFault: https://serverfault.com/questions/45734/the-coolest-server-names Linked questions: Note that there's only two listed. However, querying: http://api....
2
votes
1answer
42 views

The 'total' field of /comments result is showing up as 0.

Running the following query: http://api.stackoverflow.com/1.1/comments Yields: { "total": 0, "page": 1, "pagesize": 30, "comments": [ ... Notice that the total entry indicates there are ...
1
vote
1answer
68 views

The /top-answer-tags method is not working

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
3
votes
1answer
62 views

What happened to the /stats method?

I can't find the /stats method in the new usage documentation. A quick run of http://api.stackoverflow.com/1.1/stats reveals that the method is still there. However, it is not documented.
1
vote
1answer
42 views

fromdate is ignored for /posts/{id}/comments requests

The api docs: http://api.stackoverflow.com/1.0/help/method?method=posts/{id}/comments The test request. You can see comment itself here, it's four months old, while cutoff date in request is less ...
22
votes
3answers
281 views

Changing the display of the apps tab

We're looking at changing the front page of Stack Apps to look more like a proper app "marketplace" and less like a run of the mill Stack Exchange site. Proposal (third draft) This would replace ...
5
votes
1answer
47 views

User's display name field omitted?

If a user doesn't have a username "set" for an account, then the display_name field is omitted. This is similar to a few other questions, but the only official answer says that "display_name should ...
7
votes
1answer
66 views

User's Comments: returning 500 error?

It looks like when I try to get the comments of a user that has "a huge number" of comments, I get a 500 error. Jon Skeet's comments, 500 error: http://api.stackoverflow.com/1.0/users/22656/comments ...
6
votes
1answer
94 views

API 'search' method with 'tagged' parameter

From the docs for tagged paremeter: List of tags delimited by semi-colons of which at least one must be on a question Yet, when I execute this query (http://api.stackoverflow.com/1.0/search?tagged=...
5
votes
1answer
59 views

You can gain reputation from edits to tag wikis, although they are not accessible through the API.

Reputation gain from edits to tag wikis appear through the API; the API reports them as answers, but fetching them via the /answers route does not work. Case in point: My accepted edit (+2 rep) My ...
3
votes
1answer
103 views

Add Twitter accounts on the /sites route?

Would it be possible to add references to the site Twitter accounts in the /site listing? If your wondering what I'm talking about: blog.stackoverflow.com/2011/01/twitter-question-feeds-for-stack-...
5
votes
1answer
68 views

/user/{id}/timeline results leaking template used for badge information

From my elections statistics page: I inserted in the detail field as plain text because I wasn't sure if the results would be HTML, but the $ChatUrl left in the anchor's href is surely a bug.
2
votes
1answer
97 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
4
votes
0answers
122 views

Let's delete the off topic questions?

There's like 5 in the top few of the front page and it's a little annoying as they get in the way so can a mod just delete them they serve no useful purpose.
1
vote
1answer
72 views

Associated accounts is broken for this user

When I retrieve associated accounts for Joel Coehoorn using this query it only includes Programmers.SE and Webmasters.SE despite the fact that I retrieved the association key from a query to SU. The ...
3
votes
1answer
78 views

tag colors incorrect

the tag color for english site seem incorrect, the dark grey color is the background while the yellow colour is the foreground. This is contradictory to other sites which have the darker colours as ...
2
votes
1answer
116 views

MSO is not being returned in StackAuth's /users/{id}/associated route

In looking into a StackFlair issue, I have discovered that MSO is not being returned as part of a user's associated accounts. Please see my associated accounts according to the api. Note that there ...
2
votes
1answer
60 views

An associated query is returning a partial record for a particular user

This query returns (in addition to several complete records) this incomplete one: { "user_id": 2196, "user_type": "registered", "display_name": "Wil", "reputation": 151, "email_hash": "...
2
votes
1answer
548 views

Problem accessing API endpoints from Google App Engine

I'm experiencing a weird problem on StackPrinter hosted on Google App Engine. It seems that the application can't reach several endpoints like Super User or Server Fault; Stack Overflow and other ...
1
vote
1answer
100 views

Comments are returning markdown.

Look at the output of the following: http://api.askubuntu.com/1.0/questions/12218?comments=true Output: { "comment_id": 12713, "creation_date": 1289269467, "owner": { "user_id"...
5
votes
2answers
151 views

API Help's CSS is missing

The API Help page's CSS file, located at http://sstatic.net/so/all.css, is current returning 404 for me: <div id="header"><h1>Server Error</h1></div> <div id="content"> ...
2
votes
1answer
73 views

/questions/{id}/answers missing title attribute

http://api.stackoverflow.com/1.0/help/method?method=questions/{id}/answers (it won't linkify properly!): "title": { "description": "title of this post, in plaintext", "values": "string", "...
2
votes
1answer
34 views

/questions/id route problem: comments section is not returned when there aren't comments on question

Something is changed on questions route called with comments= True: http://api.stackoverflow.com/1.0/questions/1940243?body=True&comments=True&pagesize=1&page=1 It does not return the ...
2
votes
3answers
113 views

StackAuth returning 404?

http://stackauth.com/1.0/sites http://stackauth.com/1.0/help Both of these are currently returning 404 Not Found. What's up with that?
2
votes
1answer
72 views

Suddenly, some entries on /questions route are missing display_name

An odd bug has developed this morning. At the moment, api.stackoverflow.com/1.0/questions is returning a question of the format... ... }, { "tags": [ "jsf-2.0" ], "...
2
votes
1answer
113 views

AskUbuntu API returns wrong colours

Calling the stats method of the AskUbuntu API returns the wrong colours.
4
votes
1answer
866 views

Wrong content-type in JSONP calls

When passing jsonp parameter, the API returns "application/json" instead of "application/javascript". I found this because if you do: <script src='http://api.stackoverflow.com/1.0/badges?jsonp=...
4
votes
1answer
210 views

update crossdomain.xml on stackauth.com and api endpoints to work with current Flash

I am implementing a javascript client that uses the Flash based XHR replacement Flensed in the interest of providing more robust api communication than that provided by JSONP. Apparently the current ...
11
votes
2answers
183 views

Detecting StackExchanges with non-standard “plugins” (e.g. MathJax)

Some recent StackExchanges are starting to include site specific 3rd party JavaScripts - for example, cstheory.stackexchange.com (and math.stackexchange.com) both use what I think is MathJax to render ...
1
vote
3answers
255 views

Icons of beta sites

Icons of beta sites are different form the icons given in the http://stackauth.com/1.0/sites . As example: Original icon of the English Language and Usage is http://sstatic.net/english/img/favicon....
6
votes
1answer
184 views

Please add tags to answers

Update: This was completed as of API version 2.1. When querying any API method which returns answers (/users/ids/answers, /answers/ids, etc.) the result does not include the tag information for the ...
2
votes
1answer
94 views

stackapps favicon inconsistent rendering

A lot of us are using the favicon in our apps as it is a quite convenient size. It seems that IE does not like the stackapps favicon palette and renders the background black. While I do cache the ...
5
votes
1answer
85 views

Empty results for associated queries

Queries such as this http://stackauth.com/1.0/users/f5388585-c0b9-417f-99c5-f1a58fda3e83/associated have started giving empty results { "associated_users": [] } Expected results: SiteUrl ...
3
votes
2answers
68 views

Sorting comments by votes doesn't return 0 score comments

I have a query: http://api.stackoverflow.com/1.0/users/16822/comments?sort=votes This doesn't return comments with no votes, setting min to 0 doesn't work. This query includes them all, but isn't ...
4
votes
3answers
1k views

API usage triggering 503 (Too Many Requests)

Update: I generally try to back any claims of bugs and shortcomings with evidence. I have prepared a test page which you, dear Stack Overflow staff and my fellow developers, can use to ascertain ...
2
votes
1answer
102 views

API selectively ignores jsonp parameter - havok ensues

UPDATE: this is happening on all routes now and seems to be getting worse. Whatever it is just started this morning. compare url to json response GET /1.0/users/14/badges?key=qgAq_KfDu0KYzlNG-qaTuw&...
2
votes
1answer
69 views

API is completely down? content encoding is broken?

all requests have no content-encoding or have 'gzip,gzip', both of which fail to decompress browser side. note: the content-encoding header, when it is present, does not seem to be included in the ...
3
votes
1answer
64 views

key not being recognized by api.meta.stackoverflow.com?

I have been testing a throttle implementation against meta today and suddenly got shut down with a key violation. It is possible that I have used enough requests to prompt this but I doubt it. In ...
6
votes
0answers
60 views

OBSOLETE - /tags fromdate and todate does nothing

Although the help/documentation lists todate and fromdate parameters for tags they do not work. This may be related to tags not having a creation_date. It would be great if we could filter tags by ...
3
votes
1answer
64 views

Badges with zero count no longer returning zero

For queries such as http://api.{sitename}.com/1.0/users/{id} if a badge count is zero, the API is no longer returning "gold": 0, for example.
2
votes
1answer
195 views

Add 'linked' question data to the API

SE sites show linked questions on the right column. It would be great to add an array of ids to the question response called 'linked'. Example Linked Question
6
votes
5answers
508 views

Where can I find the reputation black market?

Apparently there is one around, at least I can't explain the recent jump in reputation of 4k for user 1026 by any other means (just kidding of course, no offense please ;) The API Beta badge accounts ...
4
votes
1answer
69 views

Encoding inconsistency on /users/{id}/reputation

Take these two calls: http://api.stackoverflow.com/1.0/users/180784/reputation?todate=1278854265&pagesize=1 "title": "Save a custom ListView&#39;s instance state?", http://api.stackoverflow....
2
votes
2answers
63 views

Provide a way to discover associated meta sites

Currently, the API doesn't specify what the associated Meta site is for a certain site (I'm talking about the stackauth.com/1.0/sites route). Sure, we could just prepend "meta." to the domain name, ...
4
votes
2answers
86 views

/users/{id}/answers - broken

Have not checked other routes, as I am busy with other things, but a failing test pointed this out... GOOD: http://api.stackoverflow.com/1.0/users/242897/answers?min=4&sort=votes { "total": 37,...
3
votes
1answer
68 views

server fault and super user rate limit bonus?

Looks like SF and SU are granting Int.MaxValue rate limit. Not that I mind, but it would be nice to have on the other sites too. ;-) Thought you would like to know. GET /1.0/users/173?key=mykey HTTP/...
4
votes
1answer
115 views

questions method returns error 4000

I'm getting error 4000 on every endpoint on questions method (with key): http://api.superuser.com/1.0/questions?sort=votes&pagesize=30&page=1&key=stackprinterkey the only endpoint not ...
7
votes
3answers
308 views

When does the judging take place?

I am planning to work some more on my apps tomorrow and get some last minute changes implemented. However, I notice that: The API Contest winners will be picked the first week of August. ...which ...
5
votes
2answers
109 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).