Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

Questions tagged [status-completed]

Indicates that a feature request has been implemented, a bug has been fixed, or another type of request has been processed.

Filter by
Sorted by
Tagged with
4
votes
2answers
97 views

Possible bug in the help page?

There are some weird dot things in this help page: api.stackoverflow.com/0.8/help/method?method=users/{id}/badges {Dead link to missing image: http://files.quickmediasolutions.com/stackbug.png} ...
3
votes
0answers
61 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
4
votes
2answers
58 views

Should we “Burninate” the [stack-exchange] tag?

The Stack Apps topic help makes it clear that all questions here must pertain to Stack Exchange in some way: If your question is about … the Stack Exchange API applications built on the ...
7
votes
2answers
79 views

Expose the contents of the “accounts” tab of the SE network profile as machine-readable data

It would be really nice if there were a way to get all the data that is displayed on the accounts tab of the Stack Exchange network profile for a user (e.g. mine) as machine-readable data with a ...
1
vote
2answers
88 views

Incorrect Wordpress and Electronics icons

Currently Meta Icon Currently Main Icon With all the other sites (except electronics, which has the same icon for both), Meta has the B&W or sepia icon, while the main site's icon is coloured. ...
8
votes
2answers
108 views

Stack Apps homepage truncates user names

A picture says more than a thousand words: These users aren't called "Bhargav Rac" and "Tunak", but Bhargav Rao and Tunaki. This happens on both the 'apps' and 'scripts' tabs of the Stack Apps ...
2
votes
1answer
59 views

Default listing images aren't served from CDN, fail to load because of certificate error

The default images used on the app/script/library pages aren't pointing to the CDN, so their use of HTTPS causes a certificate error that prevents the image from loading: Could the image sources ...
3
votes
0answers
145 views

OAuth Dialog rendering problems in iPad

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: (...
3
votes
0answers
72 views

Only Stack Overflow has documentation, but the API erroneously lists documentation privileges for all sites

Privileges related to Stack Overflow Documentation are displaying in every other site's API data. Using Meta Stack Exchange, for example, /2.2/privileges?site=meta returns the following documentation ...
1
vote
3answers
264 views

Icons of beta sites

Icons of beta sites are different form the icons given in the http://stackauth.com/1.0/sites . As example: Original icon of the English Language and Usage is     where http://stackauth....
1
vote
1answer
53 views

Why am I getting an “Access token sent over non-HTTPS request, it has been invalidated” message?

I've been using the Stack Overflow for Teams API for a while now, but since yesterday it stopped working for one of the Teams; that Team also wasn't listed in the Applications (https://stackoverflow....
2
votes
1answer
71 views

The new implicit authentication dialog doesn't handle comma-delimited scopes

The authentication docs state that the scopes parameter of the URL to which a user should be directed to, for implicit authentication, should be a list of scopes that are delimited by either commas or ...
5
votes
0answers
37 views

OBSOLETE - revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
2
votes
1answer
90 views

Why answers don't have a “locked” attribute?

When looking at an answer, I can see that there is no locked_date attribute, like there is for questions. IIRC, answers can be locked by moderators. Also, if a post is unlocked, is that field ...
3
votes
1answer
90 views

Are we going to get a Protected Date field in Question responses?

Now that questions can be marked protected, will this info be available via the API?
3
votes
1answer
2k views

SIlverlight 3 ClientHttp vs BrowserHttp stack: no cross domain policy means no gzip for Silverlight

I notice that even if I send accept-encoding=gzip the response does not seem to be compressed. ( it is late and i was conflating 'accept' with 'accept-encoding') Should we expect, in the 1.0 ...
3
votes
1answer
80 views

top-answerers / top-askers documentation bug: number of results returned incorrect

The top-answerers-on-tags and top-askers-on-tags documentation claim: Returns the top 30 answerers active in a single tag, of either all-time or the last 30 days. and Returns the top 30 askers ...
0
votes
0answers
24 views

Strange pagination behaviour of /search/excerpts [duplicate]

In an attempt to (automatically) restore broken images* which have originally been included as HTTP links, I've tried to use /search/excerpts to look for candidate posts; specifically, I'm setting the ...
3
votes
1answer
62 views

Paging fails at 10K items for /search on any site but Stack Overflow

There's a problem with requesting more than 10,000 items. With Stack Overflow it works just fine. But with Super User, Server Fault, etc. no items are returned for requests for items after the 10,...
4
votes
1answer
66 views

/questions returns wrong markdown when a suggested edit is improved

The /questions API method returns wrong markdown when the last revisions were made by a suggested edit improved in the review queue. This event leads to two revisions (one for the suggested edit and ...
5
votes
0answers
94 views

“What is meta” should be rephrased

Stackapps.com/help/whats-meta tells that there is "Meta Stack Apps". However there isn't. Stack Apps is its own meta and meta is used to ask meta questions here.
1
vote
1answer
33 views

New questions on live home page display improperly

I was browsing Stack Apps earlier today and a little box popped up indicating that there were new questions. It looked something like this: After clicking the provided link, here is what was ...
1
vote
0answers
48 views

Stack Apps “Welcome Back” banner text isn't centered

This appear to be specific to Stack Apps. The text is centered on every other site I've tried. See below: Compared to how it should appear:
-2
votes
1answer
105 views

“text/plain” content type header for x-www-form-urlencoded content? [duplicate]

I'm getting the following response body and header from https://stackoverflow.com/oauth/access_token when attempting to exchange an oauth code for a token: <DEBUG> [00:30:03] my-app - content-...
3
votes
1answer
193 views

Stack Exchange OAuth2, explicit access-token response format does not adhere to RFC6749 standard

I'm using the Stack Exchange v2.1 API. I'm using the explicit OAuth 2.0 flow, but it seems that the access token response step does not adhere to the RFC 6749 standard. Specifically, the Stack ...
6
votes
0answers
61 views

OBSOLETE - /tags fromdate and todate does nothing

Although the help/documentation lists todate and fromdate parameters for tags they do not work. This may be related to tags not having a creation_date. It would be great if we could filter tags by ...
8
votes
1answer
128 views

“Informed” badge shown as Next badge, but doesn't exist on this site

On my profile page, the Informed badge is shown as the next badge to obtain: Clicking it even shows a popup with a link to the Tour page, but it looks quite different from other SE sites. Looking at ...
8
votes
1answer
575 views

Keep getting HTTP 406

Not sure if this is a user or an API problem, but I keep getting HTTP 406 Not Acceptable when making API calls (for example http://api.stackoverflow.com/0.8/stats) from either IE 8 or Chrome 6. Here ...
5
votes
1answer
75 views

Typos on api.stackexchange.com/docs/js-lib

Under the Authentication section on https://api.stackexchange.com/docs/js-lib, there are a few typos (emphasis mine): scope (optional) – an array of scopes to request during authentication, valid ...
3
votes
1answer
41 views

The /users/{id}/timeline route is reporting incorrect totals

It seems that the /users/{id}/timeline route is returning an incorrect total. For example, the following URL is reporting a total of 1607 items: http://api.stackapps.com/1.1/users/7789/timeline ......
3
votes
0answers
78 views

Moderation request: Please make `app-key` a synonym of `api-key`

Refer to Are "api-key" and "app-key" the same thing?. Although I've now retagged the questions that used app-key, there are still plenty of places where the redundant term is ...
5
votes
0answers
94 views

Moderation request: Make [user] a synonym of [users]

Please make user a synonym of users. I proposed a synonym but there aren't enough high-rep users active here for that mechanism to work. Currently*: user has 5 questions, no tag wiki and no tag ...
4
votes
1answer
329 views

Invisible text in Markdown syntax help

Some text is invisible in the How to Format help block because of a bad combination of text and background color: That's meant to read ► backtick escapes `like _so_` but the backquoted portion is ...
3
votes
1answer
75 views

Why is “body” missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
3
votes
1answer
103 views

Add Twitter accounts on the /sites route?

Would it be possible to add references to the site Twitter accounts in the /site listing? If your wondering what I'm talking about: blog.stackoverflow.com/2011/01/twitter-question-feeds-for-stack-...
8
votes
1answer
108 views

Bug with `badges/name` endpoint

Last night I had a programme running and it errored on the first call to the badges/name endpoint on the API, exact API endpoint call: https://api.stackexchange.com/2.2/badges/name?order=asc&sort=...
6
votes
1answer
141 views

JavaScript SDK-based workflow never pushes message back from OAuth login_success page on Stack Exchange side

I'm using the JavaScript SDK by Stack Exchange provided with the latest API, and despite following the official instructions & examples it doesn't work - it seems there is a bug which breaks the ...
5
votes
2answers
189 views

Can we not limit requests based on the first one?

According to the answer given to this question, it seems like the API limits requests based on the first one. (Regardless of the presence of a key.) Can this please be changed? It really hinders ...
1
vote
1answer
116 views

Implicit Flow Isn't Redirecting

I'm using the WebAuthenticationBroker to allow users to log in to their account: var accessToken = ""; var uri = "https://stackexchange.com/oauth/dialog?redirect_uri=https://localhost.com&...
1
vote
0answers
95 views

Can we have the usage pages linked to the side bar?

The usage page for the API used in the blog is a very good reference of the current API methods, and slightly better then the current documentation link in the FAQ. Would it at all be possible to ...
6
votes
1answer
185 views

Please add tags to answers

Update: This was completed as of API version 2.1. When querying any API method which returns answers (/users/ids/answers, /answers/ids, etc.) the result does not include the tag information for the ...
1
vote
1answer
50 views

The /questions/{id}/linked method is returning extra questions

Consider the following question on ServerFault: https://serverfault.com/questions/45734/the-coolest-server-names Linked questions: Note that there's only two listed. However, querying: http://api....
1
vote
1answer
68 views

The /top-answer-tags method is not working

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
2
votes
1answer
62 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
3
votes
2answers
288 views

Key Limit is 10k or 100k?

Getting Started FAQ Question says 10k API "Hello World" code But I see 100k on Response Header X-RateLimit-Max 100000 X-RateLimit-Current 99993 Just typo in nginx setting or something ...
6
votes
1answer
66 views

Descriptions of tag-based badges are incorrect

The descriptions associated to tag-based badges are wrong, they always show 0 instead of actual thresholds: Earned at least 0 total score for at least 0 non-community wiki answers in the … tag See ...
4
votes
1answer
312 views

Login using Google fails saying OpenID 2.0 accounts for Google has gone away

Recently I have received complaints about my app suggesting that logging in with a Google account shows a warning message that OpenID authentication has gone away. When I tried to log in with my own ...
8
votes
2answers
148 views

Plans to expose details from the “accounts” tab of the user page?

One thing that I noticed was missing from the /users/ API was an ability to see what other Stack Exchange sites the user is associated with (what's usually available from the "accounts" tab of the ...
20
votes
3answers
446 views

Should there be a discovery API?

It would seem to me that a simple API that return an array of the API base URL and perhaps the common name of the sites that support the API would be valuable. Is this sensible? EDIT: This is what I ...
15
votes
1answer
406 views

Bug in the StackExchange Api ? getting “could not parse proxy url” when user not logged in

I think I may have stumbled upon a bug in the Stack Exchange JS API I'm having a problem getting its authentication to work properly, and I just discovered that the same problem exist in the official ...