Skip to main content

Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
1 vote
0 answers
509 views

OAuth login fails for Stack Exchange and Facebook, but not Google

I'm integrating with Stack Exchange API on iOS 6 & 7. To authenticate, I load up a UIWebView with the OAuth page. Google login works well, but Stack Exchange and Facebook do not. Are these ...
Pwner's user avatar
  • 185
1 vote
0 answers
64 views

Get Token button in "Try it" doesn't give me a key in IE11

When I visit for example the timeline docs to try that api I need to get a token first by clicking 'Get Token'. In IE11 (win 7/x64) this is broken. A window does pop-up but there is never a key ...
rene's user avatar
  • 2,622
1 vote
0 answers
235 views

/oauth/access_token not redirecting back to my redirect_uri

I am trying to implement Stack Exchange using oAuth 2.0. I am able to get CODE but, when I try to get access_token through this code: <?php if(isset($_GET['code'])) { ?> <form method="...
Amit Parmar's user avatar
1 vote
0 answers
27 views

The 2.1, "similar" path is returning empty results

I've been a happy user of the /2.1/similar Stack Exchange API for a while. But, at some point within the last 24 hours, or so, it started returning empty results (but otherwise reporting everything as ...
kamstrup's user avatar
1 vote
0 answers
163 views

Unread messages in inbox query shows older inbox messages

I am using the /inbox/unread route to get the unread messages in a user's inbox. Recently (over the last couple of months, perhaps) I have noticed that the entries returned from this route initially ...
Greg Hewgill's user avatar
  • 3,883
1 vote
1 answer
44 views

The inname parameter does not work with multiple parameters

I am trying to get details by passing semicolon delimited list in inname paramter but it is not working. I tried below API call: https://api.stackexchange.com/2.0/tags?order=desc&sort=popular&...
Devarshi's user avatar
  • 125
1 vote
0 answers
61 views

Stack Apps "Welcome Back" banner text isn't centered

This appear to be specific to Stack Apps. The text is centered on every other site I've tried. See below: Compared to how it should appear:
animuson's user avatar
  • 199
1 vote
1 answer
38 views

API 2.0 is not returning Programmers in list of sites

Run https://api.stackexchange.com/2.0/sites. programmers.stackexchange.com is not in the response.
Adam's user avatar
  • 809
1 vote
1 answer
68 views

Site_Type returns "main_site" for meta.stackoverflow.com

For Meta Stack Overflow, the 2.0/sites endpoint returns "main_site" rather than "meta_site". All other site_type for other stackexchange sites return correctly. URL: https://api.stackexchange.com/2.0/...
Crashthatch's user avatar
1 vote
1 answer
36 views

Answer up/down vote count not being returned in filter

As the picture shows, the up_vote_count and down_vote_count answer properties are selected but not returned. What gives?
Charles Sprayberry's user avatar
1 vote
1 answer
47 views

There is a typo in the authentication documentation

There is a typo on this documentation page. It says "The explcit OAuth 2.0 flow" but it should say "The explicit OAuth 2.0 flow".
user avatar
1 vote
1 answer
30 views

/users/{ID}/reputation is returning a 500 error.

The following API request: http://api.stackexchange.com/2.0/users/235/reputation?filter=%21DnBO_&site=askubuntu&page=1 ...is returning an error: { error_id: 500, error_name: "...
Nathan Osman's user avatar
  • 23.3k
1 vote
1 answer
48 views

Failed beta sites are showing up in the /sites method.

3D Graphics and Game of Go are both failed beta sites. I would not expect them to show up in the /sites list - but they do. Indeed, attempting to list questions on one of the sites fails: http://...
Nathan Osman's user avatar
  • 23.3k
1 vote
1 answer
31 views

Runtime error getting thrown with certain parameters on older 1.1 methods

This v1.1 URL is creating a runtime error: http://api.stackapps.com/1.1/comments&min=1323731212 Example output:
Nathan Osman's user avatar
  • 23.3k
1 vote
1 answer
26 views

questions/{id} API not working as intended for vectorized id

Show Console > Try it > Call Method button on questions/{id} API page is not working properly for vectorized id ie. when I am passing 7282205 it is working fine, but when I am passing- 7282205; ...
Devarshi's user avatar
  • 125
1 vote
0 answers
55 views

Wrong API response?

Well, if you look here, you'll see i have "down_vote_count": 94, But if you look here on my Stackoverflow profile, you see that my down vote count is 64. For those who would ask if I'm sure ...
genesis's user avatar
  • 113
1 vote
0 answers
35 views

API does not return stackoverflow user_id?

When I visit http://stackauth.com/1.1/users/aa1073f7-7e3b-4d4d-ace5-f2fca853f998/associated it returns my user_id on many stackexchange sites, but not stackoverflow itself! I'm sure this is by ...
user avatar
1 vote
0 answers
33 views

What has happened to the revision history of this answer?

This is rather odd. Consider this answer. The current content of the answer according to http://api.meta.stackoverflow.com/1.1/answers/81451?body=true is: ...<img src="https://i.sstatic.net/...
Nathan Osman's user avatar
  • 23.3k
1 vote
1 answer
69 views

The /top-answer-tags method is not working

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
Nathan Osman's user avatar
  • 23.3k
1 vote
1 answer
123 views

Confusion over my API key

This is directed at the team, since nobody else will be able to help. The key I took out for StackMobile is behaving strangely. I make a few requests, and then the limit resets to 0. (By limit, I'm ...
Nathan Osman's user avatar
  • 23.3k
1 vote
1 answer
61 views

/users - fromdate/todate broken

consider: All users on meta : "total": 18923, http://api.meta.stackoverflow.com/0.8/users?sort=creation&order=desc Users created on meta in the last month: "total": 18923, http://api.meta....
Sky Sanders's user avatar
  • 12.1k
1 vote
1 answer
44 views

help page format issue: missing parameter

/users/{id}/tags is missing id parameter fixing this will remove one more special case from my parser.
Sky Sanders's user avatar
  • 12.1k
0 votes
2 answers
89 views

Answers suddenly not getting returned.

Try: http://api.stackapps.com/0.8/questions/212 None of the answers are present.
Nathan Osman's user avatar
  • 23.3k
0 votes
1 answer
89 views

Why does the /events service sometimes pause for a couple of minutes?

In developing the firehose service, I found that the /events API often "pauses" for a couple of minutes before resuming. Is this a known issue? Specifically, I am polling /events every 10 seconds ...
Greg Hewgill's user avatar
  • 3,883
0 votes
1 answer
104 views

Getting garbage on requests

Not exactly sure how or why, but many times when I try and preview some URL, I get garbage. This has happened on several JSON preview websites as well as on my browser. Strangely this isn't all the ...
TheLQ's user avatar
  • 150
0 votes
1 answer
66 views

2.0 tags API returns only created tags

Searching for tags, using the inname parameter AND a date range returns only the tags that were created in that period, not the tags that were used in that period. When searching by inname only, or ...
Kevin's user avatar
  • 101
0 votes
1 answer
85 views

stackauth.com/1.0/users/{id}/associated not returning display_name for some sites

The problem with email_hash seems to be fixed, but now display_name is not getting returned in some cases. For example: This Super User /users/{id} query returns a display_name, but the corresponding ...
Dennis Williamson's user avatar
0 votes
1 answer
36 views

/questions/unanswered and /tags allow id parameter, but it does nothing

The /questions/unanswered and /tags queries both document (as required) and allow an "id" parameter. You can use it as /questions/unanswered?id=1;2;3, but it does nothing (that I can tell) and doesn't ...
ColinD's user avatar
  • 369
0 votes
1 answer
142 views

"Get an API key" on stackapps.com/about page is incorrect

the "Get an API key" link listed on the stackapps about page is incorrect. It points to https://stackapps.com/app/register and a lovely picture of Zardoz instead of the correct https://stackapps.com/...
Greg Bray's user avatar
  • 175
0 votes
1 answer
73 views

Multiple tags come back unordered

I am using https://api.stackexchange.com/docs/wikis-by-tags#tags=c%23%3Bsql%3Bexcel%3Bphp&filter=default&site=stackoverflow and the response is "items": [ { "...
JMP's user avatar
  • 345
0 votes
1 answer
65 views

Removing/disallowing app does nothing

I have just deleted/disallowed, the console app and the app I'm currently writing. For the console the access token I was using before deleting the app carried on working, and when I got a new token, ...
Jonathan.'s user avatar
  • 3,118
0 votes
1 answer
59 views

Mismatch between user_id as reported in StackAuth 1.1 (invalid) and 1.0 (valid)

For the association id 1de2e2b0-2fb6-4db6-b90d-d0244ed5d13a, the StackAuth 1.1 call returns an invalid user_id of 73203 for Server Fault whereas the StackAuth 1.0 call returns the correct user_id of ...
Isaac's user avatar
  • 665
0 votes
1 answer
81 views

API console always queries Stack Overflow

On any Stack Exchange site (well, I tried Super User (trilogy), Unix (SE-2.0 launched) and SFF (SE-2.0 beta)), the console (“Show Console” button) in the 1.1 API queries http://api.stackoverflow.com/1....
Gilles 'SO- stop being evil''s user avatar
0 votes
1 answer
63 views

Bug - Getting partial results for questions

When processing http://api.stackoverflow.com/1.0/questions/1156985 I only get partial results. Many of the missing fields are mandatory fields, including the owner of the question.
user avatar
0 votes
1 answer
72 views

api.meta.stackoverflow.com has state:normal - is this correct

i am not sure what the origin and exact meaning of the term 'linked_meta' is, but I would guess that it is a term created for area 51 meta sites and the implied meaning is clear. Perhaps stack meta ...
Sky Sanders's user avatar
  • 12.1k
0 votes
1 answer
94 views

Where are the new Metas?

According to the most recent blog post, ServerFault and SuperUser each got their own Meta. Shouldn't this be showing up in StackAuth?
Nathan Osman's user avatar
  • 23.3k
0 votes
1 answer
54 views

The /questions/{id}/timeline route isn't working.

I'm getting a response code 500 for the /questions/{id}/timeline route. I've tried it in Firefox and by fetching a response in Java. Example URL: http://api.stackoverflow.com/0.8/questions/59294/...
Bill the Lizard's user avatar
0 votes
1 answer
151 views

min/max parameters are incorrectly documented as date - confusion and crippled libraries ensue

I have noticed this on all sorted routes. The min/max say that they are context sensitive to the sort type yet are documented as date. How is a date min/max valid when sorting by, for instance votes?...
Sky Sanders's user avatar
  • 12.1k
0 votes
1 answer
39 views

Favorites api gives wrong results when sorted by added

For example, please compare http://api.stackoverflow.com/0.8/users/111391/favorites?sort=added with https://stackoverflow.com/api/userfavorites.html?userid=111391&page=1&pagesize=30&sort=...
Wei Hu's user avatar
  • 103
0 votes
1 answer
118 views

How to sort answers to question?

If I retrieve a question like so: http://api.stackoverflow.com/0.8/questions/1429951&sort=votes I expect the answers to be sorted by votes, but they're not. How can I do this?
Nathan Osman's user avatar
  • 23.3k
0 votes
1 answer
62 views

questions/{id}/timeline documentation: timeline_type values not listed

The timeline_type for post timelines just says "string" for the "values". From a cursory look at a few questions, I've seen the following types of events: question answer comment revision votes The ...
ColinD's user avatar
  • 369
0 votes
0 answers
78 views

Error invalid_request "OAuth request must be over HTTPS" when starting oauth flow

I'm building an application on top of StackExchange's API for a month now. While I was building the OAuth flow to allow users to authenticate using their StackExchange account, everything was working ...
Vinicius Andrade's user avatar
0 votes
0 answers
31 views

Strange pagination behaviour of /search/excerpts [duplicate]

In an attempt to (automatically) restore broken images* which have originally been included as HTTP links, I've tried to use /search/excerpts to look for candidate posts; specifically, I'm setting the ...
Glorfindel's user avatar
  • 6,782
0 votes
0 answers
45 views

`/me/associated` gives ambiguous/wrong response [duplicate]

This is my associated accounts page. No where I can see Meta Stack Overflow profile. But when I run /me/associated with meta_site as parameter to types, I get a response that tells me that I have a ...
amit jha's user avatar
  • 842
0 votes
0 answers
47 views

Application icon on authorization page isn't loading

I can't seem to get the application icon for Stack Applet to display on the authorization page. (I'm using the implicit flow.) The URL that I open the browser to is: https://stackexchange.com/oauth/...
Nathan Osman's user avatar
  • 23.3k
0 votes
0 answers
251 views

An associated query is returning a partial record for Area 51

This issue has recurred (and is ongoing) as of a couple of weeks ago. Most notably, as before, the on_site attribute is missing from Area 51. This is API 1.0, by the way.
Dennis Williamson's user avatar
0 votes
1 answer
35 views

Error when requesting the last page of results.

When I try to view the following URL: http://api.stackexchange.com/2.0/questions?page=93781&site=stackoverflow I get the error: { "error_id": 500, "error_name": "internal_error", "...
Nathan Osman's user avatar
  • 23.3k
0 votes
1 answer
48 views

issues with 'edit_count' field

Update other than the nullable issue, which is under review, the rest of this question is based on a mistake I made reading the nesting depth of the json result. Disregard. Deletion is considered. ...
Sky Sanders's user avatar
  • 12.1k
0 votes
1 answer
38 views

/stats meta data missing

So am I to assume that since we can make an extra call to another site to get meta that site node in stats has been deemed redundant data. If so, I have to suggest a reality break. This is one of ...
Sky Sanders's user avatar
  • 12.1k
-2 votes
1 answer
76 views

Should status-reproduced be made a mod-only tag?

status-review has been recently made a mod-only tag, but status-reproduced remains a normal blue tag. While not currently used on any questions (except this one, for demonstration), eventually it ...
Anonymous's user avatar
  • 479

1
6 7 8
9
10