Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
3 votes
0 answers
27 views

"Special" required tag listings only show single required tag

When you're viewing questions tagged with one of app,script,library, you get the special formatting view with the thumbnail on the left. On pages where this view is displayed, only one of these tags ...
  • 4,696
3 votes
1 answer
49 views

Elections nominations posts not showing up in API

I know that it's probably unintended that the Primary voting scores were leaked by the API, but I think if you're going to remove it, then at least make it official, so I won't have to wonder if it's ...
  • 819
3 votes
1 answer
82 views

tag colors incorrect

the tag color for english site seem incorrect, the dark grey color is the background while the yellow colour is the foreground. This is contradictory to other sites which have the darker colours as ...
  • 3,058
3 votes
0 answers
71 views

OBSOLETE - Unanswered questions with tags returns wrong total

When requesting a list of unanswered questions with a specific tags the total count show the total number of questions for that tag, not the count for the unanswered questions. Using http://api....
3 votes
1 answer
67 views

key not being recognized by api.meta.stackoverflow.com?

I have been testing a throttle implementation against meta today and suddenly got shut down with a key violation. It is possible that I have used enough requests to prompt this but I doubt it. In ...
  • 11.5k
3 votes
0 answers
62 views

/users/{id}/tags - 504 Gateway Timeout

this url is technically valid but generates 504. http://api.stackoverflow.com/1.0/users/242897/tags?filter=c%23&fromdate=0&max=1577836800&min=0&page=1&pagesize=100&sort=...
  • 11.5k
3 votes
1 answer
114 views

/users/{id}/associated - inconsistent behavior

/users/{id}/associated occasionally returns empty for an association even though there are definitely associated users. Calling it again immediately returns expected results. GET /1.0/users/e58345f5-...
  • 11.5k
3 votes
1 answer
858 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
  • 11.5k
3 votes
2 answers
127 views

Shouldn't the API help be consistent with the trademark guidance?

The description for the two StackAuth Routes within the API help both contain the phrase StackExchange network - shouldn't this rather be Stack Exchange Network to be consistent with the recently ...
  • 1,380
3 votes
1 answer
118 views

Problem getting a users questions within a date range

I'm having a problem returning a list of users questions within a given timespan. I understand that the documentation ( http://api.stackoverflow.com/0.8/help/method?method=users/{id}/questions ) that ...
user avatar
3 votes
0 answers
120 views

StackAuth needs crossdomain.xml and clientaccesspolicy.xml

These would be helpful to have. Absence breaks Silverlight apps. http://stackauth.com/crossdomain.xml http://stackauth.com/clientaccesspolicy.xml http://stackauth.com/0.8/crossdomain.xml http://...
  • 11.5k
3 votes
1 answer
64 views

Minor typo on help page

On the API Routes help page, this: /users/{id}/favorites Gets summary information for the questions that have been favorited a set of users. should probably be: /users/{id}/favorites Gets ...
2 votes
3 answers
125 views

StackAuth returning 404?

http://stackauth.com/1.0/sites http://stackauth.com/1.0/help Both of these are currently returning 404 Not Found. What's up with that?
  • 1,522
2 votes
3 answers
98 views

Method /users/{id} doesn't return "about_me" if the user has never modified it

See title. When a user never modified their "about me" section the API doesn't return that, which then causes my parser to go wild returning errors. However, when a user has modified their "about me"...
  • 4,665
2 votes
3 answers
74 views

What is the "inname" parameter to the /tags 2.0 API?

I'm just playing with the new 2.0 API and in /tags there is a field inname that I can't find any description or documentation for. What does it do? Is it like the old filter parameter on the old API? ...
2 votes
1 answer
175 views

My reputation graph is messed up.

See here: https://stackapps.com/users/18?tab=reputationhistory#tab-top Go to my rep graph and notice that it only shows about 350 points... Where's my other 4100?
  • 22.9k
2 votes
1 answer
40 views

Even though status-review has been made a moderator-only tag, it remains blue on this post

On this answer, status-review is mentioned. For whatever reason, the tag appeared as blue instead of red. I've also noticed that it does not appear on this post for some reason. I thought that ...
  • 439
2 votes
1 answer
67 views

What happened to the links to a Stack App mentioned in the documentation about write access?

The documentation about write access states: The application responsible for creating content via the API may be indicated with a link to an app's Stack Apps post. The exact manner of display is ...
  • 6,052
2 votes
1 answer
92 views

the stack exchange javascript library is 404

the library listed on the doc page for Authentication https://api.stackexchange.com/js/2.0/all.js ultimately redirects to https://api-v2cdn.sstatic.net/js/all.js which results in varying degrees ...
  • 11.5k
2 votes
1 answer
51 views

Minor spello/typo on the "Complex Queries" documentation page

The documentation page Complex Queries has a minor typo or spello: The ?filter=total build-in filter is provided for just this purpose. Should instead be: The ?filter=total built-in filter ...
2 votes
2 answers
72 views

Missing on_site in Stack Apps site data in associated_users from stackauth query

This is what I get for Stack Apps: { "display_name": "user", "email_hash": "11aa11...22bb22...", "reputation": 101, "user_id": 0000, "user_type": "...
2 votes
2 answers
815 views

Server has stopped obeying Accept-encoding header

Either today or yesterday, besides /questions/tagged having disappeared, the server started ignoring the Accept-encoding header: Ligação estabelecida com 69.59.196.211 na porta 80 GET /0.8/questions/?...
  • 123
2 votes
3 answers
150 views

display_name isn't always there (should have OpenID name if needed)

usually in the owner dictionary there is a display_name value to give the username. But in a few questions it simply doesn't exist and I can't see why only those questions: eg, this excerpt from the 0....
  • 3,058
2 votes
1 answer
39 views

Can API stats return real revision number instead of 1234.5678?

Currently it returns like this "revision": "1.0.1234.5678" And looks like that number never changed. So, Can API return real revision number whenever there is an update? It will be very useful ...
  • 5,022
2 votes
1 answer
161 views

Make www a subdomain.

Try going to http://www.stackapps.com Apparently www is not a subdomain of stackapps.com Anyone who tries to get to the site by prepending the www will be confused, as it is standard to point that ...
  • 22.9k
2 votes
1 answer
112 views

Misaligned label "Stack Apps Post (optional)" on app information page

When editing the application information (from https://stackapps.com/apps/oauth/), the label for the optional Stack Apps Post is misaligned: It should be left-aligned like the other labels; the only ...
  • 6,052
2 votes
1 answer
50 views

Timeline activities appear to be missing (because creation_date has wrong and useless values)

When I'm looking at my Stack Overflow timeline according to the API, It's missing a lot of events. According to the API, the last thing I did was posting this answer, five days ago, and you can see ...
  • 6,052
2 votes
1 answer
80 views

Notice field on questions may be absent?

The notice type, that is a field of a question, appears to be optional, yet it is not marked as "may be absent"? For example, when I request questions with a filter that has the notice field checked, ...
  • 121
2 votes
1 answer
158 views

Implicit Flow Isn't Redirecting

I'm using the WebAuthenticationBroker to allow users to log in to their account: var accessToken = ""; var uri = "https://stackexchange.com/oauth/dialog?redirect_uri=https://localhost.com&...
  • 191
2 votes
1 answer
76 views

Stack Exchange API is returning non-existant/incorrect notices for questions

When you view this question you do not see any notices other than the protected notice at bottom. Also, you are able to edit the answers and question (provided you have the privilege). However, when ...
2 votes
1 answer
64 views

Default listing images aren't served from CDN, fail to load because of certificate error

The default images used on the app/script/library pages aren't pointing to the CDN, so their use of HTTPS causes a certificate error that prevents the image from loading: Could the image sources be ...
  • 4,696
2 votes
1 answer
29 views

The "Get Started" section in the sidebar only mentions API 2.0 and API 1.1

Now that API 2.1 is "public, frozen, and out the door" shouldn't we update the "Get Started" section in the sidebar on the right side of the screen. It talks about API 2.0 and API 1.1 but doesn't ...
2 votes
1 answer
53 views

Error retrieving question using a filter that includes question.notice

I have created a filter to include the question.notice field. It seems to be OK as returned by https://api.stackexchange.com/2.1/filters/-9xc1l%2Au-JEsf_Q Then if I want to fetch this question using ...
  • 355
2 votes
1 answer
69 views

Stack Apps graph time filters make pretty much no sense

When viewing the Query Statistics graphs for an application, you have the option of choosing 'Week', 'Month', 'Year', or 'All Time'. When hovering over 'week' it states "view stats for the last 7 ...
  • 281
2 votes
1 answer
65 views

Advanced search by title doesn't filter on the title

Searching by title on the advanced search method doesn't restrict the results to posts containing the specified text as a word or even substring. Varying the string has some influence, but I can't ...
2 votes
1 answer
55 views

Does /invalidate work for no-expiry tokens?

It seems that tokens created with no_expiry scope are immune to requests to invalidate them with /access-tokens/.../invalidate. Is this by design or by bug?
  • 3,853
2 votes
1 answer
24 views

The "/tags/{tags}/wikis" API does not return the proffered "body_last_edit_date" or "excerpt_last_edit_date" fields

The API for /tags/{tags}/wikis offers body_last_edit_date and excerpt_last_edit_date fields. Both are selected in the default filter. But neither are actually returned even for tags I'm 100% sure ...
2 votes
1 answer
25 views

Guid inconsistency in 2.0?

question timeline returns "revision_guid": "335659EE-8983-4BEC-BACC-CC95784A4465" revisions by guid return "revision_guid": "335659ee89834becbacccc95784a4465" Is there any particular reason for ...
  • 193
2 votes
1 answer
57 views

/comments?fromdate is broken?

The following url should return 0 comments: http://api.stackoverflow.com/1.1/comments?fromdate=9999999999 Instead it returns all comments, not actually filtering by fromdate at all. It happens on ...
2 votes
1 answer
43 views

nottagged only works when tagged is set (/search)

On the /search route, the nottagged parameter doesn't work properly (at least it isn't specially documented to only work at certain times) For example: http://api.stackoverflow.com/1.1/search?pagesize=...
  • 3,058
2 votes
1 answer
66 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
  • 355
2 votes
1 answer
114 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } ...
2 votes
1 answer
45 views

The associated accounts are broken once again for this same user

As I reported before (and which was fixed) and again (which was also fixed), the associated accounts are broken once again for for Joel Coehoorn using this query. What's the deal?
2 votes
1 answer
79 views

/questions/{id}/answers missing title attribute

http://api.stackoverflow.com/1.0/help/method?method=questions/{id}/answers (it won't linkify properly!): "title": { "description": "title of this post, in plaintext", "values": "string", "...
  • 1,522
2 votes
1 answer
196 views

Why are 5 IP addresses using my API key?

I have an app that resides on a server. It has only ever accessed the API from 2 IP addresses. The API key has not been shared and there is no client-side code. When I go to /apps however, it says "5 ...
  • 22.9k
2 votes
1 answer
91 views

Problems with the Site Icons

I'm having trouble with the WebApps icon being returned from the /sites method. Namely, the image is composed of a larg white rectangle with a very small guy in the middle. Why can't the guy take up ...
  • 22.9k
2 votes
2 answers
137 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
  • 22.9k
2 votes
1 answer
90 views

/questions/{id}/timeline throwing 500 instead of 404

Kevin, you fixed this bug some time ago, would you like to tag it as status-complete? Sometime last week, this route stopped throwing 404 like the rest of my 'bad id' tests and started throwing 500. ...
  • 11.5k
2 votes
2 answers
76 views

Order parameter not functional

Consider these two API calls: http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=desc http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=asc ...
  • 1,522
2 votes
2 answers
96 views

Why my /mentioned page return 404?

http://api.stackoverflow.com/0.8/users/213464/mentioned?type=jsontext { "error": { "code": 404, "message": "The server has not found anything matching the Request-URI." } } Its returning ...
  • 5,022

1
3 4
5
6 7
9