Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
3 votes
1 answer
57 views

link in post_id in /me/notifications/unread is wrong

I have run /me/notifications/unread. The response contains post_id and there is a link to it. This link is wrong. The post is on Stack Apps but the link directs to Stack Overflow: I have ...
  • 822
3 votes
1 answer
109 views

top-answerers / top-askers documentation bug: number of results returned incorrect

The top-answerers-on-tags and top-askers-on-tags documentation claim: Returns the top 30 answerers active in a single tag, of either all-time or the last 30 days. and Returns the top 30 askers ...
3 votes
1 answer
65 views

Trying to get the Total results count crashes the /notifications path

I am trying to use the filter !9ciXfDSYM (same as default but with total) with the /notifications request and the response is: { "error_id": 500, "error_name": "internal_error", "...
  • 139
3 votes
1 answer
220 views

API documentation console unsuccessfully tries to load MiniProfiler results

All of the documentation pages (example) with the test console currently attempt to load MiniProfiler result data, which fails with a 404: POST https://api.stackexchange.com/mini-profiler-resources/...
  • 4,696
3 votes
1 answer
52 views

Typo in API docs: "temporarility_unavailable"

https://api.stackexchange.com/docs/authentication "temporarility" should probably be "temporarily"
3 votes
1 answer
108 views

Does stackexchange provide https access to its API?

Requests I make appear to be redirected back to plain http URLs and the certs seem questionable: % curl -O 'https://api.stackoverflow.com/1.0/questions/?key=oxXcnoD51kKE crj7TadaA&tagged=...
3 votes
1 answer
113 views

Update the default filter editor to use the API key

When I run a sample query using the SE API browser (is that right term?), say against /questions for example (here), I'll always see something to the effect of: ... "quota_remaining": 9424, "...
3 votes
1 answer
74 views

API search page size limit mismatch

The 1.1 API help text for search says that the pagesize parameter can go up to 100. Indeed, passing a value up to 100 returns some results, while passing pagesize=101 yields an HTTP 400 status (Bad ...
3 votes
2 answers
168 views

What happened to nothingtoinstall.com?

This is weird: { "name": "Web Applications", "logo_url": "http://sstatic.net/webapps/img/logo.png", "api_endpoint": "http://api.webapps.stackexchange.com", "site_url": "http://...
  • 22.9k
3 votes
1 answer
67 views

Badges with zero count no longer returning zero

For queries such as http://api.{sitename}.com/1.0/users/{id} if a badge count is zero, the API is no longer returning "gold": 0, for example.
3 votes
1 answer
142 views

Why do some Stackauth associated queries fail?

This query fails: http://stackauth.com/0.8/users/137b94e5-050c-4dd5-82c1-aeb2af0814f5/associated In Python for a jason.loads call, I get an error: 'ValueError("No JSON object could be decoded")'. I ...
3 votes
1 answer
40 views

The search method is returning an extra result.

By default the /search method is supposed to return 30 results per page, but it's returning 31. I only tested a few other values for pagesize but it looks like it always returns one extra result. In ...
3 votes
1 answer
46 views

Help page for search is missing

It looks like search is available in the current API but there is no help page for it. http://api.stackoverflow.com/0.8/search?intitle=test
  • 5,072
3 votes
1 answer
93 views

Methods that return comments document body and comments parameters but they do nothing

Methods that return comments document the "body" and "comments" parameters, but they have no effect on the results, which cannot include comments and always include the body. Specific methods: /...
  • 369
3 votes
1 answer
124 views

Permission request form is broken, approve button is hidden, css variables are missing

You can check that form doesn't work with this link https://stackoverflow.com/oauth?client_id=17581&scope=no_expiry&redirect_uri=http://functional.localdomain:3449/login/github
3 votes
1 answer
58 views

"backoff" missing when updating questions

I updated a couple of questions with the questions/{id}/edit method and got the following error: { "error_id": 407, "error_message": "You cannot perform this action for another 14 seconds", ...
  • 131
3 votes
1 answer
329 views

Why is the API giving a different response for preview true/false with POST requests?

Update This expression will evaluate to show the cause. The only requirement is an emacs with url. As you can see, the result from using curl and that from using the url package is different. ...
3 votes
1 answer
93 views

API returns the last activity date even if asked not to

Using the /questions method, I tried to get upvote and downvote counts, along with question Ids. This is the request I sent: http://api.stackexchange.com/2.2/questions/857455%3B857454?site=math&...
user avatar
3 votes
1 answer
303 views

Stack Exchange OAuth2, explicit access-token response format does not adhere to RFC6749 standard

I'm using the Stack Exchange v2.1 API. I'm using the explicit OAuth 2.0 flow, but it seems that the access token response step does not adhere to the RFC 6749 standard. Specifically, the Stack ...
  • 131
3 votes
1 answer
3k views

OAuth redirect not completing

This is the URL that I'm entering (in Safari, cleared website data and cache; my app, uses own Cookie jar; and incognito chrome) https://stackexchange.com/oauth/dialog?client_id=23&scope=...
  • 3,058
3 votes
1 answer
66 views

What happens when sites or the whole network go offline

Now that the API is all done on stackexchange.com. What happens if say just certain sites go offline (eg just Stackoverflow). Will the API continue to return results or will it return the HTML offline ...
  • 3,058
3 votes
1 answer
54 views

Documentation has broken link (JSONP)

On Wikipedia, JSONP now has its own article, instead of being part of the JSON article. The documentation links JSONP to Wikpedia:JSON#JSONP. It should link to Wikipedia:JSONP.
  • 133
3 votes
1 answer
49 views

The /users/{id}/timeline route is reporting incorrect totals

It seems that the /users/{id}/timeline route is returning an incorrect total. For example, the following URL is reporting a total of 1607 items: http://api.stackapps.com/1.1/users/7789/timeline ......
  • 22.9k
3 votes
1 answer
64 views

What happened to the /stats method?

I can't find the /stats method in the new usage documentation. A quick run of http://api.stackoverflow.com/1.1/stats reveals that the method is still there. However, it is not documented.
  • 22.9k
3 votes
1 answer
75 views

server fault and super user rate limit bonus?

Looks like SF and SU are granting Int.MaxValue rate limit. Not that I mind, but it would be nice to have on the other sites too. ;-) Thought you would like to know. GET /1.0/users/173?key=mykey HTTP/...
  • 11.5k
3 votes
1 answer
48 views

pagesize=0 on /search throwing error

http://api.stackapps.com/0.9/search?intitle=a&pagesize=0 { "error": { "code": 4001, "message": "The 'pagesize' query parameter is invalid." } }
  • 11.5k
3 votes
1 answer
58 views

both /revisions methods are spotty

These are the urls for a couple of my valid endpoint tests of the /revisions methods. http://api.stackoverflow.com/0.8/revisions/2688191 (?key=xxx) http://api.stackoverflow.com/0.8/revisions/2350874/...
  • 11.5k
3 votes
2 answers
77 views

On /users method id parameter does not work

Calling /users method with id parameter returns a list of users and not the user expected. http://api.stackoverflow.com/0.8/users?id=23234 Could be a documentation "bug" on help page: http://api....
3 votes
2 answers
92 views

Inconsistency in sort order

If I execute the following API call: http://api.stackoverflow.com/0.8/questions?sort=newest&body=True&pagesize=5&min=1275575777&order=desc versus one that does not include the min ...
  • 131
3 votes
1 answer
103 views

The Faq Has a Broken Link

Currently the first link in the FAQ points to http://dev.stackapps.com/?tab=apps. It should link to https://stackapps.com/?tab=apps. Simple fix, but it confused me for a short time.
  • 2,966
3 votes
0 answers
55 views

Pluralisation bugs in /apps/oauth

In the Manage your applications page, if 1 user has authorized and has been given an access token, the site shows 1 users instead of user: In addition, if you have one application, it shows 1 ...
3 votes
0 answers
61 views

API 404's when I try to fetch related tags for the `bin` tag

If you query the API for tags related to [bin]: https://api.stackexchange.com/2.2/tags/bin/related?site=stackoverflow this simply returns: Invalid JSON returned and a 404. (live demo) But it ...
3 votes
0 answers
49 views

Tags are not returned when querying /users/{ids}/answers

I'm querying the API for answers-by-user, and I want the tags belonging to the parent questions. I seem to be seeing intermittent results: sometimes the tags attribute of the response includes the ...
  • 141
3 votes
0 answers
80 views

/synonyms sorting is majorly broken

I'm requesting /tags/synonyms data in descending order by creation date, but the order is jumbled up: The first date is 2017-08-22 where as the second one is 2018-03-16. The same can be observed for ...
  • 161
3 votes
0 answers
33 views

"users" link lands on the answer page

On the /users/moderators documentation site, the following link is wrong: This method returns a list of users. The users link mistakenly points to the answers object instead of to the users object....
3 votes
0 answers
49 views

Authorization dialog shows wrong API version

If you go on this doc page and click on Get Token, you'll see this: Minor bug, but still, I thought it would be nice to fix this inconsistency :)
3 votes
0 answers
38 views

The tags array is missing from answer results

I'm probably missing something very obvious but it seems like /users/{ids}/answers forgets to include the tags badge in the resulting answer object: tags (2.1) an array of strings Nowhere does ...
3 votes
0 answers
97 views

Only Stack Overflow has documentation, but the API erroneously lists documentation privileges for all sites

Privileges related to Stack Overflow Documentation are displaying in every other site's API data. Using Meta Stack Exchange, for example, /2.2/privileges?site=meta returns the following documentation ...
  • 556
3 votes
0 answers
38 views

Types missing from the "Member Types" section

The following types are not listed on http://api.stackexchange.com/docs?tab=category#docs under the Member Types section: network_post closed_details original_question Note that it's a nonexhaustive ...
  • 263
3 votes
0 answers
40 views

'answer' type has "unchanged in unsafe filters" listed for the wrong field

http://api.stackexchange.com/docs/types/answer says the can_flag field is unchanged in unsafe filters. It's probably meant for the field above it: body_markdown.
  • 263
3 votes
0 answers
64 views

It's taking two calls to /oauth/dialog/ to get an access_token? [duplicate]

When we send this request: https://stackexchange.com/oauth/dialog/?client_id=`client_id`&scope=read_inbox%2cno_expiry%2cwrite_access%2cprivate_info&redirect_uri=https%3a%2f%2fstackexchange....
  • 822
3 votes
0 answers
104 views

error description: could not parse proxy url

I have seen the answers to the existing two questions on this topic but it has not helped. And the problem still persists so I am re-posting this question. Here is my code $(function(){ SE.init({ ...
3 votes
0 answers
47 views

/answers API request returns no tags if body_markdown is included [duplicate]

This API request to /answers has the filter set to return the tags field for the corresponding question. It works fine: api.stackexchange.com/docs/answers#filter=!9YdnSPElz But, when the filter is ...
  • 131
3 votes
0 answers
33 views

Buggy HTTP header behavior with the `site` parameter. Improper caching?

In sx.el we are using url-request-extra-headers to pass API requests to Stack Exchange. When performing multiple queries in quick succession, we end up receiving the same JSON response even when the ...
3 votes
0 answers
24 views

bounties_offered are not being returned correctly from /users/{ids}/reputation

When querying the /users/{ids}/reputation API route, reputation changes for bounties_offered are not being returned correctly. In my own results, I see a reputation object with a reputation_change ...
3 votes
0 answers
90 views

SSL handshake error after Stack Overflow back on - anything related to SSL certification changed?

I'm building a Stack Overflow app for BlackBerry10. Earlier today (Feb 16, 2014), Stack Overflow was down and after it came back up my app starts to have this issue. My app works fine when it's in ...
3 votes
0 answers
75 views

Why is there a difference between "questions" and "search" in API?

I have a query to find the number of questions tagged java from 2012-08-01 to 2013-08-01. Running this using both /questions and /search produces different results: https://api.stackexchange.com/2....
3 votes
0 answers
45 views

Incorrect link parameter on the "Complex Queries" documentation page

The "Complex Queries" documentation page has this link: Of these three posts on Server Fault, the one with the most recent activity where "the one with the most recent activity" links to https://...
3 votes
0 answers
73 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
  • 131
3 votes
0 answers
152 views

OAuth Dialog rendering problems in iPad

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: (...
  • 489

1 2 3
4
5
9