Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
5 votes
2 answers
474 views

The API Key does not work

I have registered an app at https://stackapps.com/apps/register, got a Key right away after I have submitted. But now when I request http://api.stackoverflow.com/0.8/stats?key=MYKEY, I got ...
  • 5,022
5 votes
1 answer
143 views

The API /questions/{ids}/timeline path doesn't return several items that occurred after the fromdate parameter

I need to get all the question activity after some particular time. I am using the timeline API, like so:       /questions/20032212/timeline?fromdate=1384705610&site=stackoverflow.com But it ...
5 votes
1 answer
84 views

The API has stopped allowing CORS requests

I just noticed that a script I have that makes CORS requests to the API stopped working on Meta Stack Overflow, claiming that the domain isn't allowed by Access-Control-Allow-Origin, which is true ...
  • 4,696
5 votes
1 answer
121 views

API docs titled "v2.0"; should be "v2.1"

The documentation is titled "StackExchange API v2.0"... this should be updated to "v2.1" as it's not readily obvious that version 2.1 has been published otherwise. https://api.stackexchange.com/docs
5 votes
1 answer
61 views

Typos in the API 2.0 Documentation

Typo #1: There are two different objects that represent a user in the Stack Exchange API, the full user object and the smaller shallow_user object. Which is returned depends on the method being ...
5 votes
2 answers
157 views

The /search route is ignoring the answers parameter.

The answers parameter was recently added to most of the requests that return a list of questions. See: Don’t include answers in question lists by default It looks like the /search request got left ...
5 votes
1 answer
416 views

API stopped allowing CORS requests

I'm currently using the API via JavaScript AJAX calls and it all of a sudden stopped allowing CORS requests. I'm on localhost and I tried uploading my code to live and am still getting: Access to ...
  • 51
5 votes
1 answer
66 views

API documentation pages match some site names incorrectly

The bug is not in the API itself, but in the pages documenting its methods. To reproduce, follow the link http://api.stackexchange.com/docs/info#filter=default&site=math and observe that the page ...
5 votes
1 answer
43 views

/posts/{id}/revisions breaks for posts with [tag:*] content

Attempting to access (at least) the revisions route for a post with a revision involving the [tag:*] syntax causes an error: Example on Meta Stack Overflow (Post History) Example on Mathematica (Post ...
  • 4,696
5 votes
2 answers
157 views

API Help's CSS is missing

The API Help page's CSS file, located at http://sstatic.net/so/all.css, is current returning 404 for me: <div id="header"><h1>Server Error</h1></div> <div id="content"> ...
  • 819
5 votes
1 answer
91 views

What's the difference between tags soapi.cs and soapi.js to get a bug triggered by the former?

Right now questions tagged soapi.cs returns a HTTP status code 404 (for various HTTP clients) while questions tagged soapi.js does not. Interestingly though, soapi.cs seems to work just fine in other ...
  • 1,380
5 votes
1 answer
163 views

Few typos in the documentation pages

https://api.stackexchange.com/docs/vectors When passing a vector, sepeate each id with a semicolon. For example, /users/1;2;3;4;5?site=somesite would fetch users with ids 1 through 5 on somesite. ...
  • 556
5 votes
1 answer
123 views

Typos on api.stackexchange.com/docs/js-lib

Under the Authentication section on https://api.stackexchange.com/docs/js-lib, there are a few typos (emphasis mine): scope (optional) – an array of scopes to request during authentication, valid ...
  • 4,325
5 votes
1 answer
81 views

API calls that return select post bodies throw JSON errors

When calling the Stack Exchange API to get the post body, it will return an error for some posts. EG: /docs/questions#page=13&pagesize=100&fromdate=2013-09-01&todate=2013-09-02&order=...
5 votes
1 answer
32 views

Typo in API filter documentation

When using unsafe filters, the API returns the highest fidelity data is can reasonably access for the given request. should be When using unsafe filters, the API returns the highest fidelity data ...
5 votes
1 answer
60 views

filter=total is returning 0?

I'm running a very simple (and contrived) call of: http://api.stackexchange.com/2.0/users/115730?site=stackoverflow&filter=total I'm expecting a response of: {"total":1} But am getting a ...
  • 5,244
5 votes
1 answer
61 views

You can gain reputation from edits to tag wikis, although they are not accessible through the API.

Reputation gain from edits to tag wikis appear through the API; the API reports them as answers, but fetching them via the /answers route does not work. Case in point: My accepted edit (+2 rep) My ...
  • 935
5 votes
2 answers
117 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).
5 votes
1 answer
126 views

Two minor typos in the API help

In http://api.stackoverflow.com/0.8/help /users/{id}/answers Gets answer summary informatino for the user with 'id'. and in the Returns section of http://api.stackoverflow.com/0.8/help/method?method=...
  • 185
5 votes
1 answer
100 views

Why doesn't the API return suggested edits on tag wikis?

Is there a reason why the API doesn't return suggested edits on tag wikis on the suggested-edits route?
5 votes
1 answer
55 views

User's display name field omitted?

If a user doesn't have a username "set" for an account, then the display_name field is omitted. This is similar to a few other questions, but the only official answer says that "display_name should ...
  • 225
5 votes
1 answer
73 views

/user/{id}/timeline results leaking template used for badge information

From my elections statistics page: I inserted in the detail field as plain text because I wasn't sure if the results would be HTML, but the $ChatUrl left in the anchor's href is surely a bug.
  • 819
5 votes
1 answer
92 views

Empty results for associated queries

Queries such as this http://stackauth.com/1.0/users/f5388585-c0b9-417f-99c5-f1a58fda3e83/associated have started giving empty results { "associated_users": [] } Expected results: SiteUrl ...
5 votes
1 answer
135 views

Intermittent bug in the /search route when providing both tagged and nottagged parameters.

I'm getting the wrong number of results back from the /search route depending on what combination of values I provide for the tagged and nottagged parameters. Examples: http://api.stackoverflow.com/1....
5 votes
1 answer
117 views

StackApps is not being reported by StackAuth

The stackauth.com sites query is not returning stackapps.com at all: http://stackauth.com/0.8/sites?type=jsontext { "api_sites": [ { "name": "Stack Overflow", "logo_url": "http://...
  • 1,522
5 votes
2 answers
58 views

Users timeline help claims to be pageable but isn't

The help page for the users timeline call claims that the timeline can handle paging but it doesn't seem to be able to. The output doesn't have the total count of pages, etc and the page attribute ...
  • 5,072
5 votes
1 answer
208 views

Cannot authenticate with OAuth2

I was testing an app and suddenly I can't login any more. Neither my app or the Stack App configuration hasn't changed, so I'm thinking this might be a bug on the API side. The OAuth error seems a ...
  • 151
5 votes
0 answers
111 views

"What is meta" should be rephrased

Stackapps.com/help/whats-meta tells that there is "Meta Stack Apps". However there isn't. Stack Apps is its own meta and meta is used to ask meta questions here.
  • 396
5 votes
0 answers
116 views

Filter doesn't consistently return comment bodies

I've been trying to set up a filter I can use with /questions/{id}/answers/ (using the UI at this link), which returns the following fields: answer: answer_id body_markdown comments ...
5 votes
0 answers
47 views

OBSOLETE - revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
5 votes
0 answers
73 views

OBSOLETE - /tags fromdate and todate does nothing

Although the help/documentation lists todate and fromdate parameters for tags they do not work. This may be related to tags not having a creation_date. It would be great if we could filter tags by ...
  • 159
4 votes
2 answers
126 views

How far behind is the data returned by calls supposed to be?

I understand that the data sourced to the API are cached, but I'm seeing some fairly extreme discrepancies between reputation reported by the API and apparent activity on the site. For example: ...
  • 3,082
4 votes
1 answer
166 views

“Try It” URL has wrong URI

On API doc pages, the “link” link at the top-right of the “Try It” sections presents a URL with the wrong domain name: For example, on docs/similar, the URL displayed will be: https://api....
4 votes
1 answer
49 views

Typo in the docs for /me

The doc says: Returns the user associated with the passed auth_token. This method returns a user. It should say "access_token" instead of "auth_token".
  • 358
4 votes
1 answer
106 views

Why is my quota constantly decreasing?

I registered an app today (API v2) for the first time (App ID 47, LaServ), and let it run a bit with its new key. It's the only API app running on this IP (I rent the IP as part of a VPS package). ...
  • 3,237
4 votes
1 answer
70 views

Please migrate the question templates to CommonMark

We have three templates for new questions (for apps, libraries and scripts): They'll insert a body like this: <!-- thumbnail: https://example.com/some-image.png --> <!-- version: 1.0 --> ...
  • 6,052
4 votes
1 answer
92 views

Search function in the API doesn't work as expected

This looks like an error in the search part of the API. This search URL: /2.2/search?tagged=javascript&intitle=get%20column%20array&site=stackoverflow doesn't return any answers. I'm ...
  • 143
4 votes
1 answer
959 views

Invisible text in Markdown syntax help

Some text is invisible in the How to Format help block because of a bad combination of text and background color: That's meant to read ► backtick escapes `like _so_` but the backquoted portion is ...
  • 259
4 votes
1 answer
47 views

API usage "Try It" form for linked questions queries meta.tex.stackexchange instead of Stackoverflow

I was wondering why the form at http://api.stackoverflow.com/1.1/usage/methods/linked-questions did not return the questions I was expecting. Then I noticed that it is calling http://api.meta.tex....
  • 606
4 votes
1 answer
12k views

/users/{id}/reputation != xxx.com/reputation

I realize that the shape of the data coming from the API may be different than that reported by the xxx/reputation url, but there seem to be some striking disparities. see 08/12 and 08/11 in both ...
  • 11.5k
4 votes
1 answer
96 views

/questions returns wrong markdown when a suggested edit is improved

The /questions API method returns wrong markdown when the last revisions were made by a suggested edit improved in the review queue. This event leads to two revisions (one for the suggested edit and ...
  • 6,052
4 votes
1 answer
331 views

Login using Google fails saying OpenID 2.0 accounts for Google has gone away

Recently I have received complaints about my app suggesting that logging in with a Google account shows a warning message that OpenID authentication has gone away. When I tried to log in with my own ...
4 votes
1 answer
78 views

"Try it" facility suffers a double-encoding bug

As you can clearly see from the above, the ampersand in the site name in the "Try It" section of the API method documentation has been double-encoded. This affects any site with an ampersand in the ...
4 votes
1 answer
72 views

Unable to sort /search results by creation_date

I think I may have stumbled upon a bug in /search and I'll try to describe it as best as I can. What works: Create a /search query with the following parameters: fromdate: 2012-01-24 order: desc ...
4 votes
1 answer
198 views

API ignores jsonp callback after initial request - erroneous caching?

This bug is still prevalent, appears to be cache related. Two identical requests return different data: first request respects jsonp query parameter, all subsequent requests ignore it until (I presume)...
  • 143
4 votes
1 answer
63 views

API 'search' method with 'min' parameter

If you search for questions posted on time 1296897085 or later (by specifying sort=creation and min=1296897085), it may still return questions posted before that date: http://api.stackoverflow.com/1....
  • 1,261
4 votes
2 answers
90 views

/users/{id}/answers - broken

Have not checked other routes, as I am busy with other things, but a failing test pointed this out... GOOD: http://api.stackoverflow.com/1.0/users/242897/answers?min=4&sort=votes { "total": 37,...
  • 11.5k
4 votes
1 answer
127 views

questions method returns error 4000

I'm getting error 4000 on every endpoint on questions method (with key): http://api.superuser.com/1.0/questions?sort=votes&pagesize=30&page=1&key=stackprinterkey the only endpoint not ...
4 votes
1 answer
114 views

http://stackauth.com/0.8/sites down

I realize you may be shaking something out but in case you are not aware: http://stackauth.com/0.8/sites is returning { "api_sites": [] }
  • 11.5k
4 votes
2 answers
107 views

Possible bug in the help page?

There are some weird dot things in this help page: api.stackoverflow.com/0.8/help/method?method=users/{id}/badges {Dead link to missing image: http://files.quickmediasolutions.com/stackbug.png} ...
  • 22.9k

1
2
3 4 5
9