Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
3 votes
3 answers
171 views

Negative voting questions?

I'm trying to, for humorous purposes, check out some of the worst scoring questions ever on SO. I'm pretty much expecting them to all be "heeeeelp homework" or "plz send me teh codez" or something to ...
  • 133
1 vote
3 answers
148 views

API not returning anything near the actual website

The API /questions page is not returning anything like the list of questions on the actual SO site. This is the first question of the 0.8/questions { "total": 705769, "page": 1, "pagesize": 30,...
  • 3,048
2 votes
2 answers
95 views

Why my /mentioned page return 404?

http://api.stackoverflow.com/0.8/users/213464/mentioned?type=jsontext { "error": { "code": 404, "message": "The server has not found anything matching the Request-URI." } } Its returning ...
  • 5,022
2 votes
1 answer
76 views

/users/{id}/badges - multiple identical results

Each badge returned in the list of results from /users/{id}/badges already contains an award_count indicating how many times the badge was awarded for the particular user attached to the badge. In ...
  • 369
4 votes
2 answers
107 views

Possible bug in the help page?

There are some weird dot things in this help page: api.stackoverflow.com/0.8/help/method?method=users/{id}/badges {Dead link to missing image: http://files.quickmediasolutions.com/stackbug.png} ...
  • 22.8k
1 vote
1 answer
79 views

/users/{id}/tags - broken

looks like touching the id parameter description broke the internet. http://api.stackoverflow.com/0.8/users/242897/tags should/was working 6/1/2010 -1:11AM - working
  • 11.5k
1 vote
1 answer
42 views

help page format issue: missing parameter

/users/{id}/tags is missing id parameter fixing this will remove one more special case from my parser.
  • 11.5k
1 vote
1 answer
52 views

help page format issue: revisionGuid

http://api.stackoverflow.com/0.8/help/method?method=revisions/{id}/{revisionguid} revisionGuid is inconsistent. revisionguid seems appropriate (and will remove one special case from my api parser).
  • 11.5k
0 votes
1 answer
37 views

Favorites api gives wrong results when sorted by added

For example, please compare http://api.stackoverflow.com/0.8/users/111391/favorites?sort=added with https://stackoverflow.com/api/userfavorites.html?userid=111391&page=1&pagesize=30&sort=...
  • 103
3 votes
1 answer
64 views

Minor typo on help page

On the API Routes help page, this: /users/{id}/favorites Gets summary information for the questions that have been favorited a set of users. should probably be: /users/{id}/favorites Gets ...
2 votes
3 answers
150 views

display_name isn't always there (should have OpenID name if needed)

usually in the owner dictionary there is a display_name value to give the username. But in a few questions it simply doesn't exist and I can't see why only those questions: eg, this excerpt from the 0....
  • 3,048
1 vote
1 answer
60 views

The user and owner objects appear to be optional in the question timeline result.

This is probably just a simple documentation fix and not really a bug. The doc for the /questions/{id}/timeline method says that the user and owner objects are not optional, but they aren't always ...
2 votes
1 answer
60 views

The users/{id}/timeline method is returning an extra result.

The users/{id}/timeline method is returning 31 results by default, and one more result than specified by the pagesize parameter. Example: http://api.stackoverflow.com/0.8/users/1288/timeline?pagesize=...
0 votes
1 answer
102 views

How to sort answers to question?

If I retrieve a question like so: http://api.stackoverflow.com/0.8/questions/1429951&sort=votes I expect the answers to be sorted by votes, but they're not. How can I do this?
  • 22.8k
4 votes
1 answer
76 views

Questions method does not return answers

I think questions method also return answers too and the help page says so http://api.stackoverflow.com/0.8/help/method?method=questions .... "answers": [ { "answer_id": { "...
  • 5,022
3 votes
1 answer
39 views

The search method is returning an extra result.

By default the /search method is supposed to return 30 results per page, but it's returning 31. I only tested a few other values for pagesize but it looks like it always returns one extra result. In ...
2 votes
1 answer
39 views

Can API stats return real revision number instead of 1234.5678?

Currently it returns like this "revision": "1.0.1234.5678" And looks like that number never changed. So, Can API return real revision number whenever there is an update? It will be very useful ...
  • 5,022
1 vote
1 answer
173 views

Why is sort by name reverse alphabetical?

It makes sense that reputation or date should sort descending, but name? I tested both /users and /tags and they sort reverse alphabetical, so Z before A. Is that by design or just a side effect of ...
1 vote
1 answer
126 views

Last activity date

It would be useful if the API allowed you to return items based on their last activity date. Let's take a question for example. /questions/fromlastactivitydate=XYZ&tolastactivitydate=XYZ All ...
  • 113
3 votes
1 answer
46 views

Help page for search is missing

It looks like search is available in the current API but there is no help page for it. http://api.stackoverflow.com/0.8/search?intitle=test
  • 5,072
5 votes
2 answers
58 views

Users timeline help claims to be pageable but isn't

The help page for the users timeline call claims that the timeline can handle paging but it doesn't seem to be able to. The output doesn't have the total count of pages, etc and the page attribute ...
  • 5,072
2 votes
1 answer
54 views

Revision help URL contains wrong header

There are two revision urls listed on the help page but they both seem to contain the same detailed information. The header for the non-guid version contains the url for the one that takes a guid. ...
  • 5,072
3 votes
1 answer
92 views

Methods that return comments document body and comments parameters but they do nothing

Methods that return comments document the "body" and "comments" parameters, but they have no effect on the results, which cannot include comments and always include the body. Specific methods: /...
  • 369
3 votes
2 answers
71 views

Inconsistency in the handling of multiple IDs with a duplicate

There appears to be some inconsistency in the way multiple ids are being handled, especially when a duplicate exists. Duplicate ID is significant For example, when requesting a timeline of multiple ...
  • 133
2 votes
1 answer
161 views

Don't allow requests with No Key to use existing session with valid API Key

Once I did a request with a valid API key http://api.stackoverflow.com/0.8/stats?key=MYKEY Every requests (from that IP) later on without key will use existing session with API key, limit counter ...
  • 5,022
8 votes
1 answer
442 views

API Key limit 10k is Per IP Address or Globally?

Getting started FAQ says No Key limit is IP Address based, but it does not say for with API Key. When I test my API Key from different IP Addresses, I noticed that 10k limit is globally, limit is ...
  • 5,022
0 votes
1 answer
36 views

/questions/unanswered and /tags allow id parameter, but it does nothing

The /questions/unanswered and /tags queries both document (as required) and allow an "id" parameter. You can use it as /questions/unanswered?id=1;2;3, but it does nothing (that I can tell) and doesn't ...
  • 369
2 votes
1 answer
97 views

Two minor typos in the "Register your Application" form

In the help text (on the right hand side) for the Application Name field on https://stackapps.com/apps/register: I think this should be changed: " ... is built on the our platform ...". For example, ...
0 votes
1 answer
61 views

questions/{id}/timeline documentation: timeline_type values not listed

The timeline_type for post timelines just says "string" for the "values". From a cursory look at a few questions, I've seen the following types of events: question answer comment revision votes The ...
  • 369
2 votes
1 answer
64 views

questions/{id} help page sort parameter description is inconsistence with others

The description of the Sort parameter in questions/{id} help page is inconsistent with those of other pages. On the questions/{id} help page: sort (optional): How a collection should be ...
  • 5,022
2 votes
3 answers
98 views

Method /users/{id} doesn't return "about_me" if the user has never modified it

See title. When a user never modified their "about me" section the API doesn't return that, which then causes my parser to go wild returning errors. However, when a user has modified their "about me"...
  • 4,665
5 votes
2 answers
470 views

The API Key does not work

I have registered an app at https://stackapps.com/apps/register, got a Key right away after I have submitted. But now when I request http://api.stackoverflow.com/0.8/stats?key=MYKEY, I got ...
  • 5,022
5 votes
1 answer
126 views

Two minor typos in the API help

In http://api.stackoverflow.com/0.8/help /users/{id}/answers Gets answer summary informatino for the user with 'id'. and in the Returns section of http://api.stackoverflow.com/0.8/help/method?method=...
  • 185
1 vote
2 answers
60 views

Unanswered questions API does not work

The /questions/unanswered API returns the full list of questions (same as /questions).
  • 2,894
1 vote
2 answers
152 views

errors/{id} documentation : 500 Internal Server Error

On Documentation page, clicking on errors/{id} returns 500 Internal Server Error EDIT: Fixed!
2 votes
1 answer
175 views

My reputation graph is messed up.

See here: https://stackapps.com/users/18?tab=reputationhistory#tab-top Go to my rep graph and notice that it only shows about 350 points... Where's my other 4100?
  • 22.8k
7 votes
1 answer
213 views

Can't get JSON representation for the help

The API Documentation and Help states: If the help URL is requested in a common web browser, a HTML styled version of the JSON help will be returned. Otherwise, the JSON help will be ...
  • 2,894
2 votes
1 answer
2k views

Help on help results in HTTP 500 Internal Server Error

A request to http://api.stackoverflow.com/0.8/help?help results in an HTTP 500 with Content-Type: application/json and an HTML body.
  • 2,894
4 votes
2 answers
156 views

Request with Invalid key still return the content and rate limit stepped down into No Key Limit

For example http://api.stackoverflow.com/0.8/stats?key=TEST1234&type=jsontext Request with Invalid key still return the content and rate limit stepped down into No Key Limit X-Ratelimit-...
  • 5,022
1 vote
1 answer
102 views

Possible Bug With positive_rep Field?

I'm looking through my /users/{id}/reputation and I think I see a possible bug regarding how positive_rep is calculated when someone upvotes your question. http://api.stackoverflow.com/0.8/users/...
0 votes
1 answer
139 views

"Get an API key" on stackapps.com/about page is incorrect

the "Get an API key" link listed on the stackapps about page is incorrect. It points to https://stackapps.com/app/register and a lovely picture of Zardoz instead of the correct https://stackapps.com/...
  • 175
4 votes
1 answer
82 views

Getting error 4002 when calling tags method without a sort parameter

According to the documentation, calling the tags method without a sort parameter should return the recently used tags, since the default sort is by activity. Instead, I get an error 4002 with the ...
9 votes
1 answer
598 views

Keep getting HTTP 406

Not sure if this is a user or an API problem, but I keep getting HTTP 406 Not Acceptable when making API calls (for example http://api.stackoverflow.com/0.8/stats) from either IE 8 or Chrome 6. Here ...
  • 2,894
1 vote
1 answer
138 views

questions/{id} API method: pagesize parameter?

I'm trying to get the lightest data about a given question id because i just need the question's title. With this call: http://api.stackoverflow.com/0.8/questions/1598715?pagesize=1 i get "pagesize":...
2 votes
1 answer
160 views

Make www a subdomain.

Try going to http://www.stackapps.com Apparently www is not a subdomain of stackapps.com Anyone who tries to get to the site by prepending the www will be confused, as it is standard to point that ...
  • 22.8k
3 votes
1 answer
101 views

The Faq Has a Broken Link

Currently the first link in the FAQ points to http://dev.stackapps.com/?tab=apps. It should link to https://stackapps.com/?tab=apps. Simple fix, but it confused me for a short time.
  • 2,966

1
5 6 7 8
9