Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
0 votes
1 answer
69 views

api.meta.stackoverflow.com has state:normal - is this correct

i am not sure what the origin and exact meaning of the term 'linked_meta' is, but I would guess that it is a term created for area 51 meta sites and the implied meaning is clear. Perhaps stack meta ...
  • 11.5k
2 votes
1 answer
75 views

stackauth is not serving gzip to silverlight3/phone7

I ported all of my integration tests to phone 7, which is a flavor of silverlight 3, and found that stackauth is not forcing gzip as expected. while this simply means that I need to check the first 2 ...
  • 11.5k
0 votes
1 answer
90 views

Where are the new Metas?

According to the most recent blog post, ServerFault and SuperUser each got their own Meta. Shouldn't this be showing up in StackAuth?
  • 22.9k
1 vote
1 answer
126 views

New Meta sites out of order in /sites

I don't know if this is by design, but the ServerFault and SuperUser Meta sites don't follow their main sites in the response for the sites API route. Having linked_meta sites follow their main (...
2 votes
1 answer
84 views

Paging /users by rep is on sites with low user count unpredictable

Resolution Fix confirmed: Tests.SortDupBug Page 1 #100 Total 11066 api.serverfault.com /users?max=2147483647&min=99&page=1&pagesize=100&key=qgAq_KfDu0KYzlNG-qaTuw Page 2 #100 Total 11066 api....
  • 11.5k
1 vote
2 answers
42 views

nottagged parameter not documented

It appears that the /questions method still takes the nottagged which specifies a list of tags to exclude questions by but this parameter is not mentioned in the documentation. Is this parameter ...
  • 6,065
2 votes
1 answer
79 views

Oddity with migration data from questions

Take a look at this question on SuperUser. Apparently, it was migrated from ServerFault, and was originally asked by user 3d1l. However, now look at the API result: http://api.superuser.com/1.0/...
  • 4,285
1 vote
1 answer
121 views

Confusion over my API key

This is directed at the team, since nobody else will be able to help. The key I took out for StackMobile is behaving strangely. I make a few requests, and then the limit resets to 0. (By limit, I'm ...
  • 22.9k
3 votes
1 answer
857 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
  • 11.5k
1 vote
1 answer
142 views

Game developer's logo isn't working.

See here: http://stackmobile.com/ - towards the bottom Neither the main logo, nor the meta logo is workin.
  • 22.9k
6 votes
1 answer
74 views

should min/max for alpha-numeric cases be case-insensitive?

I am having a hard time coming up with a use case in which case-sensitive min/max parameters make sense and several solid cases for a case-insensitive min/max. Example: With case insensitive min/max:...
  • 11.5k
1 vote
1 answer
61 views

Pro Webmasters Meta API not working.

Try this: http://api.meta.webmasters.stackexchange.com/0.9/questions?type=jsontext I can't get it to work, even though it's listed in StackAuth.
  • 22.9k
1 vote
1 answer
207 views

stackauth throwing 503 (in html format) after just a few /users/{id}/associated requests

After 5-8 successful requests 503 error, in html format, are being thrown. The requests are unique and consecutive, no api abuse is occurring. A related, but critical, concern is that any error ...
  • 11.5k
2 votes
1 answer
91 views

Problems with the Site Icons

I'm having trouble with the WebApps icon being returned from the /sites method. Namely, the image is composed of a larg white rectangle with a very small guy in the middle. Why can't the guy take up ...
  • 22.9k
4 votes
2 answers
126 views

How far behind is the data returned by calls supposed to be?

I understand that the data sourced to the API are cached, but I'm seeing some fairly extreme discrepancies between reputation reported by the API and apparent activity on the site. For example: ...
  • 3,082
3 votes
2 answers
127 views

Shouldn't the API help be consistent with the trademark guidance?

The description for the two StackAuth Routes within the API help both contain the phrase StackExchange network - shouldn't this rather be Stack Exchange Network to be consistent with the recently ...
  • 1,380
2 votes
2 answers
137 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
  • 22.9k
5 votes
1 answer
131 views

Site in closed beta but api working

Webapps has been added yesterday, website is in closed beta and it's not possible to see something on the website when you are not logged. But if you use the API you can get information. http://api....
  • 453
5 votes
1 answer
135 views

Intermittent bug in the /search route when providing both tagged and nottagged parameters.

I'm getting the wrong number of results back from the /search route depending on what combination of values I provide for the tagged and nottagged parameters. Examples: http://api.stackoverflow.com/1....
3 votes
1 answer
48 views

pagesize=0 on /search throwing error

http://api.stackapps.com/0.9/search?intitle=a&pagesize=0 { "error": { "code": 4001, "message": "The 'pagesize' query parameter is invalid." } }
  • 11.5k
2 votes
1 answer
90 views

/questions/{id}/timeline throwing 500 instead of 404

Kevin, you fixed this bug some time ago, would you like to tag it as status-complete? Sometime last week, this route stopped throwing 404 like the rest of my 'bad id' tests and started throwing 500. ...
  • 11.5k
0 votes
1 answer
52 views

The /questions/{id}/timeline route isn't working.

I'm getting a response code 500 for the /questions/{id}/timeline route. I've tried it in Firefox and by fetching a response in Java. Example URL: http://api.stackoverflow.com/0.8/questions/59294/...
2 votes
1 answer
68 views

Problem getting a users answers within a date range

This issue is similar to Problem getting a users questions within a date range. Only this time I'm calling a different api and getting unexpected results. I'm calling http://api.stackoverflow.com/0.8/...
user avatar
2 votes
1 answer
146 views

crossdomain.xml and clientaccesspolicy.xml needed on sstatic.net

Silverlight image loading from Uri fails due to lack of xdomain permission files. Needed: http://sstatic.net/clientaccesspolicy.xml http://sstatic.net/crossdomain.xml
  • 11.5k
3 votes
1 answer
58 views

both /revisions methods are spotty

These are the urls for a couple of my valid endpoint tests of the /revisions methods. http://api.stackoverflow.com/0.8/revisions/2688191 (?key=xxx) http://api.stackoverflow.com/0.8/revisions/2350874/...
  • 11.5k
1 vote
1 answer
48 views

/users - fromdate/todate broken

consider: All users on meta : "total": 18923, http://api.meta.stackoverflow.com/0.8/users?sort=creation&order=desc Users created on meta in the last month: "total": 18923, http://api.meta....
  • 11.5k
2 votes
2 answers
72 views

Missing on_site in Stack Apps site data in associated_users from stackauth query

This is what I get for Stack Apps: { "display_name": "user", "email_hash": "11aa11...22bb22...", "reputation": 101, "user_id": 0000, "user_type": "...
5 votes
1 answer
117 views

StackApps is not being reported by StackAuth

The stackauth.com sites query is not returning stackapps.com at all: http://stackauth.com/0.8/sites?type=jsontext { "api_sites": [ { "name": "Stack Overflow", "logo_url": "http://...
  • 1,522
3 votes
1 answer
142 views

Why do some Stackauth associated queries fail?

This query fails: http://stackauth.com/0.8/users/137b94e5-050c-4dd5-82c1-aeb2af0814f5/associated In Python for a jason.loads call, I get an error: 'ValueError("No JSON object could be decoded")'. I ...
3 votes
1 answer
118 views

Problem getting a users questions within a date range

I'm having a problem returning a list of users questions within a given timespan. I understand that the documentation ( http://api.stackoverflow.com/0.8/help/method?method=users/{id}/questions ) that ...
user avatar
0 votes
1 answer
37 views

/stats meta data missing

So am I to assume that since we can make an extra call to another site to get meta that site node in stats has been deemed redundant data. If so, I have to suggest a reality break. This is one of ...
  • 11.5k
4 votes
1 answer
114 views

http://stackauth.com/0.8/sites down

I realize you may be shaking something out but in case you are not aware: http://stackauth.com/0.8/sites is returning { "api_sites": [] }
  • 11.5k
3 votes
0 answers
120 views

StackAuth needs crossdomain.xml and clientaccesspolicy.xml

These would be helpful to have. Absence breaks Silverlight apps. http://stackauth.com/crossdomain.xml http://stackauth.com/clientaccesspolicy.xml http://stackauth.com/0.8/crossdomain.xml http://...
  • 11.5k
1 vote
1 answer
241 views

Question's title attribute is not HTML encoded

Question's title attribute is not HTML encoded. Examples: http://api.stackoverflow.com/0.8/questions/456815?body=true&answers=true title: "Problems with HTML <marquee> tag" http://api....
2 votes
2 answers
815 views

Server has stopped obeying Accept-encoding header

Either today or yesterday, besides /questions/tagged having disappeared, the server started ignoring the Accept-encoding header: Ligação estabelecida com 69.59.196.211 na porta 80 GET /0.8/questions/?...
  • 123
2 votes
1 answer
42 views

/answers/{id} summary incorrect

/answers/{id} Gets a set of questions enumerated in id should probably be Gets a set of answers enumerated in id
  • 11.5k
2 votes
1 answer
50 views

Why does /users/{id}/answers, which returns an array of answers, have an optional 'answers' flag?

I would assume that if you are requesting the route '/users/{id}/answers' that you wish to receive some answers.
  • 11.5k
0 votes
1 answer
148 views

min/max parameters are incorrectly documented as date - confusion and crippled libraries ensue

I have noticed this on all sorted routes. The min/max say that they are context sensitive to the sort type yet are documented as date. How is a date min/max valid when sorting by, for instance votes?...
  • 11.5k
6 votes
1 answer
103 views

The tagged parameter does not work with multiple tags

Take these two API calls: http://api.stackoverflow.com/0.8/questions?tagged=php;rant http://api.stackoverflow.com/0.8/questions/tagged/php;rant A couple of problems: Shouldn't they return the same ...
  • 1,522
9 votes
2 answers
186 views

/search intitle arg is case sensitive

This seriously cripples any search capabilities. Consider: http://api.stackapps.com/0.8/search?intitle=soapi&order=desc&sort=activity vs http://api.stackapps.com/0.8/search?intitle=Soapi&...
  • 11.5k
5 votes
2 answers
157 views

The /search route is ignoring the answers parameter.

The answers parameter was recently added to most of the requests that return a list of questions. See: Don’t include answers in question lists by default It looks like the /search request got left ...
0 votes
2 answers
82 views

Answers suddenly not getting returned.

Try: http://api.stackapps.com/0.8/questions/212 None of the answers are present.
  • 22.9k
2 votes
1 answer
65 views

Answers parameter not functional

For example the following: http://api.stackoverflow.com/0.8/questions?answers=true doesn't return answers.
  • 693
2 votes
2 answers
76 views

Order parameter not functional

Consider these two API calls: http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=desc http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=asc ...
  • 1,522
2 votes
1 answer
86 views

Include range [1, 100] on pagesize

I see that "range" is being used to indicate valid range on most numeric parameters, e.g. 32-bit integer, range [0, 2,147,483,647] 32-bit integer, range [1, 2,147,483,647] The smaller valid range ...
  • 11.5k
3 votes
2 answers
77 views

On /users method id parameter does not work

Calling /users method with id parameter returns a list of users and not the user expected. http://api.stackoverflow.com/0.8/users?id=23234 Could be a documentation "bug" on help page: http://api....
1 vote
2 answers
97 views

Possible problem calling users/?filter method searching username with tilde

I'm testing curious usernames and I am searching their user_id by: http://api.stackoverflow.com/0.8/users/?filter=username_filter I'm trying to get information about this particular user: http://...
1 vote
1 answer
66 views

Inconsistent sort ordering on users?

I'm trying to get a list of the 10 oldest users. This is the endpoint I'm using: http://api.stackoverflow.com/0.8/users?key=(key)&order=asc&sort=creation&pagesize=10&page=0 ...
  • 5,244
2 votes
1 answer
91 views

Question sort: change active to activity?

I noticed the sort newest for /questions, /questions/tagged/{tags} and /questions/unanswered was changed to creation recently, making it more consistent with other methods. Could the sort active for /...
  • 369
1 vote
2 answers
82 views

Stats not showing the same values as the Site

I get less values in the api method that in the site, is this posible? Example: form the API I get that SO has 709980 questions from site 701005

1
5 6 7
8
9