Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
6 votes
1 answer
107 views

API 'search' method with 'tagged' parameter

From the docs for tagged paremeter: List of tags delimited by semi-colons of which at least one must be on a question Yet, when I execute this query (http://api.stackoverflow.com/1.0/search?tagged=...
  • 1,261
5 votes
1 answer
61 views

You can gain reputation from edits to tag wikis, although they are not accessible through the API.

Reputation gain from edits to tag wikis appear through the API; the API reports them as answers, but fetching them via the /answers route does not work. Case in point: My accepted edit (+2 rep) My ...
  • 935
5 votes
1 answer
73 views

/user/{id}/timeline results leaking template used for badge information

From my elections statistics page: I inserted in the detail field as plain text because I wasn't sure if the results would be HTML, but the $ChatUrl left in the anchor's href is surely a bug.
  • 819
1 vote
1 answer
78 views

Is Stack Overflow Meta incorrectly configured?

If I call the Auth "sites" API, then it shows Meta Stack Overflow as: "name": "Meta Stack Overflow", "logo_url": "http://sstatic.net/stackoverflowmeta/img/logo.png", "api_endpoint": "http://api....
  • 455
2 votes
1 answer
98 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
  • 4,285
1 vote
1 answer
73 views

Associated accounts is broken for this user

When I retrieve associated accounts for Joel Coehoorn using this query it only includes Programmers.SE and Webmasters.SE despite the fact that I retrieved the association key from a query to SU. The ...
3 votes
1 answer
82 views

tag colors incorrect

the tag color for english site seem incorrect, the dark grey color is the background while the yellow colour is the foreground. This is contradictory to other sites which have the darker colours as ...
  • 3,058
3 votes
0 answers
70 views

OBSOLETE - Unanswered questions with tags returns wrong total

When requesting a list of unanswered questions with a specific tags the total count show the total number of questions for that tag, not the count for the unanswered questions. Using http://api....
6 votes
1 answer
222 views

Why these questions do not have a title?

Hitting the following /questions route: http://api.stackoverflow.com/1.0/questions/74?pagesize=1&page=1 the endpoint returns this JSON data: { "total": 1, "page": 1, "pagesize": 1, "...
2 votes
1 answer
125 views

MSO is not being returned in StackAuth's /users/{id}/associated route

In looking into a StackFlair issue, I have discovered that MSO is not being returned as part of a user's associated accounts. Please see my associated accounts according to the api. Note that there ...
2 votes
1 answer
65 views

An associated query is returning a partial record for a particular user

This query returns (in addition to several complete records) this incomplete one: { "user_id": 2196, "user_type": "registered", "display_name": "Wil", "reputation": 151, "email_hash": "...
1 vote
1 answer
104 views

Comments are returning markdown.

Look at the output of the following: http://api.askubuntu.com/1.0/questions/12218?comments=true Output: { "comment_id": 12713, "creation_date": 1289269467, "owner": { "user_id"...
  • 22.9k
5 votes
2 answers
157 views

API Help's CSS is missing

The API Help page's CSS file, located at http://sstatic.net/so/all.css, is current returning 404 for me: <div id="header"><h1>Server Error</h1></div> <div id="content"> ...
  • 819
2 votes
1 answer
79 views

/questions/{id}/answers missing title attribute

http://api.stackoverflow.com/1.0/help/method?method=questions/{id}/answers (it won't linkify properly!): "title": { "description": "title of this post, in plaintext", "values": "string", "...
  • 1,522
0 votes
1 answer
103 views

Getting garbage on requests

Not exactly sure how or why, but many times when I try and preview some URL, I get garbage. This has happened on several JSON preview websites as well as on my browser. Strangely this isn't all the ...
  • 150
2 votes
1 answer
36 views

/questions/id route problem: comments section is not returned when there aren't comments on question

Something is changed on questions route called with comments= True: http://api.stackoverflow.com/1.0/questions/1940243?body=True&comments=True&pagesize=1&page=1 It does not return the ...
2 votes
3 answers
125 views

StackAuth returning 404?

http://stackauth.com/1.0/sites http://stackauth.com/1.0/help Both of these are currently returning 404 Not Found. What's up with that?
  • 1,522
2 votes
1 answer
75 views

Suddenly, some entries on /questions route are missing display_name

An odd bug has developed this morning. At the moment, api.stackoverflow.com/1.0/questions is returning a question of the format... ... }, { "tags": [ "jsf-2.0" ], "...
  • 4,285
2 votes
1 answer
120 views

AskUbuntu API returns wrong colours

Calling the stats method of the AskUbuntu API returns the wrong colours.
  • 786
4 votes
1 answer
878 views

Wrong content-type in JSONP calls

When passing jsonp parameter, the API returns "application/json" instead of "application/javascript". I found this because if you do: <script src='http://api.stackoverflow.com/1.0/badges?jsonp=...
1 vote
1 answer
84 views

user 'about_me' field suggested_buffer_size is too small

the suggested_buffer_size of user.about_me is currently 3000. it is apparent that this is the server-side field length. the problem is that the text is stored server-side in markdown but when served ...
  • 11.5k
4 votes
1 answer
224 views

update crossdomain.xml on stackauth.com and api endpoints to work with current Flash

I am implementing a javascript client that uses the Flash based XHR replacement Flensed in the interest of providing more robust api communication than that provided by JSONP. Apparently the current ...
  • 11.5k
3 votes
2 answers
168 views

What happened to nothingtoinstall.com?

This is weird: { "name": "Web Applications", "logo_url": "http://sstatic.net/webapps/img/logo.png", "api_endpoint": "http://api.webapps.stackexchange.com", "site_url": "http://...
  • 22.9k
1 vote
3 answers
274 views

Icons of beta sites

Icons of beta sites are different form the icons given in the http://stackauth.com/1.0/sites . As example: Original icon of the English Language and Usage is     where http://stackauth....
1 vote
1 answer
77 views

question.migrated.to_site null

http://api.stackoverflow.com/1.0/questions/322108?sort=activity&order=desc { "total": 1, "page": 1, "pagesize": 30, "questions": [ { "tags": [ "discussion", "fun"...
  • 11.5k
5 votes
1 answer
92 views

Empty results for associated queries

Queries such as this http://stackauth.com/1.0/users/f5388585-c0b9-417f-99c5-f1a58fda3e83/associated have started giving empty results { "associated_users": [] } Expected results: SiteUrl ...
3 votes
2 answers
71 views

Sorting comments by votes doesn't return 0 score comments

I have a query: http://api.stackoverflow.com/1.0/users/16822/comments?sort=votes This doesn't return comments with no votes, setting min to 0 doesn't work. This query includes them all, but isn't ...
  • 786
1 vote
1 answer
110 views

new throttle does not differentiate between api requests and requests made from viewing the site

Update: I am unable to reproduce the case of interactive browsing affecting app quota. And will concede that the failures that prompted this post were likely far edge cases. The remaining issue of a ...
  • 11.5k
0 votes
1 answer
48 views

issues with 'edit_count' field

Update other than the nullable issue, which is under review, the rest of this question is based on a mistake I made reading the nesting depth of the json result. Disregard. Deletion is considered. ...
  • 11.5k
2 votes
1 answer
196 views

Why are 5 IP addresses using my API key?

I have an app that resides on a server. It has only ever accessed the API from 2 IP addresses. The API key has not been shared and there is no client-side code. When I go to /apps however, it says "5 ...
  • 22.9k
6 votes
3 answers
2k views

API usage triggering 503 (Too Many Requests)

Update: I generally try to back any claims of bugs and shortcomings with evidence. I have prepared a test page which you, dear Stack Overflow staff and my fellow developers, can use to ascertain ...
  • 11.5k
2 votes
1 answer
108 views

API selectively ignores jsonp parameter - havok ensues

UPDATE: this is happening on all routes now and seems to be getting worse. Whatever it is just started this morning. compare url to json response GET /1.0/users/14/badges?key=qgAq_KfDu0KYzlNG-qaTuw&...
  • 11.5k
2 votes
1 answer
70 views

API is completely down? content encoding is broken?

all requests have no content-encoding or have 'gzip,gzip', both of which fail to decompress browser side. note: the content-encoding header, when it is present, does not seem to be included in the ...
  • 11.5k
3 votes
1 answer
67 views

key not being recognized by api.meta.stackoverflow.com?

I have been testing a throttle implementation against meta today and suddenly got shut down with a key violation. It is possible that I have used enough requests to prompt this but I doubt it. In ...
  • 11.5k
4 votes
1 answer
12k views

/users/{id}/reputation != xxx.com/reputation

I realize that the shape of the data coming from the API may be different than that reported by the xxx/reputation url, but there seem to be some striking disparities. see 08/12 and 08/11 in both ...
  • 11.5k
5 votes
0 answers
73 views

OBSOLETE - /tags fromdate and todate does nothing

Although the help/documentation lists todate and fromdate parameters for tags they do not work. This may be related to tags not having a creation_date. It would be great if we could filter tags by ...
  • 159
5 votes
1 answer
91 views

What's the difference between tags soapi.cs and soapi.js to get a bug triggered by the former?

Right now questions tagged soapi.cs returns a HTTP status code 404 (for various HTTP clients) while questions tagged soapi.js does not. Interestingly though, soapi.cs seems to work just fine in other ...
  • 1,380
3 votes
0 answers
62 views

/users/{id}/tags - 504 Gateway Timeout

this url is technically valid but generates 504. http://api.stackoverflow.com/1.0/users/242897/tags?filter=c%23&fromdate=0&max=1577836800&min=0&page=1&pagesize=100&sort=...
  • 11.5k
3 votes
1 answer
67 views

Badges with zero count no longer returning zero

For queries such as http://api.{sitename}.com/1.0/users/{id} if a badge count is zero, the API is no longer returning "gold": 0, for example.
6 votes
5 answers
526 views

Where can I find the reputation black market?

Apparently there is one around, at least I can't explain the recent jump in reputation of 4k for user 1026 by any other means (just kidding of course, no offense please ;) The API Beta badge accounts ...
  • 1,380
4 votes
1 answer
75 views

Encoding inconsistency on /users/{id}/reputation

Take these two calls: http://api.stackoverflow.com/1.0/users/180784/reputation?todate=1278854265&pagesize=1 "title": "Save a custom ListView&#39;s instance state?", http://api.stackoverflow....
  • 1,522
4 votes
2 answers
90 views

/users/{id}/answers - broken

Have not checked other routes, as I am busy with other things, but a failing test pointed this out... GOOD: http://api.stackoverflow.com/1.0/users/242897/answers?min=4&sort=votes { "total": 37,...
  • 11.5k
0 votes
1 answer
63 views

Bug - Getting partial results for questions

When processing http://api.stackoverflow.com/1.0/questions/1156985 I only get partial results. Many of the missing fields are mandatory fields, including the owner of the question.
user avatar
1 vote
1 answer
92 views

api.money.stackexchange.com returning questions from 2009?

http://api.money.stackexchange.com/1.0/questions/?pagesize=1&fromdate=1254960000&todate=1255564793 body => question[0] => [creation_date] => 1254969799 1254969799 == Thu, 08 Oct ...
3 votes
1 answer
75 views

server fault and super user rate limit bonus?

Looks like SF and SU are granting Int.MaxValue rate limit. Not that I mind, but it would be nice to have on the other sites too. ;-) Thought you would like to know. GET /1.0/users/173?key=mykey HTTP/...
  • 11.5k
4 votes
1 answer
127 views

questions method returns error 4000

I'm getting error 4000 on every endpoint on questions method (with key): http://api.superuser.com/1.0/questions?sort=votes&pagesize=30&page=1&key=stackprinterkey the only endpoint not ...
3 votes
1 answer
114 views

/users/{id}/associated - inconsistent behavior

/users/{id}/associated occasionally returns empty for an association even though there are definitely associated users. Calling it again immediately returns expected results. GET /1.0/users/e58345f5-...
  • 11.5k
0 votes
1 answer
84 views

stackauth.com/1.0/users/{id}/associated not returning display_name for some sites

The problem with email_hash seems to be fixed, but now display_name is not getting returned in some cases. For example: This Super User /users/{id} query returns a display_name, but the corresponding ...
5 votes
2 answers
117 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).
1 vote
2 answers
136 views

On Stackauth /sites new meta sites have wrong name

This should be the correct behaviour: name: "Stack Overflow Meta" name: "Web Apps Meta" name: "Gaming Meta" .. For the newcomers Server Fault and Super User, Meta is before the parent site in the ...

1
5 6
7
8 9