Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
1 vote
0 answers
194 views

/oauth/access_token not redirecting back to my redirect_uri

I am trying to implement Stack Exchange using oAuth 2.0. I am able to get CODE but, when I try to get access_token through this code: <?php if(isset($_GET['code'])) { ?> <form method="POST" ...
6 votes
1 answer
101 views

/users/{ids}/timeline creation_date missing or incorrect

I am writing a small widget that displays the time since I was awarded my last badge on Stack Overflow. I noticed that my most recent badge was missing from the timeline data (/users/{ids}/timeline). ...
1 vote
1 answer
88 views

Most of the url are missing the protocol

Maybe you were trying to fix the other "bug" I've pointed out, but now most of the url for the icons are missing the protocol! { "site_type": "main_site", "name": "Stack Overflow", "...
  • 123
3 votes
0 answers
70 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
  • 131
5 votes
2 answers
129 views

Stack Exchange API is returning boolean(false) For 'is_answered' On Question With Accepted Answer

When you view this question you see a closed question which has an accepted answer. When you get the API info for it you get this: ["question_id"]=> int(17466804) ["creation_date"]=> int(...
2 votes
1 answer
68 views

Stack Exchange API is returning non-existant/incorrect notices for questions

When you view this question you do not see any notices other than the protected notice at bottom. Also, you are able to edit the answers and question (provided you have the privilege). However, when ...
14 votes
1 answer
135 views

Stack Exchange API is not returning the close vote counts for questions

When you visit this question (with proper privs) you can see that there are 2 close votes cast for it. However, if you access the information for this question using the Stack Exchange API you get ...
2 votes
1 answer
63 views

Default listing images aren't served from CDN, fail to load because of certificate error

The default images used on the app/script/library pages aren't pointing to the CDN, so their use of HTTPS causes a certificate error that prevents the image from loading: Could the image sources be ...
  • 4,686
5 votes
1 answer
84 views

The API has stopped allowing CORS requests

I just noticed that a script I have that makes CORS requests to the API stopped working on Meta Stack Overflow, claiming that the domain isn't allowed by Access-Control-Allow-Origin, which is true ...
  • 4,686
4 votes
0 answers
107 views

Parameter `tagged` in `search/advanced` seems to use `AND` instead of `OR`

It seems that search/advanced has the same problem as in "The tagged parameter does not work with multiple tags" question. When I select c#; .net I only get results tagged both c# and .net: http://...
1 vote
1 answer
60 views

CDN redirect for the API's JavaScript SDK is incorrect

The API's JavaScript SDK is listed as https://api.stackexchange.com/js/2.0/all.js. However, GET request produces the following response: Status Code: 301 Moved Permanently Location: https://api-...
3 votes
1 answer
299 views

Stack Exchange OAuth2, explicit access-token response format does not adhere to RFC6749 standard

I'm using the Stack Exchange v2.1 API. I'm using the explicit OAuth 2.0 flow, but it seems that the access token response step does not adhere to the RFC 6749 standard. Specifically, the Stack ...
  • 131
1 vote
1 answer
78 views

Inbox and Notifications aren't being filtered by site

I'm using the API get inbox messages and notifications for various sites on the StackExchange network, but it doesn't seem to matter what site parameter I pass in the query string. I always get my ...
1 vote
1 answer
69 views

Off-by-one error in fromdate processing

When running a query with a given fromdate value, values which match fromdate - 1 are returned. An example: When using fromdate=1367715851 results will be returned which have a creation_date of ...
1 vote
0 answers
27 views

The 2.1, "similar" path is returning empty results

I've been a happy user of the /2.1/similar Stack Exchange API for a while. But, at some point within the last 24 hours, or so, it started returning empty results (but otherwise reporting everything as ...
2 votes
1 answer
112 views

Not possible to login to approve or reject access to application on Windows Phone 7 device

I'm making an app for Windows Phone using the Stack Exchange API but I'm having a bit of trouble when I try to let the user approve the application (using client side flow). I open a web browser at ...
6 votes
0 answers
44 views

API docs for "stack overflow" still feature v1.0 docs

I guess I'd call this a doc bug. Currently the page http://api.stackoverflow.com redirects to http://api.stackoverflow.com/1.0/usage, which says at the top "Don't use 1.0, use 2.1". This URL ...
  • 161
9 votes
0 answers
367 views

Application stats are completely broken.

It appears that the application stats are completely broken. Attempting to view the number of times Stack Mobile hit the /questions/* methods results in this graph: It would seem that statistics were ...
  • 22.8k
9 votes
1 answer
68 views

Whatever happened to closed_reason?

When pulling back info on a closed question, I have come to expect closed_reason to be a present key if there's a closed_date. It seems that as of recently this is no longer true. Proof: https://api....
  • 253
3 votes
1 answer
61 views

Problem with /search tagged and max

Seems like a problem with /search when max is not set to today, and tagged is given: https://api.stackexchange.com/2.1/search?order=desc&max=1358294400&sort=activity&tagged=java&site=...
  • 413
3 votes
1 answer
85 views

Why is "body" missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
  • 22.8k
1 vote
1 answer
37 views

Questions returned by /questions/{ids}/related do not contain link properties

The API docs claim that /questions/{ids}/related return question objects, but I can't find a link property on the returned questions at all. Is there some sort of workaround to find the link for a ...
1 vote
1 answer
34 views

What is the api_site_parameter of stackapps.com in API 2.x

What is the api_site_parameter of stackapps.com in API 2.x? https://api.stackexchange.com/2.1/sites doesn't list stackapps. Why?
4 votes
0 answers
85 views

API v1.1 users call returns association_id for which the Stack Exchange web site has no profile

For a particular user, the users API v1.1 call returns an association_id that gives a "Page Not Found" error where the Stack Exchange profile should be, though their Stack Exchange profile can be ...
  • 623
12 votes
1 answer
445 views

Why is my API quota not resetting after UTC reset?

According to How API Keys Work, the default daily API limit -- which is per site, per day -- is 300. I started with 300, as expected, but over a period of days, I've noticed that the remaining quota ...
  • 733
1 vote
0 answers
161 views

Unread messages in inbox query shows older inbox messages

I am using the /inbox/unread route to get the unread messages in a user's inbox. Recently (over the last couple of months, perhaps) I have noticed that the entries returned from this route initially ...
  • 3,853
5 votes
1 answer
120 views

API docs titled "v2.0"; should be "v2.1"

The documentation is titled "StackExchange API v2.0"... this should be updated to "v2.1" as it's not readily obvious that version 2.1 has been published otherwise. https://api.stackexchange.com/docs
3 votes
1 answer
220 views

API documentation console unsuccessfully tries to load MiniProfiler results

All of the documentation pages (example) with the test console currently attempt to load MiniProfiler result data, which fails with a 404: POST https://api.stackexchange.com/mini-profiler-resources/...
  • 4,686
4 votes
1 answer
47 views

Typo in the docs for /me

The doc says: Returns the user associated with the passed auth_token. This method returns a user. It should say "access_token" instead of "auth_token".
  • 358
3 votes
1 answer
38 views

Querying "standard meta tags" for their tag wikis wrongly says they have none

I'm checking which tags have tag wiki excerpts in my code. It looks like /tags/{tags}/wikis is the right API since the tag info API doesn't even give a boolean for tag wiki excerpt presence. But ...
2 votes
1 answer
29 views

The "Get Started" section in the sidebar only mentions API 2.0 and API 1.1

Now that API 2.1 is "public, frozen, and out the door" shouldn't we update the "Get Started" section in the sidebar on the right side of the screen. It talks about API 2.0 and API 1.1 but doesn't ...
2 votes
1 answer
61 views

No token field in the docs test page for /me/reputation-history

There is no form field for an access token at: https://api.stackexchange.com/docs/me-reputation-history https://api.stackexchange.com/docs/me-full-reputation-history After attempting to Run the API ...
  • 123
16 votes
1 answer
424 views

Bug in the StackExchange Api ? getting "could not parse proxy url" when user not logged in

I think I may have stumbled upon a bug in the Stack Exchange JS API I'm having a problem getting its authentication to work properly, and I just discovered that the same problem exist in the official ...
  • 301
5 votes
1 answer
30 views

Typo in API filter documentation

When using unsafe filters, the API returns the highest fidelity data is can reasonably access for the given request. should be When using unsafe filters, the API returns the highest fidelity data ...
2 votes
1 answer
53 views

Error retrieving question using a filter that includes question.notice

I have created a filter to include the question.notice field. It seems to be OK as returned by https://api.stackexchange.com/2.1/filters/-9xc1l%2Au-JEsf_Q Then if I want to fetch this question using ...
  • 355
5 votes
1 answer
61 views

Typos in the API 2.0 Documentation

Typo #1: There are two different objects that represent a user in the Stack Exchange API, the full user object and the smaller shallow_user object. Which is returned depends on the method being ...
2 votes
1 answer
69 views

Stack Apps graph time filters make pretty much no sense

When viewing the Query Statistics graphs for an application, you have the option of choosing 'Week', 'Month', 'Year', or 'All Time'. When hovering over 'week' it states "view stats for the last 7 ...
  • 271
2 votes
1 answer
63 views

Advanced search by title doesn't filter on the title

Searching by title on the advanced search method doesn't restrict the results to posts containing the specified text as a word or even substring. Varying the string has some influence, but I can't ...
2 votes
1 answer
36 views

View count restriction isn't working for /search/advanced.

I have constructed the following URL, but the questions returned don't contain anywhere near 50k views, despite the query string parameter: http://api.stackexchange.com/2.1/search/advanced?site=...
  • 22.8k
1 vote
1 answer
38 views

The inname parameter does not work with multiple parameters

I am trying to get details by passing semicolon delimited list in inname paramter but it is not working. I tried below API call: https://api.stackexchange.com/2.0/tags?order=desc&sort=popular&...
  • 125
1 vote
0 answers
58 views

Stack Apps "Welcome Back" banner text isn't centered

This appear to be specific to Stack Apps. The text is centered on every other site I've tried. See below: Compared to how it should appear:
  • 189
5 votes
1 answer
43 views

/posts/{id}/revisions breaks for posts with [tag:*] content

Attempting to access (at least) the revisions route for a post with a revision involving the [tag:*] syntax causes an error: Example on Meta Stack Overflow (Post History) Example on Mathematica (Post ...
  • 4,686
1 vote
1 answer
20 views

Question count missing from network_user

Docs state that you get an int question_count from a network_user object but I'm not getting these fields back anymore - even when testing from https://api.stackexchange.com/docs/me-associated-users ...
2 votes
1 answer
80 views

/suggested-edits "Try it": Link for "suggested_edit_id" is broken

When using the "Try it" feature on /suggested-edits, the link for the suggested_edit_id points towards stackexchange.com and not towards the respective site. For example, retrieve data ...
  • 285
1 vote
1 answer
79 views

/me API endpoint returning 500 error

I'm making an authenticated call to /me: https://api.stackexchange.com/2.0/me?access_token=[redacted]&site=stackoverflow&key=[redacted] But it's returning: {"error_id":500,"error_name":"...
3 votes
1 answer
51 views

Typo in API docs: "temporarility_unavailable"

https://api.stackexchange.com/docs/authentication "temporarility" should probably be "temporarily"
2 votes
1 answer
63 views

/answers endpoint is error-500-ing against many sites

Just calling the "/answers" endpoint, no specific arguments, and I'm getting 500 errors: http://api.stackexchange.com/2.0/answers?order=desc&sort=activity&site=gaming {"error_id":500,"...
  • 3,237
0 votes
1 answer
85 views

Why does the /events service sometimes pause for a couple of minutes?

In developing the firehose service, I found that the /events API often "pauses" for a couple of minutes before resuming. Is this a known issue? Specifically, I am polling /events every 10 seconds ...
  • 3,853
2 votes
1 answer
55 views

Does /invalidate work for no-expiry tokens?

It seems that tokens created with no_expiry scope are immune to requests to invalidate them with /access-tokens/.../invalidate. Is this by design or by bug?
  • 3,853
1 vote
1 answer
45 views

Inbox unread since parameter not working

The since parameter of /inbox/unread no longer seems to work. I enter a date after the creation date of the item currently unread in my inbox and still the item is returned. I try putting in ...
  • 3,048

1 2 3
4
5
9