Skip to main content

Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
22 votes
1 answer
456 views

Stack Exchange thinks that Shog is a elected moderator

I was browsing the API for the list of elected moderators, The API URL is http://api.stackexchange.com/docs/elected-moderators#pagesize=100&order=desc&sort=reputation&site=stackoverflow&...
Bhargav Rao's user avatar
  • 1,357
16 votes
1 answer
446 views

Bug in the StackExchange Api ? getting "could not parse proxy url" when user not logged in

I think I may have stumbled upon a bug in the Stack Exchange JS API I'm having a problem getting its authentication to work properly, and I just discovered that the same problem exist in the official ...
Gabi Mor's user avatar
  • 301
14 votes
1 answer
147 views

Stack Exchange API is not returning the close vote counts for questions

When you visit this question (with proper privs) you can see that there are 2 close votes cast for it. However, if you access the information for this question using the Stack Exchange API you get ...
kittycat's user avatar
  • 507
13 votes
2 answers
569 views

Why is my API quota not resetting after UTC reset?

According to How API Keys Work, the default daily API limit -- which is per site, per day -- is 300. I started with 300, as expected, but over a period of days, I've noticed that the remaining quota ...
jmort253's user avatar
  • 753
11 votes
1 answer
194 views

"Informed" badge shown as Next badge, but doesn't exist on this site

On my profile page, the Informed badge is shown as the next badge to obtain: Clicking it even shows a popup with a link to the Tour page, but it looks quite different from other SE sites. Looking at ...
Glorfindel's user avatar
  • 6,772
11 votes
1 answer
359 views

Google’s OAuth redirect broken

We just tried to authenticate with our application without being logged into anything on StackExchange. This is best tested in a private browser session without any cookies etc. So after starting the ...
poke's user avatar
  • 707
11 votes
0 answers
143 views

The field body_markdown is not returned for comments [duplicate]

Using the method questions-by-ids to get the comments on a particular question, I do not get body_markdown returned despite it being selected in the filter. Here is the test query to reproduce the ...
user avatar
10 votes
0 answers
276 views

Tell us that POST is required to write

While troubleshooting /posts/{id}/comments/add in order to answer Why am I getting a 404 when trying to post a comment?, it was noticed that the API path in question only responded to POST requests. ...
michaelb958--GoFundMonica's user avatar
9 votes
1 answer
619 views

Keep getting HTTP 406

Not sure if this is a user or an API problem, but I keep getting HTTP 406 Not Acceptable when making API calls (for example http://api.stackoverflow.com/0.8/stats) from either IE 8 or Chrome 6. Here ...
Franci Penov's user avatar
  • 2,894
9 votes
1 answer
134 views

Typos in API documentation

From the /posts documentation: Most applications should use the question or answer specific methods, but /posts is available for those rare cases where any activity is of intereset. intereset => ...
Glorfindel's user avatar
  • 6,772
9 votes
1 answer
71 views

Whatever happened to closed_reason?

When pulling back info on a closed question, I have come to expect closed_reason to be a present key if there's a closed_date. It seems that as of recently this is no longer true. Proof: https://api....
Oli's user avatar
  • 253
9 votes
2 answers
190 views

/search intitle arg is case sensitive

This seriously cripples any search capabilities. Consider: http://api.stackapps.com/0.8/search?intitle=soapi&order=desc&sort=activity vs http://api.stackapps.com/0.8/search?intitle=Soapi&...
Sky Sanders's user avatar
  • 12.1k
9 votes
0 answers
385 views

Application stats are completely broken.

It appears that the application stats are completely broken. Attempting to view the number of times Stack Mobile hit the /questions/* methods results in this graph: It would seem that statistics were ...
Nathan Osman's user avatar
  • 23.3k
8 votes
1 answer
122k views

sorting ascending vs descending

I don't understand the difference between ascending and descending? Surely ascending means the most active/recent/popular/A first, and descending means the least active/recent/popular/Z first? But it ...
Jonathan.'s user avatar
  • 3,118
8 votes
2 answers
166 views

Stack Apps homepage truncates user names

A picture says more than a thousand words: These users aren't called "Bhargav Rac" and "Tunak", but Bhargav Rao and Tunaki. This happens on both the 'apps' and 'scripts' tabs of the Stack Apps ...
Glorfindel's user avatar
  • 6,772
8 votes
1 answer
225 views

Why is /questions API returning deleted questions?

In last few days I have noticed that questions API returns questions that where deleted hours before the API call. This is a short example, if more logs are need to pin point the problem, please ...
Petter Friberg's user avatar
8 votes
1 answer
459 views

API Key limit 10k is Per IP Address or Globally?

Getting started FAQ says No Key limit is IP Address based, but it does not say for with API Key. When I test my API Key from different IP Addresses, I noticed that 10k limit is globally, limit is ...
YOU's user avatar
  • 5,022
8 votes
1 answer
133 views

Bug with `badges/name` endpoint

Last night I had a programme running and it errored on the first call to the badges/name endpoint on the API, exact API endpoint call: https://api.stackexchange.com/2.2/badges/name?order=asc&sort=...
Der Kommissar's user avatar
8 votes
1 answer
136 views

Why is comment_count=1 (incorrectly) when this particular filter is used?

We're seeing that, when a particular filter we've created is used, the API will return "comment_count": 1 for questions with no comments. For a search for questions with no answers, ordered by ...
daviddoran's user avatar
7 votes
2 answers
503 views

After successfully retrieving 180 pages, the API gracelessly, semi-silently, fails

I'm trying to synchronize tags using the Stack Exchange API and this works for about 180 pages, but around 180 pages it always ends with an exception that seems to indicate that there is no HTTP ...
guido's user avatar
  • 71
7 votes
1 answer
132 views

The answer object returns an empty array for tags

Since version 2.1, the answer object has a field called tags. However, sometimes, an empty array or even nothing is returned in this field: Example with the filter !-*f(6t0Vk01e. Am I doing ...
FelixSFD's user avatar
  • 625
7 votes
1 answer
28k views

How to deal with the "Too Many Requests" error coming as HTML?

The API specifies error codes, and messages. It also specifies a "backoff" parameter. But, even while respecting the backoff and stopping at errors, and even when waiting a long time between requests ...
Denys Séguret's user avatar
7 votes
1 answer
75 views

User's Comments: returning 500 error?

It looks like when I try to get the comments of a user that has "a huge number" of comments, I get a 500 error. Jon Skeet's comments, 500 error: http://api.stackoverflow.com/1.0/users/22656/comments ...
rascher's user avatar
  • 225
7 votes
1 answer
222 views

Can't get JSON representation for the help

The API Documentation and Help states: If the help URL is requested in a common web browser, a HTML styled version of the JSON help will be returned. Otherwise, the JSON help will be ...
Franci Penov's user avatar
  • 2,894
7 votes
1 answer
246 views

Stackexchange oauth2.0 is suddenly failing

No changes in stack apps or my code, it was working fine for a while, suddenly it stopped working now. I get "InternalOAuthError: Failed to obtain access token" After more details inspection,...
Leart Beqiraj's user avatar
7 votes
1 answer
91 views

The 'should be closed' description in the flag dialog is missing a word

The 'should be closed...' reason has this description (emphasis mine): This question is completely unclear, incomplete, overly-broad, primarily opinion-based or is not about Stack Exchange API, app,...
ᔕᖺᘎᕊ's user avatar
  • 4,365
7 votes
0 answers
114 views

/me/associated doesn't return meta sites anymore

The documentation of /me/associated says: You can filter the network_users returned by this method with the types parameter. Specify, semicolon delimited, main_site or meta_site to filter by site. ...
Glorfindel's user avatar
  • 6,772
7 votes
0 answers
93 views

Requesting favorite questions should report which users have favorited it

I can request the favorite questions of a user via the users/{id}/favorites endpoint. If I'm only requesting the favorites for one user, then I know that all of the returned questions are the ...
Dave DeLong's user avatar
  • 5,264
6 votes
1 answer
135 views

API throws improper error when "date" parameters are the same

When using the Stack Exchange /questions API using the same date for fromdate and todate I get a 500 internal server error. Using different dates appears to work OK but specifying the same value ...
Andy Clark's user avatar
6 votes
5 answers
531 views

Where can I find the reputation black market?

Apparently there is one around, at least I can't explain the recent jump in reputation of 4k for user 1026 by any other means (just kidding of course, no offense please ;) The API Beta badge accounts ...
Steffen Opel's user avatar
  • 1,380
6 votes
1 answer
186 views

JavaScript SDK-based workflow never pushes message back from OAuth login_success page on Stack Exchange side

I'm using the JavaScript SDK by Stack Exchange provided with the latest API, and despite following the official instructions & examples it doesn't work - it seems there is a bug which breaks the ...
Mikhail Vink's user avatar
6 votes
1 answer
144 views

Field "comment_count" is not always returned by API

I am making a request with a custom filter that includes the "comment_count" field of the question type. My custom filter is !RtdMEtslKF6Z()NqpDUFZ58R6twu-.4V48gn0furqA*7_BL1. However, when I'm ...
Tunaki's user avatar
  • 733
6 votes
1 answer
9k views

'The target origin provided does not match the recipient window's origin' message when trying to use localhost

I am trying to experiment with the Stack Overflow API on my localhost and am struggling to get the authentication to complete. Here is my application JavaScript code (note that I am using IBM ...
MDalt's user avatar
  • 161
6 votes
1 answer
81 views

Descriptions of tag-based badges are incorrect

The descriptions associated to tag-based badges are wrong, they always show 0 instead of actual thresholds: Earned at least 0 total score for at least 0 non-community wiki answers in the … tag See ...
A.L - say no to AI's user avatar
6 votes
1 answer
111 views

API 'search' method with 'tagged' parameter

From the docs for tagged paremeter: List of tags delimited by semi-colons of which at least one must be on a question Yet, when I execute this query (http://api.stackoverflow.com/1.0/search?tagged=...
Nikita Rybak's user avatar
  • 1,271
6 votes
3 answers
2k views

API usage triggering 503 (Too Many Requests)

Update: I generally try to back any claims of bugs and shortcomings with evidence. I have prepared a test page which you, dear Stack Overflow staff and my fellow developers, can use to ascertain ...
Sky Sanders's user avatar
  • 12.1k
6 votes
1 answer
108 views

/users/{ids}/timeline creation_date missing or incorrect

I am writing a small widget that displays the time since I was awarded my last badge on Stack Overflow. I noticed that my most recent badge was missing from the timeline data (/users/{ids}/timeline). ...
Steph Sharp's user avatar
6 votes
1 answer
58 views

Several staff members are incorrectly listed as elected moderators

Several employees are being reported as elected moderators on sites they haven't been elected on, according to /2.0/users/moderators/elected. I think there was a similar issue reported before during ...
nobody's user avatar
  • 864
6 votes
1 answer
113 views

The tagged parameter does not work with multiple tags

Take these two API calls: http://api.stackoverflow.com/0.8/questions?tagged=php;rant http://api.stackoverflow.com/0.8/questions/tagged/php;rant A couple of problems: Shouldn't they return the same ...
Felix's user avatar
  • 1,522
6 votes
1 answer
226 views

Why these questions do not have a title?

Hitting the following /questions route: http://api.stackoverflow.com/1.0/questions/74?pagesize=1&page=1 the endpoint returns this JSON data: { "total": 1, "page": 1, "pagesize": 1, "...
systempuntoout's user avatar
6 votes
1 answer
77 views

should min/max for alpha-numeric cases be case-insensitive?

I am having a hard time coming up with a use case in which case-sensitive min/max parameters make sense and several solid cases for a case-insensitive min/max. Example: With case insensitive min/max:...
Sky Sanders's user avatar
  • 12.1k
6 votes
0 answers
71 views

Docs say the API returns a user's age, but it doesn't (anymore)

The doc page says that the user object returns an age property (for those users that specified an age). But the API  no  longer  does.   (Plus spot checks of users that had age in ...
Brock Adams's user avatar
  • 12.9k
6 votes
0 answers
98 views

Revisions API doesn't return all revisions if post has had multiple edits made in quick succession

I am pulling information from the posts API and then checking the revisions API for some of these posts. I am noticing that on posts which have had multiple revisions done in quick succession that the ...
Bugs's user avatar
  • 451
6 votes
0 answers
84 views

Badge numbers are wildly erroneous for meta accounts returned by the /associated query

There is a serious problem with badge counts on meta sites as returned by the /users/{ids}/associated route. Consider this user (chosen for high volume of meta activity). On Meta Stack Overflow, ...
Brock Adams's user avatar
  • 12.9k
6 votes
0 answers
428 views

Resurfacing bug: "could not parse proxy url" error message

According to this question, the "could not parse proxy url" bug was solved more than 2 years ago. However, when using the client-side OAuth flow, the aforementioned error message appears when ...
Linostar's user avatar
  • 161
6 votes
0 answers
107 views

The "advanced search" path returns very wrong results for the `q` parameter

I'm trying to search for a string. It's a hardware identifier 10ec:8168 and should be unique to that make/model of chip. Any questions that mention is should be relevant. But compare the site search ...
Oli's user avatar
  • 253
6 votes
0 answers
57 views

API docs for "stack overflow" still feature v1.0 docs

I guess I'd call this a doc bug. Currently the page http://api.stackoverflow.com redirects to http://api.stackoverflow.com/1.0/usage, which says at the top "Don't use 1.0, use 2.1". This URL ...
Leopd's user avatar
  • 161
5 votes
2 answers
150 views

'Informed' badge doesn't exist on site, but is still being promoted

The issue of a non-existent badge being promoted has been brought up before, but the following still happens: This will likely disappear once I get another badge (soon after posting this question :), ...
Joachim's user avatar
  • 151
5 votes
2 answers
136 views

Stack Exchange API is returning boolean(false) For 'is_answered' On Question With Accepted Answer

When you view this question you see a closed question which has an accepted answer. When you get the API info for it you get this: ["question_id"]=> int(17466804) ["creation_date"]=> int(...
kittycat's user avatar
  • 507
5 votes
1 answer
134 views

Site in closed beta but api working

Webapps has been added yesterday, website is in closed beta and it's not possible to see something on the website when you are not logged. But if you use the API you can get information. http://api....
radius's user avatar
  • 473

1
2 3 4 5
10