Skip to main content

Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
1 vote
1 answer
223 views

stackauth throwing 503 (in html format) after just a few /users/{id}/associated requests

After 5-8 successful requests 503 error, in html format, are being thrown. The requests are unique and consecutive, no api abuse is occurring. A related, but critical, concern is that any error ...
Sky Sanders's user avatar
  • 12.1k
10 votes
0 answers
276 views

Tell us that POST is required to write

While troubleshooting /posts/{id}/comments/add in order to answer Why am I getting a 404 when trying to post a comment?, it was noticed that the API path in question only responded to POST requests. ...
michaelb958--GoFundMonica's user avatar
7 votes
1 answer
132 views

The answer object returns an empty array for tags

Since version 2.1, the answer object has a field called tags. However, sometimes, an empty array or even nothing is returned in this field: Example with the filter !-*f(6t0Vk01e. Am I doing ...
FelixSFD's user avatar
  • 625
6 votes
0 answers
428 views

Resurfacing bug: "could not parse proxy url" error message

According to this question, the "could not parse proxy url" bug was solved more than 2 years ago. However, when using the client-side OAuth flow, the aforementioned error message appears when ...
Linostar's user avatar
  • 161
7 votes
2 answers
503 views

After successfully retrieving 180 pages, the API gracelessly, semi-silently, fails

I'm trying to synchronize tags using the Stack Exchange API and this works for about 180 pages, but around 180 pages it always ends with an exception that seems to indicate that there is no HTTP ...
guido's user avatar
  • 71
6 votes
1 answer
135 views

API throws improper error when "date" parameters are the same

When using the Stack Exchange /questions API using the same date for fromdate and todate I get a 500 internal server error. Using different dates appears to work OK but specifying the same value ...
Andy Clark's user avatar
5 votes
2 answers
150 views

'Informed' badge doesn't exist on site, but is still being promoted

The issue of a non-existent badge being promoted has been brought up before, but the following still happens: This will likely disappear once I get another badge (soon after posting this question :), ...
Joachim's user avatar
  • 151
5 votes
2 answers
168 views

The /search route is ignoring the answers parameter.

The answers parameter was recently added to most of the requests that return a list of questions. See: Don’t include answers in question lists by default It looks like the /search request got left ...
Bill the Lizard's user avatar
3 votes
1 answer
353 views

Stack Exchange OAuth2, explicit access-token response format does not adhere to RFC6749 standard

I'm using the Stack Exchange v2.1 API. I'm using the explicit OAuth 2.0 flow, but it seems that the access token response step does not adhere to the RFC 6749 standard. Specifically, the Stack ...
Wu-Man's user avatar
  • 131
3 votes
1 answer
4k views

OAuth redirect not completing

This is the URL that I'm entering (in Safari, cleared website data and cache; my app, uses own Cookie jar; and incognito chrome) https://stackexchange.com/oauth/dialog?client_id=23&scope=...
Jonathan.'s user avatar
  • 3,118
2 votes
1 answer
175 views

Implicit Flow Isn't Redirecting

I'm using the WebAuthenticationBroker to allow users to log in to their account: var accessToken = ""; var uri = "https://stackexchange.com/oauth/dialog?redirect_uri=https://localhost.com&...
RareNCool's user avatar
  • 201
16 votes
1 answer
446 views

Bug in the StackExchange Api ? getting "could not parse proxy url" when user not logged in

I think I may have stumbled upon a bug in the Stack Exchange JS API I'm having a problem getting its authentication to work properly, and I just discovered that the same problem exist in the official ...
Gabi Mor's user avatar
  • 301
11 votes
0 answers
143 views

The field body_markdown is not returned for comments [duplicate]

Using the method questions-by-ids to get the comments on a particular question, I do not get body_markdown returned despite it being selected in the filter. Here is the test query to reproduce the ...
user avatar
11 votes
1 answer
194 views

"Informed" badge shown as Next badge, but doesn't exist on this site

On my profile page, the Informed badge is shown as the next badge to obtain: Clicking it even shows a popup with a link to the Tour page, but it looks quite different from other SE sites. Looking at ...
Glorfindel's user avatar
  • 6,772
9 votes
1 answer
619 views

Keep getting HTTP 406

Not sure if this is a user or an API problem, but I keep getting HTTP 406 Not Acceptable when making API calls (for example http://api.stackoverflow.com/0.8/stats) from either IE 8 or Chrome 6. Here ...
Franci Penov's user avatar
  • 2,894
8 votes
1 answer
122k views

sorting ascending vs descending

I don't understand the difference between ascending and descending? Surely ascending means the most active/recent/popular/A first, and descending means the least active/recent/popular/Z first? But it ...
Jonathan.'s user avatar
  • 3,118
6 votes
3 answers
2k views

API usage triggering 503 (Too Many Requests)

Update: I generally try to back any claims of bugs and shortcomings with evidence. I have prepared a test page which you, dear Stack Overflow staff and my fellow developers, can use to ascertain ...
Sky Sanders's user avatar
  • 12.1k
6 votes
1 answer
226 views

Why these questions do not have a title?

Hitting the following /questions route: http://api.stackoverflow.com/1.0/questions/74?pagesize=1&page=1 the endpoint returns this JSON data: { "total": 1, "page": 1, "pagesize": 1, "...
systempuntoout's user avatar
5 votes
1 answer
145 views

The API /questions/{ids}/timeline path doesn't return several items that occurred after the fromdate parameter

I need to get all the question activity after some particular time. I am using the timeline API, like so:       /questions/20032212/timeline?fromdate=1384705610&site=stackoverflow.com But it ...
Sachin Jain's user avatar
5 votes
0 answers
135 views

Filter doesn't consistently return comment bodies

I've been trying to set up a filter I can use with /questions/{id}/answers/ (using the UI at this link), which returns the following fields: answer: answer_id body_markdown comments ...
Martin Ender's user avatar
5 votes
2 answers
497 views

The API Key does not work

I have registered an app at https://stackapps.com/apps/register, got a Key right away after I have submitted. But now when I request http://api.stackoverflow.com/0.8/stats?key=MYKEY, I got ...
YOU's user avatar
  • 5,022
4 votes
1 answer
64 views

Reputation changes from accepting answers to questions are not included in reputation results

When querying the /users/{ids}/reputation API route, the results don't include the +2 reputation changes from accepting answers. None of the reputation results from my own reputation history have a ...
Bill the Lizard's user avatar
4 votes
1 answer
12k views

/users/{id}/reputation != xxx.com/reputation

I realize that the shape of the data coming from the API may be different than that reported by the xxx/reputation url, but there seem to be some striking disparities. see 08/12 and 08/11 in both ...
Sky Sanders's user avatar
  • 12.1k
4 votes
1 answer
334 views

Login using Google fails saying OpenID 2.0 accounts for Google has gone away

Recently I have received complaints about my app suggesting that logging in with a Google account shows a warning message that OpenID authentication has gone away. When I tried to log in with my own ...
Birkan Cilingir's user avatar
3 votes
1 answer
876 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
Sky Sanders's user avatar
  • 12.1k
3 votes
1 answer
129 views

Problem getting a users questions within a date range

I'm having a problem returning a list of users questions within a given timespan. I understand that the documentation ( http://api.stackoverflow.com/0.8/help/method?method=users/{id}/questions ) that ...
user avatar
0 votes
1 answer
151 views

min/max parameters are incorrectly documented as date - confusion and crippled libraries ensue

I have noticed this on all sorted routes. The min/max say that they are context sensitive to the sort type yet are documented as date. How is a date min/max valid when sorting by, for instance votes?...
Sky Sanders's user avatar
  • 12.1k
13 votes
2 answers
569 views

Why is my API quota not resetting after UTC reset?

According to How API Keys Work, the default daily API limit -- which is per site, per day -- is 300. I started with 300, as expected, but over a period of days, I've noticed that the remaining quota ...
jmort253's user avatar
  • 753
9 votes
0 answers
385 views

Application stats are completely broken.

It appears that the application stats are completely broken. Attempting to view the number of times Stack Mobile hit the /questions/* methods results in this graph: It would seem that statistics were ...
Nathan Osman's user avatar
  • 23.3k
8 votes
1 answer
136 views

Why is comment_count=1 (incorrectly) when this particular filter is used?

We're seeing that, when a particular filter we've created is used, the API will return "comment_count": 1 for questions with no comments. For a search for questions with no answers, ordered by ...
daviddoran's user avatar
8 votes
1 answer
225 views

Why is /questions API returning deleted questions?

In last few days I have noticed that questions API returns questions that where deleted hours before the API call. This is a short example, if more logs are need to pin point the problem, please ...
Petter Friberg's user avatar
7 votes
1 answer
222 views

Can't get JSON representation for the help

The API Documentation and Help states: If the help URL is requested in a common web browser, a HTML styled version of the JSON help will be returned. Otherwise, the JSON help will be ...
Franci Penov's user avatar
  • 2,894
6 votes
0 answers
84 views

Badge numbers are wildly erroneous for meta accounts returned by the /associated query

There is a serious problem with badge counts on meta sites as returned by the /users/{ids}/associated route. Consider this user (chosen for high volume of meta activity). On Meta Stack Overflow, ...
Brock Adams's user avatar
  • 12.9k
6 votes
1 answer
186 views

JavaScript SDK-based workflow never pushes message back from OAuth login_success page on Stack Exchange side

I'm using the JavaScript SDK by Stack Exchange provided with the latest API, and despite following the official instructions & examples it doesn't work - it seems there is a bug which breaks the ...
Mikhail Vink's user avatar
6 votes
1 answer
113 views

The tagged parameter does not work with multiple tags

Take these two API calls: http://api.stackoverflow.com/0.8/questions?tagged=php;rant http://api.stackoverflow.com/0.8/questions/tagged/php;rant A couple of problems: Shouldn't they return the same ...
Felix's user avatar
  • 1,522
6 votes
5 answers
531 views

Where can I find the reputation black market?

Apparently there is one around, at least I can't explain the recent jump in reputation of 4k for user 1026 by any other means (just kidding of course, no offense please ;) The API Beta badge accounts ...
Steffen Opel's user avatar
  • 1,380
6 votes
1 answer
77 views

should min/max for alpha-numeric cases be case-insensitive?

I am having a hard time coming up with a use case in which case-sensitive min/max parameters make sense and several solid cases for a case-insensitive min/max. Example: With case insensitive min/max:...
Sky Sanders's user avatar
  • 12.1k
6 votes
1 answer
9k views

'The target origin provided does not match the recipient window's origin' message when trying to use localhost

I am trying to experiment with the Stack Overflow API on my localhost and am struggling to get the authentication to complete. Here is my application JavaScript code (note that I am using IBM ...
MDalt's user avatar
  • 161
6 votes
1 answer
108 views

/users/{ids}/timeline creation_date missing or incorrect

I am writing a small widget that displays the time since I was awarded my last badge on Stack Overflow. I noticed that my most recent badge was missing from the timeline data (/users/{ids}/timeline). ...
Steph Sharp's user avatar
5 votes
2 answers
119 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).
Dennis Williamson's user avatar
5 votes
2 answers
136 views

Stack Exchange API is returning boolean(false) For 'is_answered' On Question With Accepted Answer

When you view this question you see a closed question which has an accepted answer. When you get the API info for it you get this: ["question_id"]=> int(17466804) ["creation_date"]=> int(...
kittycat's user avatar
  • 507
5 votes
1 answer
127 views

Typos on api.stackexchange.com/docs/js-lib

Under the Authentication section on https://api.stackexchange.com/docs/js-lib, there are a few typos (emphasis mine): scope (optional) – an array of scopes to request during authentication, valid ...
ᔕᖺᘎᕊ's user avatar
  • 4,365
5 votes
1 answer
169 views

Few typos in the documentation pages

https://api.stackexchange.com/docs/vectors When passing a vector, sepeate each id with a semicolon. For example, /users/1;2;3;4;5?site=somesite would fetch users with ids 1 through 5 on somesite. ...
Arulkumar's user avatar
  • 578
5 votes
1 answer
520 views

Issue with JavaScript SDK

When using the JavaScript SDK to enable client side OAuth flow, I'm running into this issue: Uncaught TypeError: Cannot read properties of null (reading 'postMessage') And the page gets stuck with the ...
Sourabh Choraria's user avatar
5 votes
1 answer
282 views

Suddenly getting "Couldn't parse `client_id`"

For years, I've run a local PHP app using GuzzleHttp\Client to download my StackExchange posts. Today, I'm suddenly getting this problem when posting my client_id, client_secret, code, redirect_uri. { ...
Ryan's user avatar
  • 151
5 votes
1 answer
272 views

Cannot authenticate with OAuth2

I was testing an app and suddenly I can't login any more. Neither my app or the Stack App configuration hasn't changed, so I'm thinking this might be a bug on the API side. The OAuth error seems a ...
gion_13's user avatar
  • 161
5 votes
1 answer
105 views

Why doesn't the API return suggested edits on tag wikis?

Is there a reason why the API doesn't return suggested edits on tag wikis on the suggested-edits route?
Sathyajith Bhat's user avatar
4 votes
1 answer
77 views

Questions method does not return answers

I think questions method also return answers too and the help page says so http://api.stackoverflow.com/0.8/help/method?method=questions .... "answers": [ { "answer_id": { "...
YOU's user avatar
  • 5,022
4 votes
0 answers
94 views

API v1.1 users call returns association_id for which the Stack Exchange web site has no profile

For a particular user, the users API v1.1 call returns an association_id that gives a "Page Not Found" error where the Stack Exchange profile should be, though their Stack Exchange profile can be ...
Isaac's user avatar
  • 665
4 votes
0 answers
78 views

Total reputation reported by the /users/{ids}/reputation route is low

When querying the /users/{ids}/reputation API route, the total amount of reputation I get back from all reputation changes is much lower than my reputation reported on Stack Overflow. Here's my ...
Bill the Lizard's user avatar