Questions tagged [bug]

Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

Filter by
Sorted by
Tagged with
4
votes
1answer
321 views

Invisible text in Markdown syntax help

Some text is invisible in the How to Format help block because of a bad combination of text and background color: That's meant to read ► backtick escapes `like _so_` but the backquoted portion is ...
10
votes
0answers
103 views

Tell us that POST is required to write

While troubleshooting /posts/{id}/comments/add in order to answer Why am I getting a 404 when trying to post a comment?, it was noticed that the API path in question only responded to POST requests. ...
2
votes
1answer
39 views

What does “in practice” mean here?

From /answers/{id}/delete: In practice, this method will never return an object. For me, "in practice" means that the method will maybe return an object. But why? That's not good from an ...
2
votes
0answers
28 views

“users” link lands on the answer page

On the /users/moderators documentation site, the following link is wrong: This method returns a list of users. The users link mistakenly points to the answers object instead of to the users object....
3
votes
1answer
75 views

Why is “body” missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
6
votes
0answers
74 views

Revisions API doesn't return all revisions if post has had multiple edits made in quick succession

I am pulling information from the posts API and then checking the revisions API for some of these posts. I am noticing that on posts which have had multiple revisions done in quick succession that the ...
3
votes
0answers
38 views

Authorization dialog shows wrong API version

If you go on this doc page and click on Get Token, you'll see this: Minor bug, but still, I thought it would be nice to fix this inconsistency :)
3
votes
0answers
29 views

The tags array is missing from answer results

I'm probably missing something very obvious but it seems like /users/{ids}/answers forgets to include the tags badge in the resulting answer object: tags (2.1) an array of strings Nowhere does ...
2
votes
0answers
28 views

New line missing between 'notice' and 'related_site' member types

At the bottom of http://api.stackexchange.com/docs?tab=type#docs under the Member Types section, notice and related_site are on the same line. A <br> is missing between the items.
3
votes
1answer
121 views

“Try It” URL has wrong URI

On API doc pages, the “link” link at the top-right of the “Try It” sections presents a URL with the wrong domain name: For example, on docs/similar, the URL displayed will be: https://api....
20
votes
1answer
245 views

Stack Exchange thinks that Shog is a elected moderator

I was browsing the API for the list of elected moderators, The API URL is http://api.stackexchange.com/docs/elected-moderators#pagesize=100&order=desc&sort=reputation&site=stackoverflow&...
4
votes
0answers
98 views

Few typos in the documentation pages

https://api.stackexchange.com/docs/vectors When passing a vector, sepeate each id with a semicolon. For example, /users/1;2;3;4;5?site=somesite would fetch users with ids 1 through 5 on somesite. ...
4
votes
1answer
81 views

The answer object returns an empty array for tags

Since version 2.1, the answer object has a field called tags. However, sometimes, an empty array or even nothing is returned in this field: Example with the filter !-*f(6t0Vk01e. Am I doing ...
3
votes
0answers
37 views

'answer' type has “unchanged in unsafe filters” listed for the wrong field

http://api.stackexchange.com/docs/types/answer says the can_flag field is unchanged in unsafe filters. It's probably meant for the field above it: body_markdown.
2
votes
0answers
21 views

'search_excerpt' type issues

On the search_excerpt page: community_owned_date should be marked as may be absent locked_date should be marked as may be absent search/excerpts should be listed in the Methods That Return This Type ...
3
votes
0answers
33 views

Types missing from the “Member Types” section

The following types are not listed on http://api.stackexchange.com/docs?tab=category#docs under the Member Types section: network_post closed_details original_question Note that it's a nonexhaustive ...
8
votes
1answer
106 views

Bug with `badges/name` endpoint

Last night I had a programme running and it errored on the first call to the badges/name endpoint on the API, exact API endpoint call: https://api.stackexchange.com/2.2/badges/name?order=asc&sort=...
6
votes
1answer
137 views

JavaScript SDK-based workflow never pushes message back from OAuth login_success page on Stack Exchange side

I'm using the JavaScript SDK by Stack Exchange provided with the latest API, and despite following the official instructions & examples it doesn't work - it seems there is a bug which breaks the ...
2
votes
0answers
67 views

Parameter `tagged` in `search/advanced` seems to use `AND` instead of `OR`

It seems that search/advanced has the same problem as in "The tagged parameter does not work with multiple tags" question. When I select c#; .net I only get results tagged both c# and .net: http://...
5
votes
2answers
421 views

The API Key does not work

I have registered an app at https://stackapps.com/apps/register, got a Key right away after I have submitted. But now when I request http://api.stackoverflow.com/0.8/stats?key=MYKEY, I got ...
2
votes
1answer
73 views

Notice field on questions may be absent?

The notice type, that is a field of a question, appears to be optional, yet it is not marked as "may be absent"? For example, when I request questions with a filter that has the notice field checked, ...
5
votes
1answer
95 views

Field “comment_count” is not always returned by API

I am making a request with a custom filter that includes the "comment_count" field of the question type. My custom filter is !RtdMEtslKF6Z()NqpDUFZ58R6twu-.4V48gn0furqA*7_BL1. However, when I'm ...
8
votes
1answer
106 views

Why is comment_count=1 (incorrectly) when this particular filter is used?

We're seeing that, when a particular filter we've created is used, the API will return "comment_count": 1 for questions with no comments. For a search for questions with no answers, ordered by ...
1
vote
0answers
95 views

“We are currently offline for maintenance” message when authenticating to stackexchange API

I'm creating an application that connects to the Stack Exchange API for write access. I'm implementing server side explicit authentication. However, when I send the acquired code to the specified end ...
1
vote
1answer
116 views

Implicit Flow Isn't Redirecting

I'm using the WebAuthenticationBroker to allow users to log in to their account: var accessToken = ""; var uri = "https://stackexchange.com/oauth/dialog?redirect_uri=https://localhost.com&...
8
votes
1answer
165 views

Why is /questions API returning deleted questions?

In last few days I have noticed that questions API returns questions that where deleted hours before the API call. This is a short example, if more logs are need to pin point the problem, please ...
2
votes
0answers
56 views

It's taking two calls to /oauth/dialog/ to get an access_token? [duplicate]

When we send this request: https://stackexchange.com/oauth/dialog/?client_id=`client_id`&scope=read_inbox%2cno_expiry%2cwrite_access%2cprivate_info&redirect_uri=https%3a%2f%2fstackexchange....
0
votes
1answer
47 views

wrong results of /search/advanced

I am querying mobile in stackoverflow. The second result is an answer. Results of /search/advanced is giving only questions when queried mobile. This is applicable for all other terms which are to be ...
-3
votes
1answer
76 views

wrong results of api /search/advanced

I am querying for results of /search/advanced. The request I am sending is https://api.stackexchange.com/2.2/search/advanced?key=`key`&access_token=`access_token`&site=stackoverflow.com&...
0
votes
0answers
38 views

`/me/associated` gives ambiguous/wrong response [duplicate]

This is my associated accounts page. No where I can see Meta Stack Overflow profile. But when I run /me/associated with meta_site as parameter to types, I get a response that tells me that I have a ...
11
votes
1answer
316 views

Why is my API quota not resetting after UTC reset?

According to How API Keys Work, the default daily API limit -- which is per site, per day -- is 300. I started with 300, as expected, but over a period of days, I've noticed that the remaining quota ...
6
votes
0answers
58 views

Badge numbers are wildly erroneous for meta accounts returned by the /associated query

There is a serious problem with badge counts on meta sites as returned by the /users/{ids}/associated route. Consider this user (chosen for high volume of meta activity). On Meta Stack Overflow, ...
6
votes
0answers
62 views

The 'should be closed' description in the flag dialog is missing a word

The 'should be closed...' reason has this description (emphasis mine): This question is completely unclear, incomplete, overly-broad, primarily opinion-based or is not about Stack Exchange API, app,...
3
votes
1answer
62 views

The /tags query is not giving me the correct results between two dates?

I'm trying to get the yearly total number of questions that have the tag browserify. I can see that there are questions tagged from this year like this one and that one. The site reports that there ...
6
votes
0answers
76 views

The “advanced search” path returns very wrong results for the `q` parameter

I'm trying to search for a string. It's a hardware identifier 10ec:8168 and should be unique to that make/model of chip. Any questions that mention is should be relevant. But compare the site search ...
3
votes
0answers
90 views

error description: could not parse proxy url

I have seen the answers to the existing two questions on this topic but it has not helped. And the problem still persists so I am re-posting this question. Here is my code $(function(){ SE.init({ ...
1
vote
1answer
50 views

The /questions/{id}/linked method is returning extra questions

Consider the following question on ServerFault: https://serverfault.com/questions/45734/the-coolest-server-names Linked questions: Note that there's only two listed. However, querying: http://api....
1
vote
1answer
68 views

The /top-answer-tags method is not working

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
2
votes
1answer
62 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
4
votes
1answer
54 views

Reputation changes from accepting answers to questions are not included in reputation results

When querying the /users/{ids}/reputation API route, the results don't include the +2 reputation changes from accepting answers. None of the reputation results from my own reputation history have a ...
1
vote
1answer
31 views

The API /tag stats are notably different from the site totals

Why this discrepancy? --Sep 10 2015 11:26:09 GMT+0530 (IST)-- At that time, the API shows 42010 tags. But the same thing computed on the Stack Overflow tags page is 44496. Is it because of caching?
3
votes
1answer
52 views

link in post_id in /me/notifications/unread is wrong

I have run /me/notifications/unread. The response contains post_id and there is a link to it. This link is wrong. The post is on Stack Apps but the link directs to Stack Overflow: I have ...
6
votes
1answer
61 views

API returns implausibly low questions per minute rate for Stack Overflow

Yesterday, I tried using the /info method of the API to predict the time left until 10M questions on Stack Overflow. In the process, I found that the returned "questions per minute" value was always 2....
3
votes
1answer
81 views

API returns the last activity date even if asked not to

Using the /questions method, I tried to get upvote and downvote counts, along with question Ids. This is the request I sent: http://api.stackexchange.com/2.2/questions/857455%3B857454?site=math&...
3
votes
1answer
102 views

Difference between `/inbox/unread` & `/me/inbox/unread`

I ran /inbox/unread & /me/inbox/unread. What is the difference between the two? Also, the site parameter which we give in call to /me/inbox/unread is not required as inbox_item refers to global ...
3
votes
1answer
72 views

What does `total` in the /notifications route represent?

What does total in /notifications represent? I ran it. The result was items in Common Wrapper Object was array of 24 items where as total was 4.
2
votes
0answers
49 views

/me/inbox is not returning most recent items

Looks like /me/inbox is either a bit behind or it's not supposed to be realtime. Explanation: for a comment that I received 4 hours ago It's not returned in the API: https://api.stackexchange.com/...
6
votes
1answer
66 views

Descriptions of tag-based badges are incorrect

The descriptions associated to tag-based badges are wrong, they always show 0 instead of actual thresholds: Earned at least 0 total score for at least 0 non-community wiki answers in the … tag See ...
4
votes
1answer
312 views

Login using Google fails saying OpenID 2.0 accounts for Google has gone away

Recently I have received complaints about my app suggesting that logging in with a Google account shows a warning message that OpenID authentication has gone away. When I tried to log in with my own ...
1
vote
1answer
149 views

Why is sort by name reverse alphabetical?

It makes sense that reputation or date should sort descending, but name? I tested both /users and /tags and they sort reverse alphabetical, so Z before A. Is that by design or just a side effect of ...