Indicates that a feature request has been implemented, a bug has been fixed, or another type of request has been processed.

learn more… | top users | synonyms

5
votes
1answer
74 views

API 'search' method with 'tagged' parameter

From the docs for tagged paremeter: List of tags delimited by semi-colons of which at least one must be on a question Yet, when I execute this query ...
6
votes
1answer
60 views

User's Comments: returning 500 error?

It looks like when I try to get the comments of a user that has "a huge number" of comments, I get a 500 error. Jon Skeet's comments, 500 error: http://api.stackoverflow.com/1.0/users/22656/comments ...
4
votes
1answer
54 views

You can gain reputation from edits to tag wikis, although they are not accessible through the API.

Reputation gain from edits to tag wikis appear through the API; the API reports them as answers, but fetching them via the /answers route does not work. Case in point: My accepted edit (+2 rep) My ...
5
votes
1answer
63 views

/user/{id}/timeline results leaking template used for badge information

From my elections statistics page: I inserted in the detail field as plain text because I wasn't sure if the results would be HTML, but the $ChatUrl left in the anchor's href is surely a bug.
2
votes
1answer
94 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
1
vote
1answer
68 views

Associated accounts is broken for this user

When I retrieve associated accounts for Joel Coehoorn using this query it only includes Programmers.SE and Webmasters.SE despite the fact that I retrieved the association key from a query to SU. The ...
3
votes
1answer
74 views

tag colors incorrect

the tag color for english site seem incorrect, the dark grey color is the background while the yellow colour is the foreground. This is contradictory to other sites which have the darker colours as ...
1
vote
1answer
109 views

MSO is not being returned in StackAuth's /users/{id}/associated route

In looking into a StackFlair issue, I have discovered that MSO is not being returned as part of a user's associated accounts. Please see my associated accounts according to the api. Note that there ...
1
vote
1answer
493 views

Problem accessing API endpoints from Google App Engine

I'm experiencing a weird problem on StackPrinter hosted on Google App Engine. It seems that the application can't reach several endpoints like Super User or Server Fault; Stack Overflow and other ...
1
vote
1answer
54 views

An associated query is returning a partial record for a particular user

This query returns (in addition to several complete records) this incomplete one: { "user_id": 2196, "user_type": "registered", "display_name": "Wil", "reputation": 151, "email_hash": ...
3
votes
1answer
855 views

Wrong content-type in JSONP calls

When passing jsonp parameter, the API returns "application/json" instead of "application/javascript". I found this because if you do: <script ...
0
votes
1answer
96 views

Comments are returning markdown.

Look at the output of the following: http://api.askubuntu.com/1.0/questions/12218?comments=true Output: { "comment_id": 12713, "creation_date": 1289269467, "owner": { ...
4
votes
2answers
144 views

API Help's CSS is missing

The API Help page's CSS file, located at http://sstatic.net/so/all.css, is current returning 404 for me: <div id="header"><h1>Server Error</h1></div> <div id="content"> ...
2
votes
1answer
70 views

/questions/{id}/answers missing title attribute

http://api.stackoverflow.com/1.0/help/method?method=questions/{id}/answers (it won't linkify properly!): "title": { "description": "title of this post, in plaintext", "values": "string", ...
2
votes
1answer
31 views

/questions/id route problem: comments section is not returned when there aren't comments on question

Something is changed on questions route called with comments= True: http://api.stackoverflow.com/1.0/questions/1940243?body=True&comments=True&pagesize=1&page=1 It does not return the ...
1
vote
3answers
107 views

StackAuth returning 404?

http://stackauth.com/1.0/sites http://stackauth.com/1.0/help Both of these are currently returning 404 Not Found. What's up with that?
4
votes
1answer
194 views

update crossdomain.xml on stackauth.com and api endpoints to work with current Flash

I am implementing a javascript client that uses the Flash based XHR replacement Flensed in the interest of providing more robust api communication than that provided by JSONP. Apparently the current ...
2
votes
1answer
67 views

Suddenly, some entries on /questions route are missing display_name

An odd bug has developed this morning. At the moment, api.stackoverflow.com/1.0/questions is returning a question of the format... ... }, { "tags": [ "jsf-2.0" ], ...
2
votes
1answer
108 views

AskUbuntu API returns wrong colours

Calling the stats method of the AskUbuntu API returns the wrong colours.
1
vote
3answers
247 views

Icons of beta sites

Icons of beta sites are different form the icons given in the http://stackauth.com/1.0/sites . As example: Original icon of the English Language and Usage is where http://stackauth.com/1.0/sites ...
2
votes
1answer
90 views

stackapps favicon inconsistent rendering

A lot of us are using the favicon in our apps as it is a quite convenient size. It seems that IE does not like the stackapps favicon palette and renders the background black. While I do cache the ...
5
votes
1answer
83 views

Empty results for associated queries

Queries such as this http://stackauth.com/1.0/users/f5388585-c0b9-417f-99c5-f1a58fda3e83/associated have started giving empty results { "associated_users": [] } Expected results: SiteUrl ...
3
votes
2answers
57 views

Sorting comments by votes doesn't return 0 score comments

I have a query: http://api.stackoverflow.com/1.0/users/16822/comments?sort=votes This doesn't return comments with no votes, setting min to 0 doesn't work. This query includes them all, but isn't ...
3
votes
3answers
782 views

API usage triggering 503 (Too Many Requests)

Update: I generally try to back any claims of bugs and shortcomings with evidence. I have prepared a test page which you, dear Stack Overflow staff and my fellow developers, can use to ascertain ...
2
votes
1answer
97 views

API selectively ignores jsonp parameter - havok ensues

UPDATE: this is happening on all routes now and seems to be getting worse. Whatever it is just started this morning. compare url to json response GET ...
2
votes
1answer
67 views

API is completely down? content encoding is broken?

all requests have no content-encoding or have 'gzip,gzip', both of which fail to decompress browser side. note: the content-encoding header, when it is present, does not seem to be included in the ...
3
votes
1answer
56 views

key not being recognized by api.meta.stackoverflow.com?

I have been testing a throttle implementation against meta today and suddenly got shut down with a key violation. It is possible that I have used enough requests to prompt this but I doubt it. In ...
8
votes
1answer
316 views

How to batch up multiple id requests to maximize economy and still avoid (400) Bad Request [closed]

Update: All of our grumblings and the unbearable beauty of our workarounds resulted in this issue being fixed last week. You can now send 100 id in one request and receive 100 responses. See ...
1
vote
1answer
82 views

/questions/{id}/timeline throwing 500 instead of 404

Kevin, you fixed this bug some time ago, would you like to tag it as status-complete? Sometime last week, this route stopped throwing 404 like the rest of my 'bad id' tests and started throwing 500. ...
1
vote
1answer
137 views

Game developer's logo isn't working.

See here: http://stackmobile.com/ - towards the bottom Neither the main logo, nor the meta logo is workin.
7
votes
3answers
304 views

When does the judging take place?

I am planning to work some more on my apps tomorrow and get some last minute changes implemented. However, I notice that: The API Contest winners will be picked the first week of August. ...
6
votes
5answers
487 views

Where can I find the reputation black market?

Apparently there is one around, at least I can't explain the recent jump in reputation of 4k for user 1026 by any other means (just kidding of course, no offense please ;) The API Beta badge accounts ...
2
votes
1answer
54 views

Badges with zero count no longer returning zero

For queries such as http://api.{sitename}.com/1.0/users/{id} if a badge count is zero, the API is no longer returning "gold": 0, for example.
4
votes
1answer
67 views

Encoding inconsistency on /users/{id}/reputation

Take these two calls: http://api.stackoverflow.com/1.0/users/180784/reputation?todate=1278854265&pagesize=1 "title": "Save a custom ListView&#39;s instance state?", ...
4
votes
2answers
83 views

/users/{id}/answers - broken

Have not checked other routes, as I am busy with other things, but a failing test pointed this out... GOOD: http://api.stackoverflow.com/1.0/users/242897/answers?min=4&sort=votes { "total": ...
3
votes
1answer
67 views

server fault and super user rate limit bonus?

Looks like SF and SU are granting Int.MaxValue rate limit. Not that I mind, but it would be nice to have on the other sites too. ;-) Thought you would like to know. GET /1.0/users/173?key=mykey ...
5
votes
2answers
212 views

Url length limits have been increased

There's been some grumbling in the past about the unreliability of really ludicrously long URLs sent to the API. We've always considered this suboptimal, but the underlying technical constraints ...
4
votes
1answer
113 views

questions method returns error 4000

I'm getting error 4000 on every endpoint on questions method (with key): http://api.superuser.com/1.0/questions?sort=votes&pagesize=30&page=1&key=stackprinterkey the only endpoint not ...
2
votes
2answers
129 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
3
votes
3answers
157 views

Negative voting questions?

I'm trying to, for humorous purposes, check out some of the worst scoring questions ever on SO. I'm pretty much expecting them to all be "heeeeelp homework" or "plz send me teh codez" or something to ...
4
votes
1answer
199 views

all api endpoints except api.stackoverflow.com are failing paged requests with HTML 503

UPDATE: I am being told that this is by design. I could not disagree more. The inconsistent 503 throttling issue aside, the API is JSON based. HTML errors serve no purpose in response to an API ...
5
votes
1answer
120 views

Intermittent bug in the /search route when providing both tagged and nottagged parameters.

I'm getting the wrong number of results back from the /search route depending on what combination of values I provide for the tagged and nottagged parameters. Examples: ...
5
votes
2answers
102 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).
2
votes
1answer
64 views

stackauth is not serving gzip to silverlight3/phone7

I ported all of my integration tests to phone 7, which is a flavor of silverlight 3, and found that stackauth is not forcing gzip as expected. while this simply means that I need to check the first 2 ...
2
votes
1answer
79 views

Paging /users by rep is on sites with low user count unpredictable

Resolution Fix confirmed: Tests.SortDupBug Page 1 #100 Total 11066 api.serverfault.com /users?max=2147483647&min=99&page=1&pagesize=100&key=qgAq_KfDu0KYzlNG-qaTuw Page 2 #100 Total 11066 ...
3
votes
1answer
380 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
1
vote
1answer
162 views

stackauth throwing 503 (in html format) after just a few /users/{id}/associated requests

After 5-8 successful requests 503 error, in html format, are being thrown. The requests are unique and consecutive, no api abuse is occurring. A related, but critical, concern is that any error ...
2
votes
1answer
2k views

Help on help results in HTTP 500 Internal Server Error

A request to http://api.stackoverflow.com/0.8/help?help results in an HTTP 500 with Content-Type: application/json and an HTML body.
2
votes
1answer
58 views

Oddity with migration data from questions

Take a look at this question on SuperUser. Apparently, it was migrated from ServerFault, and was originally asked by user 3d1l. However, now look at the API result: ...
1
vote
1answer
84 views

Problems with the Site Icons

I'm having trouble with the WebApps icon being returned from the /sites method. Namely, the image is composed of a larg white rectangle with a very small guy in the middle. Why can't the guy take ...