Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

9
votes
0answers
351 views

Application stats are completely broken.

It appears that the application stats are completely broken. Attempting to view the number of times Stack Mobile hit the /questions/* methods results in this graph: It would seem that statistics ...
7
votes
0answers
82 views

The field body_markdown is not returned for comments

Using the method questions-by-ids to get the comments on a particular question, I do not get body_markdown returned despite it being selected in the filter. Here is the test query to reproduce the ...
6
votes
0answers
42 views

Badge numbers are wildly erroneous for meta accounts returned by the /associated query

There is a serious problem with badge counts on meta sites as returned by the /users/{ids}/associated route. Consider this user (chosen for high volume of meta activity). On Meta Stack Overflow, ...
5
votes
0answers
47 views

The 'should be closed' description in the flag dialog is missing a word

The 'should be closed...' reason has this description (emphasis mine): This question is completely unclear, incomplete, overly-broad, primarily opinion-based or is not about Stack Exchange API, ...
5
votes
0answers
190 views

Resurfacing bug: “could not parse proxy url” error message

According to this question, the "could not parse proxy url" bug was solved more than 2 years ago. However, when using the client-side OAuth flow, the aforementioned error message appears when ...
5
votes
0answers
61 views

Tell us that POST is required to write

While troubleshooting /posts/{id}/comments/add in order to answer Why am I getting a 404 when trying to post a comment?, it was noticed that the API path in question only responded to POST requests. ...
5
votes
0answers
59 views

The “advanced search” path returns very wrong results for the `q` parameter

I'm trying to search for a string. It's a hardware identifier 10ec:8168 and should be unique to that make/model of chip. Any questions that mention is should be relevant. But compare the site search ...
5
votes
0answers
27 views

API docs for “stack overflow” still feature v1.0 docs

I guess I'd call this a doc bug. Currently the page http://api.stackoverflow.com redirects to http://api.stackoverflow.com/1.0/usage, which says at the top "Don't use 1.0, use 2.1". This URL ...
5
votes
0answers
64 views

Requesting favorite questions should report which users have favorited it

I can request the favorite questions of a user via the users/{id}/favorites endpoint. If I'm only requesting the favorites for one user, then I know that all of the returned questions are the ...
4
votes
0answers
32 views

Typos on api.stackexchange.com/docs/js-lib

Under the Authentication section on https://api.stackexchange.com/docs/js-lib, there are a few typos (emphasis mine): scope (optional) – an array of scopes to request during authentication, valid ...
4
votes
0answers
73 views

“What is meta” should be rephrased

Stackapps.com/help/whats-meta tells that there is "Meta Stack Apps". However there isn't. Stack Apps is its own meta and meta is used to ask meta questions here.
4
votes
0answers
63 views

Total reputation reported by the /users/{ids}/reputation route is low

When querying the /users/{ids}/reputation API route, the total amount of reputation I get back from all reputation changes is much lower than my reputation reported on Stack Overflow. Here's my ...
4
votes
0answers
20 views

Link to applied_count leads to a 404

To Reproduce Run an API query on tag-synonyms, you will get a result that includes something like this: Issue(s) Click on the applied_count link and you get redirected to this page which is a 404....
4
votes
0answers
70 views

API v1.1 users call returns association_id for which the Stack Exchange web site has no profile

For a particular user, the users API v1.1 call returns an association_id that gives a "Page Not Found" error where the Stack Exchange profile should be, though their Stack Exchange profile can be ...
4
votes
0answers
26 views

revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
4
votes
0answers
46 views

/tags fromdate and todate does nothing

Altough the help/documentation lists 'todate' and 'fromdate' parameters for tags they do not work. This may be related to tags not having a creation_date. It would be great if we could filter tags by ...
3
votes
0answers
23 views

API returns delete vote count for questions, but not for answers

The questions method of the API returns the number of delete votes among other kinds of votes: sample query. But the answers method does not have a delete_vote_count field available in the filter: ...
3
votes
0answers
20 views

Buggy HTTP header behavior with the `site` parameter. Improper caching?

In sx.el we are using url-request-extra-headers to pass API requests to Stack Exchange. When performing multiple queries in quick succession, we end up receiving the same JSON response even when the ...
3
votes
0answers
38 views

Filter doesn't consistently return comment bodies

I've been trying to set up a filter I can use with /questions/{id}/answers/ (using the UI at this link), which returns the following fields: answer: answer_id body_markdown comments ...
3
votes
0answers
71 views

Byte Order Mark suddenly appearing in query results

Query results seem to have started including BOMs sometime today. I had to add code to handle it. I don't see this documented anywhere.
3
votes
0answers
45 views

top-answerers / top-askers documentation bug: number of results returned incorrect

The top-answerers-on-tags and top-askers-on-tags documentation claim: Returns the top 30 answerers active in a single tag, of either all-time or the last 30 days. and Returns the top 30 ...
3
votes
0answers
20 views

bounties_offered are not being returned correctly from /users/{ids}/reputation

When querying the /users/{ids}/reputation API route, reputation changes for bounties_offered are not being returned correctly. In my own results, I see a reputation object with a reputation_change ...
3
votes
0answers
64 views

Implicit OAuth Flow stopped working. Redirect happening to a non existent URL

The following URL is first hit when a user clicks on Login: https://stackexchange.com/oauth/dialog?client_id=202&redirect_uri=https%3a%2f%2fstackexchange.com%2foauth%2flogin_success&scope=...
3
votes
0answers
48 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
3
votes
0answers
127 views

OAuth Dialog rendering problems

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: ...
3
votes
0answers
64 views

Unanswered questions with tags returns wrong total

When requesting a list of unanswered questions with a specific tags the total count show the total number of questions for that tag, not the count for the unanswered questions. Using http://api....
3
votes
0answers
50 views

/users/{id}/tags - 504 Gateway Timeout

this url is technically valid but generates 504. http://api.stackoverflow.com/1.0/users/242897/tags?filter=c%23&fromdate=0&max=1577836800&min=0&page=1&pagesize=100&sort=...
2
votes
0answers
42 views

“Informed” badge shown as Next badge, but doesn't exist on this site

On my profile page, the Informed badge is shown as the next badge to obtain: Clicking it even shows a popup with a link to the Tour page, but it looks quite different from other SE sites. Looking ...
2
votes
0answers
29 views

Few typos in the documentation pages

https://api.stackexchange.com/docs/vectors When passing a vector, sepeate each id with a semicolon. For example, /users/1;2;3;4;5?site=somesite would fetch users with ids 1 through 5 on somesite. ...
2
votes
0answers
50 views

The Authentication Problem of WebAuthenticationBroke Classr in .NET 4.6

I have a problem when you test the StackExchange Authentication API to WebAuthenticationBroker. If you proceed with authentication, such as screenshots it will continue to appear only in progress. ...
2
votes
0answers
47 views

error description: could not parse proxy url

I have seen the answers to the existing two questions on this topic but it has not helped. And the problem still persists so I am re-posting this question. Here is my code $(function(){ SE.init({ ...
2
votes
0answers
50 views

Login problem on devices pre Windows Phone 8.1 Update 1

I have recently published an app for browsing Stack Exchange websites and a major feedback I received from users was about the inability to use oauth login form while loging into the app. The ...
2
votes
0answers
41 views

/me/inbox is not returning most recent items

Looks like /me/inbox is either a bit behind or it's not supposed to be realtime. Explanation: for a comment that I received 4 hours ago It's not returned in the API: https://api.stackexchange.com/...
2
votes
0answers
22 views

/answers API request returns no tags if body_markdown is included

This API request to /answers has the filter set to return the tags field for the corresponding question. It works fine: api.stackexchange.com/docs/answers#filter=!9YdnSPElz But, when the filter is ...
2
votes
0answers
28 views

Sorting and filtering is broken on /questions

Sorting error When querying /questions and sort them by creation in descending order, the creation_date drops very rapidly. I was looking for questions in the [php] tag on Stack Overflow. There are ...
2
votes
0answers
95 views

Invisible text in Markdown syntax help

Some text is invisible in the How to Format help block because of a bad combination of text and background color: That's meant to read ► backtick escapes `like _so_` but the backquoted ...
2
votes
0answers
39 views

SSL handshake error after Stack Overflow back on - anything related to SSL certification changed?

I'm building a Stack Overflow app for BlackBerry10. Earlier today (Feb 16, 2014), Stack Overflow was down and after it came back up my app starts to have this issue. My app works fine when it's in ...
2
votes
0answers
56 views

Why is there a difference between “questions” and “search” in API?

I have a query to find the number of questions tagged java from 2012-08-01 to 2013-08-01. Running this using both /questions and /search produces different results: https://api.stackexchange.com/2....
2
votes
0answers
11 views

Not all sites are returning Hi Res icons

In the /sites method, not all the sites return high_resolution_icon_url field. (e.g. Personal Finance and Money) Although if you add "@2" to the normal resolution icon you can see a high res image ...
2
votes
0answers
30 views

Incorrect link parameter on the “Complex Queries” documentation page

The "Complex Queries" documentation page has this link: Of these three posts on Server Fault, the one with the most recent activity where "the one with the most recent activity" links to https:/...
2
votes
0answers
129 views

Stack Exchange OAuth2, explicit access-token response format does not adhere to RFC6749 standard

I'm using the Stack Exchange v2.1 API. I'm using the explicit OAuth 2.0 flow, but it seems that the access token response step does not adhere to the RFC 6749 standard. Specifically, the Stack ...
2
votes
0answers
33 views

Why is “body” missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
2
votes
0answers
31 views

Secure OAuth pages contain insecure content.

I noticed that some of the OAuth pages use insecure content (http:// content on an https:// page): I'm not sure how easy this is to fix but it could potentially scare off some users who don't ...
2
votes
0answers
21 views

“Special” required tag listings only show single required tag

When you're viewing questions tagged with one of app,script,library, you get the special formatting view with the thumbnail on the left. On pages where this view is displayed, only one of these tags ...
2
votes
0answers
115 views

StackAuth needs crossdomain.xml and clientaccesspolicy.xml

These would be helpful to have. Absence breaks Silverlight apps. http://stackauth.com/crossdomain.xml http://stackauth.com/clientaccesspolicy.xml http://stackauth.com/0.8/crossdomain.xml http://...
1
vote
0answers
34 views

Implicit Flow Isn't Redirecting

I'm using the WebAuthenticationBroker to allow users to log in to their account: var accessToken = ""; var uri = "https://stackexchange.com/oauth/dialog?redirect_uri=https://localhost.com&...
1
vote
0answers
36 views

quota_remaining is decreasing much faster than expected

I registered an app and tried to make a couple of requests via Chrome (without actually creating any application yet). The thing that is really confusing is that with making a single request, ...
1
vote
0answers
17 views

Max score with tagged works incorrectly for /questions, correctly for /search

When I look for questions tagged java from the first week of September 2014 with a minimum score of 10 like this: /2.2/questions?fromdate=1409529600&todate=1410134400&min=10&sort=votes&...
1
vote
0answers
13 views

/revisions/{ids} returns results where revision_number is always 1

As of now, Code Review Question 59285 has three revisions, excluding the original question. If I fetch those three revisions using the API, I see that all of them have revision_number set to 1. That'...
1
vote
0answers
31 views

Application icon on authorization page isn't loading

I can't seem to get the application icon for Stack Applet to display on the authorization page. (I'm using the implicit flow.) The URL that I open the browser to is: https://stackexchange.com/...