Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

8
votes
0answers
269 views

Application stats are completely broken.

It appears that the application stats are completely broken. Attempting to view the number of times Stack Mobile hit the /questions/* methods results in this graph: It would seem that statistics ...
5
votes
0answers
53 views

Tell us that POST is required to write

While troubleshooting /posts/{id}/comments/add in order to answer Why am I getting a 404 when trying to post a comment?, it was noticed that the API path in question only responded to POST requests. ...
5
votes
0answers
24 views

API docs for “stack overflow” still feature v1.0 docs

I guess I'd call this a doc bug. Currently the page http://api.stackoverflow.com redirects to http://api.stackoverflow.com/1.0/usage, which says at the top "Don't use 1.0, use 2.1". This URL ...
5
votes
0answers
179 views

Why is my API quota not resetting after UTC reset?

According to How API Keys Work, the default daily API limit -- which is per site, per day -- is 300. I started with 300, as expected, but over a period of days, I've noticed that the remaining quota ...
5
votes
0answers
61 views

Requesting favorite questions should report which users have favorited it

I can request the favorite questions of a user via the users/{id}/favorites endpoint. If I'm only requesting the favorites for one user, then I know that all of the returned questions are the ...
4
votes
0answers
56 views

Total reputation reported by the /users/{ids}/reputation route is low

When querying the /users/{ids}/reputation API route, the total amount of reputation I get back from all reputation changes is much lower than my reputation reported on Stack Overflow. Here's my ...
4
votes
0answers
20 views

Link to applied_count leads to a 404

To Reproduce Run an API query on tag-synonyms, you will get a result that includes something like this: Issue(s) Click on the applied_count link and you get redirected to this page which is a ...
4
votes
0answers
45 views

/tags fromdate and todate does nothing

Altough the help/documentation lists 'todate' and 'fromdate' parameters for tags they do not work. This may be related to tags not having a creation_date. It would be great if we could filter tags by ...
3
votes
0answers
47 views

Byte Order Mark suddenly appearing in query results

Query results seem to have started including BOMs sometime today. I had to add code to handle it. I don't see this documented anywhere.
3
votes
0answers
20 views

top-answerers / top-askers documentation bug: number of results returned incorrect

The top-answerers-on-tags and top-askers-on-tags documentation claim: Returns the top 30 answerers active in a single tag, of either all-time or the last 30 days. and Returns the top 30 ...
3
votes
0answers
18 views

bounties_offered are not being returned correctly from /users/{ids}/reputation

When querying the /users/{ids}/reputation API route, reputation changes for bounties_offered are not being returned correctly. In my own results, I see a reputation object with a reputation_change ...
3
votes
0answers
17 views

Reputation changes from accepting answers to questions are not included in reputation results

When querying the /users/{ids}/reputation API route, the results don't include the +2 reputation changes from accepting answers. None of the reputation results from my own reputation history have a ...
3
votes
0answers
45 views

Implicit OAuth Flow stopped working. Redirect happening to a non existent URL

The following URL is first hit when a user clicks on Login: ...
3
votes
0answers
37 views

The “advanced search” path returns very wrong results for the `q` parameter

I'm trying to search for a string. It's a hardware identifier 10ec:8168 and should be unique to that make/model of chip. Any questions that mention is should be relevant. But compare the site search ...
3
votes
0answers
47 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
3
votes
0answers
66 views

API v1.1 users call returns association_id for which the Stack Exchange web site has no profile

For a particular user, the users API v1.1 call returns an association_id that gives a "Page Not Found" error where the Stack Exchange profile should be, though their Stack Exchange profile can be ...
3
votes
0answers
91 views

OAuth Dialog rendering problems

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: ...
3
votes
0answers
18 views

revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
3
votes
0answers
61 views

Unanswered questions with tags returns wrong total

When requesting a list of unanswered questions with a specific tags the total count show the total number of questions for that tag, not the count for the unanswered questions. Using ...
2
votes
0answers
27 views

The field body_markdown is not returned for comments

Using the method questions-by-ids to get the comments on a particular question, I do not get body_markdown returned despite it being selected in the filter. Here is the test query to reproduce the ...
2
votes
0answers
13 views

Sorting and filtering is broken on /questions

Sorting error When querying /questions and sort them by creation in descending order, the creation_date drops very rapidly. I was looking for questions in the [php] tag on Stack Overflow. There are ...
2
votes
0answers
26 views

Descriptions of tag-based badges are incorrect

The descriptions associated to tag-based badges are wrong, they always show 0 instead of actual thresholds: Earned at least 0 total score for at least 0 non-community wiki answers in the … tag ...
2
votes
0answers
41 views

Invisible text in Markdown syntax help

Some text is invisible in the How to Format help block because of a bad combination of text and background color: That's meant to read ► backtick escapes `like _so_` but the backquoted ...
2
votes
0answers
33 views

SSL handshake error after Stack Overflow back on - anything related to SSL certification changed?

I'm building a Stack Overflow app for BlackBerry10. Earlier today (Feb 16, 2014), Stack Overflow was down and after it came back up my app starts to have this issue. My app works fine when it's in ...
2
votes
0answers
11 views

Not all sites are returning Hi Res icons

In the /sites method, not all the sites return high_resolution_icon_url field. (e.g. Personal Finance and Money) Although if you add "@2" to the normal resolution icon you can see a high res image ...
2
votes
0answers
28 views

Incorrect link parameter on the “Complex Queries” documentation page

The "Complex Queries" documentation page has this link: Of these three posts on Server Fault, the one with the most recent activity where "the one with the most recent activity" links to ...
2
votes
0answers
23 views

Why is “body” missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
2
votes
0answers
40 views

Stack Apps “Welcome Back” banner text isn't centered

This appear to be specific to Stack Apps. The text is centered on every other site I've tried. See below: Compared to how it should appear:
2
votes
0answers
28 views

Secure OAuth pages contain insecure content.

I noticed that some of the OAuth pages use insecure content (http:// content on an https:// page): I'm not sure how easy this is to fix but it could potentially scare off some users who don't ...
2
votes
0answers
47 views

/users/{id}/tags - 504 Gateway Timeout

this url is technically valid but generates 504. ...
2
votes
0answers
112 views

StackAuth needs crossdomain.xml and clientaccesspolicy.xml

These would be helpful to have. Absence breaks Silverlight apps. http://stackauth.com/crossdomain.xml http://stackauth.com/clientaccesspolicy.xml http://stackauth.com/0.8/crossdomain.xml ...
1
vote
0answers
11 views

/revisions/{ids} returns results where revision_number is always 1

As of now, Code Review Question 59285 has three revisions, excluding the original question. If I fetch those three revisions using the API, I see that all of them have revision_number set to 1. ...
1
vote
0answers
16 views

Application icon on authorization page isn't loading

I can't seem to get the application icon for Stack Applet to display on the authorization page. (I'm using the implicit flow.) The URL that I open the browser to is: ...
1
vote
0answers
120 views

OAuth login fails for Stack Exchange and Facebook, but not Google

I'm integrating with Stack Exchange API on iOS 6 & 7. To authenticate, I load up a UIWebView with the OAuth page. Google login works well, but Stack Exchange and Facebook do not. Are these ...
1
vote
0answers
28 views

Get Token button in “Try it” doesn't give me a key in IE11

When I visit for example the timeline docs to try that api I need to get a token first by clicking 'Get Token'. In IE11 (win 7/x64) this is broken. A window does pop-up but there is never a key ...
1
vote
0answers
8 views

The reputation_change field is missing from the reputation results on some CW posts

When querying the /users/{ids}/reputation API route, the reputation_change field is missing from the results on community-wiki answers. I think the reputation type should always include this field, ...
1
vote
0answers
41 views

Why is there a difference between “questions” and “search” in API?

I have a query to find the number of questions tagged java from 2012-08-01 to 2013-08-01. Running this using both /questions and /search produces different results: ...
1
vote
0answers
98 views

/oauth/access_token not redirecting back to my redirect_uri

I am trying to implement Stack Exchange using oAuth 2.0. I am able to get CODE but, when I try to get access_token through this code: <?php if(isset($_GET['code'])) { ?> <form method="POST" ...
1
vote
0answers
87 views

Stack Exchange OAuth2, explicit access-token response format does not adhere to RFC6749 standard

I'm using the Stack Exchange v2.1 API. I'm using the explicit OAuth 2.0 flow, but it seems that the access token response step does not adhere to the RFC 6749 standard. Specifically, the Stack ...
1
vote
0answers
24 views

The 2.1, “similar” path is returning empty results

I've been a happy user of the /2.1/similar Stack Exchange API for a while. But, at some point within the last 24 hours, or so, it started returning empty results (but otherwise reporting everything as ...
1
vote
0answers
120 views

Unread messages in inbox query shows older inbox messages

I am using the /inbox/unread route to get the unread messages in a user's inbox. Recently (over the last couple of months, perhaps) I have noticed that the entries returned from this route initially ...
1
vote
0answers
90 views

Issue: OAuth login process does not fully work in the WP7 Mango browser control with implicit flow

We experience issues when using the implicit OAuth flow in a WP7 Mango browser control and trying to login with openid. The login process itself works fine (althought the css of the openid page does ...
1
vote
0answers
40 views

Wrong API response?

Well, if you look here, you'll see i have "down_vote_count": 94, But if you look here on my Stackoverflow profile, you see that my down vote count is 64. For those who would ask if I'm sure ...
1
vote
0answers
30 views

API does not return stackoverflow user_id?

When I visit http://stackauth.com/1.1/users/aa1073f7-7e3b-4d4d-ace5-f2fca853f998/associated it returns my user_id on many stackexchange sites, but not stackoverflow itself! I'm sure this is by ...
1
vote
0answers
29 views

What has happened to the revision history of this answer?

This is rather odd. Consider this answer. The current content of the answer according to http://api.meta.stackoverflow.com/1.1/answers/81451?body=true is: ...<img ...
1
vote
0answers
19 views

“Special” required tag listings only show single required tag

When you're viewing questions tagged with one of app,script,library, you get the special formatting view with the thumbnail on the left. On pages where this view is displayed, only one of these tags ...
0
votes
0answers
15 views

Site parameter doesn't work properly with inbox items?

I use /users/{id}/inbox/unread method to get unread items in a user's inbox. I expect that site parameter there will filter the response. But looks like I have to do it manually by looking at ...
0
votes
0answers
45 views

Error: Cannot return to provided redirect_uri

I am trying Stack Exchange OAuth in local Magento site. I tried this URL: $url = ...
0
votes
0answers
26 views

Windows Phone app forgets its place when sleeping

Sometimes, when I'm reading a question on the Windows Phone app, the phone goes to sleep. When I wake it up, it's forgotten I was reading a question, and has gone back to the main screen. This is ...
0
votes
0answers
12 views

“can_flag” is not provided for answers through /questions/{ids} endpoint

When using the /questions/{ids} endpoint, the can_flag value for answers is never provided, even when specifying the option in the filter. The can_flag for the question however, is populated. Below ...