Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

1
vote
1answer
158 views

stackauth throwing 503 (in html format) after just a few /users/{id}/associated requests

After 5-8 successful requests 503 error, in html format, are being thrown. The requests are unique and consecutive, no api abuse is occurring. A related, but critical, concern is that any error ...
1
vote
1answer
110 views

New Meta sites out of order in /sites

I don't know if this is by design, but the ServerFault and SuperUser Meta sites don't follow their main sites in the response for the sites API route. Having linked_meta sites follow their main ...
8
votes
1answer
303 views

Keep getting HTTP 406

Not sure if this is a user or an API problem, but I keep getting HTTP 406 Not Acceptable when making API calls (for example http://api.stackoverflow.com/0.8/stats) from either IE 8 or Chrome 6. Here ...
6
votes
1answer
204 views

Why these questions do not have a title?

Hitting the following /questions route: http://api.stackoverflow.com/1.0/questions/74?pagesize=1&page=1 the endpoint returns this JSON data: { "total": 1, "page": 1, "pagesize": 1, ...
5
votes
0answers
46 views

Tell us that POST is required to write

While troubleshooting /posts/{id}/comments/add in order to answer Why am I getting a 404 when trying to post a comment?, it was noticed that the API path in question only responded to POST requests. ...
4
votes
1answer
909 views

/users/{id}/reputation != xxx.com/reputation

I realize that the shape of the data coming from the API may be different than that reported by the xxx/reputation url, but there seem to be some striking disparities. see 08/12 and 08/11 in both ...
3
votes
0answers
17 views

Reputation changes from accepting answers to questions are not included in reputation results

When querying the /users/{ids}/reputation API route, the results don't include the +2 reputation changes from accepting answers. None of the reputation results from my own reputation history have a ...
3
votes
1answer
93 views

Problem getting a users questions within a date range

I'm having a problem returning a list of users questions within a given timespan. I understand that the documentation ( http://api.stackoverflow.com/0.8/help/method?method=users/{id}/questions ) that ...
2
votes
3answers
134 views

display_name isn't always there (should have OpenID name if needed)

usually in the owner dictionary there is a display_name value to give the username. But in a few questions it simply doesn't exist and I can't see why only those questions: eg, this excerpt from the ...
1
vote
0answers
79 views

OAuth login fails for Stack Exchange and Facebook, but not Google

I'm integrating with Stack Exchange API on iOS 6 & 7. To authenticate, I load up a UIWebView with the OAuth page. Google login works well, but Stack Exchange and Facebook do not. Are these ...
1
vote
1answer
67 views

Associated accounts is broken for this user

When I retrieve associated accounts for Joel Coehoorn using this query it only includes Programmers.SE and Webmasters.SE despite the fact that I retrieved the association key from a query to SU. The ...
0
votes
1answer
138 views

min/max parameters are incorrectly documented as date - confusion and crippled libraries ensue

I have noticed this on all sorted routes. The min/max say that they are context sensitive to the sort type yet are documented as date. How is a date min/max valid when sorting by, for instance ...
7
votes
0answers
262 views

Application stats are completely broken.

It appears that the application stats are completely broken. Attempting to view the number of times Stack Mobile hit the /questions/* methods results in this graph: It would seem that statistics ...
5
votes
1answer
77 views

The tagged parameter does not work with multiple tags

Take these two API calls: http://api.stackoverflow.com/0.8/questions?tagged=php;rant http://api.stackoverflow.com/0.8/questions/tagged/php;rant A couple of problems: Shouldn't they return the ...
4
votes
1answer
194 views

update crossdomain.xml on stackauth.com and api endpoints to work with current Flash

I am implementing a javascript client that uses the Flash based XHR replacement Flensed in the interest of providing more robust api communication than that provided by JSONP. Apparently the current ...
3
votes
0answers
66 views

API v1.1 users call returns association_id for which the Stack Exchange web site has no profile

For a particular user, the users API v1.1 call returns an association_id that gives a "Page Not Found" error where the Stack Exchange profile should be, though their Stack Exchange profile can be ...
7
votes
1answer
199 views

Can't get JSON representation for the help

The API Documentation and Help states: If the help URL is requested in a common web browser, a HTML styled version of the JSON help will be returned. Otherwise, the JSON help will be ...
6
votes
5answers
484 views

Where can I find the reputation black market?

Apparently there is one around, at least I can't explain the recent jump in reputation of 4k for user 1026 by any other means (just kidding of course, no offense please ;) The API Beta badge accounts ...
5
votes
2answers
99 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).
4
votes
0answers
45 views

/tags fromdate and todate does nothing

Altough the help/documentation lists 'todate' and 'fromdate' parameters for tags they do not work. This may be related to tags not having a creation_date. It would be great if we could filter tags by ...
4
votes
1answer
70 views

Questions method does not return answers

I think questions method also return answers too and the help page says so http://api.stackoverflow.com/0.8/help/method?method=questions .... "answers": [ { "answer_id": { ...
3
votes
1answer
354 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
2
votes
1answer
94 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
1
vote
0answers
120 views

Unread messages in inbox query shows older inbox messages

I am using the /inbox/unread route to get the unread messages in a user's inbox. Recently (over the last couple of months, perhaps) I have noticed that the entries returned from this route initially ...
1
vote
1answer
34 views

Typo in throttle violation error message

I was just playing around with the API locally and got throttled for the questions and answers methods (the only two I was using). Anyway, I noticed there’s a small typo in the error message that’s ...
1
vote
1answer
54 views

An associated query is returning a partial record for a particular user

This query returns (in addition to several complete records) this incomplete one: { "user_id": 2196, "user_type": "registered", "display_name": "Wil", "reputation": 151, "email_hash": ...
6
votes
1answer
65 views

should min/max for alpha-numeric cases be case-insensitive?

I am having a hard time coming up with a use case in which case-sensitive min/max parameters make sense and several solid cases for a case-insensitive min/max. Example: With case insensitive ...
5
votes
1answer
83 views

The /search route is ignoring the answers parameter.

The answers parameter was recently added to most of the requests that return a list of questions. See: Don’t include answers in question lists by default It looks like the /search request got left ...
4
votes
0answers
47 views

Total reputation reported by the /users/{ids}/reputation route is low

When querying the /users/{ids}/reputation API route, the total amount of reputation I get back from all reputation changes is much lower than my reputation reported on Stack Overflow. Here's my ...
3
votes
0answers
18 views

bounties_offered are not being returned correctly from /users/{ids}/reputation

When querying the /users/{ids}/reputation API route, reputation changes for bounties_offered are not being returned correctly. In my own results, I see a reputation object with a reputation_change ...
3
votes
1answer
84 views

“OAuth request must be over HTTPS” when request is over https

I had a bug reported to me that I was able to reproduce. When authorizing to my Badges webapp, we get the following error: error: invalid_request error description: OAuth request must be over ...
3
votes
3answers
762 views

API usage triggering 503 (Too Many Requests)

Update: I generally try to back any claims of bugs and shortcomings with evidence. I have prepared a test page which you, dear Stack Overflow staff and my fellow developers, can use to ascertain ...
2
votes
0answers
38 views

Implicit OAuth Flow stopped working. Redirect happening to a non existent URL

The following URL is first hit when a user clicks on Login: ...
2
votes
1answer
68 views

the stack exchange javascript library is 404

the library listed on the doc page for Authentication https://api.stackexchange.com/js/2.0/all.js ultimately redirects to https://api-v2cdn.sstatic.net/js/all.js which results in varying degrees ...
2
votes
1answer
87 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } Renewing the ...
2
votes
1answer
67 views

Suddenly, some entries on /questions route are missing display_name

An odd bug has developed this morning. At the moment, api.stackoverflow.com/1.0/questions is returning a question of the format... ... }, { "tags": [ "jsf-2.0" ], ...
2
votes
1answer
96 views

API selectively ignores jsonp parameter - havok ensues

UPDATE: this is happening on all routes now and seems to be getting worse. Whatever it is just started this morning. compare url to json response GET ...
2
votes
1answer
39 views

/answers/{id} summary incorrect

/answers/{id} Gets a set of questions enumerated in id should probably be Gets a set of answers enumerated in id
1
vote
1answer
32 views

Site_Type returns “main_site” for meta.stackoverflow.com

For Meta Stack Overflow, the 2.0/sites endpoint returns "main_site" rather than "meta_site". All other site_type for other stackexchange sites return correctly. URL: ...
1
vote
1answer
42 views

StackAuth 1.1 API reports a site without a site_name

Calling the StackAuth 1.1 API associated method for a particular user returns one site with no site_name property (the one for which the user_id is 349). I cannot find a matching account in ...
1
vote
1answer
32 views

fromdate is ignored for /posts/{id}/comments requests

The api docs: http://api.stackoverflow.com/1.0/help/method?method=posts/{id}/comments The test request. You can see comment itself here, it's four months old, while cutoff date in request is less ...
1
vote
3answers
107 views

StackAuth returning 404?

http://stackauth.com/1.0/sites http://stackauth.com/1.0/help Both of these are currently returning 404 Not Found. What's up with that?
1
vote
1answer
70 views

user 'about_me' field suggested_buffer_size is too small

the suggested_buffer_size of user.about_me is currently 3000. it is apparent that this is the server-side field length. the problem is that the text is stored server-side in markdown but when served ...
1
vote
1answer
99 views

new throttle does not differentiate between api requests and requests made from viewing the site

Update: I am unable to reproduce the case of interactive browsing affecting app quota. And will concede that the failures that prompted this post were likely far edge cases. The remaining issue of a ...
1
vote
1answer
60 views

Problem getting a users answers within a date range

This issue is similar to http://stackapps.com/questions/768/problem-getting-a-users-questions-within-a-date-range. Only this time I'm calling a different api and getting unexpected results. I'm ...
1
vote
2answers
84 views

Possible problem calling users/?filter method searching username with tilde

I'm testing curious usernames and I am searching their user_id by: http://api.stackoverflow.com/0.8/users/?filter=username_filter I'm trying to get information about this particular user: ...
1
vote
2answers
77 views

Stats not showing the same values as the Site

I get less values in the api method that in the site, is this posible? Example: form the API I get that SO has 709980 questions from site 701005
1
vote
1answer
122 views

questions/{id} API method: pagesize parameter?

I'm trying to get the lightest data about a given question id because i just need the question's title. With this call: http://api.stackoverflow.com/0.8/questions/1598715?pagesize=1 i get ...
0
votes
1answer
38 views

Mismatch between user_id as reported in StackAuth 1.1 (invalid) and 1.0 (valid)

For the association id 1de2e2b0-2fb6-4db6-b90d-d0244ed5d13a, the StackAuth 1.1 call returns an invalid user_id of 73203 for Server Fault whereas the StackAuth 1.0 call returns the correct user_id of ...
0
votes
1answer
94 views

Comments are returning markdown.

Look at the output of the following: http://api.askubuntu.com/1.0/questions/12218?comments=true Output: { "comment_id": 12713, "creation_date": 1289269467, "owner": { ...