Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

6
votes
1answer
44 views

Why is /questions API returning deleted questions?

In last few days I have noticed that questions API returns questions that where deleted hours before the API call. This is a short example, if more logs are need to pin point the problem, please ...
2
votes
0answers
42 views

“Informed” badge shown as Next badge, but doesn't exist on this site

On my profile page, the Informed badge is shown as the next badge to obtain: Clicking it even shows a popup with a link to the Tour page, but it looks quite different from other SE sites. Looking ...
1
vote
0answers
34 views

Implicit Flow Isn't Redirecting

I'm using the WebAuthenticationBroker to allow users to log in to their account: var accessToken = ""; var uri = "https://stackexchange.com/oauth/dialog?redirect_uri=https://localhost.com&...
0
votes
0answers
33 views

error message not clear when app is rejected

I have three concerns here: 1) I haven't approved my Stack Exchange app as shown in this snapshot. So I go to https://stackexchange.com/oauth/dialog/?client_id=client_id&scope=read_inbox,...
2
votes
0answers
48 views

It's taking two calls to /oauth/dialog/ to get an access_token? [duplicate]

When we send this request: https://stackexchange.com/oauth/dialog/?client_id=`client_id`&scope=read_inbox%2cno_expiry%2cwrite_access%2cprivate_info&redirect_uri=https%3a%2f%2fstackexchange....
2
votes
0answers
29 views

Few typos in the documentation pages

https://api.stackexchange.com/docs/vectors When passing a vector, sepeate each id with a semicolon. For example, /users/1;2;3;4;5?site=somesite would fetch users with ids 1 through 5 on somesite. ...
4
votes
0answers
32 views

Typos on api.stackexchange.com/docs/js-lib

Under the Authentication section on https://api.stackexchange.com/docs/js-lib, there are a few typos (emphasis mine): scope (optional) – an array of scopes to request during authentication, valid ...
0
votes
1answer
33 views

wrong results of /search/advanced

I am querying mobile in stackoverflow. The second result is an answer. Results of /search/advanced is giving only questions when queried mobile. This is applicable for all other terms which are to be ...
2
votes
0answers
50 views

The Authentication Problem of WebAuthenticationBroke Classr in .NET 4.6

I have a problem when you test the StackExchange Authentication API to WebAuthenticationBroker. If you proceed with authentication, such as screenshots it will continue to appear only in progress. ...
-1
votes
1answer
38 views

wrong results of api /search/advanced

I am querying for results of /search/advanced. The request I am sending is https://api.stackexchange.com/2.2/search/advanced?key=`key`&access_token=`access_token`&site=stackoverflow.com&...
0
votes
0answers
11 views

wrong response wrong parameter is passed in `/me` call

I have passed wrong site parameter in /me. The response I am getting is common wrapper object with its error_id, error_message and error_name set. This is not expected. It is not of the type error.
0
votes
0answers
10 views

`type` of common wrapper object when error is returned

Whenever error is returned by any method the type of common wrapper object should be error. Also, in the documentation of error, under "Methods That Return This Type", it should be "Every method can ...
0
votes
0answers
19 views

Privilege name mismatch in API with privilege help page

In each site's Privileges page, the privilege for the 10 reputations are Create Wiki Posts and Remove New User Restrictions. But in the /me/privileges, /users/{id}/privileges and /privileges APIs ...
0
votes
0answers
35 views

`/me/associated` gives ambiguous/wrong response [duplicate]

This is my associated accounts page. No where I can see Meta Stack Overflow profile. But when I run /me/associated with meta_site as parameter to types, I get a response that tells me that I have a ...
10
votes
1answer
248 views

Why is my API quota not resetting after UTC reset?

According to How API Keys Work, the default daily API limit -- which is per site, per day -- is 300. I started with 300, as expected, but over a period of days, I've noticed that the remaining quota ...
6
votes
0answers
42 views

Badge numbers are wildly erroneous for meta accounts returned by the /associated query

There is a serious problem with badge counts on meta sites as returned by the /users/{ids}/associated route. Consider this user (chosen for high volume of meta activity). On Meta Stack Overflow, ...
5
votes
0answers
47 views

The 'should be closed' description in the flag dialog is missing a word

The 'should be closed...' reason has this description (emphasis mine): This question is completely unclear, incomplete, overly-broad, primarily opinion-based or is not about Stack Exchange API, ...
3
votes
1answer
37 views

The /tags query is not giving me the correct results between two dates?

I'm trying to get the yearly total number of questions that have the tag browserify. I can see that there are questions tagged from this year like this one and that one. The site reports that there ...
5
votes
0answers
59 views

The “advanced search” path returns very wrong results for the `q` parameter

I'm trying to search for a string. It's a hardware identifier 10ec:8168 and should be unique to that make/model of chip. Any questions that mention is should be relevant. But compare the site search ...
2
votes
0answers
47 views

error description: could not parse proxy url

I have seen the answers to the existing two questions on this topic but it has not helped. And the problem still persists so I am re-posting this question. Here is my code $(function(){ SE.init({ ...
1
vote
1answer
48 views

The /questions/{id}/linked method is returning extra questions

Consider the following question on ServerFault: http://serverfault.com/questions/45734/the-coolest-server-names Linked questions: Note that there's only two listed. However, querying: http://api....
1
vote
1answer
67 views

The /top-answer-tags method is not working

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
2
votes
1answer
56 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
3
votes
1answer
46 views

Reputation changes from accepting answers to questions are not included in reputation results

When querying the /users/{ids}/reputation API route, the results don't include the +2 reputation changes from accepting answers. None of the reputation results from my own reputation history have a ...
1
vote
1answer
23 views

The API /tag stats are notably different from the site totals

Why this discrepancy? --Sep 10 2015 11:26:09 GMT+0530 (IST)-- At that time, the API shows 42010 tags. But the same thing computed on the Stack Overflow tags page is 44496. Is it because of ...
4
votes
0answers
26 views

revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
2
votes
1answer
44 views

link in post_id in /me/notifications/unread is wrong

I have run /me/notifications/unread. The response contains post_id and there is a link to it. This link is wrong. The post is on Stack Apps but the link directs to Stack Overflow: I have ...
5
votes
1answer
49 views

API returns implausibly low questions per minute rate for Stack Overflow

Yesterday, I tried using the /info method of the API to predict the time left until 10M questions on Stack Overflow. In the process, I found that the returned "questions per minute" value was always 2....
2
votes
1answer
73 views

API returns the last activity date even if asked not to

Using the /questions method, I tried to get upvote and downvote counts, along with question Ids. This is the request I sent: http://api.stackexchange.com/2.2/questions/857455%3B857454?site=math&...
2
votes
1answer
62 views

Difference between `/inbox/unread` & `/me/inbox/unread`

I ran /inbox/unread & /me/inbox/unread. What is the difference between the two? Also, the site parameter which we give in call to /me/inbox/unread is not required as inbox_item refers to global ...
2
votes
0answers
33 views

Why is “body” missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
3
votes
1answer
69 views

What does `total` in the /notifications route represent?

What does total in /notifications represent? I ran it. The result was items in Common Wrapper Object was array of 24 items where as total was 4.
2
votes
0answers
41 views

/me/inbox is not returning most recent items

Looks like /me/inbox is either a bit behind or it's not supposed to be realtime. Explanation: for a comment that I received 4 hours ago It's not returned in the API: https://api.stackexchange.com/...
4
votes
1answer
52 views

Descriptions of tag-based badges are incorrect

The descriptions associated to tag-based badges are wrong, they always show 0 instead of actual thresholds: Earned at least 0 total score for at least 0 non-community wiki answers in the … tag ...
4
votes
1answer
1k views

How to deal with the “Too Many Requests” error coming as HTML?

The API specifies error codes, and messages. It also specifies a "backoff" parameter. But, even while respecting the backoff and stopping at errors, and even when waiting a long time between requests ...
4
votes
1answer
282 views

Login using Google fails saying OpenID 2.0 accounts for Google has gone away

Recently I have received complaints about my app suggesting that logging in with a Google account shows a warning message that OpenID authentication has gone away. When I tried to log in with my own ...
1
vote
1answer
139 views

Why is sort by name reverse alphabetical?

It makes sense that reputation or date should sort descending, but name? I tested both /users and /tags and they sort reverse alphabetical, so Z before A. Is that by design or just a side effect of ...
3
votes
1answer
63 views

Search function in the API doesn't work as expected

This looks like an error in the search part of the API. This search URL: /2.2/search?tagged=javascript&intitle=get%20column%20array&site=stackoverflow doesn't return any answers. I'm ...
1
vote
0answers
36 views

quota_remaining is decreasing much faster than expected

I registered an app and tried to make a couple of requests via Chrome (without actually creating any application yet). The thing that is really confusing is that with making a single request, ...
2
votes
0answers
50 views

Login problem on devices pre Windows Phone 8.1 Update 1

I have recently published an app for browsing Stack Exchange websites and a major feedback I received from users was about the inability to use oauth login form while loging into the app. The ...
4
votes
1answer
3k views

'The target origin provided does not match the recipient window's origin' message when trying to use localhost

I am trying to experiment with the Stack Overflow API on my localhost and am struggling to get the authentication to complete. Here is my application JavaScript code (note that I am using IBM ...
4
votes
0answers
73 views

“What is meta” should be rephrased

Stackapps.com/help/whats-meta tells that there is "Meta Stack Apps". However there isn't. Stack Apps is its own meta and meta is used to ask meta questions here.
3
votes
0answers
23 views

API returns delete vote count for questions, but not for answers

The questions method of the API returns the number of delete votes among other kinds of votes: sample query. But the answers method does not have a delete_vote_count field available in the filter: ...
2
votes
1answer
36 views

Invalid HTML characters in questions bodies

While writing an Android App that shows questions from the SE network, I've noticed that the SE REST API returns invalid HTML characters; after a bit more of researching I've found it's not the API ...
5
votes
0answers
189 views

Resurfacing bug: “could not parse proxy url” error message

According to this question, the "could not parse proxy url" bug was solved more than 2 years ago. However, when using the client-side OAuth flow, the aforementioned error message appears when ...
5
votes
1answer
63 views

API throws improper error when “date” parameters are the same

When using the Stack Exchange /questions API using the same date for fromdate and todate I get a 500 internal server error. Using different dates appears to work OK but specifying the same value ...
12
votes
1answer
357 views

Bug in the StackExchange Api ? getting “could not parse proxy url” when user not logged in

I think I may have stumbled upon a bug in the Stack Exchange JS API I'm having a problem getting its authentication to work properly, and I just discovered that the same problem exist in the official ...
6
votes
1answer
55 views

Why is comment_count=1 (incorrectly) when this particular filter is used?

We're seeing that, when a particular filter we've created is used, the API will return "comment_count": 1 for questions with no comments. For a search for questions with no answers, ordered by ...