Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

1
vote
1answer
19 views

Sort ranges on /questions/unanswered is broken

The following API request should return all unanswered questions with a score of at least 30: http://api.stackapps.com/1.1/questions/unanswered?sort=votes&min=30 However, the response ...
1
vote
0answers
40 views

Wrong API response?

Well, if you look here, you'll see i have "down_vote_count": 94, But if you look here on my Stackoverflow profile, you see that my down vote count is 64. For those who would ask if I'm sure ...
1
vote
0answers
31 views

API does not return stackoverflow user_id?

When I visit http://stackauth.com/1.1/users/aa1073f7-7e3b-4d4d-ace5-f2fca853f998/associated it returns my user_id on many stackexchange sites, but not stackoverflow itself! I'm sure this is by ...
1
vote
1answer
21 views

rep losses aren't reflected in api

This includes rep recalcs (e.g., the latest) and (speculative) when people take upvote back. First case you can see on standard stackauth/users query: it displays meta reputation before recalc. ...
1
vote
0answers
29 views

What has happened to the revision history of this answer?

This is rather odd. Consider this answer. The current content of the answer according to http://api.meta.stackoverflow.com/1.1/answers/81451?body=true is: ...<img ...
1
vote
0answers
19 views

“Special” required tag listings only show single required tag

When you're viewing questions tagged with one of app,script,library, you get the special formatting view with the thumbnail on the left. On pages where this view is displayed, only one of these tags ...
1
vote
1answer
62 views

The /top-answer-tags method is not working.

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
1
vote
1answer
105 views

Confusion over my API key

This is directed at the team, since nobody else will be able to help. The key I took out for StackMobile is behaving strangely. I make a few requests, and then the limit resets to 0. (By limit, I'm ...
1
vote
1answer
44 views

/users - fromdate/todate broken

consider: All users on meta : "total": 18923, http://api.meta.stackoverflow.com/0.8/users?sort=creation&order=desc Users created on meta in the last month: "total": 18923, ...
1
vote
1answer
34 views

help page format issue: missing parameter

/users/{id}/tags is missing id parameter fixing this will remove one more special case from my parser.
0
votes
2answers
76 views

Answers suddenly not getting returned.

Try: http://api.stackapps.com/0.8/questions/212 None of the answers are present.
0
votes
2answers
39 views

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API
0
votes
1answer
69 views

Why does the /events service sometimes pause for a couple of minutes?

In developing the firehose service, I found that the /events API often "pauses" for a couple of minutes before resuming. Is this a known issue? Specifically, I am polling /events every 10 seconds ...
0
votes
1answer
71 views

Getting garbage on requests

Not exactly sure how or why, but many times when I try and preview some URL, I get garbage. This has happened on several JSON preview websites as well as on my browser. Strangely this isn't all the ...
0
votes
1answer
79 views

stackauth.com/1.0/users/{id}/associated not returning display_name for some sites

The problem with email_hash seems to be fixed, but now display_name is not getting returned in some cases. For example: This Super User /users/{id} query returns a display_name, but the corresponding ...
0
votes
1answer
35 views

/questions/unanswered and /tags allow id parameter, but it does nothing

The /questions/unanswered and /tags queries both document (as required) and allow an "id" parameter. You can use it as /questions/unanswered?id=1;2;3, but it does nothing (that I can tell) and doesn't ...
0
votes
1answer
117 views

“Get an API key” on stackapps.com/about page is incorrect

the "Get an API key" link listed on the stackapps about page is incorrect. It points to http://stackapps.com/app/register and a lovely picture of Zardoz instead of the correct ...
0
votes
1answer
50 views

Most of the url are missing the protocol

Maybe you were trying to fix the other "bug" I've pointed out, but now most of the url for the icons are missing the protocol! { "site_type": "main_site", "name": "Stack Overflow", ...
0
votes
1answer
53 views

CDN redirect for the API's JavaScript SDK is incorrect

The API's JavaScript SDK is listed as https://api.stackexchange.com/js/2.0/all.js. However, GET request produces the following response: Status Code: 301 Moved Permanently Location: ...
0
votes
1answer
14 views

What is the api_site_parameter of stackapps.com in API 2.x

What is the api_site_parameter of stackapps.com in API 2.x? https://api.stackexchange.com/2.1/sites doesn't list stackapps. Why?
0
votes
1answer
99 views

API is accepting requests from other OAuth domains

I've set an OAuth domain for an application (the client_id is 24) and the following link authorizes the application: ...
0
votes
1answer
39 views

2.0 tags API returns only created tags

Searching for tags, using the inname parameter AND a date range returns only the tags that were created in that period, not the tags that were used in that period. When searching by inname only, or ...
0
votes
1answer
49 views

Removing/disallowing app does nothing

I have just deleted/disallowed, the console app and the app I'm currently writing. For the console the access token I was using before deleting the app carried on working, and when I got a new token, ...
0
votes
1answer
39 views

Mismatch between user_id as reported in StackAuth 1.1 (invalid) and 1.0 (valid)

For the association id 1de2e2b0-2fb6-4db6-b90d-d0244ed5d13a, the StackAuth 1.1 call returns an invalid user_id of 73203 for Server Fault whereas the StackAuth 1.0 call returns the correct user_id of ...
0
votes
1answer
62 views

API console always queries Stack Overflow

On any Stack Exchange site (well, I tried Super User (trilogy), Unix (SE-2.0 launched) and SFF (SE-2.0 beta)), the console (“Show Console” button) in the 1.1 API queries ...
0
votes
1answer
96 views

Comments are returning markdown.

Look at the output of the following: http://api.askubuntu.com/1.0/questions/12218?comments=true Output: { "comment_id": 12713, "creation_date": 1289269467, "owner": { ...
0
votes
1answer
53 views

Bug - Getting partial results for questions

When processing http://api.stackoverflow.com/1.0/questions/1156985 I only get partial results. Many of the missing fields are mandatory fields, including the owner of the question.
0
votes
1answer
64 views

api.meta.stackoverflow.com has state:normal - is this correct

i am not sure what the origin and exact meaning of the term 'linked_meta' is, but I would guess that it is a term created for area 51 meta sites and the implied meaning is clear. Perhaps stack meta ...
0
votes
1answer
78 views

Where are the new Metas?

According to the most recent blog post, ServerFault and SuperUser each got their own Meta. Shouldn't this be showing up in StackAuth?
0
votes
1answer
45 views

The /questions/{id}/timeline route isn't working.

I'm getting a response code 500 for the /questions/{id}/timeline route. I've tried it in Firefox and by fetching a response in Java. Example URL: ...
0
votes
1answer
138 views

min/max parameters are incorrectly documented as date - confusion and crippled libraries ensue

I have noticed this on all sorted routes. The min/max say that they are context sensitive to the sort type yet are documented as date. How is a date min/max valid when sorting by, for instance ...
0
votes
1answer
32 views

Favorites api gives wrong results when sorted by added

For example, please compare http://api.stackoverflow.com/0.8/users/111391/favorites?sort=added with ...
0
votes
1answer
81 views

How to sort answers to question?

If I retrieve a question like so: http://api.stackoverflow.com/0.8/questions/1429951&sort=votes I expect the answers to be sorted by votes, but they're not. How can I do this?
0
votes
1answer
44 views

questions/{id}/timeline documentation: timeline_type values not listed

The timeline_type for post timelines just says "string" for the "values". From a cursory look at a few questions, I've seen the following types of events: question answer comment revision votes ...
0
votes
0answers
21 views

quota_remaining is decreasing much faster than expected

I registered an app and tried to make a couple of requests via Chrome (without actually creating any application yet). The thing that is really confusing is that with making a single request, ...
0
votes
0answers
12 views

Post_id is missing in timeline for new answers, not for revised or accepted answers

It is strange that in the timeline of a question, the new answers (timeline_type == 'answer') do not have a post_id field, while the update on the question (revision, accepted_answer, ...
0
votes
0answers
17 views

How many points is question upvote expected to be? [duplicate]

I noticed that a question upvote gives +10 rep (I took a question and looked in the rep tab of OP), unlike other SE sites. However help center says that a question upvote gives +5 rep. You gain ...
0
votes
0answers
15 views

Site parameter doesn't work properly with inbox items? [duplicate]

I use /users/{id}/inbox/unread method to get unread items in a user's inbox. I expect that site parameter there will filter the response. But looks like I have to do it manually by looking at ...
0
votes
1answer
57 views

API returns the last activity date even if asked not to

Using the /questions method, I tried to get upvote and downvote counts, along with question Ids. This is the request I sent: ...
0
votes
0answers
16 views

oAuth login via stackexchange api : facebook click nothing happens on mobile devices [duplicate]

I am trying to use stackexchange api to login to an app but nothing happens on facebook click is that a known bug?
0
votes
0answers
134 views

Cursor continuously switching back and forth between arrow and hand symbols

In the 'Questions' page point your mouse at the 'line' which separate the tabs(Newest, Frequent, Votes, etc) and the questions and see the mouse pointer transforms in between the two shapes (Hand ...
0
votes
0answers
28 views

Parameter `tagged` in `search/advanced` seems to use `AND` instead of `OR`

It seems that search/advanced has the same problem as in "The tagged parameter does not work with multiple tags" question. When I select c#; .net I only get results tagged both c# and .net: ...
0
votes
0answers
575 views

Receiving “redirect_uri does not match the uri used to create the passed code”, when it does match

Summary Using Oauth2, when I go to pick up the access_token, I get the following error from the server: access_denied: redirect_uri does not match the uri used to create the passed code. From what I ...
0
votes
0answers
238 views

An associated query is returning a partial record for Area 51

This issue has recurred (and is ongoing) as of a couple of weeks ago. Most notably, as before, the on_site attribute is missing from Area 51. This is API 1.0, by the way.
0
votes
1answer
20 views

Error when requesting the last page of results.

When I try to view the following URL: http://api.stackexchange.com/2.0/questions?page=93781&site=stackoverflow I get the error: { "error_id": 500, "error_name": "internal_error", ...
0
votes
1answer
30 views

API 2.0 is not returning Programmers in list of sites

Run https://api.stackexchange.com/2.0/sites. programmers.stackexchange.com is not in the response.
0
votes
1answer
28 views

Badges displayed incorrectly?

It seems that there's something odd going on with badges. If we take some random user, say 1719, which has one account, and check the user page http://stackexchange.com/users/1719/jelon, then we can ...
0
votes
1answer
24 views

No answer_id for Comment on answer inbox_item

According to the API documentation on inbox_item, inbox items corresponding to a comment on an answer to a question should have an answer_id field identifying the answer that the comment was on, but ...
0
votes
1answer
25 views

Runtime error getting thrown with certain parameters on older 1.1 methods

This v1.1 URL is creating a runtime error: http://api.stackapps.com/1.1/comments&min=1323731212 Example output:
0
votes
1answer
20 views

questions/{id} API not working as intended for vectorized id

Show Console > Try it > Call Method button on questions/{id} API page is not working properly for vectorized id ie. when I am passing 7282205 it is working fine, but when I am passing- 7282205; ...