Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

1
vote
1answer
47 views

Revision help URL contains wrong header

There are two revision urls listed on the help page but they both seem to contain the same detailed information. The header for the non-guid version contains the url for the one that takes a guid. ...
3
votes
1answer
71 views

Methods that return comments document body and comments parameters but they do nothing

Methods that return comments document the "body" and "comments" parameters, but they have no effect on the results, which cannot include comments and always include the body. Specific methods: ...
3
votes
2answers
57 views

Inconsistency in the handling of multiple IDs with a duplicate

There appears to be some inconsistency in the way multiple ids are being handled, especially when a duplicate exists. Duplicate ID is significant For example, when requesting a timeline of multiple ...
2
votes
1answer
143 views

Don't allow requests with No Key to use existing session with valid API Key

Once I did a request with a valid API key http://api.stackoverflow.com/0.8/stats?key=MYKEY Every requests (from that IP) later on without key will use existing session with API key, limit ...
7
votes
1answer
368 views

API Key limit 10k is Per IP Address or Globally?

Getting started FAQ says No Key limit is IP Address based, but it does not say for with API Key. When I test my API Key from different IP Addresses, I noticed that 10k limit is globally, limit is ...
0
votes
1answer
35 views

/questions/unanswered and /tags allow id parameter, but it does nothing

The /questions/unanswered and /tags queries both document (as required) and allow an "id" parameter. You can use it as /questions/unanswered?id=1;2;3, but it does nothing (that I can tell) and doesn't ...
3
votes
1answer
86 views

Two minor typos in the “Register your Application” form

In the help text (on the right hand side) for the Application Name field on http://stackapps.com/apps/register: I think this should be changed: " ... is built on the our platform ...". For example, ...
0
votes
1answer
44 views

questions/{id}/timeline documentation: timeline_type values not listed

The timeline_type for post timelines just says "string" for the "values". From a cursory look at a few questions, I've seen the following types of events: question answer comment revision votes ...
2
votes
1answer
48 views

questions/{id} help page sort parameter description is inconsistence with others

The description of the Sort parameter in questions/{id} help page is inconsistent with those of other pages. On the questions/{id} help page: sort (optional): How a collection should ...
2
votes
3answers
84 views

Method /users/{id} doesn't return “about_me” if the user has never modified it

See title. When a user never modified their "about me" section the API doesn't return that, which then causes my parser to go wild returning errors. However, when a user has modified their "about ...
4
votes
1answer
97 views

Two minor typos in the API help

In http://api.stackoverflow.com/0.8/help /users/{id}/answers Gets answer summary informatino for the user with 'id'. and in the Returns section of ...
1
vote
2answers
53 views

Unanswered questions API does not work

The /questions/unanswered API returns the full list of questions (same as /questions).
1
vote
2answers
141 views

errors/{id} documentation : 500 Internal Server Error

On Documentation page, clicking on errors/{id} returns 500 Internal Server Error EDIT: Fixed!
2
votes
1answer
162 views

My reputation graph is messed up.

See here: http://stackapps.com/users/18?tab=reputationhistory#tab-top Go to my rep graph and notice that it only shows about 350 points... Where's my other 4100?
7
votes
1answer
196 views

Can't get JSON representation for the help

The API Documentation and Help states: If the help URL is requested in a common web browser, a HTML styled version of the JSON help will be returned. Otherwise, the JSON help will be ...
2
votes
1answer
2k views

Help on help results in HTTP 500 Internal Server Error

A request to http://api.stackoverflow.com/0.8/help?help results in an HTTP 500 with Content-Type: application/json and an HTML body.
4
votes
2answers
136 views

Request with Invalid key still return the content and rate limit stepped down into No Key Limit

For example http://api.stackoverflow.com/0.8/stats?key=TEST1234&type=jsontext Request with Invalid key still return the content and rate limit stepped down into No Key Limit ...
1
vote
1answer
93 views

Possible Bug With positive_rep Field?

I'm looking through my /users/{id}/reputation and I think I see a possible bug regarding how positive_rep is calculated when someone upvotes your question. ...
0
votes
1answer
114 views

“Get an API key” on stackapps.com/about page is incorrect

the "Get an API key" link listed on the stackapps about page is incorrect. It points to http://stackapps.com/app/register and a lovely picture of Zardoz instead of the correct ...
4
votes
1answer
70 views

Getting error 4002 when calling tags method without a sort parameter

According to the documentation, calling the tags method without a sort parameter should return the recently used tags, since the default sort is by activity. Instead, I get an error 4002 with the ...
8
votes
1answer
285 views

Keep getting HTTP 406

Not sure if this is a user or an API problem, but I keep getting HTTP 406 Not Acceptable when making API calls (for example http://api.stackoverflow.com/0.8/stats) from either IE 8 or Chrome 6. Here ...
1
vote
1answer
122 views

questions/{id} API method: pagesize parameter?

I'm trying to get the lightest data about a given question id because i just need the question's title. With this call: http://api.stackoverflow.com/0.8/questions/1598715?pagesize=1 i get ...
2
votes
1answer
150 views

Make www a subdomain.

Try going to http://www.stackapps.com Apparently www is not a subdomain of stackapps.com Anyone who tries to get to the site by prepending the www will be confused, as it is standard to point that ...
3
votes
1answer
88 views

The Faq Has a Broken Link

Currently the first link in the FAQ points to http://dev.stackapps.com/?tab=apps. It should link to http://stackapps.com/?tab=apps. Simple fix, but it confused me for a short time.