Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

1
vote
1answer
158 views

stackauth throwing 503 (in html format) after just a few /users/{id}/associated requests

After 5-8 successful requests 503 error, in html format, are being thrown. The requests are unique and consecutive, no api abuse is occurring. A related, but critical, concern is that any error ...
1
vote
1answer
83 views

Problems with the Site Icons

I'm having trouble with the WebApps icon being returned from the /sites method. Namely, the image is composed of a larg white rectangle with a very small guy in the middle. Why can't the guy take ...
4
votes
2answers
124 views

How far behind is the data returned by calls supposed to be?

I understand that the data sourced to the API are cached, but I'm seeing some fairly extreme discrepancies between reputation reported by the API and apparent activity on the site. For example: ...
3
votes
2answers
119 views

Shouldn't the API help be consistent with the trademark guidance?

The description for the two StackAuth Routes within the API help both contain the phrase StackExchange network - shouldn't this rather be Stack Exchange Network to be consistent with the recently ...
2
votes
2answers
128 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
5
votes
1answer
117 views

Site in closed beta but api working

Hello, Webapps has been added yesterday, website is in closed beta and it's not possible to see something on the website when you are not logged. But if you use the API you can get information. ...
5
votes
1answer
120 views

Intermittent bug in the /search route when providing both tagged and nottagged parameters.

I'm getting the wrong number of results back from the /search route depending on what combination of values I provide for the tagged and nottagged parameters. Examples: ...
2
votes
1answer
46 views

pagesize=0 on /search throwing error

http://api.stackapps.com/0.9/search?intitle=a&pagesize=0 { "error": { "code": 4001, "message": "The 'pagesize' query parameter is invalid." } }
1
vote
1answer
81 views

/questions/{id}/timeline throwing 500 instead of 404

Kevin, you fixed this bug some time ago, would you like to tag it as status-complete? Sometime last week, this route stopped throwing 404 like the rest of my 'bad id' tests and started throwing 500. ...
0
votes
1answer
44 views

The /questions/{id}/timeline route isn't working.

I'm getting a response code 500 for the /questions/{id}/timeline route. I've tried it in Firefox and by fetching a response in Java. Example URL: ...
1
vote
1answer
60 views

Problem getting a users answers within a date range

This issue is similar to http://stackapps.com/questions/768/problem-getting-a-users-questions-within-a-date-range. Only this time I'm calling a different api and getting unexpected results. I'm ...
2
votes
1answer
129 views

crossdomain.xml and clientaccesspolicy.xml needed on sstatic.net

Silverlight image loading from Uri fails due to lack of xdomain permission files. Needed: http://sstatic.net/clientaccesspolicy.xml http://sstatic.net/crossdomain.xml
3
votes
1answer
56 views

both /revisions methods are spotty

These are the urls for a couple of my valid endpoint tests of the /revisions methods. http://api.stackoverflow.com/0.8/revisions/2688191 (?key=xxx) ...
1
vote
1answer
44 views

/users - fromdate/todate broken

consider: All users on meta : "total": 18923, http://api.meta.stackoverflow.com/0.8/users?sort=creation&order=desc Users created on meta in the last month: "total": 18923, ...
2
votes
2answers
66 views

Missing on_site in Stack Apps site data in associated_users from stackauth query

This is what I get for Stack Apps: { "display_name": "user", "email_hash": "11aa11...22bb22...", "reputation": 101, "user_id": 0000, "user_type": ...
4
votes
1answer
113 views

StackApps is not being reported by StackAuth

The stackauth.com sites query is not returning stackapps.com at all: http://stackauth.com/0.8/sites?type=jsontext { "api_sites": [ { "name": "Stack Overflow", "logo_url": ...
2
votes
1answer
128 views

Why do some Stackauth associated queries fail?

This query fails: http://stackauth.com/0.8/users/137b94e5-050c-4dd5-82c1-aeb2af0814f5/associated In Python for a jason.loads call, I get an error: 'ValueError("No JSON object could be decoded")'. I ...
3
votes
1answer
93 views

Problem getting a users questions within a date range

I'm having a problem returning a list of users questions within a given timespan. I understand that the documentation ( http://api.stackoverflow.com/0.8/help/method?method=users/{id}/questions ) that ...
0
votes
1answer
36 views

/stats meta data missing

So am I to assume that since we can make an extra call to another site to get meta that site node in stats has been deemed redundant data. If so, I have to suggest a reality break. This is one of ...
4
votes
1answer
97 views

http://stackauth.com/0.8/sites down

I realize you may be shaking something out but in case you are not aware: http://stackauth.com/0.8/sites is returning { "api_sites": [] }
2
votes
0answers
112 views

StackAuth needs crossdomain.xml and clientaccesspolicy.xml

These would be helpful to have. Absence breaks Silverlight apps. http://stackauth.com/crossdomain.xml http://stackauth.com/clientaccesspolicy.xml http://stackauth.com/0.8/crossdomain.xml ...
1
vote
1answer
132 views

Question's title attribute is not HTML encoded

Question's title attribute is not HTML encoded. Examples: http://api.stackoverflow.com/0.8/questions/456815?body=true&answers=true title: "Problems with HTML <marquee> tag" ...
2
votes
2answers
501 views

Server has stopped obeying Accept-encoding header

Either today or yesterday, besides /questions/tagged having disappeared, the server started ignoring the Accept-encoding header: Ligação estabelecida com 69.59.196.211 na porta 80 GET ...
2
votes
1answer
39 views

/answers/{id} summary incorrect

/answers/{id} Gets a set of questions enumerated in id should probably be Gets a set of answers enumerated in id
2
votes
1answer
49 views

Why does /users/{id}/answers, which returns an array of answers, have an optional 'answers' flag?

I would assume that if you are requesting the route '/users/{id}/answers' that you wish to receive some answers.
0
votes
1answer
138 views

min/max parameters are incorrectly documented as date - confusion and crippled libraries ensue

I have noticed this on all sorted routes. The min/max say that they are context sensitive to the sort type yet are documented as date. How is a date min/max valid when sorting by, for instance ...
5
votes
1answer
77 views

The tagged parameter does not work with multiple tags

Take these two API calls: http://api.stackoverflow.com/0.8/questions?tagged=php;rant http://api.stackoverflow.com/0.8/questions/tagged/php;rant A couple of problems: Shouldn't they return the ...
8
votes
2answers
168 views

/search intitle arg is case sensitive

This seriously cripples any search capabilities. Consider: http://api.stackapps.com/0.8/search?intitle=soapi&order=desc&sort=activity vs ...
5
votes
2answers
87 views

The /search route is ignoring the answers parameter.

The answers parameter was recently added to most of the requests that return a list of questions. See: Don’t include answers in question lists by default It looks like the /search request got left ...
0
votes
2answers
75 views

Answers suddenly not getting returned.

Try: http://api.stackapps.com/0.8/questions/212 None of the answers are present.
2
votes
1answer
59 views

Answers parameter not functional

For example the following: http://api.stackoverflow.com/0.8/questions?answers=true doesn't return answers.
2
votes
2answers
67 views

Order parameter not functional

Consider these two API calls: http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=desc http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=asc ...
2
votes
1answer
75 views

Include range [1, 100] on pagesize

I see that "range" is being used to indicate valid range on most numeric parameters, e.g. 32-bit integer, range [0, 2,147,483,647] 32-bit integer, range [1, 2,147,483,647] The smaller valid range ...
3
votes
2answers
70 views

On /users method id parameter does not work

Calling /users method with id parameter returns a list of users and not the user expected. http://api.stackoverflow.com/0.8/users?id=23234 Could be a documentation "bug" on help page: ...
1
vote
2answers
84 views

Possible problem calling users/?filter method searching username with tilde

I'm testing curious usernames and I am searching their user_id by: http://api.stackoverflow.com/0.8/users/?filter=username_filter I'm trying to get information about this particular user: ...
1
vote
1answer
56 views

Inconsistent sort ordering on users?

I'm trying to get a list of the 10 oldest users. This is the endpoint I'm using: http://api.stackoverflow.com/0.8/users?key=(key)&order=asc&sort=creation&pagesize=10&page=0 ...
2
votes
1answer
76 views

Question sort: change active to activity?

I noticed the sort newest for /questions, /questions/tagged/{tags} and /questions/unanswered was changed to creation recently, making it more consistent with other methods. Could the sort active for ...
1
vote
2answers
77 views

Stats not showing the same values as the Site

I get less values in the api method that in the site, is this posible? Example: form the API I get that SO has 709980 questions from site 701005
3
votes
2answers
77 views

Inconsistency in sort order

If I execute the following API call: http://api.stackoverflow.com/0.8/questions?sort=newest&body=True&pagesize=5&min=1275575777&order=desc versus one that does not include the min ...
3
votes
3answers
157 views

Negative voting questions?

I'm trying to, for humorous purposes, check out some of the worst scoring questions ever on SO. I'm pretty much expecting them to all be "heeeeelp homework" or "plz send me teh codez" or something to ...
1
vote
3answers
138 views

API not returning anything near the actual website

The API /questions page is not returning anything like the list of questions on the actual SO site. This is the first question of the 0.8/questions { "total": 705769, "page": 1, "pagesize": ...
2
votes
2answers
91 views

Why my /mentioned page return 404?

http://api.stackoverflow.com/0.8/users/213464/mentioned?type=jsontext { "error": { "code": 404, "message": "The server has not found anything matching the Request-URI." } } Its ...
2
votes
1answer
59 views

/users/{id}/badges - multiple identical results

Each badge returned in the list of results from /users/{id}/badges already contains an award_count indicating how many times the badge was awarded for the particular user attached to the badge. In ...
4
votes
2answers
88 views

Possible bug in the help page?

There are some weird dot things in this help page: api.stackoverflow.com/0.8/help/method?method=users/{id}/badges {Dead link to missing image: http://files.quickmediasolutions.com/stackbug.png} ...
1
vote
1answer
69 views

/users/{id}/tags - broken

looks like touching the id parameter description broke the internet. http://api.stackoverflow.com/0.8/users/242897/tags should/was working 6/1/2010 -1:11AM - working
1
vote
1answer
34 views

help page format issue: missing parameter

/users/{id}/tags is missing id parameter fixing this will remove one more special case from my parser.
0
votes
1answer
34 views

help page format issue: revisionGuid

http://api.stackoverflow.com/0.8/help/method?method=revisions/{id}/{revisionguid} revisionGuid is inconsistent. revisionguid seems appropriate (and will remove one special case from my api parser).
0
votes
1answer
32 views

Favorites api gives wrong results when sorted by added

For example, please compare http://api.stackoverflow.com/0.8/users/111391/favorites?sort=added with ...
3
votes
1answer
31 views

Minor typo on help page

On the API Routes help page, this: /users/{id}/favorites Gets summary information for the questions that have been favorited a set of users. should probably be: /users/{id}/favorites Gets ...
2
votes
3answers
134 views

display_name isn't always there (should have OpenID name if needed)

usually in the owner dictionary there is a display_name value to give the username. But in a few questions it simply doesn't exist and I can't see why only those questions: eg, this excerpt from the ...