Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

3
votes
1answer
96 views

/users/{id}/associated - inconsistent behavior

/users/{id}/associated occasionally returns empty for an association even though there are definitely associated users. Calling it again immediately returns expected results. GET ...
0
votes
1answer
79 views

stackauth.com/1.0/users/{id}/associated not returning display_name for some sites

The problem with email_hash seems to be fixed, but now display_name is not getting returned in some cases. For example: This Super User /users/{id} query returns a display_name, but the corresponding ...
5
votes
2answers
103 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).
1
vote
2answers
117 views

On Stackauth /sites new meta sites have wrong name

This should be the correct behaviour: name: "Stack Overflow Meta" name: "Web Apps Meta" name: "Gaming Meta" .. For the newcomers Server Fault and Super User, Meta is before the parent site in the ...
0
votes
1answer
64 views

api.meta.stackoverflow.com has state:normal - is this correct

i am not sure what the origin and exact meaning of the term 'linked_meta' is, but I would guess that it is a term created for area 51 meta sites and the implied meaning is clear. Perhaps stack meta ...
2
votes
1answer
64 views

stackauth is not serving gzip to silverlight3/phone7

I ported all of my integration tests to phone 7, which is a flavor of silverlight 3, and found that stackauth is not forcing gzip as expected. while this simply means that I need to check the first 2 ...
0
votes
1answer
78 views

Where are the new Metas?

According to the most recent blog post, ServerFault and SuperUser each got their own Meta. Shouldn't this be showing up in StackAuth?
1
vote
1answer
112 views

New Meta sites out of order in /sites

I don't know if this is by design, but the ServerFault and SuperUser Meta sites don't follow their main sites in the response for the sites API route. Having linked_meta sites follow their main ...
2
votes
1answer
79 views

Paging /users by rep is on sites with low user count unpredictable

Resolution Fix confirmed: Tests.SortDupBug Page 1 #100 Total 11066 api.serverfault.com /users?max=2147483647&min=99&page=1&pagesize=100&key=qgAq_KfDu0KYzlNG-qaTuw Page 2 #100 Total 11066 ...
1
vote
2answers
34 views

nottagged parameter not documented

It appears that the /questions method still takes the nottagged which specifies a list of tags to exclude questions by but this parameter is not mentioned in the documentation. Is this parameter ...
2
votes
1answer
58 views

Oddity with migration data from questions

Take a look at this question on SuperUser. Apparently, it was migrated from ServerFault, and was originally asked by user 3d1l. However, now look at the API result: ...
1
vote
1answer
103 views

Confusion over my API key

This is directed at the team, since nobody else will be able to help. The key I took out for StackMobile is behaving strangely. I make a few requests, and then the limit resets to 0. (By limit, I'm ...
3
votes
1answer
393 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
1
vote
1answer
138 views

Game developer's logo isn't working.

See here: http://stackmobile.com/ - towards the bottom Neither the main logo, nor the meta logo is workin.
6
votes
1answer
66 views

should min/max for alpha-numeric cases be case-insensitive?

I am having a hard time coming up with a use case in which case-sensitive min/max parameters make sense and several solid cases for a case-insensitive min/max. Example: With case insensitive ...
1
vote
1answer
56 views

Pro Webmasters Meta API not working.

Try this: http://api.meta.webmasters.stackexchange.com/0.9/questions?type=jsontext I can't get it to work, even though it's listed in StackAuth.
1
vote
1answer
162 views

stackauth throwing 503 (in html format) after just a few /users/{id}/associated requests

After 5-8 successful requests 503 error, in html format, are being thrown. The requests are unique and consecutive, no api abuse is occurring. A related, but critical, concern is that any error ...
1
vote
1answer
84 views

Problems with the Site Icons

I'm having trouble with the WebApps icon being returned from the /sites method. Namely, the image is composed of a larg white rectangle with a very small guy in the middle. Why can't the guy take ...
4
votes
2answers
124 views

How far behind is the data returned by calls supposed to be?

I understand that the data sourced to the API are cached, but I'm seeing some fairly extreme discrepancies between reputation reported by the API and apparent activity on the site. For example: ...
3
votes
2answers
120 views

Shouldn't the API help be consistent with the trademark guidance?

The description for the two StackAuth Routes within the API help both contain the phrase StackExchange network - shouldn't this rather be Stack Exchange Network to be consistent with the recently ...
2
votes
2answers
129 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
5
votes
1answer
118 views

Site in closed beta but api working

Hello, Webapps has been added yesterday, website is in closed beta and it's not possible to see something on the website when you are not logged. But if you use the API you can get information. ...
5
votes
1answer
120 views

Intermittent bug in the /search route when providing both tagged and nottagged parameters.

I'm getting the wrong number of results back from the /search route depending on what combination of values I provide for the tagged and nottagged parameters. Examples: ...
2
votes
1answer
46 views

pagesize=0 on /search throwing error

http://api.stackapps.com/0.9/search?intitle=a&pagesize=0 { "error": { "code": 4001, "message": "The 'pagesize' query parameter is invalid." } }
1
vote
1answer
82 views

/questions/{id}/timeline throwing 500 instead of 404

Kevin, you fixed this bug some time ago, would you like to tag it as status-complete? Sometime last week, this route stopped throwing 404 like the rest of my 'bad id' tests and started throwing 500. ...
0
votes
1answer
45 views

The /questions/{id}/timeline route isn't working.

I'm getting a response code 500 for the /questions/{id}/timeline route. I've tried it in Firefox and by fetching a response in Java. Example URL: ...
1
vote
1answer
60 views

Problem getting a users answers within a date range

This issue is similar to http://stackapps.com/questions/768/problem-getting-a-users-questions-within-a-date-range. Only this time I'm calling a different api and getting unexpected results. I'm ...
2
votes
1answer
130 views

crossdomain.xml and clientaccesspolicy.xml needed on sstatic.net

Silverlight image loading from Uri fails due to lack of xdomain permission files. Needed: http://sstatic.net/clientaccesspolicy.xml http://sstatic.net/crossdomain.xml
3
votes
1answer
57 views

both /revisions methods are spotty

These are the urls for a couple of my valid endpoint tests of the /revisions methods. http://api.stackoverflow.com/0.8/revisions/2688191 (?key=xxx) ...
1
vote
1answer
44 views

/users - fromdate/todate broken

consider: All users on meta : "total": 18923, http://api.meta.stackoverflow.com/0.8/users?sort=creation&order=desc Users created on meta in the last month: "total": 18923, ...
2
votes
2answers
66 views

Missing on_site in Stack Apps site data in associated_users from stackauth query

This is what I get for Stack Apps: { "display_name": "user", "email_hash": "11aa11...22bb22...", "reputation": 101, "user_id": 0000, "user_type": ...
4
votes
1answer
113 views

StackApps is not being reported by StackAuth

The stackauth.com sites query is not returning stackapps.com at all: http://stackauth.com/0.8/sites?type=jsontext { "api_sites": [ { "name": "Stack Overflow", "logo_url": ...
2
votes
1answer
128 views

Why do some Stackauth associated queries fail?

This query fails: http://stackauth.com/0.8/users/137b94e5-050c-4dd5-82c1-aeb2af0814f5/associated In Python for a jason.loads call, I get an error: 'ValueError("No JSON object could be decoded")'. I ...
3
votes
1answer
97 views

Problem getting a users questions within a date range

I'm having a problem returning a list of users questions within a given timespan. I understand that the documentation ( http://api.stackoverflow.com/0.8/help/method?method=users/{id}/questions ) that ...
0
votes
1answer
36 views

/stats meta data missing

So am I to assume that since we can make an extra call to another site to get meta that site node in stats has been deemed redundant data. If so, I have to suggest a reality break. This is one of ...
4
votes
1answer
98 views

http://stackauth.com/0.8/sites down

I realize you may be shaking something out but in case you are not aware: http://stackauth.com/0.8/sites is returning { "api_sites": [] }
2
votes
0answers
113 views

StackAuth needs crossdomain.xml and clientaccesspolicy.xml

These would be helpful to have. Absence breaks Silverlight apps. http://stackauth.com/crossdomain.xml http://stackauth.com/clientaccesspolicy.xml http://stackauth.com/0.8/crossdomain.xml ...
1
vote
1answer
136 views

Question's title attribute is not HTML encoded

Question's title attribute is not HTML encoded. Examples: http://api.stackoverflow.com/0.8/questions/456815?body=true&answers=true title: "Problems with HTML <marquee> tag" ...
2
votes
2answers
546 views

Server has stopped obeying Accept-encoding header

Either today or yesterday, besides /questions/tagged having disappeared, the server started ignoring the Accept-encoding header: Ligação estabelecida com 69.59.196.211 na porta 80 GET ...
2
votes
1answer
39 views

/answers/{id} summary incorrect

/answers/{id} Gets a set of questions enumerated in id should probably be Gets a set of answers enumerated in id
2
votes
1answer
49 views

Why does /users/{id}/answers, which returns an array of answers, have an optional 'answers' flag?

I would assume that if you are requesting the route '/users/{id}/answers' that you wish to receive some answers.
0
votes
1answer
138 views

min/max parameters are incorrectly documented as date - confusion and crippled libraries ensue

I have noticed this on all sorted routes. The min/max say that they are context sensitive to the sort type yet are documented as date. How is a date min/max valid when sorting by, for instance ...
5
votes
1answer
78 views

The tagged parameter does not work with multiple tags

Take these two API calls: http://api.stackoverflow.com/0.8/questions?tagged=php;rant http://api.stackoverflow.com/0.8/questions/tagged/php;rant A couple of problems: Shouldn't they return the ...
8
votes
2answers
171 views

/search intitle arg is case sensitive

This seriously cripples any search capabilities. Consider: http://api.stackapps.com/0.8/search?intitle=soapi&order=desc&sort=activity vs ...
5
votes
2answers
92 views

The /search route is ignoring the answers parameter.

The answers parameter was recently added to most of the requests that return a list of questions. See: Don’t include answers in question lists by default It looks like the /search request got left ...
0
votes
2answers
76 views

Answers suddenly not getting returned.

Try: http://api.stackapps.com/0.8/questions/212 None of the answers are present.
2
votes
1answer
60 views

Answers parameter not functional

For example the following: http://api.stackoverflow.com/0.8/questions?answers=true doesn't return answers.
2
votes
2answers
68 views

Order parameter not functional

Consider these two API calls: http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=desc http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=asc ...
2
votes
1answer
76 views

Include range [1, 100] on pagesize

I see that "range" is being used to indicate valid range on most numeric parameters, e.g. 32-bit integer, range [0, 2,147,483,647] 32-bit integer, range [1, 2,147,483,647] The smaller valid range ...
3
votes
2answers
72 views

On /users method id parameter does not work

Calling /users method with id parameter returns a list of users and not the user expected. http://api.stackoverflow.com/0.8/users?id=23234 Could be a documentation "bug" on help page: ...