Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

1
vote
1answer
138 views

Game developer's logo isn't working.

See here: http://stackmobile.com/ - towards the bottom Neither the main logo, nor the meta logo is workin.
4
votes
1answer
72 views

What's the difference between tags soapi.cs and soapi.js to get a bug triggered by the former?

Right now questions tagged soapi.cs returns a HTTP status code 404 (for various HTTP clients) while questions tagged soapi.js does not. Interestingly though, soapi.cs seems to work just fine in other ...
6
votes
5answers
491 views

Where can I find the reputation black market?

Apparently there is one around, at least I can't explain the recent jump in reputation of 4k for user 1026 by any other means (just kidding of course, no offense please ;) The API Beta badge accounts ...
2
votes
1answer
55 views

Badges with zero count no longer returning zero

For queries such as http://api.{sitename}.com/1.0/users/{id} if a badge count is zero, the API is no longer returning "gold": 0, for example.
4
votes
1answer
67 views

Encoding inconsistency on /users/{id}/reputation

Take these two calls: http://api.stackoverflow.com/1.0/users/180784/reputation?todate=1278854265&pagesize=1 "title": "Save a custom ListView's instance state?", ...
3
votes
1answer
96 views

/users/{id}/associated - inconsistent behavior

/users/{id}/associated occasionally returns empty for an association even though there are definitely associated users. Calling it again immediately returns expected results. GET ...
4
votes
2answers
83 views

/users/{id}/answers - broken

Have not checked other routes, as I am busy with other things, but a failing test pointed this out... GOOD: http://api.stackoverflow.com/1.0/users/242897/answers?min=4&sort=votes { "total": ...
0
votes
1answer
53 views

Bug - Getting partial results for questions

When processing http://api.stackoverflow.com/1.0/questions/1156985 I only get partial results. Many of the missing fields are mandatory fields, including the owner of the question.
3
votes
1answer
68 views

server fault and super user rate limit bonus?

Looks like SF and SU are granting Int.MaxValue rate limit. Not that I mind, but it would be nice to have on the other sites too. ;-) Thought you would like to know. GET /1.0/users/173?key=mykey ...
1
vote
1answer
81 views

api.money.stackexchange.com returning questions from 2009?

http://api.money.stackexchange.com/1.0/questions/?pagesize=1&fromdate=1254960000&todate=1255564793 body => question[0] => [creation_date] => 1254969799 1254969799 == Thu, 08 Oct ...
4
votes
1answer
114 views

questions method returns error 4000

I'm getting error 4000 on every endpoint on questions method (with key): http://api.superuser.com/1.0/questions?sort=votes&pagesize=30&page=1&key=stackprinterkey the only endpoint not ...
2
votes
2answers
129 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
1
vote
2answers
117 views

On Stackauth /sites new meta sites have wrong name

This should be the correct behaviour: name: "Stack Overflow Meta" name: "Web Apps Meta" name: "Gaming Meta" .. For the newcomers Server Fault and Super User, Meta is before the parent site in the ...
3
votes
3answers
157 views

Negative voting questions?

I'm trying to, for humorous purposes, check out some of the worst scoring questions ever on SO. I'm pretty much expecting them to all be "heeeeelp homework" or "plz send me teh codez" or something to ...
5
votes
1answer
120 views

Intermittent bug in the /search route when providing both tagged and nottagged parameters.

I'm getting the wrong number of results back from the /search route depending on what combination of values I provide for the tagged and nottagged parameters. Examples: ...
0
votes
1answer
79 views

stackauth.com/1.0/users/{id}/associated not returning display_name for some sites

The problem with email_hash seems to be fixed, but now display_name is not getting returned in some cases. For example: This Super User /users/{id} query returns a display_name, but the corresponding ...
5
votes
2answers
104 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).
0
votes
1answer
64 views

api.meta.stackoverflow.com has state:normal - is this correct

i am not sure what the origin and exact meaning of the term 'linked_meta' is, but I would guess that it is a term created for area 51 meta sites and the implied meaning is clear. Perhaps stack meta ...
2
votes
1answer
64 views

stackauth is not serving gzip to silverlight3/phone7

I ported all of my integration tests to phone 7, which is a flavor of silverlight 3, and found that stackauth is not forcing gzip as expected. while this simply means that I need to check the first 2 ...
0
votes
1answer
78 views

Where are the new Metas?

According to the most recent blog post, ServerFault and SuperUser each got their own Meta. Shouldn't this be showing up in StackAuth?
2
votes
1answer
79 views

Paging /users by rep is on sites with low user count unpredictable

Resolution Fix confirmed: Tests.SortDupBug Page 1 #100 Total 11066 api.serverfault.com /users?max=2147483647&min=99&page=1&pagesize=100&key=qgAq_KfDu0KYzlNG-qaTuw Page 2 #100 Total 11066 ...
1
vote
1answer
112 views

New Meta sites out of order in /sites

I don't know if this is by design, but the ServerFault and SuperUser Meta sites don't follow their main sites in the response for the sites API route. Having linked_meta sites follow their main ...
3
votes
1answer
404 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
1
vote
1answer
162 views

stackauth throwing 503 (in html format) after just a few /users/{id}/associated requests

After 5-8 successful requests 503 error, in html format, are being thrown. The requests are unique and consecutive, no api abuse is occurring. A related, but critical, concern is that any error ...
1
vote
2answers
34 views

nottagged parameter not documented

It appears that the /questions method still takes the nottagged which specifies a list of tags to exclude questions by but this parameter is not mentioned in the documentation. Is this parameter ...
2
votes
1answer
2k views

Help on help results in HTTP 500 Internal Server Error

A request to http://api.stackoverflow.com/0.8/help?help results in an HTTP 500 with Content-Type: application/json and an HTML body.
2
votes
1answer
58 views

Oddity with migration data from questions

Take a look at this question on SuperUser. Apparently, it was migrated from ServerFault, and was originally asked by user 3d1l. However, now look at the API result: ...
1
vote
1answer
84 views

Problems with the Site Icons

I'm having trouble with the WebApps icon being returned from the /sites method. Namely, the image is composed of a larg white rectangle with a very small guy in the middle. Why can't the guy take ...
1
vote
1answer
105 views

Confusion over my API key

This is directed at the team, since nobody else will be able to help. The key I took out for StackMobile is behaving strangely. I make a few requests, and then the limit resets to 0. (By limit, I'm ...
1
vote
2answers
144 views

errors/{id} documentation : 500 Internal Server Error

On Documentation page, clicking on errors/{id} returns 500 Internal Server Error EDIT: Fixed!
4
votes
2answers
124 views

How far behind is the data returned by calls supposed to be?

I understand that the data sourced to the API are cached, but I'm seeing some fairly extreme discrepancies between reputation reported by the API and apparent activity on the site. For example: ...
6
votes
1answer
66 views

should min/max for alpha-numeric cases be case-insensitive?

I am having a hard time coming up with a use case in which case-sensitive min/max parameters make sense and several solid cases for a case-insensitive min/max. Example: With case insensitive ...
0
votes
1answer
138 views

min/max parameters are incorrectly documented as date - confusion and crippled libraries ensue

I have noticed this on all sorted routes. The min/max say that they are context sensitive to the sort type yet are documented as date. How is a date min/max valid when sorting by, for instance ...
1
vote
1answer
56 views

Pro Webmasters Meta API not working.

Try this: http://api.meta.webmasters.stackexchange.com/0.9/questions?type=jsontext I can't get it to work, even though it's listed in StackAuth.
1
vote
3answers
141 views

API not returning anything near the actual website

The API /questions page is not returning anything like the list of questions on the actual SO site. This is the first question of the 0.8/questions { "total": 705769, "page": 1, "pagesize": ...
3
votes
2answers
120 views

Shouldn't the API help be consistent with the trademark guidance?

The description for the two StackAuth Routes within the API help both contain the phrase StackExchange network - shouldn't this rather be Stack Exchange Network to be consistent with the recently ...
3
votes
2answers
77 views

Inconsistency in sort order

If I execute the following API call: http://api.stackoverflow.com/0.8/questions?sort=newest&body=True&pagesize=5&min=1275575777&order=desc versus one that does not include the min ...
1
vote
1answer
71 views

/users/{id}/tags - broken

looks like touching the id parameter description broke the internet. http://api.stackoverflow.com/0.8/users/242897/tags should/was working 6/1/2010 -1:11AM - working
2
votes
1answer
46 views

pagesize=0 on /search throwing error

http://api.stackapps.com/0.9/search?intitle=a&pagesize=0 { "error": { "code": 4001, "message": "The 'pagesize' query parameter is invalid." } }
2
votes
1answer
132 views

crossdomain.xml and clientaccesspolicy.xml needed on sstatic.net

Silverlight image loading from Uri fails due to lack of xdomain permission files. Needed: http://sstatic.net/clientaccesspolicy.xml http://sstatic.net/crossdomain.xml
0
votes
1answer
45 views

The /questions/{id}/timeline route isn't working.

I'm getting a response code 500 for the /questions/{id}/timeline route. I've tried it in Firefox and by fetching a response in Java. Example URL: ...
1
vote
1answer
60 views

Problem getting a users answers within a date range

This issue is similar to http://stackapps.com/questions/768/problem-getting-a-users-questions-within-a-date-range. Only this time I'm calling a different api and getting unexpected results. I'm ...
3
votes
1answer
57 views

both /revisions methods are spotty

These are the urls for a couple of my valid endpoint tests of the /revisions methods. http://api.stackoverflow.com/0.8/revisions/2688191 (?key=xxx) ...
2
votes
2answers
66 views

Missing on_site in Stack Apps site data in associated_users from stackauth query

This is what I get for Stack Apps: { "display_name": "user", "email_hash": "11aa11...22bb22...", "reputation": 101, "user_id": 0000, "user_type": ...
4
votes
1answer
113 views

StackApps is not being reported by StackAuth

The stackauth.com sites query is not returning stackapps.com at all: http://stackauth.com/0.8/sites?type=jsontext { "api_sites": [ { "name": "Stack Overflow", "logo_url": ...
3
votes
1answer
98 views

Problem getting a users questions within a date range

I'm having a problem returning a list of users questions within a given timespan. I understand that the documentation ( http://api.stackoverflow.com/0.8/help/method?method=users/{id}/questions ) that ...
1
vote
1answer
44 views

/users - fromdate/todate broken

consider: All users on meta : "total": 18923, http://api.meta.stackoverflow.com/0.8/users?sort=creation&order=desc Users created on meta in the last month: "total": 18923, ...
2
votes
1answer
128 views

Why do some Stackauth associated queries fail?

This query fails: http://stackauth.com/0.8/users/137b94e5-050c-4dd5-82c1-aeb2af0814f5/associated In Python for a jason.loads call, I get an error: 'ValueError("No JSON object could be decoded")'. I ...
4
votes
1answer
98 views

http://stackauth.com/0.8/sites down

I realize you may be shaking something out but in case you are not aware: http://stackauth.com/0.8/sites is returning { "api_sites": [] }
0
votes
1answer
36 views

/stats meta data missing

So am I to assume that since we can make an extra call to another site to get meta that site node in stats has been deemed redundant data. If so, I have to suggest a reality break. This is one of ...