Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

2
votes
1answer
29 views

The /users/{id}/timeline route is reporting incorrect totals

It seems that the /users/{id}/timeline route is returning an incorrect total. For example, the following URL is reporting a total of 1607 items: http://api.stackapps.com/1.1/users/7789/timeline ...
2
votes
1answer
23 views

Sort ranges on /questions/unanswered is broken

The following API request should return all unanswered questions with a score of at least 30: http://api.stackapps.com/1.1/questions/unanswered?sort=votes&min=30 However, the response ...
2
votes
1answer
22 views

rep losses aren't reflected in api

This includes rep recalcs (e.g., the latest) and (speculative) when people take upvote back. First case you can see on standard stackauth/users query: it displays meta reputation before recalc. ...
2
votes
1answer
41 views

The 'total' field of /comments result is showing up as 0.

Running the following query: http://api.stackoverflow.com/1.1/comments Yields: { "total": 0, "page": 1, "pagesize": 30, "comments": [ ... Notice that the total entry indicates there are ...
2
votes
1answer
71 views

Why are StackAuth methods not returning rate-limit headers?

Visiting the page: http://stackauth.com/1.1/sites yields the following headers: Notably absent are the X-RateLimit-Max and X-RateLimit-Current headers that show up in API queries to the sites ...
2
votes
1answer
95 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
2
votes
1answer
32 views

/questions/id route problem: comments section is not returned when there aren't comments on question

Something is changed on questions route called with comments= True: http://api.stackoverflow.com/1.0/questions/1940243?body=True&comments=True&pagesize=1&page=1 It does not return the ...
2
votes
1answer
70 views

Suddenly, some entries on /questions route are missing display_name

An odd bug has developed this morning. At the moment, api.stackoverflow.com/1.0/questions is returning a question of the format... ... }, { "tags": [ "jsf-2.0" ], ...
2
votes
1answer
108 views

AskUbuntu API returns wrong colours

Calling the stats method of the AskUbuntu API returns the wrong colours.
2
votes
1answer
69 views

API is completely down? content encoding is broken?

all requests have no content-encoding or have 'gzip,gzip', both of which fail to decompress browser side. note: the content-encoding header, when it is present, does not seem to be included in the ...
2
votes
1answer
64 views

stackauth is not serving gzip to silverlight3/phone7

I ported all of my integration tests to phone 7, which is a flavor of silverlight 3, and found that stackauth is not forcing gzip as expected. while this simply means that I need to check the first 2 ...
2
votes
1answer
58 views

Oddity with migration data from questions

Take a look at this question on SuperUser. Apparently, it was migrated from ServerFault, and was originally asked by user 3d1l. However, now look at the API result: ...
2
votes
1answer
39 views

/answers/{id} summary incorrect

/answers/{id} Gets a set of questions enumerated in id should probably be Gets a set of answers enumerated in id
2
votes
1answer
62 views

Answers parameter not functional

For example the following: http://api.stackoverflow.com/0.8/questions?answers=true doesn't return answers.
2
votes
1answer
80 views

Question sort: change active to activity?

I noticed the sort newest for /questions, /questions/tagged/{tags} and /questions/unanswered was changed to creation recently, making it more consistent with other methods. Could the sort active for ...
2
votes
1answer
66 views

/users/{id}/badges - multiple identical results

Each badge returned in the list of results from /users/{id}/badges already contains an award_count indicating how many times the badge was awarded for the particular user attached to the badge. In ...
2
votes
1answer
147 views

Don't allow requests with No Key to use existing session with valid API Key

Once I did a request with a valid API key http://api.stackoverflow.com/0.8/stats?key=MYKEY Every requests (from that IP) later on without key will use existing session with API key, limit ...
2
votes
1answer
2k views

Help on help results in HTTP 500 Internal Server Error

A request to http://api.stackoverflow.com/0.8/help?help results in an HTTP 500 with Content-Type: application/json and an HTML body.
2
votes
0answers
19 views

Few typos in the documentation pages

https://api.stackexchange.com/docs/vectors When passing a vector, sepeate each id with a semicolon. For example, /users/1;2;3;4;5?site=somesite would fetch users with ids 1 through 5 on somesite. ...
2
votes
0answers
46 views

error description: could not parse proxy url

I have seen the answers to the existing two questions on this topic but it has not helped. And the problem still persists so I am re-posting this question. Here is my code $(function(){ SE.init({ ...
2
votes
0answers
48 views

Login problem on devices pre Windows Phone 8.1 Update 1

I have recently published an app for browsing Stack Exchange websites and a major feedback I received from users was about the inability to use oauth login form while loging into the app. The ...
2
votes
0answers
37 views

/me/inbox is not returning most recent items

Looks like /me/inbox is either a bit behind or it's not supposed to be realtime. Explanation: for a comment that I received 4 hours ago It's not returned in the API: ...
2
votes
0answers
19 views

/answers API request returns no tags if body_markdown is included

This API request to /answers has the filter set to return the tags field for the corresponding question. It works fine: api.stackexchange.com/docs/answers#filter=!9YdnSPElz But, when the filter is ...
2
votes
0answers
17 views

Query Statistics for my app responds with “No Requests” [duplicate]

When I access Query Statistics for my app (while logged in) I get "No Requests" Am I doing something wrong? I'm using Chrome 34 on Ubuntu.
2
votes
0answers
28 views

Sorting and filtering is broken on /questions

Sorting error When querying /questions and sort them by creation in descending order, the creation_date drops very rapidly. I was looking for questions in the [php] tag on Stack Overflow. There are ...
2
votes
0answers
95 views

Invisible text in Markdown syntax help

Some text is invisible in the How to Format help block because of a bad combination of text and background color: That's meant to read ► backtick escapes `like _so_` but the backquoted ...
2
votes
0answers
38 views

SSL handshake error after Stack Overflow back on - anything related to SSL certification changed?

I'm building a Stack Overflow app for BlackBerry10. Earlier today (Feb 16, 2014), Stack Overflow was down and after it came back up my app starts to have this issue. My app works fine when it's in ...
2
votes
0answers
55 views

Why is there a difference between “questions” and “search” in API?

I have a query to find the number of questions tagged java from 2012-08-01 to 2013-08-01. Running this using both /questions and /search produces different results: ...
2
votes
0answers
11 views

Not all sites are returning Hi Res icons

In the /sites method, not all the sites return high_resolution_icon_url field. (e.g. Personal Finance and Money) Although if you add "@2" to the normal resolution icon you can see a high res image ...
2
votes
0answers
30 views

Incorrect link parameter on the “Complex Queries” documentation page

The "Complex Queries" documentation page has this link: Of these three posts on Server Fault, the one with the most recent activity where "the one with the most recent activity" links to ...
2
votes
0answers
126 views

Stack Exchange OAuth2, explicit access-token response format does not adhere to RFC6749 standard

I'm using the Stack Exchange v2.1 API. I'm using the explicit OAuth 2.0 flow, but it seems that the access token response step does not adhere to the RFC 6749 standard. Specifically, the Stack ...
2
votes
0answers
33 views

Why is “body” missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
2
votes
1answer
24 views

View count restriction isn't working for /search/advanced.

I have constructed the following URL, but the questions returned don't contain anywhere near 50k views, despite the query string parameter: ...
2
votes
1answer
56 views

/suggested-edits “Try it”: Link for “suggested_edit_id” is broken

When using the "Try it" feature on /suggested-edits, the link for the suggested_edit_id points towards stackexchange.com and not towards the respective site. For example, retrieve data using the ...
2
votes
1answer
27 views

No answer_id for Comment on answer inbox_item

According to the API documentation on inbox_item, inbox items corresponding to a comment on an answer to a question should have an answer_id field identifying the answer that the comment was on, but ...
2
votes
1answer
33 views

There is a small discrepancy in the docs for users-id-associated

The main doc page, https://api.stackexchange.com/docs, shows /users/{id}/associated while the method page, https://api.stackexchange.com/docs/associated-users, uses /users/{ids}/associated. It's ...
2
votes
1answer
30 views

question_id missing from migration_info for this question.

Consider the following API request: http://api.stackexchange.com/2.0/questions/3064?site=stackapps This question was migrated from Stack Apps to Stack Overflow. However, the migrated_to field is ...
2
votes
0answers
31 views

Secure OAuth pages contain insecure content.

I noticed that some of the OAuth pages use insecure content (http:// content on an https:// page): I'm not sure how easy this is to fix but it could potentially scare off some users who don't ...
2
votes
1answer
98 views

API selectively ignores jsonp parameter - havok ensues

UPDATE: this is happening on all routes now and seems to be getting worse. Whatever it is just started this morning. compare url to json response GET ...
2
votes
1answer
79 views

Paging /users by rep is on sites with low user count unpredictable

Resolution Fix confirmed: Tests.SortDupBug Page 1 #100 Total 11066 api.serverfault.com /users?max=2147483647&min=99&page=1&pagesize=100&key=qgAq_KfDu0KYzlNG-qaTuw Page 2 #100 Total 11066 ...
2
votes
1answer
132 views

crossdomain.xml and clientaccesspolicy.xml needed on sstatic.net

Silverlight image loading from Uri fails due to lack of xdomain permission files. Needed: http://sstatic.net/clientaccesspolicy.xml http://sstatic.net/crossdomain.xml
2
votes
0answers
115 views

StackAuth needs crossdomain.xml and clientaccesspolicy.xml

These would be helpful to have. Absence breaks Silverlight apps. http://stackauth.com/crossdomain.xml http://stackauth.com/clientaccesspolicy.xml http://stackauth.com/0.8/crossdomain.xml ...
2
votes
1answer
49 views

Why does /users/{id}/answers, which returns an array of answers, have an optional 'answers' flag?

I would assume that if you are requesting the route '/users/{id}/answers' that you wish to receive some answers.
2
votes
1answer
77 views

Include range [1, 100] on pagesize

I see that "range" is being used to indicate valid range on most numeric parameters, e.g. 32-bit integer, range [0, 2,147,483,647] 32-bit integer, range [1, 2,147,483,647] The smaller valid range ...
1
vote
2answers
45 views

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API
1
vote
2answers
79 views

Stats not showing the same values as the Site

I get less values in the api method that in the site, is this posible? Example: form the API I get that SO has 709980 questions from site 701005
1
vote
3answers
250 views

Icons of beta sites

Icons of beta sites are different form the icons given in the http://stackauth.com/1.0/sites . As example: Original icon of the English Language and Usage is where http://stackauth.com/1.0/sites ...
1
vote
1answer
68 views

Is Stack Overflow Meta incorrectly configured?

If I call the Auth "sites" API, then it shows Meta Stack Overflow as: "name": "Meta Stack Overflow", "logo_url": "http://sstatic.net/stackoverflowmeta/img/logo.png", "api_endpoint": ...
1
vote
2answers
117 views

On Stackauth /sites new meta sites have wrong name

This should be the correct behaviour: name: "Stack Overflow Meta" name: "Web Apps Meta" name: "Gaming Meta" .. For the newcomers Server Fault and Super User, Meta is before the parent site in the ...
1
vote
1answer
113 views

Last activity date

It would be useful if the API allowed you to return items based on their last activity date. Let's take a question for example. /questions/fromlastactivitydate=XYZ&tolastactivitydate=XYZ All ...