Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

3
votes
2answers
148 views

What happened to nothingtoinstall.com?

This is weird: { "name": "Web Applications", "logo_url": "http://sstatic.net/webapps/img/logo.png", "api_endpoint": "http://api.webapps.stackexchange.com", "site_url": ...
1
vote
3answers
246 views

Icons of beta sites

Icons of beta sites are different form the icons given in the http://stackauth.com/1.0/sites . As example: Original icon of the English Language and Usage is where http://stackauth.com/1.0/sites ...
1
vote
1answer
68 views

question.migrated.to_site null

http://api.stackoverflow.com/1.0/questions/322108?sort=activity&order=desc { "total": 1, "page": 1, "pagesize": 30, "questions": [ { "tags": [ "discussion", ...
5
votes
1answer
83 views

Empty results for associated queries

Queries such as this http://stackauth.com/1.0/users/f5388585-c0b9-417f-99c5-f1a58fda3e83/associated have started giving empty results { "associated_users": [] } Expected results: SiteUrl ...
3
votes
2answers
57 views

Sorting comments by votes doesn't return 0 score comments

I have a query: http://api.stackoverflow.com/1.0/users/16822/comments?sort=votes This doesn't return comments with no votes, setting min to 0 doesn't work. This query includes them all, but isn't ...
1
vote
1answer
97 views

new throttle does not differentiate between api requests and requests made from viewing the site

Update: I am unable to reproduce the case of interactive browsing affecting app quota. And will concede that the failures that prompted this post were likely far edge cases. The remaining issue of a ...
0
votes
1answer
37 views

issues with 'edit_count' field

Update other than the nullable issue, which is under review, the rest of this question is based on a mistake I made reading the nesting depth of the json result. Disregard. Deletion is considered. ...
2
votes
2answers
176 views

Why are 5 IP addresses using my API key?

I have an app that resides on a server. It has only ever accessed the API from 2 IP addresses. The API key has not been shared and there is no client-side code. When I go to /apps however, it says "5 ...
3
votes
3answers
753 views

API usage triggering 503 (Too Many Requests)

Update: I generally try to back any claims of bugs and shortcomings with evidence. I have prepared a test page which you, dear Stack Overflow staff and my fellow developers, can use to ascertain ...
2
votes
1answer
96 views

API selectively ignores jsonp parameter - havok ensues

UPDATE: this is happening on all routes now and seems to be getting worse. Whatever it is just started this morning. compare url to json response GET ...
2
votes
1answer
62 views

API is completely down? content encoding is broken?

all requests have no content-encoding or have 'gzip,gzip', both of which fail to decompress browser side. note: the content-encoding header, when it is present, does not seem to be included in the ...
3
votes
1answer
56 views

key not being recognized by api.meta.stackoverflow.com?

I have been testing a throttle implementation against meta today and suddenly got shut down with a key violation. It is possible that I have used enough requests to prompt this but I doubt it. In ...
4
votes
1answer
828 views

/users/{id}/reputation != xxx.com/reputation

I realize that the shape of the data coming from the API may be different than that reported by the xxx/reputation url, but there seem to be some striking disparities. see 08/12 and 08/11 in both ...
4
votes
0answers
45 views

/tags fromdate and todate does nothing

Altough the help/documentation lists 'todate' and 'fromdate' parameters for tags they do not work. This may be related to tags not having a creation_date. It would be great if we could filter tags by ...
4
votes
1answer
69 views

What's the difference between tags soapi.cs and soapi.js to get a bug triggered by the former?

Right now questions tagged soapi.cs returns a HTTP status code 404 (for various HTTP clients) while questions tagged soapi.js does not. Interestingly though, soapi.cs seems to work just fine in other ...
2
votes
0answers
47 views

/users/{id}/tags - 504 Gateway Timeout

this url is technically valid but generates 504. ...
2
votes
1answer
53 views

Badges with zero count no longer returning zero

For queries such as http://api.{sitename}.com/1.0/users/{id} if a badge count is zero, the API is no longer returning "gold": 0, for example.
6
votes
5answers
483 views

Where can I find the reputation black market?

Apparently there is one around, at least I can't explain the recent jump in reputation of 4k for user 1026 by any other means (just kidding of course, no offense please ;) The API Beta badge accounts ...
4
votes
1answer
67 views

Encoding inconsistency on /users/{id}/reputation

Take these two calls: http://api.stackoverflow.com/1.0/users/180784/reputation?todate=1278854265&pagesize=1 "title": "Save a custom ListView's instance state?", ...
4
votes
2answers
82 views

/users/{id}/answers - broken

Have not checked other routes, as I am busy with other things, but a failing test pointed this out... GOOD: http://api.stackoverflow.com/1.0/users/242897/answers?min=4&sort=votes { "total": ...
0
votes
1answer
53 views

Bug - Getting partial results for questions

When processing http://api.stackoverflow.com/1.0/questions/1156985 I only get partial results. Many of the missing fields are mandatory fields, including the owner of the question.
1
vote
1answer
80 views

api.money.stackexchange.com returning questions from 2009?

http://api.money.stackexchange.com/1.0/questions/?pagesize=1&fromdate=1254960000&todate=1255564793 body => question[0] => [creation_date] => 1254969799 1254969799 == Thu, 08 Oct ...
3
votes
1answer
67 views

server fault and super user rate limit bonus?

Looks like SF and SU are granting Int.MaxValue rate limit. Not that I mind, but it would be nice to have on the other sites too. ;-) Thought you would like to know. GET /1.0/users/173?key=mykey ...
4
votes
1answer
111 views

questions method returns error 4000

I'm getting error 4000 on every endpoint on questions method (with key): http://api.superuser.com/1.0/questions?sort=votes&pagesize=30&page=1&key=stackprinterkey the only endpoint not ...
3
votes
1answer
94 views

/users/{id}/associated - inconsistent behavior

/users/{id}/associated occasionally returns empty for an association even though there are definitely associated users. Calling it again immediately returns expected results. GET ...
0
votes
1answer
77 views

stackauth.com/1.0/users/{id}/associated not returning display_name for some sites

The problem with email_hash seems to be fixed, but now display_name is not getting returned in some cases. For example: This Super User /users/{id} query returns a display_name, but the corresponding ...
5
votes
2answers
97 views

stackauth.com/1.0/users/{id}/associated no longer returning email_hash for some sites

I'm not getting email_hash for some sites from stackauth.com/1.0/users/{id}/associated since sometime after midnight CDT (UTC-0500).
1
vote
2answers
117 views

On Stackauth /sites new meta sites have wrong name

This should be the correct behaviour: name: "Stack Overflow Meta" name: "Web Apps Meta" name: "Gaming Meta" .. For the newcomers Server Fault and Super User, Meta is before the parent site in the ...
0
votes
1answer
63 views

api.meta.stackoverflow.com has state:normal - is this correct

i am not sure what the origin and exact meaning of the term 'linked_meta' is, but I would guess that it is a term created for area 51 meta sites and the implied meaning is clear. Perhaps stack meta ...
2
votes
1answer
64 views

stackauth is not serving gzip to silverlight3/phone7

I ported all of my integration tests to phone 7, which is a flavor of silverlight 3, and found that stackauth is not forcing gzip as expected. while this simply means that I need to check the first 2 ...
0
votes
1answer
75 views

Where are the new Metas?

According to the most recent blog post, ServerFault and SuperUser each got their own Meta. Shouldn't this be showing up in StackAuth?
1
vote
1answer
109 views

New Meta sites out of order in /sites

I don't know if this is by design, but the ServerFault and SuperUser Meta sites don't follow their main sites in the response for the sites API route. Having linked_meta sites follow their main ...
2
votes
1answer
79 views

Paging /users by rep is on sites with low user count unpredictable

Resolution Fix confirmed: Tests.SortDupBug Page 1 #100 Total 11066 api.serverfault.com /users?max=2147483647&min=99&page=1&pagesize=100&key=qgAq_KfDu0KYzlNG-qaTuw Page 2 #100 Total 11066 ...
1
vote
2answers
33 views

nottagged parameter not documented

It appears that the /questions method still takes the nottagged which specifies a list of tags to exclude questions by but this parameter is not mentioned in the documentation. Is this parameter ...
2
votes
1answer
58 views

Oddity with migration data from questions

Take a look at this question on SuperUser. Apparently, it was migrated from ServerFault, and was originally asked by user 3d1l. However, now look at the API result: ...
1
vote
1answer
100 views

Confusion over my API key

This is directed at the team, since nobody else will be able to help. The key I took out for StackMobile is behaving strangely. I make a few requests, and then the limit resets to 0. (By limit, I'm ...
3
votes
1answer
338 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
1
vote
1answer
137 views

Game developer's logo isn't working.

See here: http://stackmobile.com/ - towards the bottom Neither the main logo, nor the meta logo is workin.
5
votes
1answer
64 views

should min/max for alpha-numeric cases be case-insensitive?

I am having a hard time coming up with a use case in which case-sensitive min/max parameters make sense and several solid cases for a case-insensitive min/max. Example: With case insensitive ...
1
vote
1answer
56 views

Pro Webmasters Meta API not working.

Try this: http://api.meta.webmasters.stackexchange.com/0.9/questions?type=jsontext I can't get it to work, even though it's listed in StackAuth.
1
vote
1answer
154 views

stackauth throwing 503 (in html format) after just a few /users/{id}/associated requests

After 5-8 successful requests 503 error, in html format, are being thrown. The requests are unique and consecutive, no api abuse is occurring. A related, but critical, concern is that any error ...
1
vote
1answer
82 views

Problems with the Site Icons

I'm having trouble with the WebApps icon being returned from the /sites method. Namely, the image is composed of a larg white rectangle with a very small guy in the middle. Why can't the guy take ...
4
votes
2answers
124 views

How far behind is the data returned by calls supposed to be?

I understand that the data sourced to the API are cached, but I'm seeing some fairly extreme discrepancies between reputation reported by the API and apparent activity on the site. For example: ...
3
votes
2answers
119 views

Shouldn't the API help be consistent with the trademark guidance?

The description for the two StackAuth Routes within the API help both contain the phrase StackExchange network - shouldn't this rather be Stack Exchange Network to be consistent with the recently ...
2
votes
2answers
128 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
5
votes
1answer
116 views

Site in closed beta but api working

Hello, Webapps has been added yesterday, website is in closed beta and it's not possible to see something on the website when you are not logged. But if you use the API you can get information. ...
5
votes
1answer
120 views

Intermittent bug in the /search route when providing both tagged and nottagged parameters.

I'm getting the wrong number of results back from the /search route depending on what combination of values I provide for the tagged and nottagged parameters. Examples: ...
2
votes
1answer
45 views

pagesize=0 on /search throwing error

http://api.stackapps.com/0.9/search?intitle=a&pagesize=0 { "error": { "code": 4001, "message": "The 'pagesize' query parameter is invalid." } }
1
vote
1answer
81 views

/questions/{id}/timeline throwing 500 instead of 404

Kevin, you fixed this bug some time ago, would you like to tag it as status-complete? Sometime last week, this route stopped throwing 404 like the rest of my 'bad id' tests and started throwing 500. ...
0
votes
1answer
44 views

The /questions/{id}/timeline route isn't working.

I'm getting a response code 500 for the /questions/{id}/timeline route. I've tried it in Firefox and by fetching a response in Java. Example URL: ...