Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

2
votes
1answer
26 views

/answers endpoint is error-500-ing against many sites

Just calling the "/answers" endpoint, no specific arguments, and I'm getting 500 errors: http://api.stackexchange.com/2.0/answers?order=desc&sort=activity&site=gaming ...
2
votes
1answer
47 views

Mistake in API 2.0 Documentation - Wrong item type for Careers Message

On https://api.stackexchange.com/docs/types/inbox-item the Careers Message example shows the wrong item type.
2
votes
1answer
30 views

/users/{id}/tags/{tags}/top-answers returning answers by other users

According to the description, /users/{id}/tags/{tags}/top-answers should return answers by the user on that particular tag. Returns the top 30 answers a user has posted in response to questions ...
2
votes
1answer
29 views

Answer vote counts are not correct

I was trying to figure out the total number of answers I have that have been downvoted, and at first everything seemed awesome since the total was zero. However, I knew this wasn't correct. For ...
2
votes
1answer
17 views

link attribute is missing from questions in /tags/{tags}/faq

Check the following requests, the link attribute is missing from questions objects in responses. I checked with the default filter and also with custom filters (both safe and unsafe). ...
2
votes
1answer
61 views

Update the default filter editor to use the API key

When I run a sample query using the SE API browser (is that right term?), say against /questions for example (here), I'll always see something to the effect of: ... "quota_remaining": 9424, ...
2
votes
1answer
13 views

type related_site not listed in 'by type' tab list

The type "related_site" is not listed in the 'by type' tab in documentation.
2
votes
1answer
61 views

TLS security warnings from api.stackexchange.com

Each time an API request is made over HTTPS, Firefox generates the following message in the error console: Curious, I looked up RFC 5746 and the document covers the following: Transport Layer ...
2
votes
1answer
18 views

Minor spello/typo on the “Complex Queries” documentation page

The documentation page Complex Queries has a minor typo or spello: The ?filter=total build-in filter is provided for just this purpose. Should instead be: The ?filter=total built-in ...
2
votes
1answer
41 views

The 'total' field of /comments result is showing up as 0.

Running the following query: http://api.stackoverflow.com/1.1/comments Yields: { "total": 0, "page": 1, "pagesize": 30, "comments": [ ... Notice that the total entry indicates there are ...
2
votes
1answer
71 views

Why are StackAuth methods not returning rate-limit headers?

Visiting the page: http://stackauth.com/1.1/sites yields the following headers: Notably absent are the X-RateLimit-Max and X-RateLimit-Current headers that show up in API queries to the sites ...
2
votes
1answer
94 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
2
votes
1answer
30 views

/questions/id route problem: comments section is not returned when there aren't comments on question

Something is changed on questions route called with comments= True: http://api.stackoverflow.com/1.0/questions/1940243?body=True&comments=True&pagesize=1&page=1 It does not return the ...
2
votes
1answer
67 views

Suddenly, some entries on /questions route are missing display_name

An odd bug has developed this morning. At the moment, api.stackoverflow.com/1.0/questions is returning a question of the format... ... }, { "tags": [ "jsf-2.0" ], ...
2
votes
1answer
108 views

AskUbuntu API returns wrong colours

Calling the stats method of the AskUbuntu API returns the wrong colours.
2
votes
1answer
66 views

API is completely down? content encoding is broken?

all requests have no content-encoding or have 'gzip,gzip', both of which fail to decompress browser side. note: the content-encoding header, when it is present, does not seem to be included in the ...
2
votes
1answer
53 views

Badges with zero count no longer returning zero

For queries such as http://api.{sitename}.com/1.0/users/{id} if a badge count is zero, the API is no longer returning "gold": 0, for example.
2
votes
1answer
64 views

stackauth is not serving gzip to silverlight3/phone7

I ported all of my integration tests to phone 7, which is a flavor of silverlight 3, and found that stackauth is not forcing gzip as expected. while this simply means that I need to check the first 2 ...
2
votes
1answer
58 views

Oddity with migration data from questions

Take a look at this question on SuperUser. Apparently, it was migrated from ServerFault, and was originally asked by user 3d1l. However, now look at the API result: ...
2
votes
1answer
39 views

/answers/{id} summary incorrect

/answers/{id} Gets a set of questions enumerated in id should probably be Gets a set of answers enumerated in id
2
votes
1answer
59 views

Answers parameter not functional

For example the following: http://api.stackoverflow.com/0.8/questions?answers=true doesn't return answers.
2
votes
1answer
76 views

Question sort: change active to activity?

I noticed the sort newest for /questions, /questions/tagged/{tags} and /questions/unanswered was changed to creation recently, making it more consistent with other methods. Could the sort active for ...
2
votes
1answer
59 views

/users/{id}/badges - multiple identical results

Each badge returned in the list of results from /users/{id}/badges already contains an award_count indicating how many times the badge was awarded for the particular user attached to the badge. In ...
2
votes
1answer
143 views

Don't allow requests with No Key to use existing session with valid API Key

Once I did a request with a valid API key http://api.stackoverflow.com/0.8/stats?key=MYKEY Every requests (from that IP) later on without key will use existing session with API key, limit ...
2
votes
1answer
2k views

Help on help results in HTTP 500 Internal Server Error

A request to http://api.stackoverflow.com/0.8/help?help results in an HTTP 500 with Content-Type: application/json and an HTML body.
2
votes
0answers
12 views

Query Statistics for my app responds with “No Requests” [duplicate]

When I access Query Statistics for my app (while logged in) I get "No Requests" Am I doing something wrong? I'm using Chrome 34 on Ubuntu.
2
votes
0answers
13 views

Sorting and filtering is broken on /questions

Sorting error When querying /questions and sort them by creation in descending order, the creation_date drops very rapidly. I was looking for questions in the [php] tag on Stack Overflow. There are ...
2
votes
0answers
23 views

Descriptions of tag-based badges are incorrect

The descriptions associated to tag-based badges are wrong, they always show 0 instead of actual thresholds: Earned at least 0 total score for at least 0 non-community wiki answers in the … tag ...
2
votes
0answers
31 views

Invisible text in Markdown syntax help

Some text is invisible in the How to Format help block because of a bad combination of text and background color: That's meant to read ► backtick escapes `like _so_` but the backquoted ...
2
votes
0answers
33 views

SSL handshake error after Stack Overflow back on - anything related to SSL certification changed?

I'm building a Stack Overflow app for BlackBerry10. Earlier today (Feb 16, 2014), Stack Overflow was down and after it came back up my app starts to have this issue. My app works fine when it's in ...
2
votes
0answers
11 views

Not all sites are returning Hi Res icons

In the /sites method, not all the sites return high_resolution_icon_url field. (e.g. Personal Finance and Money) Although if you add "@2" to the normal resolution icon you can see a high res image ...
2
votes
0answers
38 views

Implicit OAuth Flow stopped working. Redirect happening to a non existent URL

The following URL is first hit when a user clicks on Login: ...
2
votes
0answers
28 views

Incorrect link parameter on the “Complex Queries” documentation page

The "Complex Queries" documentation page has this link: Of these three posts on Server Fault, the one with the most recent activity where "the one with the most recent activity" links to ...
2
votes
0answers
23 views

Why is “body” missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
2
votes
1answer
22 views

View count restriction isn't working for /search/advanced.

I have constructed the following URL, but the questions returned don't contain anywhere near 50k views, despite the query string parameter: ...
2
votes
0answers
39 views

Stack Apps “Welcome Back” banner text isn't centered

This appear to be specific to Stack Apps. The text is centered on every other site I've tried. See below: Compared to how it should appear:
2
votes
1answer
46 views

/suggested-edits “Try it”: Link for “suggested_edit_id” is broken

When using the "Try it" feature on /suggested-edits, the link for the suggested_edit_id points towards stackexchange.com and not towards the respective site. For example, retrieve data using the ...
2
votes
1answer
682 views

OAuth redirect not completing

This is the URL that I'm entering (in Safari, cleared website data and cache; my app, uses own Cookie jar; and incognito chrome) ...
2
votes
1answer
32 views

There is a small discrepancy in the docs for users-id-associated

The main doc page, https://api.stackexchange.com/docs, shows /users/{id}/associated while the method page, https://api.stackexchange.com/docs/associated-users, uses /users/{ids}/associated. It's ...
2
votes
1answer
30 views

question_id missing from migration_info for this question.

Consider the following API request: http://api.stackexchange.com/2.0/questions/3064?site=stackapps This question was migrated from Stack Apps to Stack Overflow. However, the migrated_to field is ...
2
votes
0answers
28 views

Secure OAuth pages contain insecure content.

I noticed that some of the OAuth pages use insecure content (http:// content on an https:// page): I'm not sure how easy this is to fix but it could potentially scare off some users who don't ...
2
votes
1answer
40 views

Documentation has broken link (JSONP)

On Wikipedia, JSONP now has its own article, instead of being part of the JSON article. The documentation links JSONP to Wikpedia:JSON#JSONP. It should link to Wikipedia:JSONP.
2
votes
1answer
96 views

API selectively ignores jsonp parameter - havok ensues

UPDATE: this is happening on all routes now and seems to be getting worse. Whatever it is just started this morning. compare url to json response GET ...
2
votes
0answers
47 views

/users/{id}/tags - 504 Gateway Timeout

this url is technically valid but generates 504. ...
2
votes
1answer
79 views

Paging /users by rep is on sites with low user count unpredictable

Resolution Fix confirmed: Tests.SortDupBug Page 1 #100 Total 11066 api.serverfault.com /users?max=2147483647&min=99&page=1&pagesize=100&key=qgAq_KfDu0KYzlNG-qaTuw Page 2 #100 Total 11066 ...
2
votes
1answer
46 views

pagesize=0 on /search throwing error

http://api.stackapps.com/0.9/search?intitle=a&pagesize=0 { "error": { "code": 4001, "message": "The 'pagesize' query parameter is invalid." } }
2
votes
1answer
129 views

crossdomain.xml and clientaccesspolicy.xml needed on sstatic.net

Silverlight image loading from Uri fails due to lack of xdomain permission files. Needed: http://sstatic.net/clientaccesspolicy.xml http://sstatic.net/crossdomain.xml
2
votes
0answers
112 views

StackAuth needs crossdomain.xml and clientaccesspolicy.xml

These would be helpful to have. Absence breaks Silverlight apps. http://stackauth.com/crossdomain.xml http://stackauth.com/clientaccesspolicy.xml http://stackauth.com/0.8/crossdomain.xml ...
2
votes
1answer
49 views

Why does /users/{id}/answers, which returns an array of answers, have an optional 'answers' flag?

I would assume that if you are requesting the route '/users/{id}/answers' that you wish to receive some answers.
2
votes
1answer
75 views

Include range [1, 100] on pagesize

I see that "range" is being used to indicate valid range on most numeric parameters, e.g. 32-bit integer, range [0, 2,147,483,647] 32-bit integer, range [1, 2,147,483,647] The smaller valid range ...