Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

2
votes
1answer
37 views

Invalid HTML characters in questions bodies

While writing an Android App that shows questions from the SE network, I've noticed that the SE REST API returns invalid HTML characters; after a bit more of researching I've found it's not the API ...
2
votes
1answer
77 views

the stack exchange javascript library is 404

the library listed on the doc page for Authentication https://api.stackexchange.com/js/2.0/all.js ultimately redirects to https://api-v2cdn.sstatic.net/js/all.js which results in varying degrees ...
2
votes
1answer
136 views

Reputation query doesn't match that on SO

This morning, at 2011-04-06 00:22:38Z, I received a question upvote for this question. That shows up as giving me 5 reputation when looking at the Stack Overflow reputation page. However, when I use ...
2
votes
2answers
66 views

Missing on_site in Stack Apps site data in associated_users from stackauth query

This is what I get for Stack Apps: { "display_name": "user", "email_hash": "11aa11...22bb22...", "reputation": 101, "user_id": 0000, "user_type": "...
2
votes
2answers
679 views

Server has stopped obeying Accept-encoding header

Either today or yesterday, besides /questions/tagged having disappeared, the server started ignoring the Accept-encoding header: Ligação estabelecida com 69.59.196.211 na porta 80 GET /0.8/questions/...
2
votes
3answers
138 views

display_name isn't always there (should have OpenID name if needed)

usually in the owner dictionary there is a display_name value to give the username. But in a few questions it simply doesn't exist and I can't see why only those questions: eg, this excerpt from the 0....
2
votes
1answer
34 views

Can API stats return real revision number instead of 1234.5678?

Currently it returns like this "revision": "1.0.1234.5678" And looks like that number never changed. So, Can API return real revision number whenever there is an update? It will be very useful ...
2
votes
1answer
154 views

Make www a subdomain.

Try going to http://www.stackapps.com Apparently www is not a subdomain of stackapps.com Anyone who tries to get to the site by prepending the www will be confused, as it is standard to point that ...
2
votes
1answer
44 views

link in post_id in /me/notifications/unread is wrong

I have run /me/notifications/unread. The response contains post_id and there is a link to it. This link is wrong. The post is on Stack Apps but the link directs to Stack Overflow: I have ...
2
votes
1answer
65 views

Difference between `/inbox/unread` & `/me/inbox/unread`

I ran /inbox/unread & /me/inbox/unread. What is the difference between the two? Also, the site parameter which we give in call to /me/inbox/unread is not required as inbox_item refers to global ...
2
votes
1answer
48 views

Stack Exchange API is returning non-existant/incorrect notices for questions

When you view this question you do not see any notices other than the protected notice at bottom. Also, you are able to edit the answers and question (provided you have the privilege). However, when ...
2
votes
1answer
34 views

Error retrieving question using a filter that includes question.notice

I have created a filter to include the question.notice field. It seems to be OK as returned by https://api.stackexchange.com/2.1/filters/-9xc1l%2Au-JEsf_Q Then if I want to fetch this question using ...
2
votes
1answer
36 views

Advanced search by title doesn't filter on the title

Searching by title on the advanced search method doesn't restrict the results to posts containing the specified text as a word or even substring. Varying the string has some influence, but I can't ...
2
votes
1answer
43 views

Does /invalidate work for no-expiry tokens?

It seems that tokens created with no_expiry scope are immune to requests to invalidate them with /access-tokens/.../invalidate. Is this by design or by bug?
2
votes
1answer
34 views

Events: field request

The "Event" object doesn't have an easy way for getting at the object relating to the event. There's a link field, but I don't fancy having to parse the information out of that (although I could). ...
2
votes
1answer
17 views

The “/tags/{tags}/wikis” API does not return the proffered “body_last_edit_date” or “excerpt_last_edit_date” fields

The API for /tags/{tags}/wikis offers body_last_edit_date and excerpt_last_edit_date fields. Both are selected in the default filter. But neither are actually returned even for tags I'm 100% sure ...
2
votes
1answer
29 views

Minor spello/typo on the “Complex Queries” documentation page

The documentation page Complex Queries has a minor typo or spello: The ?filter=total build-in filter is provided for just this purpose. Should instead be: The ?filter=total built-in ...
2
votes
1answer
23 views

Guid inconsistency in 2.0?

question timeline returns "revision_guid": "335659EE-8983-4BEC-BACC-CC95784A4465" revisions by guid return "revision_guid": "335659ee89834becbacccc95784a4465" Is there any particular reason for ...
2
votes
1answer
41 views

/comments?fromdate is broken?

The following url should return 0 comments: http://api.stackoverflow.com/1.1/comments?fromdate=9999999999 Instead it returns all comments, not actually filtering by fromdate at all. It happens ...
2
votes
1answer
28 views

Error occurs when retrieving timeline for this question

Here is the question: http://meta.stackoverflow.com/questions/51812/the-api-sandbox Here is the API URL: http://api.meta.stackoverflow.com/1.1/questions/51812/timeline?pagesize=100?page=2 Here is ...
2
votes
1answer
27 views

nottagged only works when tagged is set (/search)

On the /search route, the nottagged parameter doesn't work properly (at least it isn't specially documented to only work at certain times) For example: http://api.stackoverflow.com/1.1/search?pagesize=...
2
votes
1answer
56 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
2
votes
1answer
90 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } Renewing the ...
2
votes
1answer
41 views

The associated accounts are broken once again for this same user

As I reported before (and which was fixed) and again (which was also fixed), the associated accounts are broken once again for for Joel Coehoorn using this query. What's the deal?
2
votes
1answer
70 views

/questions/{id}/answers missing title attribute

http://api.stackoverflow.com/1.0/help/method?method=questions/{id}/answers (it won't linkify properly!): "title": { "description": "title of this post, in plaintext", "values": "string", "...
2
votes
1answer
180 views

Why are 5 IP addresses using my API key?

I have an app that resides on a server. It has only ever accessed the API from 2 IP addresses. The API key has not been shared and there is no client-side code. When I go to /apps however, it says "5 ...
2
votes
1answer
85 views

Problems with the Site Icons

I'm having trouble with the WebApps icon being returned from the /sites method. Namely, the image is composed of a larg white rectangle with a very small guy in the middle. Why can't the guy take ...
2
votes
2answers
130 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
2
votes
1answer
84 views

/questions/{id}/timeline throwing 500 instead of 404

Kevin, you fixed this bug some time ago, would you like to tag it as status-complete? Sometime last week, this route stopped throwing 404 like the rest of my 'bad id' tests and started throwing 500. ...
2
votes
1answer
64 views

Problem getting a users answers within a date range

This issue is similar to http://stackapps.com/questions/768/problem-getting-a-users-questions-within-a-date-range. Only this time I'm calling a different api and getting unexpected results. I'm ...
2
votes
1answer
132 views

Why do some Stackauth associated queries fail?

This query fails: http://stackauth.com/0.8/users/137b94e5-050c-4dd5-82c1-aeb2af0814f5/associated In Python for a jason.loads call, I get an error: 'ValueError("No JSON object could be decoded")'. I ...
2
votes
2answers
68 views

Order parameter not functional

Consider these two API calls: http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=desc http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=asc ...
2
votes
2answers
92 views

Why my /mentioned page return 404?

http://api.stackoverflow.com/0.8/users/213464/mentioned?type=jsontext { "error": { "code": 404, "message": "The server has not found anything matching the Request-URI." } } Its ...
2
votes
1answer
57 views

The users/{id}/timeline method is returning an extra result.

The users/{id}/timeline method is returning 31 results by default, and one more result than specified by the pagesize parameter. Example: http://api.stackoverflow.com/0.8/users/1288/timeline?pagesize=...
2
votes
1answer
48 views

Revision help URL contains wrong header

There are two revision urls listed on the help page but they both seem to contain the same detailed information. The header for the non-guid version contains the url for the one that takes a guid. ...
2
votes
1answer
51 views

questions/{id} help page sort parameter description is inconsistence with others

The description of the Sort parameter in questions/{id} help page is inconsistent with those of other pages. On the questions/{id} help page: sort (optional): How a collection should ...
2
votes
1answer
84 views

Why is the API giving a different response for preview true/false with POST requests?

Update This expression will evaluate to show the cause. The only requirement is an emacs with url. As you can see, the result from using curl and that from using the url package is different. ...
2
votes
1answer
73 views

API returns the last activity date even if asked not to

Using the /questions method, I tried to get upvote and downvote counts, along with question Ids. This is the request I sent: http://api.stackexchange.com/2.2/questions/857455%3B857454?site=math&...
2
votes
1answer
74 views

Advanced search API not returning data for “phonegap” tag

I am trying to gather results from the API for the tag phonegap but the API is not returning any data. I am using /search/advanced and get nothing back for November: { "items": [], "...
2
votes
1answer
117 views

V2.1 API body HTML has unclosed li tags

The Stack Exchange API (with a safe filter) is returning question body content with malformed HTML, specifically <li> elements that do not have closing tags (and no valid parent). I've seen ...
2
votes
1answer
36 views

Default listing images aren't served from CDN, fail to load because of certificate error

The default images used on the app/script/library pages aren't pointing to the CDN, so their use of HTTPS causes a certificate error that prevents the image from loading: Could the image sources be ...
2
votes
1answer
63 views

Stack Apps graph time filters make pretty much no sense

When viewing the Query Statistics graphs for an application, you have the option of choosing 'Week', 'Month', 'Year', or 'All Time'. When hovering over 'week' it states "view stats for the last 7 ...
2
votes
1answer
45 views

/answers endpoint is error-500-ing against many sites

Just calling the "/answers" endpoint, no specific arguments, and I'm getting 500 errors: http://api.stackexchange.com/2.0/answers?order=desc&sort=activity&site=gaming {"error_id":500,"...
2
votes
1answer
48 views

Mistake in API 2.0 Documentation - Wrong item type for Careers Message

On https://api.stackexchange.com/docs/types/inbox-item the Careers Message example shows the wrong item type.
2
votes
1answer
30 views

/users/{id}/tags/{tags}/top-answers returning answers by other users

According to the description, /users/{id}/tags/{tags}/top-answers should return answers by the user on that particular tag. Returns the top 30 answers a user has posted in response to questions ...
2
votes
1answer
22 views

Why doesn't the API return suggested edits on tag wikis?

Is there a reason why the API doesn't return suggested edits on tag wikis on the suggested-edits route?
2
votes
1answer
16 views

Dead link in documentation

On the docs for question timelines the link for "Question" points to /docs/type/question when it should point to /docs/types/question
2
votes
1answer
31 views

Answer vote counts are not correct

I was trying to figure out the total number of answers I have that have been downvoted, and at first everything seemed awesome since the total was zero. However, I knew this wasn't correct. For ...
2
votes
1answer
17 views

link attribute is missing from questions in /tags/{tags}/faq

Check the following requests, the link attribute is missing from questions objects in responses. I checked with the default filter and also with custom filters (both safe and unsafe). https://api....
2
votes
1answer
13 views

type related_site not listed in 'by type' tab list

The type "related_site" is not listed in the 'by type' tab in documentation.