Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

4
votes
1answer
131 views

Certain users aren't showing up in /users when filter is applied

NB: The filter parameter in v1.x of the API had a different meaning to the filter parameter in v2.0 Consider the following query: http://api.stackoverflow.com/1.1/users?filter=jon%20skeet ...
2
votes
1answer
40 views

Documentation has broken link (JSONP)

On Wikipedia, JSONP now has its own article, instead of being part of the JSON article. The documentation links JSONP to Wikpedia:JSON#JSONP. It should link to Wikipedia:JSONP.
2
votes
1answer
38 views

/comments?fromdate is broken?

The following url should return 0 comments: http://api.stackoverflow.com/1.1/comments?fromdate=9999999999 Instead it returns all comments, not actually filtering by fromdate at all. It happens ...
1
vote
1answer
36 views

/stats is broken on OnStartups

The following URL is returning an object that is missing some data: http://api.onstartups.stackexchange.com/1.1/stats The entire site object is missing from the returned data. Other sites, such ...
1
vote
1answer
26 views

The /users/{id}/timeline route is reporting incorrect totals

It seems that the /users/{id}/timeline route is returning an incorrect total. For example, the following URL is reporting a total of 1607 items: http://api.stackapps.com/1.1/users/7789/timeline ...
1
vote
1answer
19 views

Sort ranges on /questions/unanswered is broken

The following API request should return all unanswered questions with a score of at least 30: http://api.stackapps.com/1.1/questions/unanswered?sort=votes&min=30 However, the response ...
0
votes
1answer
19 views

questions/{id} API not working as intended for vectorized id

Show Console > Try it > Call Method button on questions/{id} API page is not working properly for vectorized id ie. when I am passing 7282205 it is working fine, but when I am passing- 7282205; ...
2
votes
1answer
44 views

What happened to the unique users count?

When visiting http://stackapps.com/apps, I used to be able to see how many unique users were using my application - but now all I see is zeroes for all of the apps. Were the numbers reset or is this ...
1
vote
0answers
40 views

Wrong API response?

Well, if you look here, you'll see i have "down_vote_count": 94, But if you look here on my Stackoverflow profile, you see that my down vote count is 64. For those who would ask if I'm sure ...
1
vote
1answer
69 views

Incorrect Wordpress and Electronics icons

Currently Meta Icon Currently Main Icon With all the other sites (except electronics, which has the same icon for both), Meta has the B&W or sepia icon, while the main site's icon is coloured. ...
1
vote
1answer
70 views

stack applet not getting sign in

I am facing problem during running of Stack Applet. How can I sign in? Moreover when I click on presences it comes up with localhost error . Here is the picture As it can be seen, the Applet is ...
3
votes
1answer
74 views

How do you retrieve list of users sorted by reputation?

I am failing in my attempt to retrieve results sorted by reputation. For example, the following query sorts the results by ID. Is there an error in the URI? ...
1
vote
1answer
26 views

Error occurs when retrieving timeline for this question

Here is the question: http://meta.stackoverflow.com/questions/51812/the-api-sandbox Here is the API URL: http://api.meta.stackoverflow.com/1.1/questions/51812/timeline?pagesize=100?page=2 Here is ...
1
vote
0answers
31 views

API does not return stackoverflow user_id?

When I visit http://stackauth.com/1.1/users/aa1073f7-7e3b-4d4d-ace5-f2fca853f998/associated it returns my user_id on many stackexchange sites, but not stackoverflow itself! I'm sure this is by ...
1
vote
1answer
34 views

/questions/{id}/linked is failing for this question on ServerFault.

This route is reporting an error: http://api.serverfault.com/1.1/questions/45734/linked Incidentally, I discovered this error thanks to my handy tool StackStatus, which runs a status check on the ...
4
votes
1answer
37 views

API usage “Try It” form for linked questions queries meta.tex.stackexchange instead of Stackoverflow

I was wondering why the form at http://api.stackoverflow.com/1.1/usage/methods/linked-questions did not return the questions I was expecting. Then I noticed that it is calling ...
1
vote
1answer
24 views

nottagged only works when tagged is set (/search)

On the /search route, the nottagged parameter doesn't work properly (at least it isn't specially documented to only work at certain times) For example: ...
0
votes
2answers
39 views

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API
1
vote
1answer
121 views

Reputation query doesn't match that on SO

This morning, at 2011-04-06 00:22:38Z, I received a question upvote for this question. That shows up as giving me 5 reputation when looking at the Stack Overflow reputation page. However, when I use ...
1
vote
1answer
21 views

rep losses aren't reflected in api

This includes rep recalcs (e.g., the latest) and (speculative) when people take upvote back. First case you can see on standard stackauth/users query: it displays meta reputation before recalc. ...
2
votes
1answer
49 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
0
votes
1answer
18k views

sorting ascending vs descending

I don't understand the difference between ascending and descending? Surely ascending means the most active/recent/popular/A first, and descending means the least active/recent/popular/Z first? But it ...
1
vote
1answer
43 views

StackAuth 1.1 API reports a site without a site_name

Calling the StackAuth 1.1 API associated method for a particular user returns one site with no site_name property (the one for which the user_id is 349). I cannot find a matching account in ...
0
votes
1answer
38 views

Mismatch between user_id as reported in StackAuth 1.1 (invalid) and 1.0 (valid)

For the association id 1de2e2b0-2fb6-4db6-b90d-d0244ed5d13a, the StackAuth 1.1 call returns an invalid user_id of 73203 for Server Fault whereas the StackAuth 1.0 call returns the correct user_id of ...
2
votes
1answer
89 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } Renewing the ...
1
vote
0answers
29 views

What has happened to the revision history of this answer?

This is rather odd. Consider this answer. The current content of the answer according to http://api.meta.stackoverflow.com/1.1/answers/81451?body=true is: ...<img ...
1
vote
0answers
19 views

“Special” required tag listings only show single required tag

When you're viewing questions tagged with one of app,script,library, you get the special formatting view with the thumbnail on the left. On pages where this view is displayed, only one of these tags ...
3
votes
1answer
63 views

API search page size limit mismatch

The 1.1 API help text for search says that the pagesize parameter can go up to 100. Indeed, passing a value up to 100 returns some results, while passing pagesize=101 yields an HTTP 400 status (Bad ...
0
votes
1answer
61 views

API console always queries Stack Overflow

On any Stack Exchange site (well, I tried Super User (trilogy), Unix (SE-2.0 launched) and SFF (SE-2.0 beta)), the console (“Show Console” button) in the 1.1 API queries ...
2
votes
1answer
54 views

Comments in user timeline are returning Markdown

In users/{id}/timeline, the detail field for comment events is formatted with Markdown and not HTML. Is it normal? I saw in the question Comments are returning markdown that the API should return ...
2
votes
1answer
38 views

The associated accounts are broken once again for this same user

As I reported before (and which was fixed) and again (which was also fixed), the associated accounts are broken once again for for Joel Coehoorn using this query. What's the deal?
4
votes
1answer
169 views

API ignores jsonp callback after initial request - erroneous caching?

This bug is still prevalent, appears to be cache related. Two identical requests return different data: first request respects jsonp query parameter, all subsequent requests ignore it until (I ...
1
vote
1answer
47 views

The /questions/{id}/linked method is returning extra questions.

Consider the following question on ServerFault: http://serverfault.com/questions/45734/the-coolest-server-names Linked questions: Note that there's only two listed. However, querying: ...
2
votes
1answer
41 views

The 'total' field of /comments result is showing up as 0.

Running the following query: http://api.stackoverflow.com/1.1/comments Yields: { "total": 0, "page": 1, "pagesize": 30, "comments": [ ... Notice that the total entry indicates there are ...
1
vote
1answer
61 views

The /top-answer-tags method is not working.

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
2
votes
1answer
71 views

Why are StackAuth methods not returning rate-limit headers?

Visiting the page: http://stackauth.com/1.1/sites yields the following headers: Notably absent are the X-RateLimit-Max and X-RateLimit-Current headers that show up in API queries to the sites ...
3
votes
1answer
61 views

What happened to the /stats method?

I can't find the /stats method in the new usage documentation. A quick run of http://api.stackoverflow.com/1.1/stats reveals that the method is still there. However, it is not documented.
1
vote
1answer
32 views

fromdate is ignored for /posts/{id}/comments requests

The api docs: http://api.stackoverflow.com/1.0/help/method?method=posts/{id}/comments The test request. You can see comment itself here, it's four months old, while cutoff date in request is less ...
5
votes
0answers
61 views

Requesting favorite questions should report which users have favorited it

I can request the favorite questions of a user via the users/{id}/favorites endpoint. If I'm only requesting the favorites for one user, then I know that all of the returned questions are the ...
3
votes
1answer
42 views

Elections nominations posts not showing up in API

I know that it's probably unintended that the Primary voting scores were leaked by the API, but I think if you're going to remove it, then at least make it official, so I won't have to wonder if it's ...
5
votes
1answer
41 views

User's display name field omitted?

If a user doesn't have a username "set" for an account, then the display_name field is omitted. This is similar to a few other questions, but the only official answer says that "display_name should ...
6
votes
1answer
60 views

User's Comments: returning 500 error?

It looks like when I try to get the comments of a user that has "a huge number" of comments, I get a 500 error. Jon Skeet's comments, 500 error: http://api.stackoverflow.com/1.0/users/22656/comments ...
3
votes
1answer
40 views

API 'search' method with 'min' parameter

If you search for questions posted on time 1296897085 or later (by specifying sort=creation and min=1296897085), it may still return questions posted before that date: ...
5
votes
1answer
74 views

API 'search' method with 'tagged' parameter

From the docs for tagged paremeter: List of tags delimited by semi-colons of which at least one must be on a question Yet, when I execute this query ...
4
votes
1answer
54 views

You can gain reputation from edits to tag wikis, although they are not accessible through the API.

Reputation gain from edits to tag wikis appear through the API; the API reports them as answers, but fetching them via the /answers route does not work. Case in point: My accepted edit (+2 rep) My ...
5
votes
1answer
63 views

/user/{id}/timeline results leaking template used for badge information

From my elections statistics page: I inserted in the detail field as plain text because I wasn't sure if the results would be HTML, but the $ChatUrl left in the anchor's href is surely a bug.
1
vote
1answer
66 views

Is Stack Overflow Meta incorrectly configured?

If I call the Auth "sites" API, then it shows Meta Stack Overflow as: "name": "Meta Stack Overflow", "logo_url": "http://sstatic.net/stackoverflowmeta/img/logo.png", "api_endpoint": ...
2
votes
1answer
94 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
1
vote
1answer
68 views

Associated accounts is broken for this user

When I retrieve associated accounts for Joel Coehoorn using this query it only includes Programmers.SE and Webmasters.SE despite the fact that I retrieved the association key from a query to SU. The ...
3
votes
1answer
74 views

tag colors incorrect

the tag color for english site seem incorrect, the dark grey color is the background while the yellow colour is the foreground. This is contradictory to other sites which have the darker colours as ...