Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

1
vote
1answer
66 views

Incorrect Wordpress and Electronics icons

Currently Meta Icon Currently Main Icon With all the other sites (except electronics, which has the same icon for both), Meta has the B&W or sepia icon, while the main site's icon is coloured. ...
3
votes
1answer
72 views

How do you retrieve list of users sorted by reputation?

I am failing in my attempt to retrieve results sorted by reputation. For example, the following query sorts the results by ID. Is there an error in the URI? ...
1
vote
0answers
30 views

API does not return stackoverflow user_id?

When I visit http://stackauth.com/1.1/users/aa1073f7-7e3b-4d4d-ace5-f2fca853f998/associated it returns my user_id on many stackexchange sites, but not stackoverflow itself! I'm sure this is by ...
1
vote
1answer
34 views

/questions/{id}/linked is failing for this question on ServerFault.

This route is reporting an error: http://api.serverfault.com/1.1/questions/45734/linked Incidentally, I discovered this error thanks to my handy tool StackStatus, which runs a status check on the ...
4
votes
1answer
37 views

API usage “Try It” form for linked questions queries meta.tex.stackexchange instead of Stackoverflow

I was wondering why the form at http://api.stackoverflow.com/1.1/usage/methods/linked-questions did not return the questions I was expecting. Then I noticed that it is calling ...
1
vote
1answer
24 views

nottagged only works when tagged is set (/search)

On the /search route, the nottagged parameter doesn't work properly (at least it isn't specially documented to only work at certain times) For example: ...
1
vote
1answer
21 views

rep losses aren't reflected in api

This includes rep recalcs (e.g., the latest) and (speculative) when people take upvote back. First case you can see on standard stackauth/users query: it displays meta reputation before recalc. ...
0
votes
2answers
38 views

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API
1
vote
1answer
113 views

Reputation query doesn't match that on SO

This morning, at 2011-04-06 00:22:38Z, I received a question upvote for this question. That shows up as giving me 5 reputation when looking at the Stack Overflow reputation page. However, when I use ...
2
votes
1answer
49 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
1
vote
1answer
41 views

StackAuth 1.1 API reports a site without a site_name

Calling the StackAuth 1.1 API associated method for a particular user returns one site with no site_name property (the one for which the user_id is 349). I cannot find a matching account in ...
0
votes
1answer
12k views

sorting ascending vs descending

I don't understand the difference between ascending and descending? Surely ascending means the most active/recent/popular/A first, and descending means the least active/recent/popular/Z first? But it ...
2
votes
1answer
86 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } Renewing the ...
0
votes
1answer
37 views

Mismatch between user_id as reported in StackAuth 1.1 (invalid) and 1.0 (valid)

For the association id 1de2e2b0-2fb6-4db6-b90d-d0244ed5d13a, the StackAuth 1.1 call returns an invalid user_id of 73203 for Server Fault whereas the StackAuth 1.0 call returns the correct user_id of ...
1
vote
0answers
29 views

What has happened to the revision history of this answer?

This is rather odd. Consider this answer. The current content of the answer according to http://api.meta.stackoverflow.com/1.1/answers/81451?body=true is: ...<img ...
1
vote
0answers
19 views

“Special” required tag listings only show single required tag

When you're viewing questions tagged with one of app,script,library, you get the special formatting view with the thumbnail on the left. On pages where this view is displayed, only one of these tags ...
3
votes
1answer
63 views

API search page size limit mismatch

The 1.1 API help text for search says that the pagesize parameter can go up to 100. Indeed, passing a value up to 100 returns some results, while passing pagesize=101 yields an HTTP 400 status (Bad ...
2
votes
1answer
38 views

The associated accounts are broken once again for this same user

As I reported before (and which was fixed) and again (which was also fixed), the associated accounts are broken once again for for Joel Coehoorn using this query. What's the deal?
2
votes
1answer
53 views

Comments in user timeline are returning Markdown

In users/{id}/timeline, the detail field for comment events is formatted with Markdown and not HTML. Is it normal? I saw in the question Comments are returning markdown that the API should return ...
4
votes
1answer
161 views

API ignores jsonp callback after initial request - erroneous caching?

This bug is still prevalent, appears to be cache related. Two identical requests return different data: first request respects jsonp query parameter, all subsequent requests ignore it until (I ...
5
votes
0answers
60 views

Requesting favorite questions should report which users have favorited it

I can request the favorite questions of a user via the users/{id}/favorites endpoint. If I'm only requesting the favorites for one user, then I know that all of the returned questions are the ...
3
votes
1answer
61 views

What happened to the /stats method?

I can't find the /stats method in the new usage documentation. A quick run of http://api.stackoverflow.com/1.1/stats reveals that the method is still there. However, it is not documented.
2
votes
1answer
71 views

Why are StackAuth methods not returning rate-limit headers?

Visiting the page: http://stackauth.com/1.1/sites yields the following headers: Notably absent are the X-RateLimit-Max and X-RateLimit-Current headers that show up in API queries to the sites ...
1
vote
1answer
47 views

The /questions/{id}/linked method is returning extra questions.

Consider the following question on ServerFault: http://serverfault.com/questions/45734/the-coolest-server-names Linked questions: Note that there's only two listed. However, querying: ...
1
vote
1answer
59 views

The /top-answer-tags method is not working.

I tried the new /top-answer-tags method on Ask Ubuntu, but it isn't working: URL: http://api.askubuntu.com/1.1/users/5/top-answer-tags Output: { "error": { "code": 500, "message": "A ...
2
votes
1answer
41 views

The 'total' field of /comments result is showing up as 0.

Running the following query: http://api.stackoverflow.com/1.1/comments Yields: { "total": 0, "page": 1, "pagesize": 30, "comments": [ ... Notice that the total entry indicates there are ...
1
vote
1answer
32 views

fromdate is ignored for /posts/{id}/comments requests

The api docs: http://api.stackoverflow.com/1.0/help/method?method=posts/{id}/comments The test request. You can see comment itself here, it's four months old, while cutoff date in request is less ...
5
votes
1answer
40 views

User's display name field omitted?

If a user doesn't have a username "set" for an account, then the display_name field is omitted. This is similar to a few other questions, but the only official answer says that "display_name should ...
3
votes
1answer
42 views

Elections nominations posts not showing up in API

I know that it's probably unintended that the Primary voting scores were leaked by the API, but I think if you're going to remove it, then at least make it official, so I won't have to wonder if it's ...
5
votes
1answer
70 views

API 'search' method with 'tagged' parameter

From the docs for tagged paremeter: List of tags delimited by semi-colons of which at least one must be on a question Yet, when I execute this query ...
3
votes
1answer
40 views

API 'search' method with 'min' parameter

If you search for questions posted on time 1296897085 or later (by specifying sort=creation and min=1296897085), it may still return questions posted before that date: ...
6
votes
1answer
57 views

User's Comments: returning 500 error?

It looks like when I try to get the comments of a user that has "a huge number" of comments, I get a 500 error. Jon Skeet's comments, 500 error: http://api.stackoverflow.com/1.0/users/22656/comments ...
4
votes
1answer
54 views

You can gain reputation from edits to tag wikis, although they are not accessible through the API.

Reputation gain from edits to tag wikis appear through the API; the API reports them as answers, but fetching them via the /answers route does not work. Case in point: My accepted edit (+2 rep) My ...
5
votes
1answer
61 views

/user/{id}/timeline results leaking template used for badge information

From my elections statistics page: I inserted in the detail field as plain text because I wasn't sure if the results would be HTML, but the $ChatUrl left in the anchor's href is surely a bug.
1
vote
1answer
66 views

Is Stack Overflow Meta incorrectly configured?

If I call the Auth "sites" API, then it shows Meta Stack Overflow as: "name": "Meta Stack Overflow", "logo_url": "http://sstatic.net/stackoverflowmeta/img/logo.png", "api_endpoint": ...
2
votes
1answer
94 views

Something's changed about user timelines

Six to Eight's user display has just broken, as the /user/id/timeline route seems to have started returning different data. Previously, timeline_type of entries in the user_timelines array used to be ...
1
vote
1answer
67 views

Associated accounts is broken for this user

When I retrieve associated accounts for Joel Coehoorn using this query it only includes Programmers.SE and Webmasters.SE despite the fact that I retrieved the association key from a query to SU. The ...
3
votes
0answers
61 views

Unanswered questions with tags returns wrong total

When requesting a list of unanswered questions with a specific tags the total count show the total number of questions for that tag, not the count for the unanswered questions. Using ...
3
votes
1answer
73 views

tag colors incorrect

the tag color for english site seem incorrect, the dark grey color is the background while the yellow colour is the foreground. This is contradictory to other sites which have the darker colours as ...
6
votes
1answer
203 views

Why these questions do not have a title?

Hitting the following /questions route: http://api.stackoverflow.com/1.0/questions/74?pagesize=1&page=1 the endpoint returns this JSON data: { "total": 1, "page": 1, "pagesize": 1, ...
1
vote
1answer
109 views

MSO is not being returned in StackAuth's /users/{id}/associated route

In looking into a StackFlair issue, I have discovered that MSO is not being returned as part of a user's associated accounts. Please see my associated accounts according to the api. Note that there ...
1
vote
1answer
54 views

An associated query is returning a partial record for a particular user

This query returns (in addition to several complete records) this incomplete one: { "user_id": 2196, "user_type": "registered", "display_name": "Wil", "reputation": 151, "email_hash": ...
3
votes
1answer
822 views

Wrong content-type in JSONP calls

When passing jsonp parameter, the API returns "application/json" instead of "application/javascript". I found this because if you do: <script ...
0
votes
1answer
93 views

Comments are returning markdown.

Look at the output of the following: http://api.askubuntu.com/1.0/questions/12218?comments=true Output: { "comment_id": 12713, "creation_date": 1289269467, "owner": { ...
4
votes
2answers
141 views

API Help's CSS is missing

The API Help page's CSS file, located at http://sstatic.net/so/all.css, is current returning 404 for me: <div id="header"><h1>Server Error</h1></div> <div id="content"> ...
2
votes
1answer
70 views

/questions/{id}/answers missing title attribute

http://api.stackoverflow.com/1.0/help/method?method=questions/{id}/answers (it won't linkify properly!): "title": { "description": "title of this post, in plaintext", "values": "string", ...
0
votes
1answer
68 views

Getting garbage on requests

Not exactly sure how or why, but many times when I try and preview some URL, I get garbage. This has happened on several JSON preview websites as well as on my browser. Strangely this isn't all the ...
2
votes
1answer
30 views

/questions/id route problem: comments section is not returned when there aren't comments on question

Something is changed on questions route called with comments= True: http://api.stackoverflow.com/1.0/questions/1940243?body=True&comments=True&pagesize=1&page=1 It does not return the ...
1
vote
3answers
106 views

StackAuth returning 404?

http://stackauth.com/1.0/sites http://stackauth.com/1.0/help Both of these are currently returning 404 Not Found. What's up with that?
4
votes
1answer
194 views

update crossdomain.xml on stackauth.com and api endpoints to work with current Flash

I am implementing a javascript client that uses the Flash based XHR replacement Flensed in the interest of providing more robust api communication than that provided by JSONP. Apparently the current ...