Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

3
votes
1answer
53 views

“Authentication Statistics” graph y-axis labels are overly granular

Yesterday there was a spike in my app's authentication requests (thanks for that, by the way ;) which has caused my authentication graph to show a much wider range of Y values than it did previously. ...
2
votes
1answer
41 views

HTTP 500 error when calling /apps/{accessTokens}/de-authenticate with an access_token argument in GET

For almost all API calls, I pass both my key and my access_token. This doesn't exactly make sense for the "de-authenticate" endpoint, as the access token is already in the URL. Passing one anyway ...
2
votes
1answer
18 views

Is the display name meant to be escaped HTML in the 2.0 version of the API?

The display_name field of a user is HTML escaped. See here for example. Is this expected behavior or a bug? The documentation doesn't mention it.
1
vote
1answer
33 views

read item in unread inbox method again

I'm getting a read item in the inbox/unread method, again. This happened before, but I can't find the post about it (I'm pretty sure you fixed/explained it). But the item is very old, not a cache ...
0
votes
1answer
20 views

questions/{id} API not working as intended for vectorized id

Show Console > Try it > Call Method button on questions/{id} API page is not working properly for vectorized id ie. when I am passing 7282205 it is working fine, but when I am passing- 7282205; ...
1
vote
1answer
44 views

Quota remaining is negative

I think I must be doing something very stupid, that I just can't see I just registered an app, in the last ~10 minutes. I have just been going to the /info route, no authentication or anything else. ...
2
votes
1answer
63 views

TLS security warnings from api.stackexchange.com

Each time an API request is made over HTTPS, Firefox generates the following message in the error console: Curious, I looked up RFC 5746 and the document covers the following: Transport Layer ...
1
vote
1answer
31 views

Failed beta sites are showing up in the /sites method.

3D Graphics and Game of Go are both failed beta sites. I would not expect them to show up in the /sites list - but they do. Indeed, attempting to list questions on one of the sites fails: ...
0
votes
1answer
97 views

API is accepting requests from other OAuth domains

I've set an OAuth domain for an application (the client_id is 24) and the following link authorizes the application: ...
2
votes
1answer
17 views

The “/tags/{tags}/wikis” API does not return the proffered “body_last_edit_date” or “excerpt_last_edit_date” fields

The API for /tags/{tags}/wikis offers body_last_edit_date and excerpt_last_edit_date fields. Both are selected in the default filter. But neither are actually returned even for tags I'm 100% sure ...
0
votes
1answer
61 views

API console always queries Stack Overflow

On any Stack Exchange site (well, I tried Super User (trilogy), Unix (SE-2.0 launched) and SFF (SE-2.0 beta)), the console (“Show Console” button) in the 1.1 API queries ...
4
votes
1answer
403 views

Why do I get a throttle violation after 300 requests while using a key but no access_token?

I'm doing some testing on my app, and I let it run on a machine this afternoon while I was away. When I got back, I was geting 503 throttle violation errors from my API calls. I was calling the ...
2
votes
1answer
42 views

Documentation has broken link (JSONP)

On Wikipedia, JSONP now has its own article, instead of being part of the JSON article. The documentation links JSONP to Wikpedia:JSON#JSONP. It should link to Wikipedia:JSONP.
5
votes
1answer
53 views

filter=total is returning 0?

I'm running a very simple (and contrived) call of: http://api.stackexchange.com/2.0/users/115730?site=stackoverflow&filter=total I'm expecting a response of: {"total":1} But am getting a ...
2
votes
1answer
18 views

Minor spello/typo on the “Complex Queries” documentation page

The documentation page Complex Queries has a minor typo or spello: The ?filter=total build-in filter is provided for just this purpose. Should instead be: The ?filter=total built-in ...
2
votes
1answer
21 views

Guid inconsistency in 2.0?

question timeline returns "revision_guid": "335659EE-8983-4BEC-BACC-CC95784A4465" revisions by guid return "revision_guid": "335659ee89834becbacccc95784a4465" Is there any particular reason for ...
3
votes
1answer
68 views

Why is my quota constantly decreasing?

I registered an app today (API v2) for the first time (App ID 47, LaServ), and let it run a bit with its new key. It's the only API app running on this IP (I rent the IP as part of a VPS package). ...
0
votes
1answer
47 views

Removing/disallowing app does nothing

I have just deleted/disallowed, the console app and the app I'm currently writing. For the console the access token I was using before deleting the app carried on working, and when I got a new token, ...
3
votes
0answers
19 views

revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
0
votes
1answer
25 views

Runtime error getting thrown with certain parameters on older 1.1 methods

This v1.1 URL is creating a runtime error: http://api.stackapps.com/1.1/comments&min=1323731212 Example output:
2
votes
0answers
29 views

Secure OAuth pages contain insecure content.

I noticed that some of the OAuth pages use insecure content (http:// content on an https:// page): I'm not sure how easy this is to fix but it could potentially scare off some users who don't ...
5
votes
1answer
118 views

Site in closed beta but api working

Hello, Webapps has been added yesterday, website is in closed beta and it's not possible to see something on the website when you are not logged. But if you use the API you can get information. ...
2
votes
1answer
38 views

/comments?fromdate is broken?

The following url should return 0 comments: http://api.stackoverflow.com/1.1/comments?fromdate=9999999999 Instead it returns all comments, not actually filtering by fromdate at all. It happens ...
1
vote
1answer
26 views

The /users/{id}/timeline route is reporting incorrect totals

It seems that the /users/{id}/timeline route is returning an incorrect total. For example, the following URL is reporting a total of 1607 items: http://api.stackapps.com/1.1/users/7789/timeline ...
1
vote
1answer
26 views

Error occurs when retrieving timeline for this question

Here is the question: http://meta.stackoverflow.com/questions/51812/the-api-sandbox Here is the API URL: http://api.meta.stackoverflow.com/1.1/questions/51812/timeline?pagesize=100?page=2 Here is ...
1
vote
1answer
19 views

Sort ranges on /questions/unanswered is broken

The following API request should return all unanswered questions with a score of at least 30: http://api.stackapps.com/1.1/questions/unanswered?sort=votes&min=30 However, the response ...
2
votes
1answer
44 views

What happened to the unique users count?

When visiting http://stackapps.com/apps, I used to be able to see how many unique users were using my application - but now all I see is zeroes for all of the apps. Were the numbers reset or is this ...
1
vote
0answers
40 views

Wrong API response?

Well, if you look here, you'll see i have "down_vote_count": 94, But if you look here on my Stackoverflow profile, you see that my down vote count is 64. For those who would ask if I'm sure ...
1
vote
1answer
70 views

stack applet not getting sign in

I am facing problem during running of Stack Applet. How can I sign in? Moreover when I click on presences it comes up with localhost error . Here is the picture As it can be seen, the Applet is ...
1
vote
1answer
69 views

Incorrect Wordpress and Electronics icons

Currently Meta Icon Currently Main Icon With all the other sites (except electronics, which has the same icon for both), Meta has the B&W or sepia icon, while the main site's icon is coloured. ...
3
votes
1answer
74 views

How do you retrieve list of users sorted by reputation?

I am failing in my attempt to retrieve results sorted by reputation. For example, the following query sorts the results by ID. Is there an error in the URI? ...
1
vote
0answers
31 views

API does not return stackoverflow user_id?

When I visit http://stackauth.com/1.1/users/aa1073f7-7e3b-4d4d-ace5-f2fca853f998/associated it returns my user_id on many stackexchange sites, but not stackoverflow itself! I'm sure this is by ...
1
vote
1answer
35 views

/questions/{id}/linked is failing for this question on ServerFault.

This route is reporting an error: http://api.serverfault.com/1.1/questions/45734/linked Incidentally, I discovered this error thanks to my handy tool StackStatus, which runs a status check on the ...
4
votes
1answer
37 views

API usage “Try It” form for linked questions queries meta.tex.stackexchange instead of Stackoverflow

I was wondering why the form at http://api.stackoverflow.com/1.1/usage/methods/linked-questions did not return the questions I was expecting. Then I noticed that it is calling ...
1
vote
1answer
24 views

nottagged only works when tagged is set (/search)

On the /search route, the nottagged parameter doesn't work properly (at least it isn't specially documented to only work at certain times) For example: ...
1
vote
1answer
21 views

rep losses aren't reflected in api

This includes rep recalcs (e.g., the latest) and (speculative) when people take upvote back. First case you can see on standard stackauth/users query: it displays meta reputation before recalc. ...
0
votes
2answers
39 views

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API

Meta Stack Overflow API Try-It form sends request to Stack Overflow API instead of Meta API
1
vote
1answer
122 views

Reputation query doesn't match that on SO

This morning, at 2011-04-06 00:22:38Z, I received a question upvote for this question. That shows up as giving me 5 reputation when looking at the Stack Overflow reputation page. However, when I use ...
2
votes
1answer
50 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
1
vote
1answer
43 views

StackAuth 1.1 API reports a site without a site_name

Calling the StackAuth 1.1 API associated method for a particular user returns one site with no site_name property (the one for which the user_id is 349). I cannot find a matching account in ...
2
votes
1answer
21k views

sorting ascending vs descending

I don't understand the difference between ascending and descending? Surely ascending means the most active/recent/popular/A first, and descending means the least active/recent/popular/Z first? But it ...
2
votes
1answer
89 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } Renewing the ...
0
votes
1answer
38 views

Mismatch between user_id as reported in StackAuth 1.1 (invalid) and 1.0 (valid)

For the association id 1de2e2b0-2fb6-4db6-b90d-d0244ed5d13a, the StackAuth 1.1 call returns an invalid user_id of 73203 for Server Fault whereas the StackAuth 1.0 call returns the correct user_id of ...
1
vote
0answers
29 views

What has happened to the revision history of this answer?

This is rather odd. Consider this answer. The current content of the answer according to http://api.meta.stackoverflow.com/1.1/answers/81451?body=true is: ...<img ...
1
vote
0answers
19 views

“Special” required tag listings only show single required tag

When you're viewing questions tagged with one of app,script,library, you get the special formatting view with the thumbnail on the left. On pages where this view is displayed, only one of these tags ...
3
votes
1answer
63 views

API search page size limit mismatch

The 1.1 API help text for search says that the pagesize parameter can go up to 100. Indeed, passing a value up to 100 returns some results, while passing pagesize=101 yields an HTTP 400 status (Bad ...
2
votes
1answer
38 views

The associated accounts are broken once again for this same user

As I reported before (and which was fixed) and again (which was also fixed), the associated accounts are broken once again for for Joel Coehoorn using this query. What's the deal?
2
votes
1answer
54 views

Comments in user timeline are returning Markdown

In users/{id}/timeline, the detail field for comment events is formatted with Markdown and not HTML. Is it normal? I saw in the question Comments are returning markdown that the API should return ...
4
votes
1answer
175 views

API ignores jsonp callback after initial request - erroneous caching?

This bug is still prevalent, appears to be cache related. Two identical requests return different data: first request respects jsonp query parameter, all subsequent requests ignore it until (I ...
5
votes
0answers
62 views

Requesting favorite questions should report which users have favorited it

I can request the favorite questions of a user via the users/{id}/favorites endpoint. If I'm only requesting the favorites for one user, then I know that all of the returned questions are the ...