Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

3
votes
0answers
17 views

Reputation changes from accepting answers to questions are not included in reputation results

When querying the /users/{ids}/reputation API route, the results don't include the +2 reputation changes from accepting answers. None of the reputation results from my own reputation history have a ...
3
votes
0answers
36 views

The “advanced search” path returns very wrong results for the `q` parameter

I'm trying to search for a string. It's a hardware identifier 10ec:8168 and should be unique to that make/model of chip. Any questions that mention is should be relevant. But compare the site search ...
3
votes
0answers
47 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
3
votes
0answers
66 views

API v1.1 users call returns association_id for which the Stack Exchange web site has no profile

For a particular user, the users API v1.1 call returns an association_id that gives a "Page Not Found" error where the Stack Exchange profile should be, though their Stack Exchange profile can be ...
3
votes
0answers
90 views

OAuth Dialog rendering problems

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: ...
3
votes
0answers
17 views

revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
3
votes
1answer
42 views

Elections nominations posts not showing up in API

I know that it's probably unintended that the Primary voting scores were leaked by the API, but I think if you're going to remove it, then at least make it official, so I won't have to wonder if it's ...
3
votes
1answer
74 views

tag colors incorrect

the tag color for english site seem incorrect, the dark grey color is the background while the yellow colour is the foreground. This is contradictory to other sites which have the darker colours as ...
3
votes
0answers
61 views

Unanswered questions with tags returns wrong total

When requesting a list of unanswered questions with a specific tags the total count show the total number of questions for that tag, not the count for the unanswered questions. Using ...
3
votes
1answer
56 views

key not being recognized by api.meta.stackoverflow.com?

I have been testing a throttle implementation against meta today and suddenly got shut down with a key violation. It is possible that I have used enough requests to prompt this but I doubt it. In ...
3
votes
1answer
94 views

/users/{id}/associated - inconsistent behavior

/users/{id}/associated occasionally returns empty for an association even though there are definitely associated users. Calling it again immediately returns expected results. GET ...
3
votes
1answer
354 views

Need some help verifying 503 throttle issue

Update: We've confirmed the issue... fixing it is taking more time than anticipated. – Kevin Montrose Color me happy. The throttle is now applied to api.stackoverflow.com so we have an ...
3
votes
2answers
119 views

Shouldn't the API help be consistent with the trademark guidance?

The description for the two StackAuth Routes within the API help both contain the phrase StackExchange network - shouldn't this rather be Stack Exchange Network to be consistent with the recently ...
3
votes
1answer
31 views

Minor typo on help page

On the API Routes help page, this: /users/{id}/favorites Gets summary information for the questions that have been favorited a set of users. should probably be: /users/{id}/favorites Gets ...
2
votes
3answers
86 views

Method /users/{id} doesn't return “about_me” if the user has never modified it

See title. When a user never modified their "about me" section the API doesn't return that, which then causes my parser to go wild returning errors. However, when a user has modified their "about ...
2
votes
3answers
58 views

What is the “inname” parameter to the /tags 2.0 API?

I'm just playing with the new 2.0 API and in /tags there is a field inname that I can't find any description or documentation for. What does it do? Is it like the old filter parameter on the old API? ...
2
votes
1answer
162 views

My reputation graph is messed up.

See here: http://stackapps.com/users/18?tab=reputationhistory#tab-top Go to my rep graph and notice that it only shows about 350 points... Where's my other 4100?
2
votes
1answer
68 views

the stack exchange javascript library is 404

the library listed on the doc page for Authentication https://api.stackexchange.com/js/2.0/all.js ultimately redirects to https://api-v2cdn.sstatic.net/js/all.js which results in varying degrees ...
2
votes
1answer
17 views

Is the display name meant to be escaped HTML in the 2.0 version of the API?

The display_name field of a user is HTML escaped. See here for example. Is this expected behavior or a bug? The documentation doesn't mention it.
2
votes
2answers
66 views

Missing on_site in Stack Apps site data in associated_users from stackauth query

This is what I get for Stack Apps: { "display_name": "user", "email_hash": "11aa11...22bb22...", "reputation": 101, "user_id": 0000, "user_type": ...
2
votes
2answers
498 views

Server has stopped obeying Accept-encoding header

Either today or yesterday, besides /questions/tagged having disappeared, the server started ignoring the Accept-encoding header: Ligação estabelecida com 69.59.196.211 na porta 80 GET ...
2
votes
3answers
134 views

display_name isn't always there (should have OpenID name if needed)

usually in the owner dictionary there is a display_name value to give the username. But in a few questions it simply doesn't exist and I can't see why only those questions: eg, this excerpt from the ...
2
votes
1answer
32 views

Can API stats return real revision number instead of 1234.5678?

Currently it returns like this "revision": "1.0.1234.5678" And looks like that number never changed. So, Can API return real revision number whenever there is an update? It will be very useful ...
2
votes
1answer
150 views

Make www a subdomain.

Try going to http://www.stackapps.com Apparently www is not a subdomain of stackapps.com Anyone who tries to get to the site by prepending the www will be confused, as it is standard to point that ...
2
votes
1answer
46 views

Stack Exchange API is returning non-existant/incorrect notices for questions

When you view this question you do not see any notices other than the protected notice at bottom. Also, you are able to edit the answers and question (provided you have the privilege). However, when ...
2
votes
1answer
31 views

Error retrieving question using a filter that includes question.notice

I have created a filter to include the question.notice field. It seems to be OK as returned by https://api.stackexchange.com/2.1/filters/-9xc1l%2Au-JEsf_Q Then if I want to fetch this question using ...
2
votes
1answer
26 views

Advanced search by title doesn't filter on the title

Searching by title on the advanced search method doesn't restrict the results to posts containing the specified text as a word or even substring. Varying the string has some influence, but I can't ...
2
votes
1answer
39 views

Does /invalidate work for no-expiry tokens?

It seems that tokens created with no_expiry scope are immune to requests to invalidate them with /access-tokens/.../invalidate. Is this by design or by bug?
2
votes
1answer
33 views

Events: field request

The "Event" object doesn't have an easy way for getting at the object relating to the event. There's a link field, but I don't fancy having to parse the information out of that (although I could). ...
2
votes
1answer
39 views

HTTP 500 error when calling /apps/{accessTokens}/de-authenticate with an access_token argument in GET

For almost all API calls, I pass both my key and my access_token. This doesn't exactly make sense for the "de-authenticate" endpoint, as the access token is already in the URL. Passing one anyway ...
2
votes
1answer
15 views

The “/tags/{tags}/wikis” API does not return the proffered “body_last_edit_date” or “excerpt_last_edit_date” fields

The API for /tags/{tags}/wikis offers body_last_edit_date and excerpt_last_edit_date fields. Both are selected in the default filter. But neither are actually returned even for tags I'm 100% sure ...
2
votes
1answer
21 views

Guid inconsistency in 2.0?

question timeline returns "revision_guid": "335659EE-8983-4BEC-BACC-CC95784A4465" revisions by guid return "revision_guid": "335659ee89834becbacccc95784a4465" Is there any particular reason for ...
2
votes
1answer
38 views

/comments?fromdate is broken?

The following url should return 0 comments: http://api.stackoverflow.com/1.1/comments?fromdate=9999999999 Instead it returns all comments, not actually filtering by fromdate at all. It happens ...
2
votes
1answer
44 views

What happened to the unique users count?

When visiting http://stackapps.com/apps, I used to be able to see how many unique users were using my application - but now all I see is zeroes for all of the apps. Were the numbers reset or is this ...
2
votes
1answer
49 views

Method /users/{id}/top-answer-tags is returning wrong results

I'm trying the following request: (555004 happens to be my user id) http://api.stackoverflow.com/1.1/users/555004/top-answer-tags and I'm a bit confused by the result: { top_tags: [ { ...
2
votes
1answer
87 views

Authorized requests: auth parameter seems broken

I'm having problem with authorized requests. Every requests with a valid auth token get: error: { code: 4009 message: "The 'auth' query parameter is not a valid auth token." } Renewing the ...
2
votes
1answer
53 views

Comments in user timeline are returning Markdown

In users/{id}/timeline, the detail field for comment events is formatted with Markdown and not HTML. Is it normal? I saw in the question Comments are returning markdown that the API should return ...
2
votes
1answer
38 views

The associated accounts are broken once again for this same user

As I reported before (and which was fixed) and again (which was also fixed), the associated accounts are broken once again for for Joel Coehoorn using this query. What's the deal?
2
votes
1answer
70 views

/questions/{id}/answers missing title attribute

http://api.stackoverflow.com/1.0/help/method?method=questions/{id}/answers (it won't linkify properly!): "title": { "description": "title of this post, in plaintext", "values": "string", ...
2
votes
2answers
178 views

Why are 5 IP addresses using my API key?

I have an app that resides on a server. It has only ever accessed the API from 2 IP addresses. The API key has not been shared and there is no client-side code. When I go to /apps however, it says "5 ...
2
votes
2answers
128 views

StackApps API is down.

It seems to not be responding to any request. * at least according to downforeveryoneorjustme.com Update: seems like all the SE sites are down :(
2
votes
1answer
128 views

Why do some Stackauth associated queries fail?

This query fails: http://stackauth.com/0.8/users/137b94e5-050c-4dd5-82c1-aeb2af0814f5/associated In Python for a jason.loads call, I get an error: 'ValueError("No JSON object could be decoded")'. I ...
2
votes
2answers
67 views

Order parameter not functional

Consider these two API calls: http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=desc http://api.stackoverflow.com/0.8/questions?pagesize=1&sort=votes&order=asc ...
2
votes
2answers
91 views

Why my /mentioned page return 404?

http://api.stackoverflow.com/0.8/users/213464/mentioned?type=jsontext { "error": { "code": 404, "message": "The server has not found anything matching the Request-URI." } } Its ...
2
votes
1answer
55 views

The users/{id}/timeline method is returning an extra result.

The users/{id}/timeline method is returning 31 results by default, and one more result than specified by the pagesize parameter. Example: ...
2
votes
1answer
48 views

questions/{id} help page sort parameter description is inconsistence with others

The description of the Sort parameter in questions/{id} help page is inconsistent with those of other pages. On the questions/{id} help page: sort (optional): How a collection should ...
2
votes
1answer
58 views

Advanced search API not returning data for “phonegap” tag

I am trying to gather results from the API for the tag phonegap but the API is not returning any data. I am using /search/advanced and get nothing back for November: { "items": [], ...
2
votes
1answer
60 views

V2.1 API body HTML has unclosed li tags

The Stack Exchange API (with a safe filter) is returning question body content with malformed HTML, specifically <li> elements that do not have closing tags (and no valid parent). I've seen ...
2
votes
1answer
22 views

Default listing images aren't served from CDN, fail to load because of certificate error

The default images used on the app/script/library pages aren't pointing to the CDN, so their use of HTTPS causes a certificate error that prevents the image from loading: Could the image sources be ...
2
votes
1answer
57 views

Stack Apps graph time filters make pretty much no sense

When viewing the Query Statistics graphs for an application, you have the option of choosing 'Week', 'Month', 'Year', or 'All Time'. When hovering over 'week' it states "view stats for the last 7 ...