Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

3
votes
1answer
43 views

Typo in API docs: “temporarility_unavailable”

https://api.stackexchange.com/docs/authentication "temporarility" should probably be "temporarily"
2
votes
1answer
30 views

/answers endpoint is error-500-ing against many sites

Just calling the "/answers" endpoint, no specific arguments, and I'm getting 500 errors: http://api.stackexchange.com/2.0/answers?order=desc&sort=activity&site=gaming ...
0
votes
1answer
69 views

Why does the /events service sometimes pause for a couple of minutes?

In developing the firehose service, I found that the /events API often "pauses" for a couple of minutes before resuming. Is this a known issue? Specifically, I am polling /events every 10 seconds ...
2
votes
1answer
41 views

Does /invalidate work for no-expiry tokens?

It seems that tokens created with no_expiry scope are immune to requests to invalidate them with /access-tokens/.../invalidate. Is this by design or by bug?
1
vote
1answer
29 views

Inbox unread since parameter not working

The since parameter of /inbox/unread no longer seems to work. I enter a date after the creation date of the item currently unread in my inbox and still the item is returned. I try putting in ...
0
votes
0answers
600 views

Receiving “redirect_uri does not match the uri used to create the passed code”, when it does match

Summary Using Oauth2, when I go to pick up the access_token, I get the following error from the server: access_denied: redirect_uri does not match the uri used to create the passed code. From what I ...
0
votes
0answers
238 views

An associated query is returning a partial record for Area 51

This issue has recurred (and is ongoing) as of a couple of weeks ago. Most notably, as before, the on_site attribute is missing from Area 51. This is API 1.0, by the way.
3
votes
1answer
29 views

tagged and min max creation gives wrong total

I am trying to get the total number of question with a specific tag AND created within a specific date span. For example, the number of questions tagged as 'java' created between 16 and 17 Jan 2012: ...
1
vote
1answer
36 views

Typo in throttle violation error message

I was just playing around with the API locally and got throttled for the questions and answers methods (the only two I was using). Anyway, I noticed there’s a small typo in the error message that’s ...
1
vote
1answer
16 views

New questions on live home page display improperly.

I was browsing Stack Apps earlier today and a little box popped up indicating that there were new questions. It looked something like this: After clicking the provided link, here is what was ...
1
vote
0answers
96 views

Issue: OAuth login process does not fully work in the WP7 Mango browser control with implicit flow

We experience issues when using the implicit OAuth flow in a WP7 Mango browser control and trying to login with openid. The login process itself works fine (althought the css of the openid page does ...
0
votes
1answer
20 views

Error when requesting the last page of results.

When I try to view the following URL: http://api.stackexchange.com/2.0/questions?page=93781&site=stackoverflow I get the error: { "error_id": 500, "error_name": "internal_error", ...
2
votes
1answer
48 views

Mistake in API 2.0 Documentation - Wrong item type for Careers Message

On https://api.stackexchange.com/docs/types/inbox-item the Careers Message example shows the wrong item type.
1
vote
1answer
31 views

API 2.0 is not returning Programmers in list of sites

Run https://api.stackexchange.com/2.0/sites. programmers.stackexchange.com is not in the response.
2
votes
1answer
30 views

/users/{id}/tags/{tags}/top-answers returning answers by other users

According to the description, /users/{id}/tags/{tags}/top-answers should return answers by the user on that particular tag. Returns the top 30 answers a user has posted in response to questions ...
1
vote
1answer
29 views

Badges displayed incorrectly?

It seems that there's something odd going on with badges. If we take some random user, say 1719, which has one account, and check the user page http://stackexchange.com/users/1719/jelon, then we can ...
1
vote
1answer
35 views

Site_Type returns “main_site” for meta.stackoverflow.com

For Meta Stack Overflow, the 2.0/sites endpoint returns "main_site" rather than "meta_site". All other site_type for other stackexchange sites return correctly. URL: ...
3
votes
0answers
112 views

OAuth Dialog rendering problems

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: ...
1
vote
1answer
20 views

Why doesn't the API return suggested edits on tag wikis?

Is there a reason why the API doesn't return suggested edits on tag wikis on the suggested-edits route?
1
vote
1answer
13 views

Dead link in documentation

On the docs for question timelines the link for "Question" points to /docs/type/question when it should point to /docs/types/question
1
vote
1answer
25 views

No answer_id for Comment on answer inbox_item

According to the API documentation on inbox_item, inbox items corresponding to a comment on an answer to a question should have an answer_id field identifying the answer that the comment was on, but ...
2
votes
1answer
1k views

OAuth redirect not completing

This is the URL that I'm entering (in Safari, cleared website data and cache; my app, uses own Cookie jar; and incognito chrome) ...
3
votes
1answer
29 views

Stylistic error on the JavaScript SDK documentation page

There is a small stylistic error on the JavaScript SDK documentation page. Your application must have the client side OAuth flow enabled, and must not have disabled the desktop application ...
1
vote
1answer
28 views

Answer up/down vote count not being returned in filter

As the picture shows, the up_vote_count and down_vote_count answer properties are selected but not returned. What gives?
3
votes
1answer
51 views

What happens when sites or the whole network go offline

Now that the API is all done on stackexchange.com. What happens if say just certain sites go offline (eg just Stackoverflow). Will the API continue to return results or will it return the HTML offline ...
1
vote
1answer
26 views

Running queries from the Documentation pages hangs browser for minutes at a time

I've been playing with some queries on the documentation page, and I've noticed that it's taking an abnormally long time to load even reasonably sized API call results: ...
5
votes
1answer
44 views

Several staff members are incorrectly listed as elected moderators

Several employees are being reported as elected moderators on sites they haven't been elected on, according to /2.0/users/moderators/elected. I think there was a similar issue reported before during ...
2
votes
1answer
74 views

the stack exchange javascript library is 404

the library listed on the doc page for Authentication https://api.stackexchange.com/js/2.0/all.js ultimately redirects to https://api-v2cdn.sstatic.net/js/all.js which results in varying degrees ...
2
votes
1answer
33 views

There is a small discrepancy in the docs for users-id-associated

The main doc page, https://api.stackexchange.com/docs, shows /users/{id}/associated while the method page, https://api.stackexchange.com/docs/associated-users, uses /users/{ids}/associated. It's ...
2
votes
1answer
33 views

Events: field request

The "Event" object doesn't have an easy way for getting at the object relating to the event. There's a link field, but I don't fancy having to parse the information out of that (although I could). ...
3
votes
1answer
102 views

Does stackexchange provide https access to its API?

Requests I make appear to be redirected back to plain http URLs and the certs seem questionable: % curl -O 'https://api.stackoverflow.com/1.0/questions/?key=oxXcnoD51kKE ...
1
vote
1answer
27 views

There is a typo in the authentication documentation

There is a typo on this documentation page. It says "The explcit OAuth 2.0 flow" but it should say "The explicit OAuth 2.0 flow".
2
votes
1answer
31 views

Answer vote counts are not correct

I was trying to figure out the total number of answers I have that have been downvoted, and at first everything seemed awesome since the total was zero. However, I knew this wasn't correct. For ...
2
votes
1answer
17 views

link attribute is missing from questions in /tags/{tags}/faq

Check the following requests, the link attribute is missing from questions objects in responses. I checked with the default filter and also with custom filters (both safe and unsafe). ...
2
votes
1answer
30 views

question_id missing from migration_info for this question.

Consider the following API request: http://api.stackexchange.com/2.0/questions/3064?site=stackapps This question was migrated from Stack Apps to Stack Overflow. However, the migrated_to field is ...
1
vote
1answer
25 views

/users/{ID}/reputation is returning a 500 error.

The following API request: http://api.stackexchange.com/2.0/users/235/reputation?filter=%21DnBO_&site=askubuntu&page=1 ...is returning an error: { error_id: 500, error_name: ...
1
vote
1answer
24 views

Minor typo in /tags/{tag}/top-askers/{period}

The discussion for the above method says "Returns the top 30 answerers active in a single tag, of either all-time or the last 30 days." It should be corrected as askers.
3
votes
1answer
44 views

Unable to sort /search results by creation_date

I think I may have stumbled upon a bug in /search and I'll try to describe it as best as I can. What works: Create a /search query with the following parameters: fromdate: 2012-01-24 order: desc ...
2
votes
1answer
67 views

Update the default filter editor to use the API key

When I run a sample query using the SE API browser (is that right term?), say against /questions for example (here), I'll always see something to the effect of: ... "quota_remaining": 9424, ...
1
vote
1answer
18 views

Documentation of /users/{id}/top-answer-tags conflicts with implementation.

According to the documentation: /users/{id}/top-answer-tags or /me/top-answer-tags – Get the top 30 tags (by score) a single user has posted answers in. However in practice, when retrieving data ...
2
votes
1answer
13 views

type related_site not listed in 'by type' tab list

The type "related_site" is not listed in the 'by type' tab in documentation.
3
votes
1answer
53 views

“Authentication Statistics” graph y-axis labels are overly granular

Yesterday there was a spike in my app's authentication requests (thanks for that, by the way ;) which has caused my authentication graph to show a much wider range of Y values than it did previously. ...
2
votes
1answer
18 views

Is the display name meant to be escaped HTML in the 2.0 version of the API?

The display_name field of a user is HTML escaped. See here for example. Is this expected behavior or a bug? The documentation doesn't mention it.
2
votes
1answer
43 views

HTTP 500 error when calling /apps/{accessTokens}/de-authenticate with an access_token argument in GET

For almost all API calls, I pass both my key and my access_token. This doesn't exactly make sense for the "de-authenticate" endpoint, as the access token is already in the URL. Passing one anyway ...
1
vote
1answer
31 views

Failed beta sites are showing up in the /sites method.

3D Graphics and Game of Go are both failed beta sites. I would not expect them to show up in the /sites list - but they do. Indeed, attempting to list questions on one of the sites fails: ...
0
votes
1answer
102 views

API is accepting requests from other OAuth domains

I've set an OAuth domain for an application (the client_id is 24) and the following link authorizes the application: ...
2
votes
1answer
17 views

The “/tags/{tags}/wikis” API does not return the proffered “body_last_edit_date” or “excerpt_last_edit_date” fields

The API for /tags/{tags}/wikis offers body_last_edit_date and excerpt_last_edit_date fields. Both are selected in the default filter. But neither are actually returned even for tags I'm 100% sure ...
1
vote
1answer
34 views

read item in unread inbox method again

I'm getting a read item in the inbox/unread method, again. This happened before, but I can't find the post about it (I'm pretty sure you fixed/explained it). But the item is very old, not a cache ...
2
votes
1answer
63 views

TLS security warnings from api.stackexchange.com

Each time an API request is made over HTTPS, Firefox generates the following message in the error console: Curious, I looked up RFC 5746 and the document covers the following: Transport Layer ...
4
votes
1answer
469 views

Why do I get a throttle violation after 300 requests while using a key but no access_token?

I'm doing some testing on my app, and I let it run on a machine this afternoon while I was away. When I got back, I was geting 503 throttle violation errors from my API calls. I was calling the ...