Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

0
votes
1answer
28 views

Badges displayed incorrectly?

It seems that there's something odd going on with badges. If we take some random user, say 1719, which has one account, and check the user page http://stackexchange.com/users/1719/jelon, then we can ...
1
vote
1answer
33 views

Site_Type returns “main_site” for meta.stackoverflow.com

For Meta Stack Overflow, the 2.0/sites endpoint returns "main_site" rather than "meta_site". All other site_type for other stackexchange sites return correctly. URL: ...
3
votes
0answers
90 views

OAuth Dialog rendering problems

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: ...
1
vote
1answer
19 views

Why doesn't the API return suggested edits on tag wikis?

Is there a reason why the API doesn't return suggested edits on tag wikis on the suggested-edits route?
1
vote
1answer
13 views

Dead link in documentation

On the docs for question timelines the link for "Question" points to /docs/type/question when it should point to /docs/types/question
0
votes
1answer
22 views

No answer_id for Comment on answer inbox_item

According to the API documentation on inbox_item, inbox items corresponding to a comment on an answer to a question should have an answer_id field identifying the answer that the comment was on, but ...
2
votes
1answer
737 views

OAuth redirect not completing

This is the URL that I'm entering (in Safari, cleared website data and cache; my app, uses own Cookie jar; and incognito chrome) ...
3
votes
1answer
28 views

Stylistic error on the JavaScript SDK documentation page

There is a small stylistic error on the JavaScript SDK documentation page. Your application must have the client side OAuth flow enabled, and must not have disabled the desktop application ...
1
vote
1answer
25 views

Answer up/down vote count not being returned in filter

As the picture shows, the up_vote_count and down_vote_count answer properties are selected but not returned. What gives?
3
votes
1answer
47 views

What happens when sites or the whole network go offline

Now that the API is all done on stackexchange.com. What happens if say just certain sites go offline (eg just Stackoverflow). Will the API continue to return results or will it return the HTML offline ...
1
vote
1answer
23 views

Running queries from the Documentation pages hangs browser for minutes at a time

I've been playing with some queries on the documentation page, and I've noticed that it's taking an abnormally long time to load even reasonably sized API call results: ...
5
votes
1answer
42 views

Several staff members are incorrectly listed as elected moderators

Several employees are being reported as elected moderators on sites they haven't been elected on, according to /2.0/users/moderators/elected. I think there was a similar issue reported before during ...
2
votes
1answer
68 views

the stack exchange javascript library is 404

the library listed on the doc page for Authentication https://api.stackexchange.com/js/2.0/all.js ultimately redirects to https://api-v2cdn.sstatic.net/js/all.js which results in varying degrees ...
2
votes
1answer
32 views

There is a small discrepancy in the docs for users-id-associated

The main doc page, https://api.stackexchange.com/docs, shows /users/{id}/associated while the method page, https://api.stackexchange.com/docs/associated-users, uses /users/{ids}/associated. It's ...
2
votes
1answer
33 views

Events: field request

The "Event" object doesn't have an easy way for getting at the object relating to the event. There's a link field, but I don't fancy having to parse the information out of that (although I could). ...
3
votes
1answer
96 views

Does stackexchange provide https access to its API?

Requests I make appear to be redirected back to plain http URLs and the certs seem questionable: % curl -O 'https://api.stackoverflow.com/1.0/questions/?key=oxXcnoD51kKE ...
1
vote
1answer
26 views

There is a typo in the authentication documentation

There is a typo on this documentation page. It says "The explcit OAuth 2.0 flow" but it should say "The explicit OAuth 2.0 flow".
2
votes
1answer
29 views

Answer vote counts are not correct

I was trying to figure out the total number of answers I have that have been downvoted, and at first everything seemed awesome since the total was zero. However, I knew this wasn't correct. For ...
2
votes
1answer
17 views

link attribute is missing from questions in /tags/{tags}/faq

Check the following requests, the link attribute is missing from questions objects in responses. I checked with the default filter and also with custom filters (both safe and unsafe). ...
2
votes
1answer
30 views

question_id missing from migration_info for this question.

Consider the following API request: http://api.stackexchange.com/2.0/questions/3064?site=stackapps This question was migrated from Stack Apps to Stack Overflow. However, the migrated_to field is ...
1
vote
1answer
23 views

/users/{ID}/reputation is returning a 500 error.

The following API request: http://api.stackexchange.com/2.0/users/235/reputation?filter=%21DnBO_&site=askubuntu&page=1 ...is returning an error: { error_id: 500, error_name: ...
1
vote
1answer
21 views

Minor typo in /tags/{tag}/top-askers/{period}

The discussion for the above method says "Returns the top 30 answerers active in a single tag, of either all-time or the last 30 days." It should be corrected as askers.
3
votes
1answer
42 views

Unable to sort /search results by creation_date

I think I may have stumbled upon a bug in /search and I'll try to describe it as best as I can. What works: Create a /search query with the following parameters: fromdate: 2012-01-24 order: desc ...
2
votes
1answer
63 views

Update the default filter editor to use the API key

When I run a sample query using the SE API browser (is that right term?), say against /questions for example (here), I'll always see something to the effect of: ... "quota_remaining": 9424, ...
1
vote
1answer
17 views

Documentation of /users/{id}/top-answer-tags conflicts with implementation.

According to the documentation: /users/{id}/top-answer-tags or /me/top-answer-tags – Get the top 30 tags (by score) a single user has posted answers in. However in practice, when retrieving data ...
2
votes
1answer
13 views

type related_site not listed in 'by type' tab list

The type "related_site" is not listed in the 'by type' tab in documentation.
3
votes
1answer
53 views

“Authentication Statistics” graph y-axis labels are overly granular

Yesterday there was a spike in my app's authentication requests (thanks for that, by the way ;) which has caused my authentication graph to show a much wider range of Y values than it did previously. ...
2
votes
1answer
17 views

Is the display name meant to be escaped HTML in the 2.0 version of the API?

The display_name field of a user is HTML escaped. See here for example. Is this expected behavior or a bug? The documentation doesn't mention it.
2
votes
1answer
40 views

HTTP 500 error when calling /apps/{accessTokens}/de-authenticate with an access_token argument in GET

For almost all API calls, I pass both my key and my access_token. This doesn't exactly make sense for the "de-authenticate" endpoint, as the access token is already in the URL. Passing one anyway ...
1
vote
1answer
29 views

Failed beta sites are showing up in the /sites method.

3D Graphics and Game of Go are both failed beta sites. I would not expect them to show up in the /sites list - but they do. Indeed, attempting to list questions on one of the sites fails: ...
0
votes
1answer
90 views

API is accepting requests from other OAuth domains

I've set an OAuth domain for an application (the client_id is 24) and the following link authorizes the application: ...
2
votes
1answer
15 views

The “/tags/{tags}/wikis” API does not return the proffered “body_last_edit_date” or “excerpt_last_edit_date” fields

The API for /tags/{tags}/wikis offers body_last_edit_date and excerpt_last_edit_date fields. Both are selected in the default filter. But neither are actually returned even for tags I'm 100% sure ...
1
vote
1answer
33 views

read item in unread inbox method again

I'm getting a read item in the inbox/unread method, again. This happened before, but I can't find the post about it (I'm pretty sure you fixed/explained it). But the item is very old, not a cache ...
2
votes
1answer
61 views

TLS security warnings from api.stackexchange.com

Each time an API request is made over HTTPS, Firefox generates the following message in the error console: Curious, I looked up RFC 5746 and the document covers the following: Transport Layer ...
4
votes
1answer
332 views

Why do I get a throttle violation after 300 requests while using a key but no access_token?

I'm doing some testing on my app, and I let it run on a machine this afternoon while I was away. When I got back, I was geting 503 throttle violation errors from my API calls. I was calling the ...
3
votes
1answer
68 views

Why is my quota constantly decreasing?

I registered an app today (API v2) for the first time (App ID 47, LaServ), and let it run a bit with its new key. It's the only API app running on this IP (I rent the IP as part of a VPS package). ...
5
votes
1answer
52 views

filter=total is returning 0?

I'm running a very simple (and contrived) call of: http://api.stackexchange.com/2.0/users/115730?site=stackoverflow&filter=total I'm expecting a response of: {"total":1} But am getting a ...
2
votes
1answer
18 views

Minor spello/typo on the “Complex Queries” documentation page

The documentation page Complex Queries has a minor typo or spello: The ?filter=total build-in filter is provided for just this purpose. Should instead be: The ?filter=total built-in ...
2
votes
1answer
21 views

Guid inconsistency in 2.0?

question timeline returns "revision_guid": "335659EE-8983-4BEC-BACC-CC95784A4465" revisions by guid return "revision_guid": "335659ee89834becbacccc95784a4465" Is there any particular reason for ...
1
vote
1answer
48 views

No award_count field on any badges

The docs say the default filter includes award_count, and I've made a filter with it in. But no award_count is returned on any badge route. The exception being when a badge item is returned in ...
1
vote
1answer
32 views

Authentication Statistics are the same for all apps

I know the stats are new, I'm not sure if they are still in development. But they are identical for the 3 apps I have registered, given that the app's id is in the URL of the stats page, I guess the ...
1
vote
1answer
43 views

Quota remaining is negative

I think I must be doing something very stupid, that I just can't see I just registered an app, in the last ~10 minutes. I have just been going to the /info route, no authentication or anything else. ...
0
votes
1answer
38 views

2.0 tags API returns only created tags

Searching for tags, using the inname parameter AND a date range returns only the tags that were created in that period, not the tags that were used in that period. When searching by inname only, or ...
2
votes
3answers
58 views

What is the “inname” parameter to the /tags 2.0 API?

I'm just playing with the new 2.0 API and in /tags there is a field inname that I can't find any description or documentation for. What does it do? Is it like the old filter parameter on the old API? ...
0
votes
1answer
45 views

Removing/disallowing app does nothing

I have just deleted/disallowed, the console app and the app I'm currently writing. For the console the access token I was using before deleting the app carried on working, and when I got a new token, ...
3
votes
0answers
18 views

revisions/{id} is returning an error for locked posts

The API is returning the following error message when I request the revision history for locked posts. Example URL: http://api.stackoverflow.com/1.1/revisions/194812 { "error": { "code": 500, ...
0
votes
1answer
25 views

Runtime error getting thrown with certain parameters on older 1.1 methods

This v1.1 URL is creating a runtime error: http://api.stackapps.com/1.1/comments&min=1323731212 Example output:
2
votes
0answers
28 views

Secure OAuth pages contain insecure content.

I noticed that some of the OAuth pages use insecure content (http:// content on an https:// page): I'm not sure how easy this is to fix but it could potentially scare off some users who don't ...
4
votes
1answer
131 views

Certain users aren't showing up in /users when filter is applied

NB: The filter parameter in v1.x of the API had a different meaning to the filter parameter in v2.0 Consider the following query: http://api.stackoverflow.com/1.1/users?filter=jon%20skeet ...
2
votes
1answer
40 views

Documentation has broken link (JSONP)

On Wikipedia, JSONP now has its own article, instead of being part of the JSON article. The documentation links JSONP to Wikpedia:JSON#JSONP. It should link to Wikipedia:JSONP.