Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

2
votes
0answers
23 views

Why is “body” missing from certain inbox items?

I have run into some confusion over the presence of the body attribute in an inbox-item returned by the /inbox method. When item_type is set to "careers_invitations", the body attribute appears to be ...
1
vote
2answers
84 views

Possible problem calling users/?filter method searching username with tilde

I'm testing curious usernames and I am searching their user_id by: http://api.stackoverflow.com/0.8/users/?filter=username_filter I'm trying to get information about this particular user: ...
3
votes
0answers
66 views

API v1.1 users call returns association_id for which the Stack Exchange web site has no profile

For a particular user, the users API v1.1 call returns an association_id that gives a "Page Not Found" error where the Stack Exchange profile should be, though their Stack Exchange profile can be ...
1
vote
1answer
25 views

Questions returned by /questions/{ids}/related do not contain link properties

The API docs claim that /questions/{ids}/related return question objects, but I can't find a link property on the returned questions at all. Is there some sort of workaround to find the link for a ...
0
votes
1answer
13 views

What is the api_site_parameter of stackapps.com in API 2.x

What is the api_site_parameter of stackapps.com in API 2.x? https://api.stackexchange.com/2.1/sites doesn't list stackapps. Why?
5
votes
0answers
166 views

Why is my API quota not resetting after UTC reset?

According to How API Keys Work, the default daily API limit -- which is per site, per day -- is 300. I started with 300, as expected, but over a period of days, I've noticed that the remaining quota ...
1
vote
0answers
120 views

Unread messages in inbox query shows older inbox messages

I am using the /inbox/unread route to get the unread messages in a user's inbox. Recently (over the last couple of months, perhaps) I have noticed that the entries returned from this route initially ...
5
votes
1answer
57 views

API docs titled “v2.0”; should be “v2.1”

The documentation is titled "StackExchange API v2.0"... this should be updated to "v2.1" as it's not readily obvious that version 2.1 has been published otherwise. https://api.stackexchange.com/docs
2
votes
1answer
13 views

type related_site not listed in 'by type' tab list

The type "related_site" is not listed in the 'by type' tab in documentation.
3
votes
1answer
94 views

API documentation console unsuccessfully tries to load MiniProfiler results

All of the documentation pages (example) with the test console currently attempt to load MiniProfiler result data, which fails with a 404: POST ...
4
votes
1answer
33 views

Typo in the docs for /me

The doc says: Returns the user associated with the passed auth_token. This method returns a user. It should say "access_token" instead of "auth_token".
3
votes
1answer
31 views

Querying “standard meta tags” for their tag wikis wrongly says they have none

I'm checking which tags have tag wiki excerpts in my code. It looks like /tags/{tags}/wikis is the right API since the tag info API doesn't even give a boolean for tag wiki excerpt presence. But ...
1
vote
1answer
18 views

The “Get Started” section in the sidebar only mentions API 2.0 and API 1.1

Now that API 2.1 is "public, frozen, and out the door" shouldn't we update the "Get Started" section in the sidebar on the right side of the screen. It talks about API 2.0 and API 1.1 but doesn't ...
1
vote
1answer
13 views

No token field in the docs test page for /me/reputation-history

There is no form field for an access token at: https://api.stackexchange.com/docs/me-reputation-history https://api.stackexchange.com/docs/me-full-reputation-history After attempting to Run the ...
10
votes
1answer
240 views

Bug in the StackExchange Api ? getting “could not parse proxy url” when user not logged in

I think I may have stumbled upon a bug in the StackExchange JS API I'm having a problem getting its authentication to work properly, and I just discovered that the same problem exist in the official ...
4
votes
1answer
10 views

Typo in API filter documentation

When using unsafe filters, the API returns the highest fidelity data is can reasonably access for the given request. should be When using unsafe filters, the API returns the highest fidelity ...
2
votes
1answer
29 views

Error retrieving question using a filter that includes question.notice

I have created a filter to include the question.notice field. It seems to be OK as returned by https://api.stackexchange.com/2.1/filters/-9xc1l%2Au-JEsf_Q Then if I want to fetch this question using ...
4
votes
1answer
70 views

Getting error 4002 when calling tags method without a sort parameter

According to the documentation, calling the tags method without a sort parameter should return the recently used tags, since the default sort is by activity. Instead, I get an error 4002 with the ...
5
votes
1answer
46 views

Typos in the API 2.0 Documentation

Typo #1: There are two different objects that represent a user in the Stack Exchange API, the full user object and the smaller shallow_user object. Which is returned depends on the method being ...
2
votes
1answer
55 views

Stack Apps graph time filters make pretty much no sense

When viewing the Query Statistics graphs for an application, you have the option of choosing 'Week', 'Month', 'Year', or 'All Time'. When hovering over 'week' it states "view stats for the last 7 ...
1
vote
1answer
24 views

Advanced search by title doesn't filter on the title

Searching by title on the advanced search method doesn't restrict the results to posts containing the specified text as a word or even substring. Varying the string has some influence, but I can't ...
1
vote
1answer
19 views

View count restriction isn't working for /search/advanced.

I have constructed the following URL, but the questions returned don't contain anywhere near 50k views, despite the query string parameter: ...
1
vote
1answer
21 views

The inname parameter does not work with multiple parameters

I am trying to get details by passing semicolon delimited list in inname paramter but it is not working. I tried below API call: ...
1
vote
1answer
14 views

Question count missing from network_user

Docs state that you get an int question_count from a network_user object but I'm not getting these fields back anymore - even when testing from https://api.stackexchange.com/docs/me-associated-users ...
5
votes
1answer
31 views

/posts/{id}/revisions breaks for posts with [tag:*] content

Attempting to access (at least) the revisions route for a post with a revision involving the [tag:*] syntax causes an error: Example on Meta Stack Overflow (Post History) Example on Mathematica ...
2
votes
0answers
39 views

Stack Apps “Welcome Back” banner text isn't centered

This appear to be specific to Stack Apps. The text is centered on every other site I've tried. See below: Compared to how it should appear:
0
votes
1answer
37 views

2.0 tags API returns only created tags

Searching for tags, using the inname parameter AND a date range returns only the tags that were created in that period, not the tags that were used in that period. When searching by inname only, or ...
2
votes
1answer
45 views

/suggested-edits “Try it”: Link for “suggested_edit_id” is broken

When using the "Try it" feature on /suggested-edits, the link for the suggested_edit_id points towards stackexchange.com and not towards the respective site. For example, retrieve data using the ...
0
votes
1answer
63 views

Why does the /events service sometimes pause for a couple of minutes?

In developing the firehose service, I found that the /events API often "pauses" for a couple of minutes before resuming. Is this a known issue? Specifically, I am polling /events every 10 seconds ...
1
vote
1answer
47 views

/me API endpoint returning 500 error

I'm making an authenticated call to /me: https://api.stackexchange.com/2.0/me?access_token=[redacted]&site=stackoverflow&key=[redacted] But it's returning: ...
3
votes
1answer
43 views

Typo in API docs: “temporarility_unavailable”

https://api.stackexchange.com/docs/authentication "temporarility" should probably be "temporarily"
2
votes
1answer
26 views

/answers endpoint is error-500-ing against many sites

Just calling the "/answers" endpoint, no specific arguments, and I'm getting 500 errors: http://api.stackexchange.com/2.0/answers?order=desc&sort=activity&site=gaming ...
2
votes
1answer
38 views

Does /invalidate work for no-expiry tokens?

It seems that tokens created with no_expiry scope are immune to requests to invalidate them with /access-tokens/.../invalidate. Is this by design or by bug?
1
vote
1answer
25 views

Inbox unread since parameter not working

The since parameter of /inbox/unread no longer seems to work. I enter a date after the creation date of the item currently unread in my inbox and still the item is returned. I try putting in ...
0
votes
0answers
314 views

Receiving “redirect_uri does not match the uri used to create the passed code”, when it does match

Summary Using Oauth2, when I go to pick up the access_token, I get the following error from the server: access_denied: redirect_uri does not match the uri used to create the passed code. From what I ...
1
vote
1answer
21 views

Minor typo in /tags/{tag}/top-askers/{period}

The discussion for the above method says "Returns the top 30 answerers active in a single tag, of either all-time or the last 30 days." It should be corrected as askers.
0
votes
0answers
235 views

An associated query is returning a partial record for Area 51

This issue has recurred (and is ongoing) as of a couple of weeks ago. Most notably, as before, the on_site attribute is missing from Area 51. This is API 1.0, by the way.
2
votes
1answer
30 views

/users/{id}/tags/{tags}/top-answers returning answers by other users

According to the description, /users/{id}/tags/{tags}/top-answers should return answers by the user on that particular tag. Returns the top 30 answers a user has posted in response to questions ...
3
votes
1answer
28 views

tagged and min max creation gives wrong total

I am trying to get the total number of question with a specific tag AND created within a specific date span. For example, the number of questions tagged as 'java' created between 16 and 17 Jan 2012: ...
1
vote
1answer
16 views

New questions on live home page display improperly.

I was browsing Stack Apps earlier today and a little box popped up indicating that there were new questions. It looked something like this: After clicking the provided link, here is what was ...
1
vote
1answer
33 views

Typo in throttle violation error message

I was just playing around with the API locally and got throttled for the questions and answers methods (the only two I was using). Anyway, I noticed there’s a small typo in the error message that’s ...
1
vote
0answers
87 views

Issue: OAuth login process does not fully work in the WP7 Mango browser control with implicit flow

We experience issues when using the implicit OAuth flow in a WP7 Mango browser control and trying to login with openid. The login process itself works fine (althought the css of the openid page does ...
0
votes
1answer
20 views

Error when requesting the last page of results.

When I try to view the following URL: http://api.stackexchange.com/2.0/questions?page=93781&site=stackoverflow I get the error: { "error_id": 500, "error_name": "internal_error", ...
1
vote
1answer
31 views

Site_Type returns “main_site” for meta.stackoverflow.com

For Meta Stack Overflow, the 2.0/sites endpoint returns "main_site" rather than "meta_site". All other site_type for other stackexchange sites return correctly. URL: ...
0
votes
1answer
29 views

API 2.0 is not returning Programmers in list of sites

Run https://api.stackexchange.com/2.0/sites. programmers.stackexchange.com is not in the response.
0
votes
1answer
27 views

Badges displayed incorrectly?

It seems that there's something odd going on with badges. If we take some random user, say 1719, which has one account, and check the user page http://stackexchange.com/users/1719/jelon, then we can ...
3
votes
0answers
85 views

OAuth Dialog rendering problems

I'm using the implicit OAuth flow for our native iPad app. We're calling the standard URLs in a UIWebView. The Stack Exchange login renders with several UI glitches. The first screen looks correct: ...
1
vote
1answer
19 views

Why doesn't the API return suggested edits on tag wikis?

Is there a reason why the API doesn't return suggested edits on tag wikis on the suggested-edits route?
3
votes
1answer
45 views

What happens when sites or the whole network go offline

Now that the API is all done on stackexchange.com. What happens if say just certain sites go offline (eg just Stackoverflow). Will the API continue to return results or will it return the HTML offline ...
1
vote
1answer
13 views

Dead link in documentation

On the docs for question timelines the link for "Question" points to /docs/type/question when it should point to /docs/types/question