Indicates you've found an erroneous or unexpected behavior in the Stack Exchange API, or the Stack Exchange HTML or CSS, that needs to be fixed.

learn more… | top users | synonyms

4
votes
1answer
30 views

API documentation pages match some site names incorrectly

The bug is not in the API itself, but in the pages documenting its methods. To reproduce, follow the link http://api.stackexchange.com/docs/info#filter=default&site=math and observe that the page ...
0
votes
0answers
19 views

Windows Phone app forgets its place when sleeping

Sometimes, when I'm reading a question on the Windows Phone app, the phone goes to sleep. When I wake it up, it's forgotten I was reading a question, and has gone back to the main screen. This is ...
0
votes
0answers
10 views

“can_flag” is not provided for answers through /questions/{ids} endpoint

When using the /questions/{ids} endpoint, the can_flag value for answers is never provided, even when specifying the option in the filter. The can_flag for the question however, is populated. Below ...
0
votes
0answers
11 views

OAuth Domain does not accept subdomains, but the documentation says it should

The help information for the "OAuth Domain" setting says: For the purposes of redirection, subdomains are considered to be under their parent domain. Registering example.com would allow a ...
4
votes
1answer
127 views

Certain users aren't showing up in /users when filter is applied

NB: The filter parameter in v1.x of the API had a different meaning to the filter parameter in v2.0 Consider the following query: http://api.stackoverflow.com/1.1/users?filter=jon%20skeet ...
3
votes
0answers
29 views

Total reputation reported by the /users/{ids}/reputation route is low

When querying the /users/{ids}/reputation API route, the total amount of reputation I get back from all reputation changes is much lower than my reputation reported on Stack Overflow. Here's my ...
1
vote
0answers
19 views

Get Token button in “Try it” doesn't give me a key in IE11

When I visit for example the timeline docs to try that api I need to get a token first by clicking 'Get Token'. In IE11 (win 7/x64) this is broken. A window does pop-up but there is never a key ...
2
votes
0answers
14 views

Invisible text in Markdown syntax help

Some text is invisible in the How to Format help block because of a bad combination of text and background color: That's meant to read ► backtick escapes `like _so_` but the backquoted ...
3
votes
0answers
17 views

bounties_offered are not being returned correctly from /users/{ids}/reputation

When querying the /users/{ids}/reputation API route, reputation changes for bounties_offered are not being returned correctly. In my own results, I see a reputation object with a reputation_change ...
2
votes
0answers
12 views

Reputation changes from accepting answers to questions are not included in reputation results

When querying the /users/{ids}/reputation API route, the results don't include the +2 reputation changes from accepting answers. None of the reputation results from my own reputation history have a ...
1
vote
0answers
6 views

The reputation_change field is missing from the reputation results on some CW posts

When querying the /users/{ids}/reputation API route, the reputation_change field is missing from the results on community-wiki answers. I think the reputation type should always include this field, ...
2
votes
0answers
30 views

SSL handshake error after Stack Overflow back on - anything related to SSL certification changed?

I'm building a Stack Overflow app for BlackBerry10. Earlier today (Feb 16, 2014), Stack Overflow was down and after it came back up my app starts to have this issue. My app works fine when it's in ...
4
votes
1answer
53 views

“Try it” facility suffers a double-encoding bug

As you can clearly see from the above, the ampersand in the site name in the "Try It" section of the API method documentation has been double-encoded. This affects any site with an ampersand in ...
9
votes
1answer
91 views

Google’s OAuth redirect broken

We just tried to authenticate with our application without being logged into anything on StackExchange. This is best tested in a private browser session without any cookies etc. So after starting the ...
1
vote
0answers
37 views

Why is there a difference between “questions” and “search” in API?

I have a query to find the number of questions tagged java from 2012-08-01 to 2013-08-01. Running this using both /questions and /search produces different results: ...
5
votes
0answers
39 views

Tell us that POST is required to write

While troubleshooting /posts/{id}/comments/add in order to answer Why am I getting a 404 when trying to post a comment?, it was noticed that the API path in question only responded to POST requests. ...
2
votes
0answers
11 views

Not all sites are returning Hi Res icons

In the /sites method, not all the sites return high_resolution_icon_url field. (e.g. Personal Finance and Money) Although if you add "@2" to the normal resolution icon you can see a high res image ...
2
votes
1answer
52 views

Advanced search API not returning data for “phonegap” tag

I am trying to gather results from the API for the tag phonegap but the API is not returning any data. I am using /search/advanced and get nothing back for November: { "items": [], ...
2
votes
0answers
34 views

Implicit OAuth Flow stopped working. Redirect happening to a non existent URL

The following URL is first hit when a user clicks on Login: ...
2
votes
0answers
28 views

Incorrect link parameter on the “Complex Queries” documentation page

The "Complex Queries" documentation page has this link: Of these three posts on Server Fault, the one with the most recent activity where "the one with the most recent activity" links to ...
0
votes
0answers
66 views

Cursor continuously switching back and forth between arrow and hand symbols

In the 'Questions' page point your mouse at the 'line' which separate the tabs(Newest, Frequent, Votes, etc) and the questions and see the mouse pointer transforms in between the two shapes (Hand ...
2
votes
1answer
52 views

V2.1 API body HTML has unclosed li tags

The Stack Exchange API (with a safe filter) is returning question body content with malformed HTML, specifically <li> elements that do not have closing tags (and no valid parent). I've seen ...
4
votes
1answer
92 views

The API /timeline path doesn't return several items that occurred after the fromdate parameter

I need to get all the question activity after some particular time. I am using the timeline API, like so:       /questions/20032212/timeline?fromdate=1384705610&site=stackoverflow.com But it ...
4
votes
0answers
20 views

Link to applied_count leads to a 404

To Reproduce Run an API query on tag-synonyms, you will get a result that includes something like this: Issue(s) Click on the applied_count link and you get redirected to this page which is a ...
3
votes
1answer
68 views

“OAuth request must be over HTTPS” when request is over https

I had a bug reported to me that I was able to reproduce. When authorizing to my Badges webapp, we get the following error: error: invalid_request error description: OAuth request must be over ...
1
vote
1answer
48 views

No award_count field on any badges

The docs say the default filter includes award_count, and I've made a filter with it in. But no award_count is returned on any badge route. The exception being when a badge item is returned in ...
3
votes
1answer
43 views

Trying to get the Total results count crashes the /notifications path

I am trying to use the filter !9ciXfDSYM (same as default but with total) with the /notifications request and the response is: { "error_id": 500, "error_name": "internal_error", ...
4
votes
1answer
51 views

API calls that return select post bodies throw JSON errors

When calling the Stack Exchange API to get the post body, it will return an error for some posts. EG: ...
3
votes
0answers
34 views

The “advanced search” path returns very wrong results for the `q` parameter

I'm trying to search for a string. It's a hardware identifier 10ec:8168 and should be unique to that make/model of chip. Any questions that mention is should be relevant. But compare the site search ...
1
vote
0answers
77 views

/oauth/access_token not redirecting back to my redirect_uri

I am trying to implement Stack Exchange using oAuth 2.0. I am able to get CODE but, when I try to get access_token through this code: <?php if(isset($_GET['code'])) { ?> <form method="POST" ...
6
votes
1answer
56 views

/users/{ids}/timeline creation_date missing or incorrect

I am writing a small widget that displays the time since I was awarded my last badge on Stack Overflow. I noticed that my most recent badge was missing from the timeline data (/users/{ids}/timeline). ...
0
votes
1answer
42 views

Most of the url are missing the protocol

Maybe you were trying to fix the other "bug" I've pointed out, but now most of the url for the icons are missing the protocol! { "site_type": "main_site", "name": "Stack Overflow", ...
2
votes
1answer
47 views

Mistake in API 2.0 Documentation - Wrong item type for Careers Message

On https://api.stackexchange.com/docs/types/inbox-item the Careers Message example shows the wrong item type.
4
votes
2answers
50 views

Stack Exchange API is returning boolean(false) For 'is_answered' On Question With Accepted Answer

When you view this question you see a closed question which has an accepted answer. When you get the API info for it you get this: ["question_id"]=> int(17466804) ["creation_date"]=> ...
2
votes
1answer
44 views

Stack Exchange API is returning non-existant/incorrect notices for questions

When you view this question you do not see any notices other than the protected notice at bottom. Also, you are able to edit the answers and question (provided you have the privilege). However, when ...
3
votes
0answers
47 views

SE API V1.1 documentation, date errata

The Stack Exchange API, version 1.1, documentation is ever so slightly confusing wherever Unix timestamps are mentioned (perhaps any ranges, I haven't dug too deeply) For instance: todate – Unix ...
12
votes
1answer
62 views

Stack Exchange API is not returning the close vote counts for questions

When you visit this question (with proper privs) you can see that there are 2 close votes cast for it. However, if you access the information for this question using the Stack Exchange API you get ...
2
votes
1answer
22 views

Default listing images aren't served from CDN, fail to load because of certificate error

The default images used on the app/script/library pages aren't pointing to the CDN, so their use of HTTPS causes a certificate error that prevents the image from loading: Could the image sources be ...
3
votes
1answer
36 views

The API has stopped allowing CORS requests

I just noticed that a script I have that makes CORS requests to the API stopped working on Meta Stack Overflow, claiming that the domain isn't allowed by Access-Control-Allow-Origin, which is true ...
0
votes
0answers
27 views

Parameter `tagged` in `search/advanced` seems to use `AND` instead of `OR`

It seems that search/advanced has the same problem as in "The tagged parameter does not work with multiple tags" question. When I select c#; .net I only get results tagged both c# and .net: ...
0
votes
1answer
44 views

CDN redirect for the API's JavaScript SDK is incorrect

The API's JavaScript SDK is listed as https://api.stackexchange.com/js/2.0/all.js. However, GET request produces the following response: Status Code: 301 Moved Permanently Location: ...
1
vote
0answers
77 views

Stack Exchange OAuth2, explicit access-token response format does not adhere to RFC6749 standard

I'm using the Stack Exchange v2.1 API. I'm using the explicit OAuth 2.0 flow, but it seems that the access token response step does not adhere to the RFC 6749 standard. Specifically, the Stack ...
1
vote
0answers
24 views

The 2.1, “similar” path is returning empty results

I've been a happy user of the /2.1/similar Stack Exchange API for a while. But, at some point within the last 24 hours, or so, it started returning empty results (but otherwise reporting everything as ...
0
votes
1answer
53 views

Inbox and Notifications aren't being filtered by site

I'm using the API get inbox messages and notifications for various sites on the StackExchange network, but it doesn't seem to matter what site parameter I pass in the query string. I always get my ...
1
vote
1answer
50 views

Off-by-one error in fromdate processing

When running a query with a given fromdate value, values which match fromdate - 1 are returned. An example: When using fromdate=1367715851 results will be returned which have a creation_date of ...
1
vote
1answer
52 views

Not possible to login to approve or reject access to application on Windows Phone 7 device

I'm making an app for Windows Phone using the Stack Exchange API but I'm having a bit of trouble when I try to let the user approve the application (using client side flow). I open a web browser at ...
5
votes
0answers
23 views

API docs for “stack overflow” still feature v1.0 docs

I guess I'd call this a doc bug. Currently the page http://api.stackoverflow.com redirects to http://api.stackoverflow.com/1.0/usage, which says at the top "Don't use 1.0, use 2.1". This URL ...
7
votes
0answers
227 views

Application stats are completely broken.

It appears that the application stats are completely broken. Attempting to view the number of times Stack Mobile hit the /questions/* methods results in this graph: It would seem that statistics ...
8
votes
1answer
50 views

Whatever happened to closed_reason?

When pulling back info on a closed question, I have come to expect closed_reason to be a present key if there's a closed_date. It seems that as of recently this is no longer true. Proof: ...
3
votes
1answer
42 views

Problem with /search tagged and max

Seems like a problem with /search when max is not set to today, and tagged is given: ...